Welcome to the Lectora Information Center
The Lectora Information Center was designed so that you can quickly find the information you need and continue working on your Lectora titles. The Information Center is divided into the following main sections:

- **Getting Started**
  View important information that you should know before using Lectora.

- **The Lectora Workspace**
  Familiarize yourself with the important features of the Lectora Workspace so you can make your Lectora experience easy and efficient.

- **Building a Title**
  This section contains topics for starting out with a blank title to adding chapters, sections, and pages.

- **Working with Text**
  This section contains topics about using text to enhance your title.

- **Working with Objects**
  This section contains topics about adding objects like images, audio, and video.

- **Tests, Surveys and Questions**
  Add tests, surveys, and questions to test your users' knowledge and interact with your users.

- **Working with Forms**
  Add forms to capture data and feedback from your users.

- **Actions and Variables**
  Actions and variables can be used to create interesting titles with varying interactivity and dynamically updated information.

- **Tools and Wizards**
  Learn about time-saving tools and helpful wizards available within Lectora.

- **Publishing a Title**
  View the options available for publishing your completed title.

Getting Started
This chapter presents information to help you get started with Lectora.

In this chapter, the following topics are covered:

- **System Requirements**
- **Installing Lectora**
- **Registering Lectora**
- **Accessing Help**
- **Tips and Training**
- **Uninstalling Lectora**
- **What's New in 2008**
- **How Lectora Works**
System Requirements
Be sure you meet the following minimum system requirements before installing Lectora:
- Intel® or AMD® class processor
- 32MB RAM
- 230MB free hard disk space for the application

Internet courses produced by Lectora require Internet Explorer 6.0 or newer or any version of Mozilla Firefox. CD-ROM courses produced by Lectora require one of the following operating systems and a CD-ROM drive:
- Windows 2000
- Windows NT
- Windows XP
- Window Vista

To use the test submittal, form submittal, and e-mail features of Lectora-published HTML content, Macintosh-based users must ensure their browser supports LiveConnect. LiveConnect enables JavaScript and Java to freely interchange data on a Web site. Windows-based browsers provide LiveConnect support, by default.

Installing Lectora
1. Insert the Lectora product CD into your computer’s CD drive.
2. If the CD does not automatically start, double-click the CD icon and follow the on-screen instructions.

See also: Uninstalling Lectora

Registering Lectora
Register your copy of Lectora so that Trivantis can inform you of updates and provide information about new features and products.

Do one of the following:
- Install Lectora to access the Registration window, and then follow the on-screen instructions. An active Internet connection is required.
- Register at any time by choosing Help > Register.

Be sure to register within 2 weeks of activation. Otherwise, the software becomes inactive.

Accessing Help
The Lectora Information Center is a browser-based system that provides Help topics of the tasks you can complete using Lectora tools. To access the Help, click the Help button where available. You can also select Contents from the Help menu within Lectora or any of the Suite tools.

The Help menu item corresponds with clicking the toolbar graphic or typing the F1 key.

Navigating the Information Center
To navigate the Information Center, click the plus sign (+) to the left of the section name to expand the section. Click the title of the topic to display the topic. Click the minus sign (-) to collapse a section.

Click the Index tab to access the Information Center Index. To quickly navigate the Index, type in a keyword in the keyword field at the top of the Index. Topics matching the Index words appear in the navigation pane. Click the title of the topic to display the topic.

Click the Search tab to enter words or phrases to quickly find topics. Topics containing the search words or phrases appear in the navigation pane. Click the title of the topic to display the topic.
Lectora
Information Center

To improve your search, use quotation marks around a phrase, such as “Group Object”. Only those topics
containing all words in the phrase are displayed.
Other ways to get help:
Lectora provides the following additional information:
 Video Agent Help
View the Video Agents for introductions and overviews of Lectora’s powerful and time-saving features. You can access the
Video Agents using one of the following ways:
- Click Run Overview when you start Lectora for the first time
- Click the Video Agent graphic
on Lectora windows where available
- Select Video Tour from the Help menu for a complete video title
- Select Video Tour Agents from the Help menu for individual topics



Lectora Online
Open a printable version of the Lectora Information Center



Tool tips
Tool tips contain information about Lectora tools. Position your cursor over a tool to view the tool tip information.



Lectora User Community
Share and exchange ideas with Lectora users and experts.

Tips and Training
A variety of resources are available with Lectora:
The Quick Start Guide included with the Lectora product packaging details the top ten features of the Lectora interface. A
handy list of shortcut keys that can be used to add objects, publish your title and more, can be found on the back side of the
guide.
Trivantis also offers the following instructor-led training courses to enhance your Lectora experience. These courses are offered
at the Trivantis locations or can be scheduled at your location. Online training is also available. For more information, visit

Lectora Fundamentals

Learn how to create a title from scratch. Begin by creating the title’s
organization and add images, text, buttons and other objects to the title. Create
interactive components such as rollovers and hotspots. Use some of Lectora’s
time-saving tools and wizards to create buttons, page numbering, and
backgrounds. Learn how to create a graded test assessment, and how to
submit it to an email address, a back-end database, or a Learning Management
System. Finally, error check and publish the title to the desired format.

Lectora Intermediate

Take your Lectora knowledge to the next level and learn how to create
additional interactivity. This course focuses on the use of variables within
Lectora. Variables can be used to display generic information such as the
user’s name (pulled from a Learning Management system) or the current date
on a page. Use variables to conditionally branch within the title, display test
results on a certificate of completion, and display completion status within a
title.

Lectora Extreme

Move beyond the basics of Lectora to produce advanced functionality. Create
pre-tests that will count towards completion of a course; display completion
status of chapters within a title. Create custom, gradable questions that are not


of the standard 6 question types. Interact with Flash objects, and learn how to pass information to and retrieve information from a Flash object. Create software simulations and use form elements to store user input. This course relies heavily on the use of variables to create advanced functionality within a title.

Uninstalling Lectora
To uninstall Lectora, use the Windows Control Panel. Select Add or Remove Programs and locate Lectora in the list of programs. Select Uninstall and follow the on-screen instructions.

What’s New in 2008
This release of Lectora contains the following changes:

Media
- **Media conversion to Flash format**
  Lectora now enables you to convert media types to Flash format. Convert and compress video and audio resources to Flash when publishing to the Internet. A new tab labeled Compression has been added to the property windows for the three Web-based publishing destinations (Publishing to HTML, Publishing to AICC/Web-based, and Publishing to SCORM/Web-based). The Compression tab contains a slider to select the compression and quality ratio so the media can be tailored to suit your needs.

  You can now also directly add Flash Video (.flv files) to your title for use with audio and video objects.

  Objects, such as audio from the Lectora Audio Editor and video from the Lectora Video Editor, can be saved to Flash format and played by users using a Flash plug-in. Your captured screen sequences from the Lectora Screen Camera Tool can also be saved as Flash format.

- **Add media events to Flash audio and video**
  You can add events using the Audio Editor and Video Editor to media saved in Flash format. Events are inserted into media to trigger actions.

- **New pause action**
  Users can pause and resume playback on audio, video, and animation. Animated GIFs can be paused within a title that is published to CD or as an executable.

Tools
- **Create custom certificates with the Certificate Tool**
  Use the new Certificate Tool to quickly and easily add custom certificates for tests and course completion to your title. Certificate Tool is a new option on the Tools menu.

- **Manage your media with the new Media Library Organizer**
  The Media Library Organizer has been added to the Tools menu. Add, copy, and remove all types of media from your titles, as well as search for media and assign metadata that is carried through with the object when you add it to your title. You can define and save media to custom categories that you and the members on your team create to help organize and share media.

- **Create custom buttons with custom highlight colors**
  The Button Wizard allows you to choose a custom highlight color when creating a custom button.

- **Include British and Canadian English variants in the Spell Check dictionary**
  You can assign British English or Canadian English as the main dictionary language for spell check.
• Create unique resources in Resource Manager
  Assign a unique resource to each object, if the same resource is used by more than one object.

• Identify and remove unused resources and variables
  New tabs have been added to the Resource Manager and Variable Manager that identify unused resources and variables.

Tests, Surveys, and Questions
• Provide immediate question feedback
  You can configure test questions to immediately display feedback when the user has answered the question.

• Display multiple choice answers using a drop-down list or a list box
  You can configure multiple choice questions to display answers as a drop-down list or a list box.

• Specify custom Likert responses
  You can configure Likert questions in your surveys to contain custom responses, including the number of choices and choice text.

• Create Likert questions in table format
  The Likert table is a new choice when configuring your survey. This new option allows you to display Likert questions in table format.

• New IsPassed and IsNotPassed conditions
  Select the new conditions – IsPassed and IsNotPassed – when configuring tests. These conditions are made available when enabling the option to grade the test. The conditions are determined by the lowest passing score of the test.

• New grading option for multiple choice and hotspot questions
  Multiple Choice and Hot Spot questions with multiple correct answers can now be individually graded.

Resource Management
• Improved search in the Resource Manager
  Use the Resource Manager to search for specified resources in the title. Find resources by resource name or resource type.

Publishing
• Adjustable image compression
  You can specify the amount of compression used for images when they are converted for publishing.

• Automatic removal of unused variables
  To help manage the variables in your title, you can flag unused variables and configure Lectora to automatically remove them from your title.

• Protect published content
  Enable the Protect Content option when publishing your title to prevent your published content from being copied. Users are unable to access Clipboard functions and context menus.

• Cryptic test naming to deter cheating
  Test names are assigned more cryptic names when published. This makes it harder for students to find them in the browser cache.

Text
• Highlight text
Use the new Highlighter graphic on the Text toolbar to highlight text. The last color selected is remembered, allowing you to apply this color to text with a single click.

- **Adjust the line spacing**
  Use new paragraph spacing options to adjust the line height in a text box, along with the space before and after the paragraph.

- **Display text formatting marks**
  You can display text formatting marks, such as paragraph returns, hard and soft returns, spaces, tabs, and page breaks. The formatting marks are not shown to the user when the title is published.

- **Check spelling when typing**
  When enabled, Lectora can automatically check your spelling while you type. Misspelled words will appear underlined in red while you are editing the text block.

**Debugging**

- **Use Debug Mode to find and remove bugs**
  Run your titles in the new Debug Mode to view variable data, actions triggered, and other debug information.

- **Debug published titles**
  Use the new publishing option that will enable you to debug your published title. This option is available when publishing to HTML, AICC, SCORM, CourseMill, and LRN.

**Objects**

- **Specify custom images for check boxes and radio buttons**
  You can select custom images when configuring check boxes and radio buttons on form elements, true/false questions, Likert questions, and more.

- **Customize your submenus**
  Use the new Top Level Layout and Submenu Layout tabs when configuring menu properties. Options are available for customizing the menu and submenus.

- **Transparent background option for menus**
  You can set the background for menu objects to transparent.

**Ease/Speed of Use**

- **View object graphics in Action Target list and inheritance list**
  To help differentiate between objects, the object graphics representing the objects in your title are displayed when selecting a Target for an Action. This also occurs when configuring inherited objects for chapters, sections, and pages.

- **Highlight and press Enter to view object properties**
  To quickly gain access to the properties of an object, highlight the object and press Enter. The properties window will open, allowing you to view and make changes.

- **Pages containing notes are bolded in the left-hand pane**
  To indicate that pages contain notes, the pages appear in bold, italicized type in the left-hand pane. All parent chapter and sections are displayed in bold type if they contain a page with a note.

- **Copy and paste multiple rows of a condition**
  When you define multiple conditions for an action, you can select to copy and paste the conditions into another action's Condition tab.
- **Snap to guides and grids for all sides and resizing**
  When moving and resizing an object, all sides and corners will snap to guides and grids.

- **Reset object to original size**
  When editing images, buttons, and animations, you can reset the object to its original size.

- **Display HTML page names**
  You can display HTML page names at the top of each Page Properties window.

- **Resize layout of multiple objects at once**
  You can resize multiple objects to the same size. Objects can be set to the same width, height, or both.

- **Export styles**
  You can export text styles so that styles can be shared between titles and team members.

- **Use relative percentage for the Size To action**
  When configuring the Size To action, you can specify the new width and height as a percentage or in pixels.

- **Adjust zoom level, position, and size on the status bar**
  You can adjust the zoom level, position, and size of objects using controls on the status bar.

**Miscellaneous**

- **View the Video Agents to learn about Lectora**
  Watch videos to learn about the following Lectora topics:
  - Introduction to Lectora
  - Work Areas
  - Work Modes: Edit, Run, Preview
  - Chapters, Sections, Pages
  - Buttons
  - Text
  - Text Links
  - Images
  - Audio
  - Video
  - Animations/Flash
  - Actions
  - Object Properties
  - Motion Transitions
  - Understanding Inheritance
  - Creating tests
  - Publishing
  - Lectora User Community

- **Improved Help**
  Use the task-oriented Help to find what you are looking for and quickly get back to creating your title.

- **Use the Templates tab to view the templates**
  You can preview and select the templates from the Lectora Template Gallery using the Templates tab when configuring your title.

- **Include notes when printing storyboard and outline format**
  When printing, you can include notes when you print in storyboard and outline format.
• **Course ID used in Manifest Identifier**
  When publishing to SCORM, the course ID is used as the Manifest Identifier to accommodate many LMS requirements.

• **Round and Round Down for Modify Variable action**
  When configuring the Modify Variable action, use the Round Variable and Round Down Variable modification types.

• **Link to the Trivantis Community Forum**
  Select the [Community Forum](#) item in the Help menu to open the Trivantis Community Forum Web page.

### How Lectora Works
Lectora relies on two basic concepts that novice users should learn before using Lectora. This section explains the book metaphor from which Lectora is based, defines the title hierarchy, and describes how to inherit objects to simplify creating a title. Understanding these concepts will make using Lectora easier and will enable you to maximize its full potential.

The following sections present additional information about the book metaphor and inheritance:

- [Understanding the Book Metaphor](#)
- [Understanding Inheritance](#)

### Understanding the Book Metaphor
Lectora uses a book metaphor to help you create an organized hierarchy of content. The title represents the overall course (or book metaphorically), and the course (book) can contain and be organized using chapters, sections, sub-sections, and pages. The pages represent the physical pages that are designed by the author. Chapters, sections, and sub-sections are not physical pages, but rather a means of organizing the title.

Here’s a more detailed look at these title components:

#### The Title
- Holds all the information on a particular subject
- Contains pages
-Organizes those pages into chapters or sections, or both
- Can include title-wide features such as a company logo or forward and backward navigation

#### The Chapters
- Contain logical “major” subdivisions of information about the subject
- Can be further subdivided into sections
- Contain sections, pages, or both, but not other chapters
- Can include chapter-wide features that are apparent on every page within that chapter

#### The Sections
- Contain logical “minor” subdivisions of information about the subject
- Can be further subdivided into smaller sections (called sub-sections)
- Contain sub-sections, pages, or both
- Can include section-wide features that are apparent on every page within that section

#### The Pages
- Contain physical objects such as text, images, and video
- Cannot be further subdivided
- Are the physical pages that your users will see
With Lectora, you can use the same approach to organizing your content. There is a direct relationship between the elements of a book and the elements that comprise your Lectora title. The title can contain only pages or you can organize those pages into chapters, sections, and subsections.

Understanding Inheritance
One of the biggest time-saving features that Lectora offers is a concept called inheritance. This concept may not be natural to you, and it will very likely be the aspect of Lectora that requires the most thought when you are designing a new title. The scenario in which you'll realize the greatest benefits from using inheritance is when you have an object or a group of common objects that need to appear on more than one page of your title.

A Scenario
For instance, let’s imagine that your course will have a How to Sharpen a Pencil section with 10 pages in it, and you want the student to be able to traverse forward and backward through the pages by using a Next button and a Previous button. Furthermore, you always want a Glossary button to appear on each of those pages, so the student can quickly display a Glossary of terms when necessary. Suppose also that the last page of your How to Sharpen a Pencil section is the last page of the entire title. Since it is the last page of your title, it should not have a Next button.

Achieving the Scenario Without Using Inheritance
Traditionally, you would create ten new pages in the How to Sharpen a Pencil section. You would then import and place the Next, Previous and Glossary buttons on one of the pages, and make the Action of each button go specifically to the next page, the previous page, and the glossary respectively. Finally, you would copy and paste all three of the buttons on the remaining nine pages within the section (minus the Next button on the last page).

Achieving the Scenario Using Inheritance
Alternatively, take advantage of Lectora’s inheritance feature. With inheritance, you can import and place those three buttons (Next, Previous, and Glossary) on the Section level object that you titled How to Sharpen a Pencil instead of placing them on all the pages.

You will place these three buttons on that Section one time, you will set the buttons actions one time, and then you will simply start creating new pages in that section. The inheritance feature enables those three buttons to automatically appear on every new page you create in the How to Sharpen a Pencil section! Anything you place on the section level will automatically appear on every page you create in that section.

You Don’t Always Have to Inherit Everything
As mentioned above in the scenario, the last page should not have a Next button, since it is the last page of the title. By placing all three buttons on the Section, every page created in that Section contains all three buttons, which we know is not desirable on the last page.

To solve this problem, Lectora offers you the ability to exclude certain objects from being inherited. By using this feature, you can continue to inherit the three buttons throughout the section, while excluding the Next button from the last page.

See also: Excluding Objects Using Inheritance

Inheritance Summary
- Anything placed on a page appears on only that page
- Anything placed on a section appears on every Page* of every sub-Section in that Section
- Anything placed on a chapter appears on every Page* of every Section in that Chapter
- Anything placed on a test appears on every Page* of every Section in that Test
- Anything placed on your title appears on every Page* of every Section of every Chapter in that Title

*Unless you use the Exclude Inheritance of Certain Objects property on the page.
The Lectora Workspace
Each time you launch Lectora, a launch pad is displayed that presents options for creating new titles and accessing existing titles. Once you have opened a title, the Lectora workspace is revealed. It consists of menus, toolbars, a left-hand pane, and a work area. You can further customize your Lectora workspace by setting preferences.

The following sections present additional information about the Lectora workspace:

- Using the Launch Pad
- The Lectora Interface
- Setting Lectora Preferences

Using the Launch Pad
The launch pad opens when you start Lectora. (It also opens when you select File > New Title or File > Open an Existing Title.)

Using the launch pad, you can:

- Start the Title Wizard
- Create a new, blank title
- Open an existing title
- Use a pre-designed template

You must create a title before you can start adding chapters, sections, pages, and media objects.

Starting the Title Wizard
The Title Wizard makes it easy to get rolling with Lectora. The Title Wizard guides you through creating a title from one of the pre-designed title styles. Your answers to the Wizard’s questions will enable Lectora to create the framework for the style of title you selected.

Click the Title Wizard tab to start the Title Wizard.

Use the Title Wizard tab to quickly select one of the pre-designed titles. Previews of the first page of each title are displayed on the right of the window and short descriptions of each title are displayed in the lower-right corner of the window.

Select the desired style from the window and click OK.

Follow the on-screen instructions to build your title. When you have answered all of the questions and clicked Finish, your title is displayed in the work area. The outline is displayed in the left-hand pane and the first page is displayed in the work space on the right.

If you need to return to the Title Wizard to create another title, click File > New Title and select the Title Wizard tab.

See also: Creating a title using the Title Wizard

Creating a new, blank title
To create a new title from scratch without the use of a wizard, click the New Title tab on the launch pad.

Enter the name of the new title in the New Title Name field and use the Choose Folder button to select a location to which to save the title. The default location is My Documents\My Titles\<title name>.awt. Click OK to create the new title.

See also: Creating a new title
Opening an existing title
To open an existing title using the launch pad, click the **Open Existing Title** tab. This tab displays the last six titles that you have opened using Lectora. To open one of the listed titles, double-click the title from the **Recently Used Files** list (or select it and click **OK**.) Otherwise, use the **Browse** button to search for a title that does not appear in the list.

*See also:*  [Opening an existing title](#)

Using a pre-designed template
To use a pre-designed template to create a new title, click the **Templates** tab.

Templates are a convenient way to store boilerplate versions of titles that can be used as a starting point for future titles that are created. For instance, if your organization has a standard "look and feel" that should be applied to all titles, you can create a template that contains the layout and all associated text and graphics for that title. You would then use this template when creating all of your titles.

*See also:*  [Using a template](#)

The Lectora Interface
The Lectora interface consists of the following areas and menus:

- **Menu bar**
  Contains menus organized by tasks. For example, the **Add** menu contains commands for adding different objects to your title.

  *See also:*  [Using the Menu bar](#)

- **Toolbar area**
  Contains toolbars for quickly completing commands and selecting tools. For example, to quickly save your title, click the
Save toolbar graphic on the Standard toolbar. Toolbars can be rearranged within this area by dragging-and-dropping the toolbar to the new location.

See also: Using the toolbar area

Left-hand pane
Displays the structure of your title and the objects contained within it. You can copy and paste within this left-hand pane, as well as drag-and-drop objects from one level of your title to another.

See also: Using the left-hand pane

Work area
Allows you to interactively manage the objects contained within up your title. Drag-and-drop objects to the work area to place them within your title, and double-click on objects to review their properties.

See also: Using the work area

Status bar
Displays useful information such as the current cursor location and the RGB value of the color of the current cursor location.

See also: Using the Status bar

Using the menu bar
Use the menu bar to access all the functions of Lectora. Most of the functions that exist within the menus are also accessible from the toolbars. Keyboard shortcuts appear to the right of the frequently used menu items, and mnemonics are included for each menu title and menu item. If the menu item has a graphic located to its left, then it will also have the same graphic representation on one of the toolbars.

The menu bar consists of the following menus:

- File
- Edit
- Add
- Layout
- Tools
- Mode
- Publish
- View
- Help

See also: Specifying hotkeys preferences

File menu
Use the File menu to manage your titles.

New Title
Select this to start a new title. When you select this menu item, the Lectora launch pad appears, opened to the New Title tab. You can type the name of the title you want to create and click OK to open it.

See also: Creating a new title

This menu item corresponds with clicking the toolbar graphic or typing the Ctrl+N keyboard shortcut.
Open an Existing Title
Select this to open an existing title. When you select this menu item, the Lectora launch pad appears, opened to the Open Existing Title tab. You can type the name of an existing title, use Browse to navigate to it, or select a title from the list of Recently Used Files.

See also: Opening an existing title

This menu item corresponds with clicking the toolbar graphic or typing the Ctrl+O keyboard shortcut.

Close Title
Select this to close the current title. You will be prompted to save the current title if you made changes to it.

Save Title
Select this to save the current title. This menu item is available if you have made changes that need to be saved to the current title.

See also: Saving a Title

This menu item corresponds with clicking the toolbar graphic or typing the Ctrl+S keyboard shortcut.

Save a Copy of Title
Select this to create a copy of the current title. This menu item is available when you open a title. When you select this item, you are prompted for the folder to which to save a copy of the current title. After the title is copied, the current title will be closed and the newly created copy of the title will be opened.

See also: Saving a Title

Save Title as Template
Select this to save the current title as a template.

See also: Saving a Title as a Template

Print
Select this to print the current title. Lectora supports a number of different printing options such as Storyboard and Outline.

This menu item corresponds with clicking the toolbar graphic or typing the Ctrl+P keyboard shortcut.

Import
Select this to import content from the following supported import types:
- CSV Question File
- QTI
- XML
- Zip

See also: Importing and Exporting Content

Export
Select this to export content to the following supported export types:
- QTI
- XML
- Zip
See also: Importing and Exporting Content

Preferences
Select this to access the preference settings for your Lectora application. Options selected within the Preferences will remain until they are changed.

See also: Setting Lectora Preferences

(Recently used files)
Select one of the files listed to open it. You will be prompted if you made changes that need to be saved to the current title.

Exit
Select this to exit Lectora. You will be prompted if you made changes that need to be saved to the current title.

Edit menu
Use the Edit menu to manage your changes.

Undo
Select this to undo your unsaved changes one-at-a-time. The menu item will change to reflect the most recently processed command (for example, Undo Move). Lectora can undo up to 20 commands.

This menu item corresponds with clicking the toolbar graphic or typing the Ctrl+Z keyboard shortcut.

Redo
Select this to redo your unsaved changes one-at-a-time. The menu item will change to reflect the most recently processed command (for example, Redo Insert). Lectora can redo up to 20 commands.

This menu item corresponds with clicking the toolbar graphic or typing the Ctrl+Y keyboard shortcut.

Cut
Select this to cut the selected object and store it in the clipboard. Paste the object in another location using Paste.

This menu item corresponds to clicking the toolbar graphic or typing the Ctrl+X keyboard shortcut.

Copy
Select this to copy the selected item or object and store it in the clipboard. Paste the item or object in another location using Paste.

This menu item corresponds to clicking the toolbar graphic or typing the Ctrl+C keyboard shortcut.

Paste
Select this to paste the item or object that you cut or copied to the clipboard.

This menu item corresponds to clicking the toolbar graphic or typing the Ctrl+V keyboard shortcut.

Paste Unformatted Text
Select this to paste the text, which you cut or copied to the clipboard, so that it does not retain its original formatting. The pasted text will use the default font style instead.

This menu item corresponds to typing the Ctrl+Shift+V keyboard shortcut.
Paste As
Select this to paste text that you cut or copied to the clipboard as one of the following:

- **Unformatted Unicode Text**
  Use this to paste text from the clipboard and remove its original unicode formatting.

- **Unformatted Text**
  Use this to paste text from the clipboard and remove its original formatting.

Delete
Select this to delete the selected object or item.

This menu item corresponds to typing the Del key.

Find
Select this to search for text within your title, including "behind the scenes" text for menus, hyperlinks, and buttons and actions, for example. When you select this menu item, the Find window opens. Type the word or phrase you want to find in the Find what field and click Find to find words or phrases. Enable Title Contents if you want to search within the contents of your title, enable Notes if you want to search within the notes in your title, and enable Object Name to search for objects by name.

This menu item corresponds to clicking the toolbar graphic or typing the Ctrl+F keyboard shortcut.

Find Next
Select this to find the next instance of the word or phrase for which you are searching.

This menu item corresponds to clicking the toolbar graphic or pressing F3.

Replace
Select this to search and replace the text specified in the Find window.

This menu item corresponds to typing the Ctrl+H keyboard shortcut.

Add menu
Use the Add menu to add objects to your title.

Assignable Unit
Select this to add an assignable unit to your title. For details about adding assignable units, see Adding an assignable unit.

This menu item corresponds to typing the Ctrl+0 keyboard shortcut.

See also:  Working with Assignable Units

Chapter
Select this to add a chapter to your title.

See also:  Working with Chapters

This menu item corresponds to clicking the toolbar graphic or typing the Ctrl+1 keyboard shortcut.

Section
Select this to add a section to your title.

See also:  Working with Sections
This menu item corresponds to clicking the toolbar graphic or typing the **Ctrl+2** keyboard shortcut.

**Page**
Select this to add a page to your title.

**See also:**  [Working with Pages](#)

This menu item corresponds to clicking the toolbar graphic or typing the **Ctrl+3** keyboard shortcut.

**Object**
Select this to add an object to your title.

**See also:**  [Adding Objects to Your Title](#)

Use the **Add > Object** submenu to add the following objects. These menu items correspond to clicking the associated toolbar graphic or typing the keyboard shortcuts listed below:

- **Animation** (Ctrl+9)
- **Audio** (Ctrl+Shift+0)
- **Button** (Ctrl+Shift+1)
- **Document** (Ctrl+Shift+2)
- **Equation** (Ctrl+Shift+3)
- **External HTML** (Ctrl+Shift+4)
- **Image** (Ctrl+Shift+5)
- **IPIX image** (Ctrl+Shift+6)
- **Menu** (Ctrl+Shift+7)
- **Progress bar** (Ctrl+Alt+9)
- **Reference list** (Ctrl+Shift+8)
- **Table of contents** (Ctrl+Shift+9)
- **Text block** (Ctrl+Alt+0)
- **Video** (Ctrl+Alt+1)

Use the **Add > Object > Form Object** submenu to add the following objects. These menu items correspond to clicking the associated toolbar graphic or typing the keyboard shortcuts listed below:

- **Form** (Ctrl+Alt+2)
- **Radio button group** (Ctrl+Alt+3)
- **Radio button** (Ctrl+Alt+4)
- **Check box** (Ctrl+Alt+5)
- **Entry field** (Ctrl+Alt+6)
- **Drop-down list** (Ctrl+Alt+7)
- **List box** (Ctrl+Alt+8)
**Action**
Select this to add an action to your title.

*See also:* [Adding an action](#)

This menu item corresponds to clicking the toolbar graphic or typing the **Ctrl+4** keyboard shortcut.

**Group**
Select this to add a group to your title.

*See also:* [Grouping and Ungrouping Objects](#)

This menu item corresponds to clicking the toolbar graphic or typing the **Ctrl+5** keyboard shortcut.

**Test**
Select this to add a test to your title.

*See also:* [Creating a test](#)

This menu item corresponds to clicking the toolbar graphic or typing the **Ctrl+6** keyboard shortcut.

**Test Section**
Select this to add a test section to your title. This menu item is available if you have a test in your title.

*See also:* [Adding sections to a test](#)

This menu item corresponds to clicking the toolbar graphic or typing the **Ctrl+7** keyboard shortcut.

**Question**
Select this to add a question to your title.

*See also:* [Adding Questions](#)

This menu item corresponds to clicking the toolbar graphic or typing the **Ctrl+8** keyboard shortcut.

**Survey**
Select this to add a survey to your title.

*See also:* [Creating a survey](#)

This menu item corresponds to clicking the toolbar graphic or typing the **Alt+6** keyboard shortcut.

**Survey Question**
Select this to add a survey question to your title.

*See also:* [Adding Survey Questions](#)

This menu item corresponds to clicking the toolbar graphic or typing the **Alt+8** keyboard shortcut.

**Layout menu**
Use the **Layout** menu to manage the arrangement of objects and text used in your title.
**Align**  
Select this to align selected objects to the direction you want. These menu items are available if multiple objects are selected. Use the Layout > Align submenu to select from the following directions. These menu items correspond to clicking the associated toolbar graphic.

- **Left**
- **Right**
- **Top**
- **Bottom**
- **Horizontal center**
- **Vertical center**

*See also:* Aligning objects

**Center**  
Select this to center the selected objects within the page. These menu items are available if at least one object is selected. Use the Layout > Center submenu to select from the following centering options. These menu items correspond to clicking the associated toolbar graphic:

- **Horizontal**
- **Vertical**

*See also:* Centering objects on a page

**Space Evenly**  
Select this to space several objects evenly on a page. These menu items are available if more than two objects are selected. Use the Layout > Space Evenly submenu to select from the following spacing options. These menu items correspond to clicking the associated toolbar graphic.

- **Across**
- **Down**

*See also:* Spacing objects evenly

**Make Same Size**  
Select this to size objects consistently on a page. These menu items are available if multiple objects are selected. Use the Layout > Make Same Size submenu to select from the following sizing options. These menu items correspond to clicking the associated toolbar graphic.

- **Width**
- **Height**
- **Both**

*See also:* Making objects the same size

**Page Layouts**  
Select this to manage the available page layouts. You can add your own layouts to the list, customize the pre-defined layouts, and import and export layouts.

When you select this menu item, the Page Layouts window opens. Use this window to:

- **Replace layout with current page layout** modifies the selected layout to match the current page layout of objects.
- **Add new layout from current page layout** creates a new layout based off the layout of objects on the current page.
- **Import Layout** launches the Open window to add layouts to the list.
- **Export Layout** launches the Save As window to save and name the file.
Delete Layout deletes the selected user-created layout. You cannot delete the predefined layouts.

See also: Using Page Layouts

Tools menu
Use the Tools menu to run checks, access wizards, and use tools to prepare your title for publishing.

Error Check
Select this to check for errors within your title. For example, if you have placed a Next Page button on the last page of your title, Lectora will issue an error indicating that you have a button with an invalid destination.

See also: Running an Error Check

508 Compliance Check
Select this to check that your title is complaint with Section 508 of the Rehabilitation Act, Paragraph 1194.22 (a) through (p) for Web-based Intranet and Internet Information and Applications. The 508 Compliance Checker only applies to titles that will be published to a web-based format (HTML, CourseMill, AICC/Web-based, and SCORM/Web-based).

See also: Checking for 508 Compliance

Import from Existing Title
Select this to save time by importing objects from existing Lectora titles. You can import entire titles, chapters, sections, and pages, as well as individual objects and text blocks.

See also: Importing Objects from Existing Lectora Titles

Spell Check
Select this to check the spelling of all text in your title, including all text blocks, question feedback, messages, button text, and menu items.

Use the Tools > Spell Check submenu to select whether to check the Current Page or the Entire Title. You can also specify spelling Options such as whether to consider case-sensitivity.

See also: Checking Spelling

Shapes/Lines
Select this to add shapes and lines to your title. These objects can be used to place emphasis on a particular part of a page. The images are created in Windows Media Format (.wmf) enabling you to resize them without losing quality.

Use the Tools > Shapes/Lines submenu to select from the following options. These menu items correspond to clicking the associated toolbar graphics within the Shape Bar. Additional shapes such as block arrows, triangles, trapezoids and parallelograms are available from the Block Arrow Bar, Triangle Bar, Trapezoid Bar, and Parallelogram Bar.

- Set line/file properties
- Line
- Arrow
- Two way arrow
- Rectangle
- Rounded rectangle
- Diamond
Library Object
Select this to organize various objects in one location so you can easily share them with others. The objects are saved in a Library folder. The default location of the Library folder is `C:\ Program Files\Trivantis\Lectora\Library`. This location can be changed and kept on a shared network drive.

Use the Tools > Library Object submenu to select from the following options:

- Save current selection as Library Object
- Insert Library Object from file

See also: Working with Library Objects

Add a Note
Select this to add a note to your title to share ideas or provide instructions.

See also: Adding a Note

Variable Manager
Select this to manage the variables used in your title. Variables are objects within a Lectora title that enable you to store, modify, and test values of numbers or strings during the runtime of a published title. You can use variable values to conditionally perform actions in a title or set the contents of a text block.

See also: Using the Variable Manager

Resource Manager
Select this to view a list of the resources in your title. Resources in Lectora are the actual files that are used for objects such as images, audio and video. The name of the file that the resource represents can be changed, and it lists all instances of the resource in the title. Selecting one of the occurrences in the list presents a preview of the resource.

See also: Managing Resources

Media Library Organizer
You can use the Media Organizer to find and share digital media files that are on your computer or shared among team members on a network folder. The Media Organizer makes it easy to find the media you are looking for by organizing the files into categories. You can add and remove categories and media as your media library grows.

See also: Working with the Media Library Organizer
Audio Recording Tool*
Select this to record and insert audio in your title. Select from the following audio recording formats:

- Flash Audio
- Windows Media Audio
- Real Audio
- WAV audio

See also: Creating New Media Using the Publishing Suite Tools

*This tool is only available with the Lectora Professional Publishing Suite. If you are using the Lectora Enterprise addition, this option will not appear in the Tools menu.

Background Wizard
Select this to start a wizard that helps you add backgrounds to your title. Backgrounds enhance the appearance of your title.

See also: Creating Custom Backgrounds

Button Wizard
Select this to start a wizard that helps you add buttons to your title. Choose from custom color buttons with text or stock buttons from clipart.

See also: Creating Custom Buttons

Certificate Tool
Create and customize certificates using the Certificate Tool. The tool guides you through customizing a certificate to add to your title. When completed, the certificate is added as a page within your title.

See also: Creating Custom Certificates

New Animation Tool*
Select this to add an animation to your title. The New Animation Tool allows you to manage the animation frame-by-frame.

See also: Creating New Media Using the Publishing Suite Tools

*This tool is only available with the Lectora Professional Publishing Suite. If you are using the Lectora Enterprise addition, this option will not appear in the Tools menu.

New Image Tool*
Select this to start Lectora’s Image Editor. The Image Editor allows you to create new images and modify existing ones.

See also: Creating New Media Using the Publishing Suite Tools

*This tool is only available with the Lectora Professional Publishing Suite. If you are using the Lectora Enterprise addition, this option will not appear in the Tools menu.

Page Numbering Tool
Select this to number pages throughout your title.

See also: Automatically Numbering Pages

PowerPoint Slide Tool*
Select this to import PowerPoint slides into your title.

*This tool is only available with the Lectora Professional Publishing Suite. If you are using the Lectora Enterprise addition, this option will not appear in the Tools menu.
Screen Capture Tool*
Select this to capture and save a portion of the visual image of your screen. This is valuable when creating step-by-step software demonstrations, displaying examples of Web pages, or capturing an event on your system. After you’ve captured a screen image, you can manipulate it in a variety of ways.

See also: Creating New Media Using the Publishing Suite Tools

Screen Recording Tool*
Select this to record screen activity and save it in one of the following video recording formats:
- Flash Video
- Windows Media Video
- Real Video
- AVI Video
- Animated GIF (without audio)

See also: Creating New Media Using the Publishing Suite Tools

Translation Tool
Select this to extract and place text from your title into a rich text format (RFT) file. This enables you to translate the text into another language using an RTF editor, such as Microsoft Word or WordPad. The translated text can then be imported into your title.

See also: Translating Your Title's Text

Mode menu
Use the Mode menu to switch between the various modes.

See also: Using Lectora's Modes

Edit
Select this to return to the working mode in which you create your title.

This menu item corresponds to clicking the toolbar graphic or typing the F12 key.

Run
Select this to view your title with all buttons, links, and actions active.

This menu item corresponds to clicking the toolbar graphic or typing the F10 key.
Preview
Select this to preview your title in a centered background outside of the Lectora interface. All buttons, links, and actions are active.

This menu item corresponds to clicking the toolbar graphic or typing the F11 key.

Debug
Select this to view your title with all button, links, and actions active. Actions performed on a page are recorded in a Debug window along with variable values and additional information.

Preview in Browser
Select this to preview your title in a chosen browser. All actions on the page are active, but because only a single page is published, navigation to other pages will not function.

This menu item corresponds to clicking the toolbar graphic or typing the F9 key.

Publish menu
Use the Publish menu to select the appropriate publishing format. Lectora will automatically perform an error check before publishing to the chosen format. The publishing properties will appear when the title is free from errors.

Publish to Single File Executable
Select this to publish your title as a self-contained executable file. This option compacts the entire title and all supporting files into a single file for easier distribution, for example, as a downloaded file from the Web.

See also: Publishing to a single file executable

This menu item corresponds to typing the F2 key.

Publish to CD-Rom
Select this to publish your title for writing to a CD. This option compresses the entire title and all supporting files into a single file and creates an auto-start file that will automatically launch the title when the CD is placed into a CD-ROM drive.

See also: Publishing to CD-ROM

This menu item corresponds to typing the F6 key.

Publish to HTML
Select this to publish your title to HTML so you can post the resulting pages on the Web.

See also: Publishing to HTML

This menu item corresponds to typing the F8 key.

Publish to CourseMill
Select this to publish your title so that it is compatible with the CourseMill Enterprise learning management system offered by Trivantis.

See also: Publishing to CourseMill

This menu item corresponds to typing the Ctrl+F2 keyboard shortcut.

Publish to AICC/Web-Based
Select this to publish your title so that it is compatible with the Aviation Industry CBT Committee (AICC). AICC was
established in 1988 to define standards on how Computer Managed Instruction (CMI) systems should operate in presenting title materials to students. For the latest specifications, documents, and explanations of terms, refer to the official AICC website at [http://www.aicc.org](http://www.aicc.org).

**See also:** Publishing to AICC

This menu item corresponds to typing the Ctrl+F6 keyboard shortcut.

**Publish to SCORM/Web-Based**
Select this to publish your title so that it is compatible with the Shareable Content Object Reference Model (SCORM). SCORM is a set of interrelated technical specifications built upon the work of the AICC, IMS, and IEEE to create a unified content model for Web-based learning content. For the latest specifications, documents, and explanations of terms, refer to the official SCORM website at [http://www.adlnet.gov](http://www.adlnet.gov).

**See also:** Publishing to SCORM

This menu item corresponds to typing the Ctrl+F8 keyboard shortcut.

**Publish to LRN**
Select this to publish your title so that it is compatible with the Learning Resource Interchange (LRN). LRN is a Microsoft-specified content interchange descriptor that provides to content creators a standard way of identifying, sharing, updating, and creating online content.

**See also:** Publishing to LRN

**Publish to SCORM/Disconnected**
Select this to publish your title so that it is compatible with the Shareable Content Object Reference Model (SCORM) for use in an off-line environment. SCORM is a set of interrelated technical specifications built upon the work of the AICC, IMS, and IEEE to create a unified content model for Web-based learning content. For the latest specifications, documents, and explanations of terms, refer to the official SCORM website at [http://www.adlnet.gov](http://www.adlnet.gov)

**See also:** Publishing to SCORM Disconnected

**View menu**
Use the View menu to select the various toolbars and design tools (grid, rulers, and guides) that you want displayed or used within the Lectora interface. The toolbars in the submenu that have a check mark in front of their name will be shown in the interface. You can change the display status of each toolbar by selecting the menu item with that toolbar’s name.

**Toolbars**
Select this to choose which toolbars you want to be displayed in the user interface. When you select a toolbar for the user interface, a check appears to the left of the View > Toolbar sub-menu item. Choose from the following toolbars:

- Insert Toolbar
- Text Toolbar
- Standard Toolbar
- Status Bar
- Layout Bar
- Mode Bar
- Form Bar
- Shape Bar
- Block Arrow Bar
- Triangle Bar
- Trapezoid Bar
● Parallelogram Bar

See also: Using the toolbar area

Status Bar
Select this to choose the information you want displayed in the Status Bar. The current zoom setting is displayed by default, and additionally the x- and y- coordinates, width and height if an object is selected. When you select the information to display, a check appears to the left of the View > Status Bar sub-menu item. Choose from the following status bar display options:

- **Current Position** Displays the current position of the mouse cursor within an image.
- **Color at Cursor Position** Displays values of the red (R), green (G), and blue (B) color codes.

See also: Using the Status bar

Show Grid
Select this to display the grid in the work area. The grid is an alignment and spacing guide that is displayed as a page background. When used with Snap to Grid, you can move objects to the nearest grid increment for proper alignment. When you select to show the grid, a check appears to the left of the View > Show Grid menu item.

See also: Specifying Grids and Guides preferences

This menu item corresponds to typing the Ctrl+G keyboard shortcut.

Show Rulers
Select this to display the horizontal and vertical rulers to the left and top of the work area. Displaying the rulers allows for the creation of guides. When used with Snap to Guide, you can move objects to the nearest guide for proper alignment. When you select to show the rulers, a check appears to the left of the View > Show Rulers menu item.

See also: Specifying Grids and Guides preferences

This menu item corresponds to typing the Ctrl+R keyboard shortcut.

Show Guides
Select this to display guides in the work area. Guides are horizontal and vertical lines that originate from the ruler and can be placed anywhere on the page for object alignment. When you select to show guides, a check appears to the left of the View > Show Guides menu item.

See also: Specifying Grids and Guides preferences

This menu item corresponds to typing the Ctrl+E keyboard shortcut.

Snap to Grid
Select this to move objects to the nearest grid increment for proper alignment. When you select to snap to grid, a check appears to the left of the View > Snap to Grid menu item.

See also: Specifying Grids and Guides preferences

Snap to Guides
Select this to move objects to the nearest guide. When you select to snap to guide, a check appears to the left of the View > Snap to Guide menu item.

See also: Specifying Grids and Guides preferences
**Zoom**
Select this to change the zoom level. Using the `Zoom > Zoom` sub-menu, you can zoom in up to 400% or zoom out to 25% of the actual page size. This feature is only available in Edit mode.

Selecting the `Zoom > Zoom In` sub-menu item corresponds to clicking the `Ctrl+Space Bar` keyboard shortcut. Selecting the `Zoom > Zoom Out` sub-menu item corresponds to clicking the `Alt+Space Bar` keyboard shortcut.

*See also:* [Using the Status bar](#)

**Refresh**
Select this to refresh or update the currently displayed page.

This menu item corresponds to typing the F5 key.

**Help menu**
Use the Help menu to access the available help and to view information about your version of Lectora.

*See also:* [Accessing help](#)

**Contents**
Select this to open the Lectora Information Center. You can search words in the Index, select tasks from the Contents or search for words or phrases in the Information Center.

This menu item corresponds to clicking the toolbar graphic or typing the F1 key.

*See also:* [Accessing help](#)

**Video Tour**
Select this to launch a complete video tour of Lectora, starting with an introduction to Lectora. The tour starts automatically or you can select individual videos you want to view.

**Video Help Agents**
Instead of viewing the entire video tour, directly select the individual video you want to view.

You can also launch the individual video help agents directly from many of the properties windows in Lectora. When you see the Video Agent graphic 🎥 within a window, click on it to view the help agent corresponding to the property you are setting.

**Community Forum**
Select this to launch Lectora’s online community forum at [http://community.trivantis.com](http://community.trivantis.com). Within the community forum you can exchange tips, ask questions, and find out about product updates directly from Trivantis developers and other Lectora users. An Internet connection is required to access the community forum.

**Lectora Online**
Select this to launch the online, PDF version of the Lectora Information Center. The PDF document can be saved to your computer or even printed.

**About Lectora**
Select this to display product information about the version of Lectora you are using. View the following information:
- Serial number
- Version number, along with the service pack and build levels
- Copyright notice

**Register**
If you have not yet registered your copy of Lectora, this option will appear within the Help menu. Select this to register Lectora.

See also: Registering Lectora

Using the toolbar area
Toolbars can be rearranged within the toolbar area. Select the far left side of the toolbar, and while holding the right mouse button down, drag the toolbar to the new location within the toolbar area. If the toolbar is dragged toward the left-hand pane or work area of the Lectora interface, it will float. The following toolbars can be rearranged within the toolbar area:

Standard toolbar
Contains commands for managing your files, such as opening an existing file and cutting and paste content.

Text Toolbar
Contains commands for editing and working with text.

Modes Toolbar
Contains commands for switching between Lectora’s modes.

Insert Toolbar
Contains commands for inserting objects into your title.

Alignment Toolbar
Contains commands for aligning objects.

Arrow Toolbar
Contains commands for creating arrows of the type chosen.

Trapezoid Toolbar
Contains commands for creating trapezoids of the type chosen.

Triangle Toolbar
Contains commands for creating triangles of the type chosen.

Parallelogram Toolbar
Contains commands for creating parallelograms of the type chosen.

Shapes/Line Toolbar
Contains commands for creating and editing shapes and lines.

Form Toolbar
Contains commands for inserting form objects into your title.

Using the left-hand pane
The left-hand pane displays the entire structure of your title. Use this pane to access object properties by double-clicking on the object icon. You can cut, copy and paste objects directly within the left-hand pane or drag and drop objects to reorganize your title. When an object is selected in the left-hand pane, focus is placed on that object within the work area to the right. Hold down the Shift key to select a list of objects, or hold down the Ctrl key to select multiple objects not in a list.

While in Edit mode, use your keyboard's Page Up and Page Down keys to navigate between pages in your title.

See also: Showing visibility check boxes in left-hand pane
Using Lectora's Modes

Using the work area
The work area enables you to interactively manage the layout of objects that make up your title. Drag and drop images, audio, video and other supported media types directly to the work area. Use your mouse to drag and move items on a page, and double-click on an object to reveal its properties. Each object that is visible within the work area will also have a representation in the left-hand pane.

See also: Supported Media Types

Using the Status bar
The status bar provides information on the current position of the mouse cursor on the page, as well as information about the currently selected object. The status bar is divided into the following sections:

Message area
Located in the lower-left corner, this area displays status messages and tool descriptions. For example, when you place your cursor over a toolbar graphic, the description of the tool is displayed in the message area.

View percentage
Displays the current zoom value. Select a zoom value to change the current view.

Object coordinates
When an object is selected, the X and Y coordinates of the object will be displayed here. Coordinates are relative to the top-left corner of the page. Type a numeric value directly into the X or Y coordinate areas to reposition the object to the specified location.

Object width and height
When an object is selected, the width and height of the object will be displayed here. Type a numeric value directly into the width or height areas to resize the object to the specified dimensions.

Cursor position
Displays the X and Y coordinates of the cursor position. Coordinates are relative to the top-left corner of the page.

Color at cursor position
Displays the RGB color value.

See also: Moving and Resizing Objects
Setting Lectora Preferences
Use the Preferences window to specify how you want your version of Lectora to perform. For example, select whether or not you want the program to perform auto save or auto-update functions. Preferences must only be set once, and persist with each title you create.

You can complete the following within the Preferences window:

**General tab**
- Show visibility check boxes in left-hand pane
- Configure the left-hand pane
- Show HTML published object names in object properties
- Use resource names as object names
- Enable spell check while typing
- Show text formatting marks
- Use default IMS metadata when creating objects
- Specify the location of your media library
- Specify your user name

**Editors tab**
- Set editor preferences

**CourseMill tab**
- Set CourseMill preferences

**Auto Save tab**
- Set auto save preferences

**Auto Update tab**
- Specify when to check for program updates

**Notes tab**
- Specify notes preferences

**Grid/Guides tab**
- Specify grids and guides preferences

**Publish Strings tab**
- Specify publish strings preferences

**Publish Messages tab**
- Specify publish messages preferences

**Form Elements tab**
- Specify form elements preferences

**Hotkeys tab**
- Specify hotkeys preferences

**Showing visibility check boxes in left-hand pane**
Choose whether to show visibility check boxes in the left-hand pane. The left-hand pane will display an eye graphic next to the object that is visible. To turn visibility off, click on the eye and the graphic will disappear in the left-hand pane, and the object will be made invisible within the work area. This could be helpful when working with multiple objects layered on a page. For example, suppose you have two hyperlinks on a page that will display the definitions of the hyperlinked words. You might want these definitions to appear in the same place on the page, but only once the user has clicked on the corresponding hyperlink. To make it easy to work with these definitions, you can uncheck the visibility icon for one of them, while working with the other, and vice versa. The visibility icons do not affect your title’s functionality while viewing it in Run or Preview mode, and does not affect the published title.

Visibility states are preserved between sessions of Lectora.

To enable the visibility-state icon in the left-hand pane:
1. Select **Preferences** from the **File** menu. The Preferences window opens. Click the **General** tab if the Preferences window...
is not already opened to this tab.

2. Check the **Show visibility check boxes in the left-hand pane** box.

3. Click **OK**.

The visibility state icon is enabled in the left-hand pane. While in Edit mode, an open eye displays the corresponding object on the page. A closed eye conceals the corresponding object from view. Visibility states are preserved between sessions of Lectora.

**Configuring the left-hand pane**

By default, the background in the left-hand pane uses a gradient effect. You can change it to a solid background. The gradient color is determined by the color scheme set within your computer's Display Properties located in the Control Panel. If disabled, Lectora will display a solid white left-hand pane.

To change to a solid white background in the left-hand pane:

1. Select **Preferences** from the **File** menu. The Preferences window opens. Click the **General** tab if the Preferences window is not already opened to this tab.

2. Uncheck the **Use color gradient background in the left-hand pane** box.

3. Click **OK**.

The background in the left-hand pane changes to a solid white color.

**Showing HTML published object names in object properties**

You can display the corresponding HTML object name for referencing within external HTML code. Every object, action and page used within your title will have a unique HTML name. When this option is enabled, the HTML object name will appear in the upper-right corner of the **General** tab within every objects’ Properties window. This preference is initially disabled.

To show HTML published object names in the Properties window:

1. Select **Preferences** from the **File** menu. The Preferences window opens. Click the **General** tab if the Preferences window is not already opened to this tab.

2. Check the **Show HTML published object names in object properties** box.

3. Click **OK**.

**Using resource names as object names**

You can automatically assign the file name (minus the extension) to an object as the object name. For example, with this option selected, if you drag-and-drop MyImage.jpg into your title, the image will appear listed in the left-hand pane as MyImage.

To enable automatically assigning the file name to an object:

1. Select **Preferences** from the **File** menu. The Preferences window opens. Click the **General** tab if the Preferences window is not already opened to this tab.

2. Check the **Use resource names for object names** box.

3. Click **OK**.

**Enabling spell check while typing**

You can have Lectora automatically check the spelling of text as you type it. Misspelled words will appear underlined in red. The red underlines will only be visible while the text block is being edited. If an underlined word is not misspelled, it can be added to the dictionary. You can also right-click on underlined words to select from a list of suggested spellings. Spelling
changes you add to the dictionaries will be reflected in the automatic spell checking results.

See also: Checking Spelling

To enable automatic spell checking:
1. Select Preferences from the File menu. The Preferences window opens. Click the General tab if the Preferences window is not already opened to this tab.
2. Check the Spell check text objects while typing box.
3. Click OK.

Showing text formatting marks
You can show text formatting marks within text blocks, such as paragraph returns, hard and soft returns, spaces, tabs, and page breaks.

To show text formatting marks:
1. Select Preferences from the File menu. The Preferences window opens. Click the General tab if the Preferences window is not already opened to this tab.
2. Check the Show text formatting marks box.
3. Click OK.

To quickly enable and disable this feature while working within your title, right-click on a text block and select Show Text Formatting Marks. When enabled, a check mark appears next to the Show Text Formatting Marks menu item.

Using default IMS metadata when creating objects
To save time, you can automatically define all the objects that you add to your title to have IMS metadata data elements (IEEE LTSC LOM). This eliminates having to manually define each object's IMS metadata data element.

To select the use default IMS metadata preference:
4. Select Preferences from the File menu. The Preferences window opens. Click the General tab if the Preferences window is not already opened to this tab.
5. Check the Use default IMS metadata when creating objects box.
6. Click OK.

See also: Including metadata for an object

Specifying the location of your media library
Use the Media Library Folder field to specify the location of your shared media library. When you install Lectora, the Lectora ClipArt folder is the default directory for the Media Library Organizer. This location can be changed to a local or network folder where media intended for reuse is stored. The media can then be accessed from Lectora and added to any title.

If you specify a different location for your Media Library, and still want to be able to access the clip art installed with Lectora, you should copy or move the entire ClipArt (C:\Program Files\Trivantis\Lectora\ClipArt) directory from Lectora's installation path and paste it into your new Media Library location.

See also: Working with the Media Library Organizer

To specify the location of your Media Library folder:
1. Select Preferences from the File menu. The Preferences window opens. Click the General tab if the Preferences window
2. Specify the folder in the **Media Library Folder** field or click the **Browse** button to navigate and select the folder.

3. Click **OK**.

**Specifying your user name**
If you create notes to add to your title, your user name will appear on them. Notes are helpful when working in a team environment, and can be placed on pages as reminders or additional information. Notes are only displayed in Lectora's Edit mode and are not visible in published titles.

*See also:* Specifying notes preferences
Adding a Note

To specify your user name:
1. Select **Preferences** from the **File** menu. The Preferences window opens. Click the **General** tab if the Preferences window is not already opened to this tab.

2. Specify your user name in the **User Name** field.

3. Click **OK**.

**Setting editor preferences**
You can specify the editor applications used by Lectora to externally edit resource files used within a title. For each type of editable resource supported by Lectora (*images, audio, video, animations, documents*, and *text files*), you can define an external application that edits that resource type.

When you install the Lectora Professional Publishing Suite, the corresponding Suite tool editors are automatically populated on this tab. If you install the Lectora Publisher (also known as the Lectora Enterprise Edition), you must specify your own editing applications for the different media types.

Within Lectora, you can edit the resource by selecting the **Edit** option from the object’s right-click menu or by selecting the **Edit** button from the object’s properties window. This action will then launch the defined editor for the resource type, with the current resource as the editor’s target. If you save changes to the resource in the external editor, Lectora will automatically reload the modified resource when you return focus to the Lectora title.

Until you have defined a resource editor for a particular resource type, the **Edit** options discussed above will be disabled.

1. Select **Preferences** from the **File** menu. The Preferences window opens. Click the **Editors** tab.

2. For each resource type, type the full file path and name of the corresponding editor’s executable file or use the browse button to locate and select it.

3. Click **OK**.

**Setting CourseMill preferences**
CourseMill® is a learning management system designed and developed by Trivantis Corporation. If you are using a CourseMill server, the information specified on this tab will enable you to easily transfer published titles to the server. Specify the Web address of the CourseMill server and the location on the CourseMill server where the CourseMill system resides.

If you are not using a CourseMill server, this tab can be ignored.

To specify the location of the CourseMill server:
1. Select **Preferences** from the **File** menu. The Preferences window opens. Click the **CourseMill** tab.
2. In the **CourseMill Host** field, specify the Web address of the CourseMill server. By default, this value is **www.CourseMill.com**.

3. In the **Path to CourseMill on Host** field, specify the location on the CourseMill server where the CourseMill system resides. By default, this value is set to `/`. If the CourseMill system was installed with the default settings, enter `coursemill` in this field.

4. Click **OK**.

### Setting auto save preferences

You can specify how Lectora automatically saves your work. The Auto Save feature minimizes the loss of work due to unexpected computer issues or power outages.

Auto Save defaults to on and saves a title every five minutes. The on/off status can be changed, as well as the amount of minutes between every save occurrence. There is also a **Use recovery file for Auto Save** option that is selected by default.

Do not rely on **Auto Save** as a substitute for regularly saving your work by clicking the Save toolbar graphic.

**See also:** [Saving a Title](#)

To specify your auto save preferences:

1. Select **Preferences** from the **File** menu. The Preferences window opens. Click the **Auto Save** tab.

2. By default, Lectora saves a title every five minutes. Clear the **Auto Save on/off** check box to disable the Auto Save feature. Use **Save every n minutes** to specify how often you want your title to be automatically saved.

3. If the **Use recovery file for Auto Save** option is selected, Lectora will not overwrite the original .awt title, but instead save it to a temporary file, which is identified by a tilde (~), at each time interval specified. When you save the title, Lectora deletes the original .awt file in the directory and renames the temporary file.

   If **Use recovery file for Auto Save** option is not selected, Lectora saves to the original file at each time interval specified.

4. Click **OK**.

### Specifying when to check for program updates

You can specify when Lectora should automatically check for program updates. If an update is available, Lectora will notify you. Follow the on-screen instructions to download and update your version of Lectora.

You must have administrative rights on your computer to set this feature.

To specify your program update preferences:

1. Select **Preferences** from the **File** menu. The Preferences window opens. Click the **Auto Update** tab.

2. Enable **Check for program updates every n days** to have Lectora check for updates and specify the number of days.

3. If you want to check for updates now, click the **Check for Updates Now** button.

4. Click **OK**.

### Specifying notes preferences

Add notes throughout a title as a way to share ideas or provide instructions to the other authors of the title. You can customize
the way your notes will appear within your title.

See also: Adding a Note

To use the Notes tab on the Preferences window:
1. Select Preferences from the File menu. The Preferences window opens. Click the Notes tab.

2. In the Default Note Color field, specify the default note color as one of the following:
   - Emergency Red!
   - Pink
   - Yellow
   - White
   - Blue
   - Green

3. In the Text Style field, specify the text style to use when writing notes.

4. Click OK.

Specifying grids and guides preferences
You can specify preferences for grid and guide features. The grid is an alignment and spacing framework that is displayed as a page background. Guides are horizontal and vertical lines which originate from the ruler and can be placed anywhere on a page for object alignment. These are useful for precisely aligning objects such as images, test questions or form objects. The Snap to Grid feature enables you to move Lectora-created objects to the nearest grid increment. The Snap to Guides feature enables you to move Lectora-created objects to the nearest guide increment.

To specify grid and guide preferences:
1. Select Preferences from the File menu. The Preferences window opens. Click the Grid/Guides tab.

2. For grid preferences, use the Color drop-down list to select the color to use for grids. Select the Show Grid check box if you want the grid displayed in the background of the work area. Select the Snap to Grid check box to enable the Snap to Grid feature. When the Snap to Grid check box is enabled, objects you move will be pulled toward the closest grid point. This is useful for accurate placement of objects. Use the Grid Spacing field to specify the grid spacing in pixels. The default is 20.

3. For guide preferences, use the Color drop-down list to select the color to use for guides. Select the Show Rulers check box to show rulers along the top and left-side of the work area. Select the Show Guides check box to show guides in the content area. Click the Snap to Guides checkbox to enable the Snap to Guides feature. When the Snap to Guides check box is enabled, objects you move will be pulled toward the closest guide lines. This is useful for accurate placement of objects.

   Click within a ruler and drag the guide onto the page. The guides can be removed from a page by dragging each off the page while holding down the Ctrl key on your keyboard.

4. Click OK.

Specifying publish strings preferences
You can customize the text used in the Lectora runtime. Change the text displayed within the Test Results window, content generated emails, and some program buttons. For example, you can change the FAILED text message, that is displayed within test results to students with a non-passing test score, to more sensitive terminology. Publish strings can also be changed here if you are producing content written in a language other than English.

To specify Publish String preferences:
1. Select Preferences from the File menu bar. The Preferences window opens. Click the Publish Strings tab.
2. Use the **String Set** drop-down to select the string set that you want to customize.

   Additional custom Publish String sets can be created, which enables you to select from a list of predefined Publish String sets when publishing titles for different audiences and languages. Click **Add** to add a new string set. Click **Import** to import a text file of a string set. Click **Export** to save a string set to a text file. This enables you to translate and change the publish strings of the exported text file using any text editor and import them back into Lectora. Click **Delete** to delete a string set.

3. Select the row you want to change and alter the text in the **Value** column as necessary. The **Description** column lists instances at which the corresponding text in the **Value** column will be displayed. The **Value** column lists Lectora default text that is displayed to the student during the corresponding instance in the **Description** column.

4. Change the text and click **OK** to return to the Publish Strings tab.

5. Repeat Steps 3 through 5 as necessary.

6. Click **OK**.

**Specifying publish messages preferences**

You can specify the type of messages that are displayed during an error check. Selections made here will determine the information is displayed during an error check initiated from the **Tools** menu or by publishing.

To determine which publish messages should be displayed during an error check:
1. Select **Preferences** from the **File** menu bar. The Preferences window opens. Click the **Publish Messages** tab.

2. Select the **Show only errors and warnings** check box if you want informational messages (displayed in black) to be omitted from the Publish and Error Check windows.

3. Select the **Show HTML Warnings** check box to enable the selection of HTML-specific warnings. Select from the following warning options:

   | Show warnings for resource sizes | Select this to display warnings for any resources used within the title that are larger than 128Kb in size. |
   | Show warnings for unused resources/variables | Select this to display warnings for any resources (images, audio, video, and so on) and variables that are not used within the title. This can occur with resources that were added to the title but then later deleted. Lectora will ask during the error-check process if those unused resources and variables should be removed. |
   | Show warnings for Macintosh content | Select this to display warning messages for anything that might not display properly on a Macintosh computer. |

4. Click **OK**.

**Specifying form elements preferences**

You can use custom images for radio buttons and check boxes. Using custom images for these type of form elements will affect the appearance of test and survey questions, along with any individual radio buttons or check boxes that are added to a title. Select from the available images or import your own images.

To specify Form Elements preferences:
1. Select **Preferences** from the **File** menu bar. The Preferences window opens. Click the **Form Elements** tab.

2. Select the **Radio Buttons** check box to enable customizing the images for radio buttons. Use the **Selected** list to select an image to use for radio buttons that have been selected. Use the **Unselected image** list to select an image to use for
radio buttons that are not selected. Samples are displayed to the right.

To choose your own image, select **Custom Image** from the list. Locate and select the image you want to use and click **Open**.

3. Select the **Check Boxes** check box to enable customizing the images for check boxes. Use the **Selected** list to select an image to use for selected check boxes. Use the **Unselected image** pull-down list to select an image to use for unselected check boxes. Samples are displayed to the right.

To choose your own image, select **Custom Image** from the list. Locate and select the image you want to use and click **Open**.

4. Click **OK**.

**Specifying hotkeys preferences**

You can assign custom hotkeys to save time and be more efficient. Add new shortcut keys or replace the default shortcuts.

To assign custom hotkeys:
1. Select **Preferences** from the **File** menu bar. The Preferences window opens. Click the **Hotkeys** tab.

2. Select the category of the command containing the shortcut you want to add or change. Select from the following categories:
   - **File**
   - **Edit**
   - **Add**
   - **Layout**
   - **Tools**
   - **Mode**
   - **Publish**
   - **View**
   - **Help**
   - **Text**
   - **Other**

   The commands for each category are listed. The **Current keys** box lists the hotkeys defined for each command. The box under the commands list provides a brief description of each command.

3. Using the list of commands, click the command you want to update.

4. Place your cursor in the **Press new shortcut key** field. Using your keyboard, press the new shortcut sequence you want to add. Type a letter to add a Alt hotkey. Otherwise, press and hold the **Ctrl** key and type a letter to add a Ctrl hotkey.

   The key sequence you type is displayed in the **Press new shortcut key** field.

5. Click **Assign**.

   The new shortcut is added to the **Current keys** list.

   To remove a shortcut from the **Current keys** list, highlight the shortcut and click **Remove**.

   To remove all custom shortcuts and restore the Hotkey shortcuts to the default assignments, click **Reset all**.

6. Click **OK**.
Building a Title

This chapter explains how to start building your title using Lectora. If you are a novice Lectora user, it is a good idea to review the concepts discussed in How Lectora Works before building titles. When you understand the essentials behind Lectora, you will find it easier to use the information provided in this chapter.

In this chapter, the following topics are covered:
- Creating a Title
- Configuring Title Properties
- Saving a Title
- Saving a Title as a Template
- Working with Chapters
- Working with Sections
- Working with Pages
- Working with Assignable Units
- Using Page Layouts
- Working with Frames
- Using Lectora’s Modes
- How Lectora Organizes Your Content

Creating a Title

You must first create a title before you can start adding chapters, sections, pages, and media objects. This section describes how to create a title by one of the following ways:
- Create a title using the Title Wizard
- Create a new title (without the Title Wizard)
- Open an existing title
- Use a template

Creating a title using the Title Wizard

Use the Title Wizard to quickly generate titles with a pre-designed “look and feel”. The Title Wizard will ask you questions that will enable Lectora to automatically create a functional title for you, including pages, buttons, and navigation.

Follow these steps to create a title using the Title Wizard:
1. If the Lectora launch pad is not already displayed, do one of the following:
   - From the File menu, select New Title
   - Click the New Title toolbar graphic
   - Type Ctrl+N
2. Click the Title Wizard tab, if it is not already opened.
3. Select from one of the styles in the Title Wizard Gallery and click OK.
4. Respond to the on-screen questions and click Finish to create your title.

Your newly-created title is displayed in Edit mode and you can begin adding objects to complete its functionality.

Creating a new title

Follow these steps to create a new title:
1. If the Lectora launch pad is not already displayed, do one of the following:
From the File menu, select New Title
- Click the New Title toolbar graphic
- Type Ctrl+N

Click the New Title tab if the window is not already opened to this tab.

2. Enter the name of the new title in the New Title Name field and use the Choose Folder button to select a location to which to save the title. Notice how the New Title Location changes when you type in your New Title Name. The default location is C:\My Documents\My Titles\<title name>\<title name>.awt where <title name> is your new title name. Click OK to create the new title.

Your newly-created, blank title is displayed in Edit mode and you can begin adding objects to complete its functionality.

See also: Using Lectora's Modes

Opening an existing title

Follow these steps to open an existing title:

1. If the Lectora launch pad is not already displayed, do one of the following:
   - From the File menu, select Open an Existing Title
   - Click the Open toolbar graphic
   - Type Ctrl+O

   Click the Open Existing Title tab if the window is not already opened to this tab.

2. The window displays the last six titles that you have opened using Lectora. To open one of the listed titles, double-click the title from the Recently Used Files list (or select it and click OK.) Otherwise, use the Browse button to search for a title that does not appear in the list.

Your title is displayed in Edit mode and you can begin adding objects to complete its functionality.

See also: Using Lectora's Modes

Using a Template

Templates are a convenient way to store boilerplate versions of titles that can be used as a starting point for future titles that are created. For example, if your organization has a standard "look and feel" for a title that should be applied to all titles, you can create a template that contains the layout and all associated text and graphics for that title. You would then use this template when creating additional titles.

1. If the Lectora launch pad is not already displayed, do one of the following:
   - From the File menu, select New Title
   - Click the New Title toolbar graphic
   - Type Ctrl+N

   Click the Templates tab.

2. Use the list to select from a gallery of custom and predefined templates. Templates that you have created or imported are stored within the My Templates gallery. Select the iPhone gallery for predefined templates designed specifically for the iPhone and iPod Touch. Select a color gallery to access over 200 pre-installed templates. Color categories include:
   - Aqua
   - Blue
   - Brown
   - Gray
3. Select from one of the templates in the gallery and click OK. The New Title window opens.

4. Enter the name of the new title in the **New Title Name** field and use the **Choose Folder** button to select a location to which to save the title. The default location is *My Documents*\*My Titles*\*<title name>\*<title name>.awt*. Click **Finish** to create the new title.

Your newly created title is displayed in Edit mode and you can begin adding objects to complete its functionality.

*See also:*  
[Saving a title as a template](#)  
[Using Lectora's Modes](#)

### Configuring Title Properties

Title Properties are especially important. Within the Title Properties, you can set up the overall appearance of your title including page size and alignment, background colors and sounds, and default text styles. You can also specify the use of additional files, and specify the type of title you are creating. Settings made within the Title Properties will be applied to all pages within your title. These settings can be changed at any time by revisiting the Title Properties, or you can specify separate properties for individual chapters, sections or pages.

*See also:*  
[Working with Chapters](#)  
[Working with Sections](#)  
[Working with Pages](#)

You can complete the following within the Title Properties window:

- **General tab**
  - Change the name of your title
  - Change a title's page size and alignment

- **Background tab**
  - Change a title's background properties
  - Change a title's text properties

- **Content tab**
  - Specify the type of title

- **Frames tab**
  - Specify frame properties

- **Additional files tab**
  - Add additional files to your title

- **Author Control tab**
  - Protect your title with a password

- **Transitions tab**
  - Set a title's transition properties

### Changing the name of your title

To change the name of your title:

1. Double-click the title graphic 📖 in the left-hand pane. The Title Properties window opens. Click the **General** tab if the Title Properties window is not already opened to this tab.

2. In the **Title Name** field, specify the name of your title as you want it to appear at the top of the left-hand pane.

3. Click **OK**.
Changing a title's page size and alignment

Each page within your title will use the default page size and alignment specified within the Title Properties. Consideration should be made for your intended users, and the width of the page size should match the most common resolution of users' monitors. The alignment will determine how the content is displayed within the user's browser window for any Web-based, published content.

To change the page size of your title:

1. Double-click the title graphic in the left-hand pane. The Title Properties window opens. Click the General tab if the Title Properties window is not already opened to this tab.

2. In the Page Size in Screen Pixels box, specify the Width and Height of the page or select the Use Default check box to use the default page size (785 x 600). The default page size takes the 15-pixel vertical scroll bar into account for properly displaying content.

3. Choose the Page Alignment for HTML Publishing from the list. The default is Left Justified. You can also choose Centered.

4. Click OK.

Changing a title's background properties

You can change the default background color, the default background image, and the default background sound used on the pages within your title.

To change these background properties:

1. Double-click the title graphic in the left-hand pane. The Title Properties window opens. Click the Background tab.

2. Specify the following background information:

   **Default Background Color**
   Use the list to select the default background color for your pages. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

   See also: Matching Colors Used within Your Title

   If you choose a background image, you will not be able to see your background color.

   **Default Background Image**
   To use a background image for the pages of your title, select a previously imported image from the list or click on the Import button to navigate and select the image. You can also click on the arrow within the Import button to choose from the following:

   - From File
   - Media Library

   See also: Working with the Media Library Organizer

   You can also use the Background Wizard to create a background for your title.

   If you use a background image that is smaller than your page size, Lectora will automatically tile that image across and down your page; however, the browser will cache the image and only load the image one time. This is a much more efficient manner of creating a background as opposed to one large background image that will have a much longer load time.
If you choose a background image, the background color will not be visible, unless the image is somewhere transparent.

**Default Background Sound**

To use a background sound for the pages of your title, select a previously imported audio file from the list or click on the **Import** button to navigate and select the audio file. You can also click on the arrow within the **Import** button to choose from the following:

- **From File** Select this to navigate and select an audio file.
- **Media Library** Select this to launch your media library to select an audio file.

*See also:* [Working with the Media Library Organizer](#)

A background sound will play continuously throughout the entire title. The sound will continue playing as users navigate throughout the title, and will repeat.

3. Click **OK**.

### Changing a title's text properties

You can change the default text style and the default link color used on the pages of your title.

To change these text properties:

1. Double-click the title graphic in the left-hand pane. The Title Properties window opens. Click the **Background** tab.

2. Specify the following text information:

   **Default Text Style** Use the list to select a default text style to be used within your title. Text blocks created within your title will be automatically formatted to the selected style. To create a new text style, click on the **Styles** button.

   *See also:* [Managing text styles](#)

   Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

   **Default Link Color** Use the list to select the color to be used for all hyperlinks within your title. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

   *See also:* [Matching Colors Used within Your Title](#)

3. Click **OK**.

### Specifying the type of title

Your type of title should be consistent with the preferred publishing format for your title. Selecting the AICC/SCORM option in this window provides you with the option of using multiple assignable units throughout your title. If you do not set this option, you will be unable to add assignable units.

*See also:* [Working with Assignable Units](#)

To specify the type of title:

1. Double-click the title graphic in the left-hand pane. The Title Properties window opens. Click the **Content** tab.
2. Select the type of title you are publishing. Select from:

- **Standard Lectora Title**: This is a title that will be published to either CD-ROM, a single-file executable or HTML without any extra specifications. This is the default.

- **CourseMill 2.0 (or older) Published Title**: This is a title that is being created for placement on the CourseMill 2.0 learning management system.

- **AICC/SCORM/CourseMill (3.x and above) Published Title**: This is a title that needs to be in compliance with AICC or SCORM regulations. Selecting this automatically adds an assignable unit to your title and provides the option of later adding multiple assignable units. Use this option if you are running CourseMill 3.x or above. This option will publish your title to SCORM 1.0, 1.1, 1.2 conformance or SCORM 2004 for integration in most learning management systems.

3. Click **OK**.

### Specifying frame properties

You can configure the use of frames within your title. Frames can be used to subdivide your pages into separate areas. For example, you can have a top frame, typically where you would place advertisements (banner ads) or notices, a navigation frame where the course menu would be located, and a contents frame, where the topic information is displayed.

**See also**: [Working with Frames](#)

Frames are not AICC- or SCORM-compatible and should not be used for any AICC, SCORM, or CourseMill Published titles.

To specify the frame properties:

1. Double-click the title graphic in the left-hand pane. The Title Properties window opens. Click the **Frames** tab.

2. Select from one of the predefined frame styles from the **Frame Style** list. Lectora will generate a preview of the style in the **Preview** box.

3. Select the **Use Thick Visible Frames** check box to display thick borders around each frame.

4. You can specify the size of the frames directly in pixels or as a percentage of the total width and height of your pages. The **Top Row Height** and **Left Column Width** fields are enabled based on the frame style you have selected.

    - If you want to specify the frame size in percentages, select the **Specify Size in Percentages** check box and specify the height percentage in the **Top Row Height** field and the width percentage in the **Left Column Width** field.

    - If you want to specify the frame size in pixels, uncheck the **Specify Size in Percentages** check box and specify the height in pixels in the **Top Row Height** field and the width in pixels in the **Left Column Width** field.

5. Click **OK**.

### Adding additional files to your title

You can add files that you want to launch that are not natively supported by Lectora (for example, PDF files). Specifying the files enables you to publish them along with all other imported resources. Additional files require that the user have the corresponding application on their computer that will open the file. For example, if you have added a PDF as an additional file, accessing the PDF would require that the user have Adobe Acrobat installed on their computer. When you add an additional file using the **Additional Files** tab, a copy of the file will be placed in an `extern` folder located within the title directory.
To add an additional file:

1. Double-click the title graphic in the left-hand pane. The Title Properties window opens. Click the Additional files tab.

2. Click the Add File button and browse to the file you want to add. Click Open and click OK to add the file.

   You can also simply drag-and-drop the additional file directly onto a page. If the file is not a supported media type, Lectora will prompt you with a message asking if the file should be added as an additional file. Any additional files added to your title will appear within the list on the Additional Files tab of the title properties.

3. Click OK.

   See also: Supported Media Types

Protecting your title with a password

You can protect portions of your work from being changed by other users. With Author Control enabled, you place a restricted lock on one or more items within a title (and by inheritance, any children items that are related to the item on which the restriction is placed). When you enable Author Control, an item or its children cannot be modified in any way within the title unless the Author Control restriction is lifted using the master Author Control password.

To enable author control:

1. Double-click the title graphic in the left-hand pane. The Title Properties window opens. Click the Author Control tab.

2. Select the Enable Author Control check box to enable the feature and then click Set Password to set a password for the current title.

   The Set Author Control Password window opens.

3. Type the same password in both fields and click OK on the Set Author Control Password window.

4. Click OK.

Once enabled, any item in the title can be placed under author control by either selecting the Author Control option from the right-click context menu for an individual item or by selecting the Author Control check box in the General Properties window for that item. During a single editing session, an author will only be prompted to enter the Author Control password once. After the correct password has been given, the author will have full editing capabilities within the title. If the Author Control password is forgotten, the author must import the contents of the title into a new title to make any changes to the protected items.

Setting a title's transition properties

You can specify how your pages will load within the title. Transitions will produce a special effect as users navigate from one page to another. You can select from over 20 different transitions. There is a Slow to Fast slider to determine the speed at which the transition takes place.

To set your title's transitions:

1. Double-click the title graphic in the left-hand pane. The Title Properties window opens. Click the Transitions tab.

2. Select a transition from the Transition Type list, and adjust the Slow/Fast slider accordingly.

3. Click OK.

   Transitions are not recommended for titles published to the Web. This is because an entire page needs to load before the transition occurs and a result, buttons and hyperlinks are disabled until a the transition is complete.
Saving a Title
Lectora organizes the files you use to create your title. The My Titles directory is automatically created on your hard drive when you install Lectora. Whenever you create a new title, Lectora automatically creates a folder specifically for that title in the My Titles directory. Within your title folder, Lectora organizes all your media and image files.

See also: How Lectora Organizes Your Content

You should save your work on a regular basis. Publishing your title is not the same as saving, so you should always save before you publish, as well as frequently throughout title creation.

You can save your title three different ways:

- Select Save Title from the File menu, or press Ctrl-S on the keyboard.
- Click the Save toolbar graphic.
- Select Save a Copy of Title from the File menu. This method saves your entire title, with all of its media files, to the newly-specified location.

See also: Setting auto save preferences
Saving a title as a template

Saving a Title as a Template
Use Save Title as Template to create a template with the same framework and dimensions as the current title. To save the current title as a template, select Save Title as Template from the File menu.

A window appears, asking you to enter a file name with the .awp file extension and a description for the new template. Templates are saved to a Templates directory located in the same location as Lectora was installed, typically C:/Program Files/Trivantis/Lectora. Templates saved to this directory will automatically appear within the My Templates gallery on the Templates tab of Lectora’s launch pad for easy access. You can also import and export templates for use in creating titles.

See also: Using a template
Importing and exporting templates

Importing and exporting templates
You can import and export templates. This will enable you to add templates for use in creating titles (import) and save a copy of a template (export) in a location for easy access for sharing or emailing. Custom template files contain the .awp file extension.

To import a template:
1. Select New Title from the File menu. Click the Templates tab.
2. Click Import to navigate and add a custom template to the list of custom templates.
3. Click Cancel to close the window.

To export a template:
1. Select New Title from the File menu. Click the Templates tab.
2. Select the template you want to export and click Export. The Save As window opens.
3. Navigate and save the template to the desired location.
4. Click Cancel to close the window.

Common Chapter, Section and Page Properties
Many properties for chapters, sections and pages are the same. You can access these properties for a chapter, section or page by double-clicking the chapter, section or page graphic in the left-hand pane, or by selecting the chapter, section or page and pressing the Enter key.

The following can be completed within chapter, section and page properties:

- Change the name of a chapter, section or page
- Change chapter, section and page sizes and alignment
- Removing a chapter, section or page from the table of contents
- Enable author control on chapters, section and pages
- Change text properties for chapters, section and pages
- Specify inheritance properties for chapters, sections and pages
- Setting transition properties for chapters, sections and pages

Changing the name of a chapter, section or page
To change the name of your chapter, section or page:

1. Double-click the chapter, section, or page graphic of the chapter, section or page you want to rename in the left-hand pane. The Properties window opens. Click the General tab if the Properties window is not already opened to this tab.

2. In the Name field, specify the name of your chapter, section or page as you want it to appear in the left-hand pane.

3. Click OK.

Changing chapter, section and page sizes and alignment
When setting these options, consideration should be made for your intended users, and the width of the page size should match the most common resolution of users' monitors. The page alignment will determine how the content is displayed within the user's browser window for any Web-based, published content.

The page size and alignment of a chapter are inherited from the title properties by default. Changes applied to the page size and alignment within a chapter's properties will only be applied to the pages contained within the chapter.

The page size and alignment of a section are inherited by default from the chapter to which it belongs. Changes applied to the page size and alignment within a section's properties will only be applied to the pages contained within the section.

The page size and alignment of a page are inherited by default from the chapter (or section) to which it belongs. Changes applied to the page size and alignment within your page’s properties will only be applied to the current page.

Consideration should be made for your intended users, and the width of the page size should match the most common resolution of users' monitors. The alignment will determine how the content is displayed within the user's browser window for any Web-based, published content.

To change the page size of your chapter, section or page:

1. Double-click the chapter, section, or page graphic of the chapter, section or page you want to change in the left-hand pane. The Properties window opens. Click the General tab if the Properties window is not already opened to this tab.

2. In the Page Size in Screen Pixels box, clear the Use Default check box to specify the Width and Height of the pages. If Use Default is selected, the inherited page size is used.

3. Choose the Page Alignment for HTML Publishing from the list. The Default page alignment is inherited.

4. Click OK.
Removing a chapter, section or page from the table of contents

A Table of Contents in Lectora is a menu system that is automatically populated with the chapters, sections and pages within your title. Users can use the Table of Contents to navigate to the different areas of your title. By default, all chapters, sections, and pages are included in a Table of Contents, however you can specify not to include individual chapters, sections or pages.

When you remove a chapter from the Table of Contents, neither the chapter nor any of the pages within the chapter will appear within the Table of Contents.

When you remove a section from the Table of Contents, neither the section nor any of the pages within the section will appear within the Table of Contents.

When you remove a page from the Table of Contents, the page will not appear within the Table of Contents.

These settings also affect the Table of Contents progress bar.

See also:  Working with Tables of Contents
Working with Progress Bars

To remove a chapter, section or page from the Table of Contents:

1. Double-click the chapter [chapter], section [section], or page [page] graphic of the chapter, section or page you want to change in the left-hand pane. The Properties window opens. Click the General tab if the Properties window is not already opened to this tab.

2. Clear the Include in Table of Contents check box.

3. Click OK.

Enabling author control on chapters, sections and pages

You can protect the contents of a chapter, section or page by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the contents of the chapter, section or page unless they have the master Author Control password.

When you enable Author Control on a chapter, additional authors will not be able to edit the chapter or any of the sections or pages within the chapter. When you enable Author Control on a section, additional authors will not be able to edit the section or any of the pages within the section, and when you enable Author Control on a page, additional authors will not be able to edit the page or any of the objects on the page.

The master Author Control password must first be set within the Title Properties.

See also:  Protecting your title with a password

To enable Author Control on a chapter, section or page:

1. Double-click the chapter [chapter], section [section], or page [page] graphic of the chapter, section or page you want to change in the left-hand pane. The Properties window opens. Click the General tab if the Properties window is not already opened to this tab.

2. Check the Author Control check box.

3. Click OK.

Changing background properties for chapters, sections and pages

The default background color, the default background image, and the default background sound are automatically inherited.
Changes applied to the background color, image, or sound within a chapter's properties will only be applied to the pages contained within the chapter. Changes applied to the background color, image, or sound within a section's properties will only be applied to the pages contained within the section, and changes applied to the background color, image, or sound within a page's properties will only be applied to the current page.

To change these background properties:

1. Double-click the chapter, section, or page graphic of the chapter, section or page you want to change in the left-hand pane. The Properties window opens. Click the Background tab.

2. Specify the following background information:

   **Default Background Color**
   A chapter's default background color is inherited from the title properties. A section's default background color is inherited from the chapter to which it belongs, and a page's default background color is inherited from the section or chapter to which it belongs. Use the list to select a new default background color. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

   **See also:** [Matching Colors Used within Your Title](#)

   ![Image of a background color](image)

   If you choose a background image, you will not be able to see your background color.

   **Default Background Image**
   A chapter's default background image is inherited from the title properties. A section's default background image is inherited from the chapter to which it belongs, and a page's default background image is inherited from the section or chapter to which it belongs. To use a new background image for your chapter, section or page, select a previously imported image from the list or click on the Import button to navigate and select the image. You can also click on the arrow within the Import button to choose from the following:

   - From File: Select this to navigate and select an image.
   - Media Library: Select this to launch your media library to select an image.

   **See also:** [Working with the Media Library Organizer](#)

   You can also use the Background Wizard to create a background for your title.

   If you use a background image that is smaller than your page size, Lectora will automatically tile that image across and down your page; however, the browser will cache the image and only load the image one time. This is a much more efficient manner of creating a background as opposed to one large background image that will have a much longer load time.

   ![Image of a background image](image)

   If you choose a background image, the background color will not be visible, unless the image is somewhere transparent.

   **Default Background Sound**
   A chapter's default background sound is inherited from the title properties. A section's default background sound is inherited from the chapter to which it belongs, and a page's default background sound is inherited from the section or chapter to which it belongs. To use a new background sound for your chapter, section or page, select a previously imported audio file from the list or click on the Import button to navigate and select the audio file. You can also click on the arrow within the Import button to choose from the following:
From File Select this to navigate and select an audio file.

Media Library Select this to launch your media library to select an audio file.

See also: Working with the Media Library Organizer

A background sound will play continuously while users navigate within a chapter, a section or only while on a page. The sound will continue playing and repeat until the user navigates out of the chapter, out of the section, or off the page.

3. Click OK.

Changing text properties for chapters, sections and pages
The default text style and link color are automatically inherited. Changes applied to the text style and link color within a chapter's properties will only be applied to the pages contained within the chapter. Changes applied to the text style and link color within a section's properties will only be applied to the pages contained within the section, and changes applied to the text style and link color within a page's properties will only be applied to the current page.

To change these text properties:
1. Double-click the chapter, section, or page graphic of the chapter, section or page you want to change in the left-hand pane. The Properties window opens. Click the Background tab.

2. Specify the following text information:

Default Text Style A chapter's default text style is inherited from the title properties. A section's default text style is inherited from the chapter to which it belongs, and a page's default text style is inherited from the section or chapter to which it belongs. Use the list to select a new default text style to be used within your chapter, section or page. Text blocks created within your chapter, section or page will be automatically formatted to the selected style. To create a new text style, click on the Styles button.

See also: Managing text styles

A chapter's default link color is inherited from the title properties. A section's default link color is inherited from the chapter to which it belongs, and a page's default link color is inherited from the section or chapter to which it belongs. Use the list to select the color to be used for all hyperlinks within your chapter, section or page. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

See also: Matching Colors Used within Your Title

Textual hyperlinks are underlined and displayed in the selected color.

3. Click OK.

Specifying inheritance properties for chapters, sections and pages
With Lectora’s inheritance capabilities, objects you add directly to the main title will appear on every page of your title. Furthermore, any objects added directly to a chapter will appear on every page in that chapter including pages that are inside
of a section within the chapter. Objects added directly to a section will appear on every page in that section and objects added directly to a page will appear only on that page.

See also: Understanding Inheritance

The inherit tab is available within all chapter, section and page properties. If the object is excluded within the properties of a chapter, it will not appear on any page within that chapter. If the object is excluded within the properties of a section, it will not appear on any page within that section, and if the object is excluded within the properties of a page, then the object will be excluded from that page.

To exclude an inherited object:

1. Double-click the chapter, section, or page graphic of the chapter, section or page you want to change in the left-hand pane. The Properties window opens. Click the Inherit tab.

2. Select from one of the following inheritance options:
   - Inherit all objects from parent
   - Inherit no objects from parent
   - Exclude inheritance of certain objects

   **Inherit all object from parent** will place all objects within the Inherited list. These objects will continue to appear throughout your chapter. **Inherit no objects from parent** will place all objects within the Excluded list. These objects will not appear on any pages within your chapter.

   Select **Exclude inheritance of certain objects** to move objects from one list to the other. Select an object in either list and click the arrow buttons to move items from one list to the other in the direction of the buttons. Select several objects by holding down the Ctrl key while selecting objects.

   You can select several objects by holding down the Ctrl key while selecting multiple objects.

3. Click OK.

**Setting transition properties for chapters, sections and pages**

You can specify how your pages will load within the title. Transitions will produce a special effect as users navigate from one page to another, and can be applied to a chapter, section or page.

The transition type is automatically inherited. Changes applied to the transition type within a chapter's properties will only be applied to the pages contained within the chapter. Changes applied to the transition type within a section's properties will only be applied to the pages contained within the section, and changes applied to the transition type within a page's properties will only be applied to the current page.

You can select from over 20 different transitions. There is a Slow to Fast slider to determine the speed at which the transition takes place.

To set transitions:

1. Double-click the chapter graphic of the chapter you want to change in the left-hand pane. The Chapter Properties window opens. Click the Transitions tab.

2. Select a transition from the Transition Type list, and adjust the Slow/Fast slider accordingly.

3. Click OK.
Transitions are not recommended for titles published to the Web. This is because an entire page needs to load before the transition occurs and as a result, buttons and hyperlinks are disabled until the transition is complete.

**Working with Chapters**
This section describes how to add chapters to your title without using the Title Wizard. Chapters are the largest unit of organization in a title. Chapters cannot contain other chapters, but they can contain sections and pages.

*See also:* [Understanding the Book Metaphor](#)

This section describes:

- Adding a chapter

Once you have added a chapter, you can specify the following within the Chapter Properties window:

**General tab**
- Change the name of a chapter
- Change a chapter's page size and alignment
- Remove a chapter from the table of contents
- Enable author control for a chapter

**Inherit tab**
- Specify a chapter's inheritance properties

**Background tab**
- Change a chapter's background properties
- Change a chapter's text properties

**Transitions tab**
- Set a chapter's transition properties

**Adding a chapter**
To add a chapter to your title, in the left-hand pane, highlight the location in the title where you want to add the chapter, and do one of the following:

- From the Add menu, select Chapter
- Select the Add Chapter toolbar graphic
- Right-click and select New > Chapter
- Type Ctrl+1

When you add the new chapter, a chapter graphic appears in the left-hand pane.

- The new chapter is inserted after the object that was highlighted in the left-hand pane.
- You can easily re-order items in the left-hand pane by clicking on them, and while holding down the left mouse button, dragging the item within the left-hand pane to its new location. Once the location is chosen, release the left mouse button, and the item will be moved.
- Lectora will attempt to assign a number to the new chapter. If the sequence is out-of-order, or if you would like to rename the chapter, click on the text located next to the chapter graphic in the left-hand pane, and enter the new name for the chapter.

**Working with Sections**
This section describes how to add sections to your title. A section is the second largest unit of organization in a title. Sections can contain pages or other sections, called *sub-sections*.

*See also:* [Understanding the Book Metaphor](#)
Adding a section

Once you have added a section, you can specify the following within the Section Properties window:

**General tab**
- Change the name of a section
- Change a section's page size and alignment
- Remove a section from the table of contents
- Enable author control for a section

**Inherit tab**
- Specify a section's inheritance properties

**Background tab**
- Change a section's background properties
- Change a section's text properties

Adding a section

To add a section to your title, in the left-hand pane, highlight the chapter (or section) in the title to which you want to add the section (or sub-section), and do one of the following:

- From the Add menu, select Section
- Select the Add Section toolbar graphic
- Right-click and select New > Section
- Type Ctrl+2

When you add the new section, a section graphic appears in the left-hand pane in the chapter (or section) you selected.

- The new section is inserted into the chapter or section that was highlighted in the left-hand pane.
- You can easily re-order items in the left-hand pane by clicking on them, and while holding down the left mouse button, dragging the item within the left-hand pane to its new location. Once the location is chosen, release the left mouse button, and the item will be moved.
- Lectora will attempt to assign a number to the new section. If the sequence is out-of-order, or if you would like to rename the section, click on the text located next to the section graphic in the left-hand pane, and enter the new name for the section.

Working with Pages

This section describes how to add pages to your title. A page is the smallest unit of organization within your title. The pages are what your users will see when they are viewing the published title.

*See also:* Understanding the Book Metaphor

This section describes:

- Adding a page

Once you have added a page, you can specify the following within the Page Properties window:

**General tab**
- Change the name of a page
- Change a page's size and alignment
- Remove a page from the table of contents

**Inherit tab**
- Specify a page's inheritance properties

**Background tab**
- Change a page's background properties
- Change a page's text properties

**Transitions tab**
Enable author control on a page

Background tab
- Change a page's background properties
- Change a page's text properties

Metadata tab
- Set a page's transition properties

- Include metadata on a page

Adding a page
To add a page to your title, in the left-hand pane, highlight the chapter (or section) in the title to which you want to add the page, and do one of the following:
- From the Add menu, select Page
- Select the Add Page toolbar graphic
- Right-click and select New > Page
- Type Ctrl+3

When you add the new page, a page graphic appears in the left-hand pane in the chapter (or section) you selected.

- The new page is inserted into the chapter or section that was highlighted in the left-hand pane.
- You can easily re-order items in the left-hand pane by clicking on them, and while holding down the left mouse button, dragging the item within the left-hand pane to its new location. Once the location is chosen, release the left mouse button, and the item will be moved.
- Lectora will attempt to assign a number to the new page. If the sequence is out-of-order, or if you would like to rename the page, click on the text located next to the page graphic in the left-hand pane, and enter the new name for the page.

Including metadata on a page
You can associate metadata with a page. Metadata is data about data. It typically includes information such as a description of the object, the author, the date it was created, and so on. Search engines look within metadata for relevant information to the term that was searched. Within Lectora objects, the metadata will be published as standard XML metadata into the accompanying imsmanifest.xml file for any AICC, SCORM, or CourseMill published titles. Metadata added to objects within a title that is published strictly to HTML will be written directly to the resulting HTML pages containing the objects. The metadata can be specified as custom metadata, an external XML file containing metadata, or as name/value pairs using predefined IMS Metadata Data Elements following the IEEE LTSC LOM standard.

To include metadata on your page:
1. Double-click the page graphic of the page you want to change in the left-hand pane. The Page Properties window opens. Click the Metadata tab.
2. Select Use Metadata and select one of the following metadata options:

- **Custom Metadata**: Select this to display the Custom Metadata text field for you to directly enter custom metadata.

- **Use external XML file for custom Metadata**: Select this to import an external XML file containing metadata.

- **IMS Metadata Data Elements (IEEE LTSC LOM)**: Select this to display a pre-populated list of name value pairs for all the SCORM 1.2 required IMS Metadata data elements. Click the Add button to open the Metadata Data Element Entry window. Select a predefined data element from the Name combo box and specify a data
element value from the Value edit/combo box. Select OK to accept the data element. Select from previously entered data elements from the Name/Value lists and click Edit or Remove to edit or remove the selected element.

3. **Publish this object's Metadata** is checked by default so that the metadata is included in the published title. Clear this option if you do not want the metadata included in the published title.

4. Click OK.

**Working with Assignable Units**

Assignable units are specific to AICC/SCORM titles. An assignable unit is the largest unit of organization in an AICC/SCORM published title. Assignable units cannot contain other assignable units, but they can contain chapters, sections, tests, and/or pages.

With the addition of multiple assignable units, several new restrictions have been added to AICC/SCORM-published title materials generated by Lectora:

- Jumps between assignable units are only supported when publishing the content to SCORM (disconnected). Jumps between assignable units on a Web-published title violate the AICC guidelines for LMS direction of flow between assignable units.
- There must always be at least one assignable unit defined within the title. When you select AICC/SCORM in the Title Properties window, an assignable unit that encompasses the entire title is generated. If this option is not selected, and you publish to AICC, SCORM or CourseMill, an assignable unit encompassing the entire title is automatically created.

This section describes:

- **Adding an assignable unit**

Once you have added an Assignable Unit, you can specify the following within the Assignable Unit Properties window:

**General tab**
- **Change the name of an assignable unit**
- **Change an assignable unit's page size and alignment**
- **Remove an assignable unit from the table of contents**
- **Enable author control for an assignable unit**

**Inherit tab**
- **Specify an assignable unit's inheritance properties**

**Assignable Unit Properties tab**
- **Specify assignable unit properties**

**Prerequisites tab**
- **Specify assignable unit prerequisites**

**Adding an assignable unit**

You can only add assignable units if you have selected the **AICC/SCORM Published Title** check box in the Content tab of the Title Properties window. When this option is set, an assignable unit will automatically appear in the title. If you choose not to select this option and still publish to AICC/SCORM, your entire title will be considered the assignable unit.

**See also:** [Specifying the type of title]

When publishing to SCORM, the Assignable Unit will be converted to a SCO (the SCORM equivalent).
To add an assignable unit, in the left-hand pane, select the location within the title into which you want to add the new assignable unit, and do one of the following:

- From the **Add** menu, select **Assignable Unit**
- Right-click and select **New > Assignable Unit**
- Type **Ctrl+0**

When you add the new assignable unit, an assignable unit graphic appears in the left-hand pane.

- The new assignable unit is inserted after the chapter or assignable unit that was highlighted in the left-hand pane.
- You can easily re-order items in the left-hand pane by clicking on them, and while holding down the left mouse button, dragging the item within the left-hand pane to its new location. Once the location is chosen, release the left mouse button, and the item will be moved.
- Lectora will attempt to assign a number to the new assignable unit. If the sequence is out-of-order, or if you would like to rename the assignable unit, click on the text located next to the assignable unit graphic in the left-hand pane, and enter the new name for the assignable unit.

**Changing the name of an assignable unit**

The name of your assignable unit is used by the AICC/SCORM learning management system. This is the name that the course will be referred to within the system.

To change the name of your assignable unit:

1. Double-click the assignable unit graphic of the assignable unit you want to rename in the left-hand pane. The Assignable Unit Properties window opens. Click the **General** tab if the Assignable Unit Properties window is not already opened to this tab.

2. In the **Assignable Unit Name** field, specify the name of your assignable unit as you want it to appear in the left-hand pane and as it will be referenced within your AICC/SCORM learning management system.

3. Click **OK**.

**Changing an assignable unit’s page size and alignment**

The page size and alignment of your assignable unit are inherited from the title properties by default. Changes applied to the page size and alignment within your assignable unit’s properties will only be applied to the pages contained within the assignable unit. Consideration should be made for your intended users, and the width of the page size should match the most common resolution of users’ monitors. The alignment will determine how the content is displayed within the user's browser window for any Web-based, published content.

To change the page size of your assignable unit:

1. Double-click the assignable unit graphic of the assignable unit you want to change in the left-hand pane. The Assignable Unit Properties window opens. Click the **General** tab if the Assignable Unit Properties window is not already opened to this tab.

2. In the **Page Size in Screen Pixels** box, clear the **Use Default** check box to specify the **Width** and **Height** of the assignable unit's pages. If **Use Default** is selected, the page size you specified in the title properties will apply.

3. Choose the **Page Alignment for HTML Publishing** from the list. The **Default** page alignment is inherited from the title properties.
4. Click **OK**.

**Removing an assignable unit from the table of contents**

A Table of Contents in Lectora is a menu system that is automatically populated with the chapters, sections and pages within your title. Users can use the Table of Contents to navigate to the different areas of your title. By default, all chapters, sections, and pages are included in a Table of Contents, however you can specify not to include individual chapters, sections or pages. When you remove an assignable unit from the Table of Contents, none of the chapters, sections or pages within the assignable unit will appear within the Table of Contents. Users will not be able to navigate to any area of the assignable unit using the Table of Contents. This setting also affects the Table of Contents progress bar.

**See also:** Working with Tables of Contents
Working with Progress Bars

To remove an assignable unit from the Table of Contents:

1. Double-click the assignable unit graphic of the assignable unit you want to change in the left-hand pane. The Assignable Unit Properties window opens. Click the **General** tab if the Assignable Unit Properties window is not already opened to this tab.

2. Clear the **Include in Table of Contents** check box.

3. Click **OK**.

**Enabling author control for an assignable unit**

You can protect the contents of an assignable unit by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the contents of the assignable unit unless they have the master Author Control password. This includes all pages within the assignable unit and all objects on those pages. The master Author Control password must first be set within the Title Properties.

**See also:** Protecting your title with a password

To enable Author Control for an assignable unit:

1. Double-click the assignable unit graphic of the assignable unit you want to change in the left-hand pane. The Assignable Unit Properties window opens. Click the **General** tab if the Assignable Unit Properties window is not already opened to this tab.

2. Check the **Author Control** check box.

3. Click **OK**.

**Changing an assignable unit’s background properties**

The default background color, the default background image, and the default background sound are inherited from the title properties by default. Changes applied to the background color, image, or sound within your assignable unit’s properties will only be applied to the pages contained within the assignable unit.

To change these background properties:

1. Double-click the assignable unit graphic of the assignable unit you want to change in the left-hand pane. The Assignable Unit Properties window opens. Click the **Background** tab.

2. Specify the following background information:

   - **Default Background Color** the default background color inherited from the title properties is specified. Use the list to select a new default background color. Select a predefined color, select the eyedropper tool to use a color from elsewhere within your title, or select **Custom** to select a
custom color from the Color wheel.

见 also: Matching Colors Used within Your Title

如果你选择一个背景图片，你将无法看到你的背景颜色。

默认背景图片

默认背景图片由标题属性指定。要使用新背景图片为可赋值单元的页面，从列表中选择已导入的图片或单击导入按钮以浏览并选择图片。你也可以点击导入按钮中的箭头选择以下内容：

From File  选择此选项以浏览并选择一个图片。
Media Library  选择此选项以启动媒体库选择一个图片。

见 also: Working with the Media Library Organizer

你也可以使用背景向导来为你的标题创建背景。

如果你使用一个背景图片，其大小小于你的页面尺寸，Lectora将自动平铺该图片并重复你的页面；然而，浏览器将缓存该图片并仅加载一次。这是创建背景的一种更高效的方法，相比一次性加载一个大型背景图片。

如果你选择一个背景图片，背景颜色将不会可见，除非图片是透明的。

默认背景声音

默认背景声音由标题属性指定。要使用新背景声音为可赋值单元的页面，从列表中选择已导入的音频文件或单击导入按钮以浏览并选择音频文件。你也可以点击导入按钮中的箭头选择以下内容：

From File  选择此选项以浏览并选择一个音频文件。
Media Library  选择此选项以启动媒体库选择一个音频文件。

见 also: Working with the Media Library Organizer

背景声音将连续播放，直到用户浏览可赋值单元或关闭标题。

3. 点击OK。

可赋值单元的文字属性

默认文字样式和链接颜色由标题属性默认。在可赋值单元的属性中，对默认文字样式和默认链接颜色所作的更改仅适用于包含在可赋值单元中的页面。
To change these text properties:
1. Double-click the assignable unit graphic of the assignable unit you want to change in the left-hand pane. The Assignable Unit Properties window opens. Click the Background tab.

2. Specify the following text information:

   **Default Text Style**
   The default text style inherited from the title properties is specified. Use the list to select a new default text style to be used within your assignable unit. Text blocks created within your assignable unit will be automatically formatted to the selected style. To create a new text style, click on the Styles button.

   *See also:* Managing text styles

   Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

   **Default Link Color**
   The default link color inherited from the title properties is specified. Use the list to select the color to be used for all hyperlinks within your assignable unit. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

   *See also:* Matching Colors Used within Your Title

   Textual hyperlinks are underlined and displayed in the selected color.

3. Click OK.

**Specifying an assignable unit's inheritance properties**
With Lectora’s inheritance capabilities, objects you add directly to the main title will appear on every page of your title and are automatically inherited by assignable units. Furthermore, any objects added directly to a chapter will appear on every page in that chapter including pages that are inside of a section within the chapter. Objects added directly to a section will appear on every page in that section and objects added directly to a page will appear only on that page.

*See also:* Understanding Inheritance

The inherit tab is available within all assignable unit, chapter, section and page properties. If an object is excluded within the properties of an assignable unit, it will not appear in any of the chapters, sections, or pages contained within the assignable unit.

To exclude an inherited object:
1. Double-click the assignable unit graphic of the assignable unit you want to change in the left-hand pane. The Assignable Unit Properties window opens. Click the Inherit tab.

2. Select from one of the following inheritance options:
   - Inherit all objects from parent
   - Inherit no objects from parent
   - Exclude inheritance of certain objects

   **Inherit all objects from parent** will place all objects within the Inherited list. These objects will continue to appear throughout your assignable unit. **Inherit no objects from parent** will place all objects within the Excluded list. These objects will not appear on any pages within your assignable unit.
Select **Exclude inheritance of certain objects** to move objects from one list to the other. Select an object in either list and click the arrow buttons to move items from one list to the other in the direction of the buttons.

You can select several objects by holding down the **Ctrl** key while selecting multiple objects.

3. Click **OK**.

**Specifying assignable unit prerequisites**

A title can contain multiple assignable units. If there are multiple assignable units, prerequisites can be set within the individual assignable units’ properties. The learning management system will ensure the prerequisites are fulfilled before allowing the student to access the assignable unit.

For example, a student can be required to complete two assignable units before advancing to a third assignable unit.

To set assignable unit prerequisites:

1. Double-click the assignable unit graphic of the assignable unit you want to change in the left-hand pane. The Assignable Unit Properties window opens. Click the **Prerequisites** tab.

2. Select the required prerequisite assignable units by checking the boxes next to the assignable unit names in the list. If more than two assignable units are checked, select whether **All of the following selected Assignable Units** or **Any of the following selected Assignable Units** are prerequisites for the current assignable unit.

3. Click **OK**.

**Specifying assignable unit properties**

You can provide AICC/SCORM-related information as it pertains to each assignable unit.

To specify AICC/SCORM-related information for an assignable unit:

1. Double-click the assignable unit graphic of the assignable unit you want to change in the left-hand pane. The Assignable Unit Properties window opens. Click the **Assignable Unit Properties** tab.

2. Specify the following information:

   - **System ID**: This specifies the system identifier of the assignable unit within the current title.
   - **Developer ID**: Specify the developer or author of the assignable unit.
   - **Description**: Specify a description of the assignable unit. This is the entry that will appear in most online catalogs for the assignable unit when the title is published to an AICC/SCORM learning management system.
   - **Assignable Unit Type**: Specify the short description for the type of assignable unit within the learning management system. By default, the value is set to **Lesson**.
   - **Maximum Score**: Specify the maximum number of points (score) that a user can receive when completing this title. If you leave this field blank, Lectora will automatically supply this value with 100 points times the total number of graded tests within the assignable unit.
   - **Mastery Score**: Specify the score that marks the threshold where a user will be considered to have passed the assignable unit. By default, the value is set to 75% of the maximum score of all tests combined within the assignable unit.
   - **Max Time Allowed**: Specify the maximum time that you want users to be able to spend within the
assignable unit. Leave this field empty if you want to give users unlimited time to access the assignable unit.

**Time Limit Action**

Used in conjunction with **Max Time Allowed**, use the list to select the action to take when the max time allowed has elapsed.

3. Click **OK**.

**Using Page Layouts**

Page layouts determine how objects are placed on your page. You can use page layouts to apply a consistent design to multiple pages. For example, if your title will consist of a number of pages containing an image and corresponding text, you can use a page layout to ensure that the image and text are always in the same location on those pages. Page layouts provide a convenient means of creating multiple pages with the same design and organization. You can apply predefined layouts to your pages or you can create your own custom layouts for use within your title.

When a new page is added, it will use the layout that is currently selected in the layout list on the insert toolbar. This enables authors that are creating multiple similar content pages to create their layout once, and then begin each page with that same layout to ensure consistency.

Select **Page Layouts** from the **Layout** menu to add your own custom layouts to the layout list, customize the pre-defined layouts, and import and export layouts so they can be shared in a team.

This section covers the following topics:

- **Applying a page layout to a page**
- **Creating a custom page layout**
- **Replacing a page layout**
- **Deleting a custom page layout**
- **Importing and exporting page layouts**

**Applying a page layout to a page**

When you apply a page layout to a page, Lectora puts placeholders on your page for the components that comprise the page layout. The placeholders are boxes with dotted lines into which you can add text, images, audio, video or other Lectora objects. For example, if you apply the **Image and text column** page layout to a page, Lectora will create a placeholder for the image, and a placeholder for the text. You can then populate these areas with your text and image.

To apply a page layout to a page:

1. Select the page you want to change in the left-hand pane.

2. On the Insert toolbar, select the layout you want from the **Page Layout** list and click the **Page Layout** toolbar graphic located to the right of the list.

The page layout for the page you selected is changed and the placeholders appear on the page. If you add additional pages to your title, they will automatically use the page layout selected.

Predefined layouts include the following:

- Blank
- Image and bullets columns
- Title, Video and text
Creating a custom page layout
You can create a custom page layout based on a page within your title. For example, suppose you have a page that contains a paragraph of text on the left, an image to the right of that text, and a textual caption beneath the image. If you create a custom page layout based off that page, the page layout will contain a place holder for text on the left, a place holder for an image on the right, and another place holder for text beneath the image.

Instead of creating a new custom page layout, you can also replace an existing layout based on a page within your title.

See also: Replacing a page layout

To create the custom page layout:
1. Select the page in the left-hand pane from which you want to create the layout.

2. Select Page Layouts from the Layout menu. The Page Layouts window opens.

3. Click the Add new layout from current page layout button. The Layouts Name window opens.

4. In the Layouts Name window, specify a name for the new page layout and click OK.

5. Click Done to exit the Page Layouts window.

The new layout is added to the list of available page layouts.

Replacing a page layout
You can replace an existing page layout with a new page layout that matches the current page layout.

To update a page layout to match the current page layout:
1. Select the page in the left-hand pane from which you want to define the layout.

2. Select Page Layouts from the Layout menu. The Page Layouts window opens.

3. Select the page layout that you want to replace and click the Replace layout with current page layout button.

4. Click Done.

Deleting a custom page layout
You can delete custom page layouts you are not using. Predefined layouts provided by Lectora cannot be deleted.

To delete a page layout:
2. Select the custom page layout you want to delete and click **Delete Layout**. The custom page layout is removed from the list.

3. Click **Done**.

**Importing and exporting page layouts**
You can import and export page layouts. This will enable you to add page layouts for use within your titles (import) and save a copy of a page layout (export) in a location for easy access for sharing or emailing. Custom layout files contain the `.alt` file extension.

To import a page layout:
4. Select **Page Layouts** from the **Layout** menu. The Page Layouts window opens.

5. Click **Import Layout** to navigate and add a custom layout to the list of available page layouts.

6. Click **Done**.

To export a page layout:
5. Select **Page Layouts** from the **Layout** menu. The Page Layouts window opens.

6. Select the layout you want to export and click **Export Layout**. The Save As window opens.

7. Navigate and save the layout to the desired location.

8. Click **Done**.

**Working with Frames**
Lectora enables you to incorporate **frames** into your title design. Using frames, you can divide your title’s pages into multiple regions, decide which content will go in which regions, and change the content in each region at different times based on various interactions or automation. This way, one region of the screen can always contain buttons for navigating through the title, another region on the screen can hold varying advertisements or instructions, while yet another area of the screen can be the main area where title information and/or tests are presented.

For example, a very common title design is to use the **Contents** frame style, which features two frames:

- A narrow vertical left frame: Used for a title-wide or global navigation menu.
- A wide right-side frame: Contains the main body of the title. The content here is always changing in response to the selections made in the left frame.

Frames are useful for navigation, logos, banner ads, and more. The possibilities are limitless and Lectora provides you with a wide variety of frame styles from which to choose.

This section describes:

- Using frames within your title

Once you have added frames to your title, you can specify the following within the Frame Properties window:

**General tab**
- Change the name of a frame

**Background tab**
- Change a frame's background properties
- Change a frame's text properties

**Transitions tab**
- Set a frame's transition properties
Frames are not AICC- or SCORM-compatible and should not be used for any AICC, SCORM, or CourseMill Published titles.

Frames function in the same way as a chapter or a section. Any objects added directly to the frame will appear on every page in that frame including pages that are inside of a chapter or section.

Frames can also refer to one another. For instance, if one frame contains your title's navigation, the buttons or links can refer to pages within the main frame of the title. When creating navigation components, you will be asked to provide the referring frame.

Using frames within your title
You can incorporate frames into your title design. It is best to add frames to your title before you have created any chapters, sections, or pages, and then add pages according to where they fit within your frames.

To add frames to your title:
1. Double-click the title graphic in the left-hand pane. The Title Properties window opens. Click the Frames tab.
2. Select from one of the predefined frame styles from the Frame Style list. Lectora will generate a preview of the style in the Preview box. Select from the following predefined frame styles:

- **No frames**: Select this if you do not want to apply a frame style. This option is set as the default.
- **Contents**: Select this to divide the window into a narrow left frame and wide main frame.
- **Top Banner and Contents**: Select this to divide the window into three frames: a narrow top frame, a narrow left frame, and large main frame. The top frame can be useful for banner advertisements or logos.
- **Header**: Select this to divide the window into two frames: a narrow top frame and large main frame. The top frame can be useful for navigation buttons or for banner advertisement.
- **Four Pane Split**: Select this to divide the window into four frames: a narrow left frame for contents, a narrow top frame for banner advertisements, an upper left corner frame for a logo, and a large main frame for content.
- **Footer**: Select this to divide the window into two frames: a narrow bottom frame and large main frame. This bottom frame can be useful for banner advertisements or navigation buttons.
- **Horizontal Split**: Select this to horizontally split the window into two same-size frames on the top and bottom.
- **Vertical Split**: Select this to vertically split the window into two same-size frames on the left and right.
- **Banner and Contents**: Select this to divide the window into three frames: a narrow left frame that runs from top to bottom, a large main frame split near the top, and a narrow frame along the top right portion of the window.
- **Contents on Right Side**: Select this to divide the window into a narrow right frame and wide main frame.

3. Select the Use Thick Visible Frames check box to display thick borders around each frame.
4. You can specify the size of the frames directly in pixels or as a percentage of the total width and height of your pages. The Top Row Height and Left Column Width fields are enabled based on the frame style you have selected.

If you want to specify the frame size in percentages, select the Specify Size in Percentages check box and specify the
height percentage in the **Top Row Height** field and the width percentage in the **Left Column Width** field.

If you want to specify the frame size in pixels, uncheck the **Specify Size in Percentages** check box and specify the height in pixels in the **Top Row Height** field and the width in pixels in the **Left Column Width** field.

5. Click **OK**. Your frames will be visible as icons 🏛️ in the left-hand pane.

You can now add chapters, sections, pages, and objects into the frames.

**Changing the name of a frame**

To change the name of your frame:

1. Double-click the frame graphic 🏛️ of the frame you want to rename in the left-hand pane. The Frame Properties window opens. Click the **General** tab if the Frame Properties window is not already opened to this tab.

2. In the **Frame Name** field, specify the name of your frame as you want it to appear in the left-hand pane.

3. Click **OK**.

**Changing a frame's background properties**

The default background color, the default background image, and the default background sound are inherited from the title properties by default. Changes applied to the background color, image, or sound within your frame's properties will only be applied to the pages contained within the frame.

To change these background properties:

1. Double-click the frame graphic 🏛️ of the frame you want to change in the left-hand pane. The Frame Properties window opens. Click the **Background** tab.

2. Specify the following background information:

   **Default Background Color**  
   The default background color inherited from the title properties is specified. Use the list to select a new default background color for the pages within your frame. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

   *See also:* [Matching Colors Used within Your Title](#)

   If you choose a background image, you will not be able to see your background color.

   **Default Background Image**  
   The default background image inherited from the title properties is specified. To use a new background image for the pages of your frame, select a previously imported image from the list or click the **Import** button to navigate and select an image. You can also click on the arrow within the **Import** button to choose from the following:

   **From File**  
   Select this to navigate and select an image.

   **Media Library**  
   Select this to launch your media library to select an image.

   *See also:* [Working with the Media Library Organizer](#)

   You can also use the **Background Wizard** to create a background for your title.
If you use a background image that is smaller than your page size, Lectora will automatically tile that image across and down your page; however, the browser will cache the image and only load the image one time. This is a much more efficient manner of creating a background as opposed to one large background image that will have a much longer load time.

If you choose a background image, the background color will not be visible, unless the image is somewhere transparent.

**Default Background Sound**  
The default background sound inherited from the title properties is specified. To use a new background sound for the pages of your frame, select a previously imported sound file from the list or click the **Import** button to navigate and select a sound file. You can also click on the arrow within the **Import** button to choose from the following:

- **From File**  
  Select this to navigate and select an audio file.

- **Media Library**  
  Select this to launch your media library to select an audio file.

**See also:** Working with the Media Library Organizer

A background sound will play continuously while users navigate within the title. The sound will continue playing and repeat until the user closes the title.

3. Click **OK**.

**Changing a frame’s text properties**

The default text style and link color are inherited from the title properties by default. Changes applied to the default text style and default link color within your frame’s properties will only be applied to the pages contained within the frame.

To change these text properties:

1. Double-click the frame graphic of the frame you want to change in the left-hand pane. The **Frame Properties** window opens. Click the **Background** tab.

2. Specify the following text information:

   - **Default Text Style**  
     The default text style inherited from the title properties is specified. Use the list to select a new default text style to be used within your frame. Text blocks created on pages within your frame will be automatically formatted to the selected style. To create a new text style, click on the **Styles** button.

     **See also:** Managing text styles

     Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

   - **Default Link Color**  
     The default link color inherited from the title properties is specified. Use the list to select the color to be used for all hyperlinks created on pages within your frame. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or
select **Custom** to select a custom color from the Color wheel.

**See also:** Matching Colors Used within Your Title

Textual hyperlinks are underlined and displayed in the selected color.

3. Click **OK**.

**Setting a frame’s transition properties**
The transition type is inherited from the title properties by default. Changes applied to the transition type within your frame's properties will only be applied to the pages contained within the frame. Transitions will produce a special effect as users navigate from one page to another within the frame. You can select from over 20 different transitions. There is a **Slow to Fast** slider to determine the speed at which the transition takes place.

To set your frame’s transitions:
1. Double-click the frame graphic of the frame you want to change in the left-hand pane. The Frame Properties window opens. Click the **Transitions** tab.
2. Select a transition from the **Transition Type** list, and adjust the **Slow/Fast** slider accordingly.
3. Click **OK**.

Transitions are not recommended for titles published to the Web. This is because an entire page needs to load before the transition occurs and as a result, buttons and hyperlinks are disabled until the transition is complete.

**Using Lectora’s Modes**
Lectora provides five modes in which to view your title. These modes will enable you to preview and test your titles before publishing them for distribution.

**Edit Mode (F12):**
Edit mode is the working mode in which you create your title and edit the changes. When you create a new title, it will default to Edit mode. To view your title in Edit mode, select **Edit** from the **Mode** menu, click the **Edit** toolbar graphic, or press **F12** on your keyboard. While in Edit mode, use your keyboard’s **Page Up** and **Page Down** keys to navigate between pages in your title.

**Run Mode (F10):**
In Run mode, you may view your title with all buttons, links, and actions active. For example, in run mode, when you click on the Next button within your title, it will navigate to the next page, enabling you to run the content of your title, and test its functionality while having your left-hand pane in view. To view your title in run mode, select **Run** from the **Mode** menu, click the Run toolbar graphic, or press **F10** on your keyboard. Be sure to switch back to **Edit** mode when you want to continue working on the title.

**Preview Mode (F11):**
Preview mode shows your title in a centered background outside of the Lectora interface. All buttons, links, and actions are active. This functions identically the same as when in Run mode, however, you are no longer viewing your title within the Lectora interface. To view your title in Preview mode, select **Preview** from the **Mode** menu, click the Preview toolbar graphic, or press **F11** on your keyboard. To exit **Preview** mode, press **Esc** on your keyboard.

**Debug Mode:**
Debug mode is similar to Run mode. In Debug mode, all buttons, links, and actions are active, enabling you to run the content of your title, and test its functionality while having your left-hand pane in view. In addition, a debug window logs all
actions executed and all variable manipulations as you preview the functionality of your title. To view your title in Debug mode, select **Debug** from the **Mode** menu, click the Debug toolbar graphic. When you close the debug window, you will be returned to Edit mode.

**See also:** [Setting debug options](#)
[ Saving your debug log](#)
[ Printing your debug log](#)
[ Clearing your debug log](#)
[ Changing variables in debug mode](#)

**Preview in Browser (F9):**

Preview in Browser mode shows the title in a chosen browser. All actions on the page are active, but because only a single page is published, navigation to other pages will not function. To view a page within your browser, select **Preview in Browser** from the **Mode** menu, click the Preview in Browser toolbar graphic, or press F9 on your keyboard.

**Setting debug options**

You can specify the type of information you would like displayed within the debug window.

To set your debug options:

1. Run your title in debug mode by clicking the Debug Mode toolbar graphic or by selecting **Debug** from the **Mode** menu.

2. From the Debug Window, click on the **Options** button. The Debug Logging Options window appears.

3. Select the information you would like displayed within the Debug Window. Select any of the following:

   **Include all Variable Reads**  
   With this selected, the Debug Window will display the original variable values for variables that are associated with objects on the page. Variable values for questions, form objects, change contents actions, submit actions and variable modification actions are displayed within the Debug Window.

   **See also:** [Working With Variables](#)

   **Include all Variable Writes**  
   With this selected, the Debug Window will display new variable values as they are changed on the page. That is, if the variable is modified through a question, form object, variable modification action or other means, the new variable value will be displayed within the Debug Window.

   **See also:** [Working With Variables](#)

   **Include all Actions Triggered**  
   With this selected, the Debug Window will display an "Action fired!" message every time an action is triggered, along with details of what triggered the action.

   **Include all HTTP Communications**  
   This option is only available if you are publishing with Debug mode enabled. With this selected, any **POST** or **GET** methods used to communicate within the title will be posted to the debug window when they are executed.

   **Include all LMS Communications**  
   This option is only available if you are publishing with Debug mode enabled. With this selected, if you load your published title into a learning management system, the Debug Window will log all communications with the learning management system. This includes the transfer of test results as well as other communications.
4. Click **OK** to close the Debug Logging Options window.

**Working with the Debug window**
Using the Debug window, you can save, print, and clear your debug log as well as manipulate variable values when debugging your title.

Use the Debug window to complete these tasks:
- **Save your debug log**
- **Print your debug log**
- **Clear your debug log**
- **Change variable values in debug mode**

**Saving your debug log**
When testing the functionality of your title, it can be advantageous to save your debug log, especially if you run into problems. When you save your debug log, all of the messages contained within the Debug Window are exported to a .log textual file that you can review.

To save your debug log:
1. Run your title in debug mode by clicking the Debug Mode toolbar graphic or by selecting **Debug** from the **Mode** menu.
2. From the Debug Window, click the **Save** button. The Save As window opens.
3. Navigate to the location you want to save your log file and click **Save**.

**Printing your debug log**
You can print the debug log from the Debug Window.

To print your debug log:
1. Run your title in debug mode by clicking the Debug Mode toolbar graphic or by selecting **Debug** from the **Mode** menu.
2. From the Debug Window, click the **Print** button.

**Clearing your debug log**
While viewing your title in debug mode, you can clear all of the current messages displayed within the window.

To clear your debug log:
1. Run your title in debug mode by clicking the Debug Mode toolbar graphic or by selecting **Debug** from the **Mode** menu.
2. From the Debug Window, click the **Clear** button. This will clear all of the messages currently contained in your debug log, and you can begin debugging with an empty log.

**Changing variable values in debug mode**
While viewing your title in debug mode, you can change variable values. This allows for more thorough debugging by manipulating variables as you step through your title.

To change variables in debug mode:
1. Run your title in debug mode by clicking the Debug Mode toolbar graphic or by selecting **Debug** from the **Mode** menu.
The Debug Window opens.

2. From the Debug Window, click the Variables button.

   The Watch Variables window opens, displaying the current values for reserved and user-defined variables. Reserved variables that appear grayed out cannot be changed.

3. Modify a variable's value by changing the value in the field next to the variable name and clicking the Update button. Click Refresh to undo your changes.

   The variable's value is updated within the title.

4. Close the Variables window to continue viewing your title in debug mode.

   See also: Working with Variables

How Lectora Organizes Your Content
Lectora organizes the files you use to create your title. The My Titles directory is automatically created within your My Documents folder when you install Lectora. Whenever you create a new title, Lectora automatically creates a folder specifically for that title in the My Titles directory. Within your title folder, Lectora organizes all your media and image files.

For instance, if your title is called Orientation, a folder called Orientation will be present in the My Titles directory. Within the Orientation folder, you will find copies of every image or media file you have used within the title. When you add objects to a title, Lectora will copy the imported file into the title directory. Because Lectora copies all of its files, you will always have access to your original file, in its original location - as well as the one used in your title.

Your Orientation title folder, then, may contain a folder named images, another named media, and so on, as well as the title file, specified by an .awt extension. When you publish to HTML or CD-ROM, corresponding folders containing the published content will also appear in the Orientation folder.

Working with Text
Textual content in Lectora is created with the use of text blocks. The text block object, like all other objects, has configurable properties, and can be placed anywhere within your title. When you have added a text block to a page, you can begin typing your content. Double-click in the text block to view the cursor tool.

This chapter covers the following text options:
- About Adding Text
- Adding Text to Your Title
- Specifying Text Block Properties
- Changing Paragraph and Text Attributes
- Associating References to a Text Block
- Adding Hyperlinks to Text
- Adding Tables
- Adding an Object to a Text Block
- Changing the Default Text Style
- Formatting Multiple Text Blocks at Once
- Finding and Replacing Text
- Checking Spelling

About Adding Text

The following are some basic guidelines to follow when working with text:
- Remember not to use soft returns if you plan on converting to HTML. HTML sometimes reads soft returns as ASCII text.
- Text can be pasted inside of a text block. The text block will automatically resize to accommodate all of the text unless the text block expands beyond the content page. In this case, the text block will place a (+) in the bottom right corner. Any time you see the (+) in the bottom right corner of a text block, you can double-click on it to expand the text block to fit all of the text contained within it.
- Not all users will have the same fonts on their machine as you have. Therefore, it is best to use common fonts, such as Times New Roman, Helvetica, Arial, and other Windows standard fonts. Choosing these fonts will preserve the look and feel of your title.
- Although print media suggests that a serif font, such as Courier or Times New Roman is best, the exact opposite applies to online documentation. A Serif font can sometimes appear blurry on a computer monitor, whereas a Sans Serif font, such as Arial, Tahoma or Verdana will appear crisp and clean.

Common Text Formatting Shortcuts

<table>
<thead>
<tr>
<th>Function</th>
<th>Keyboard Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Undo</td>
<td>Ctrl+Z</td>
<td>Erases the last change done to your title. Use this to delete misspellings or typos. You can undo the last 20 changes.</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl+Y</td>
<td>Reverses the previous undo command. Use this if you unintentionally undo some changes.</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
<td>Copies highlighted text to the clipboard. Use this with the Paste function to repeat text in other places in your title.</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
<td>Copies highlighted text to the clipboard and removes it from your text block. Use this with the Paste function to remove text and paste it in other places in your title.</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
<td>Places cut or copied text from the clipboard at the cursor location within the text block.</td>
</tr>
</tbody>
</table>
Adding Text to Your Title

Choose from two methods to add text to your title:

- **Copy and paste text from an existing document**
- **Add a text block and type the text within the text block**

**Copying and pasting text from an existing document**

Adding text to Lectora can be completed by using standard copy and paste functionality.

To copy and paste text from an existing document:

1. Open the document containing the text to be added. For example, if you are copying from a Microsoft Word document, open the document in Word.

2. Highlight and copy the text by right-clicking and selecting **Copy** or by using the **Ctrl+C** keyboard shortcut.

3. Click within the content page in Lectora to which you want to add the text.

4. You can paste the text as formatted or unformatted text. Pasting as **Formatted Text** will paste the text maintaining its current formatting (font face, style, size, and so on) from the application from which it was copied. Pasting as **Unformatted Text** will paste the text, abandoning its current formatting, and will instead use the default text style selected within Lectora.

Paste the text by selecting **Paste As > Formatted Text** or **Paste As > Unformatted Text** from the **Edit** menu, or by using the **Ctrl+V** (formatted) or **Ctrl+Shift+V** (unformatted) keyboard shortcuts.

Lectora will automatically create a text block with the pasted text, however, in most cases, it will need to be resized to fit all of the text. Double-click on the text block to automatically resize it vertically until all the text is displayed. Alternatively, resize the text block by dragging the sides or corners of the text block to the appropriate size.

See also: **Moving and Resizing Objects**

**Adding a text block and typing the text within the text block**

Follow these steps to add a text block to your page:

1. In the left-hand pane, select the location onto which you want to add text and do one of the following:
   - From the **Add** menu, select **Object > Text Block**.
   - Click the **Add Text Block** toolbar graphic on the Insert toolbar.

   A text block appears in the upper left corner of your page.

2. Drag the text block to the appropriate place on the page.

3. Double-click the text to access the cursor tool, and begin typing your text.
Access the text block’s properties to add a background color, a border, or specify other options.

**See also:** Specifying Text Block Properties

### Specifying Text Block Properties
To access the properties of a text block object, right-click on the text block in the left-hand pane or within your work area and select **Properties**.

**See also:** Adding Text to Your Title

Use the controls on the Text Properties window to complete the following tasks:

#### General tab
- Change the name of a text block
- Specify the HTML text type of a text block
- Change the background color of a text block
- Make a text block initially invisible
- Place a text block on the top layer
- Lock the size and position of a text block
- Enable author control on a text block
- Render a text block as an image
- Wrap text around overlapping objects
- Display a vertical scroll bar in a text block
- Associate a text block with a form object

#### Position and Size tab
- Specify a text block’s position and size

#### Transitions tab
- Specify a text block’s transitions

#### Border and Margin tab
- Specify text block borders and margins

You can change the properties at any time by right-clicking on the text block and selecting **Properties**.

### Changing the name of a text block
Change the name of your text blocks so you can better recognize and manage them.

To change the name of a text block:

1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens. Click the **General** tab if the Text Properties window is not already opened to this tab.

2. Specify the new name of the text block in the **Text Block Name** field.

3. Click **OK**.

### Specifying the HTML text type of a text block
You can specify whether the text block should be labeled with an HTML H1 (heading level one), an HTML H2 (heading level two), or as normal HTML body text. This selection will not affect the formatting of the text block, but will define the importance of the text relative to the content. These headings are used by search engines to find pages containing content matching the searched keywords.

To specify the HTML text type of a text block:

1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens. Click the **General** tab if the Text Properties window is not already opened to this tab.

2. Use the **HTML Text Type** list to select the type of HTML text.
3. Click OK.

Changing the background color of a text block
You can select a background color or make the text block transparent. Select from several predefined colors, define a custom color, or use the eye-dropper tool to select a color from elsewhere within your title. The background color will appear behind the text in the text block.

To specify the background color of a text block:
1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens. Click the General tab if the Text Properties window is not already opened to this tab.

2. Use the Background Color list to select a background color. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

See also:  Matching Colors Used within Your Title

3. Click OK.

Making a text block initially invisible
By default, text blocks are set to be initially visible. That is, they appear when users open the pages on which the text blocks are located. You can initially hide a text block until an action has been executed to show the text block.

See also:  Selecting an action

To make a text block initially invisible:
1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens. Click the General tab if the Text Properties window is not already opened to this tab.

2. Clear the Initially Visible check box.

3. Click OK.

Placing a text block on the top layer
You can force a text block to always be on the top layer of the page. This is useful when you have multiple objects, including the text block, layered on your page.

To force a text block to the top layer:
1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens. Click the General tab if the Text Properties window is not already opened to this tab.

2. Select the Always on Top check box.

If multiple objects are set to Always on Top, Lectora will refer to the ordering of the objects in the left-hand pane to determine which of the objects is on the top-most layer. The top-most object listed on the page in the left-hand pane is on the bottom-most layer of the page.

See also:  Layering Objects

3. Click OK.

Locking the size and position of a text block
You can lock the size and position of a text block. This preserves it from getting accidentally moved by you or by other authors
working on your title.

The text block will be locked in size and position within Edit mode.

To lock the position and size of a text block:
1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens.
   Click the General tab if the Text Properties window is not already opened to this tab.
2. Select the Size/Position Locked check box.
3. Click OK.

You can also lock the size and position of the text block by right-clicking on the text block within the left-hand pane or within your work area and selecting Size/Position Locked from the right-click context menu. When the text block is locked, a check mark will appear to the left of the Size/Position Locked option within the menu.

**Enabling author control on a text block**
Protect the contents of a text block by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the contents of the text block unless they have the master Author Control password. The master Author Control password must first be set within the Title Properties.

**See also:** Protecting your title with a password

To enable author control on a text block:
1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens.
   Click the General tab if the Text Properties window is not already opened to this tab.
2. Select the Author Control check box.
3. Click OK.

You can also enable author control on the text block by right-clicking on the text block within the left-hand pane or within your work area and selecting Author Control from the right-click context menu. When author control is enabled, a check mark will appear to the left of the Author Control option within the menu.

**Rendering a text block as an image**
When publishing your title, you can select to publish a text block as an image rather than as text. This can have several advantages. During publishing, word wrapping and line height can sometimes vary between browsers, or even between versions of the same browser. If you need to maintain exact word alignment, such as when you are aligning overlapping images and text, use this setting. Also, use this setting if you use a non-standard font, and want it to be represented exactly. Some drawbacks of rendering text as an image are increased download time for images as opposed to text, and that a student will not be able to copy text from the text block to the clipboard. This setting cannot be used if the text block has embedded hyperlinks, is the target of a Change Contents action or if the text block has a vertical scroll bar.

If a text block is published as an image, the first 128 characters of text is used as its Alt tag. Alt tags have a limitation of 128 characters.

To render a text block as an image when published:
1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens.
   Click the General tab if the Text Properties window is not already opened to this tab.
2. Select the Render text as image when published check box.
3. Click **OK**.

**Wrapping text around overlapping objects**
You can have text within a text block automatically flow around objects layered above the text block. Objects layered below the text block will not affect the contents of the text block.

*See also:* Layering Objects

To wrap text around overlapping objects:

1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens. Click the **General** tab if the Text Properties window is not already opened to this tab.

2. Select the **Wrap text around overlapping objects** check box.

3. Click **OK**.

**Displaying a vertical scroll bar in a text block**
For text blocks with more text that can fit within the text block, you can provide a vertical scroll bar enabling users to view the entire contents. Lectora will display a plus sign (+) in the lower-right corner of a text block to indicate that additional text is unable to be displayed within the text block.

Selecting to show the vertical scroll bar will disable the ability to wrap text around overlapping objects and rendering text as an image when published.

If a plus-sign is displayed in the text block, double-click the text block to automatically resize the text block to fit all the text. Otherwise, enable the vertical bar so that users can view the entire content.

To show a vertical scroll bar within the text block:

1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens. Click the **General** tab if the Text Properties window is not already opened to this tab.

2. Select the **Show Vertical Scroll Bar** check box.

3. Click **OK**.

**Associating a text block with a form object**
You can associate the text block with a form object, such as a drop-down list or an entry field. After you have added the form object and text block to the page, you can associate the two to use the text block as a label for the form object.

To associate a text block with a form object:

1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens. Click the **General** tab if the Text Properties window is not already opened to this tab.

2. Select the **Label for** check box and select the form object from the drop-down list.

3. Click **OK**.

**Specifying a text block's position and size**
You can directly set the position and size of a text block from within its properties.

To specify the position and size of a text block:

1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens.
Click the **Position and Size** tab.

2. Specify the following information. All measurements are based on pixels.

   **X Coordinate**
   Specify the horizontal distance of the text block relative to the top-left corner of the page.

   **Y Coordinate**
   Specify the vertical distance of the text block relative to the top-left corner of the page.

   **Offset from right**
   Select this to change the reference point (from the right) from which the text block is placed.

   **Offset from bottom**
   Select this to change the reference point (from the bottom) from which the text block is placed.

   **Width**
   Specify the width of the text block.

   **Height**
   Specify the height of the text block.

3. Click **OK**.

You can also specify the position of your text block directly from the status bar.

See also: [Using the Status bar](#)

**Specifying a text block's transitions**

You can specify how a text block is displayed on a page. Transitions will produce a visual effect as the object appears and disappears. You can select from over 20 different transitions. There is a **Slow** to **Fast** slider to determine the speed at which the transition takes place.

To specify the transition:

1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens. Click the **Transitions** tab.

2. Specify the following information:

   **Transition In**
   Select this to enable a transition when displaying the text block as the page opens or the text block is made visible with an action.

   **Transition (In) Type**
   Select a transition type as one of the following:

   - Box In
   - Box Out
   - Circle In
   - Circle Out
   - Wipe Up
   - Wipe Down
   - Wipe Right
   - Wipe Left
   - Blinds Vertical
   - Blinds Horizontal
   - Checker Across
   - Checker Down
   - Split out Horizontal
   - Strips Down left
   - Strips Up left
   - Strips Downright
   - Strips Upright
   - Horizontal Bars
   - Vertical Bars
   - Fly Top
   - Fly Top right
   - Fly Right
   - Fly Bottom right
   - Fly Bottom
Delay before transition Specify the delay in seconds before starting the transition. Select between 0 and 600 seconds.

Slow > Fast Use the slider to specify the speed at which the transition should occur.

Transition Out Select this to enable a transition when hiding the text block as the page closes or the text block is hidden with an action.

Transition (Out) Type Select a transition type as one of the following:
- Box In
- Box Out
- Circle In
- Circle Out
- Wipe Up
- Wipe Down
- Wipe Right
- Wipe Left
- Blinds Vertical
- Blinds Horizontal
- Checker Across
- Checker Down
- Dissolve
- Split in Vertical
- Split out Vertical
- Split in Horizontal
- Split out Horizontal
- Strips Down left
- Strips Up left
- Strips Down right
- Strips Upright
- Horizontal Bars
- Vertical Bars
- Fly Top
- Fly Top right
- Fly Right
- Fly Bottom right
- Fly Bottom
- Fly Bottom left
- Fly Left
- Fly Top left
- Random Effect

Delay before transition Specify the delay in seconds before starting the transition. Select between 0 and 600 seconds.

Slow > Fast Use the slider to specify the speed at which the transition should occur.

3. Click OK.

Specifying text block borders and margins
You can add borders and specify margins of your text block.

To configure the border and margin:
1. Double-click on the text block graphic of the text block in the left-hand pane. The Text Properties window opens. Click the Border and Margin tab.

2. Specify the following information:

  Border Size Select the border size in pixels. The border will be created along the perimeter of the text block.

  Border Color Select the color of the border. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color Lectora Information Center.
wheel.

**See also:** Matching Colors Used within Your Title

**Border Style**
Select the style of the border.

**Outline**
Select this to add a one-pixel wide box around the text block. The outline is an additional outermost outline that will appear around the perimeter of the text block.

**Outline Color**
Select the color of the outline. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

**See also:** Matching Colors Used within Your Title

**Margin Size**
Select the size of the margin for the text block. The margin is the space between the text within the text block and the border.

3. Click **OK**.

### Changing Paragraph and Text Attributes
Use Lectora’s Text toolbar to format text and paragraph attributes. Double-click within a text block to display the cursor, and highlight the text whose attributes you want to change.

You can complete the following using Lectora’s Text toolbar:

- Apply a text style
- Change the font
- Change the font size
- Change the font color
- **Bold, Italicize, and underline**
- **Superscript and subscript**
- Justify text
- Highlight text
- Add indent levels
- Add bullets
- Add a numbered list
- **Changing paragraph spacing**

### Applying a text style
You can define text styles that automatically set text attributes such as the font face, style, size and color. Instead of manually formatting text, you can apply a text style to a text block. Lectora will then format the text to include all attributes that are specified within the text style.

To apply a text style to your text block:
1. Select the text block you want to change.

2. On the Text toolbar, use the **Text Style** list to select a text style. Choose from the following predefined text styles:
   - Title
   - Subtitle
   - Body text
You can edit the default styles or create your own styles. Text styles can also be applied to your entire title or to individual chapters, sections, and pages.

See also: Managing Text Styles  
Changing text properties for chapter, sections and pages

Changing the font
You can quickly change the font of the text in a text block.

Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

To change the font:
1. Double-click within the text block and select the text you want to change.
2. On the Text toolbar, use the Font list to select a font.

A default font can be used throughout your entire title, within a chapter, within a section, or on a page.

See also: Managing Text Styles  
Changing text properties for chapter, sections and pages

Changing font size
You can quickly change the font size of the text in a text block. Font sizes are displayed in points, as in most standard word processing applications. If you convert to HTML, Lectora automatically matches the font size to the HTML equivalent.

To change the font size:
1. Double-click within the text block and select the text you want to change.
2. On the Text toolbar, use the Font size list to select a font size or type the font size directly in the Font size list.

Changing font color
You can quickly change the color of the font. Select from several predefined colors, define a custom color, or use the eye-dropper tool to select a color from elsewhere within your title.

To change the font color:
1. Double-click within the text block and select the text you want to change.
2. On the Text toolbar, use the Font color list to select a font color. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

See also: Matching Colors Used within Your Title

Bolding, italics, and underlining
You can make text bold, italic, or underlined.

To bold, italicize or underline text:
1. Double-click within the text block and select the text you want to change.
2. Choose from three ways to apply these attributes:
   o Click the appropriate graphic on the Text toolbar:
     - **Bold**
     - *Italic*
     - **Underline**

   o Right-click, and select the appropriate attribute from the Font submenu:
     - **Font > Bold** — **Bold**
     - **Font > Italic** — *Italic*
     - **Font > Underline** — **Underline**

   o Type the appropriate keyboard shortcut:
     - **Ctrl+B** — **Bold**
     - **Ctrl+I** — *Italic*
     - **Ctrl+U** — **Underline**

**Superscripting and subscripting**
You can superscript and subscript text.

To superscript or subscript text:
1. Double-click within the text block and select the text you want to change.

2. Choose from two ways to apply these attributes:
   o Right-click, and select the appropriate attribute from the Font submenu:
     - **Font > Superscript** — **A**
     - **Font > Subscripts** — **A**

   o Type the appropriate keyboard shortcut:
     - **Alt+4** — **A**
     - **Alt+5** — **A**

**Justifying text**
You can select how the text is to be justified within a text block. Select from aligning left or right, centering in the middle, or justified left and right.

To justify your text:
1. Double-click within the text block and select the text you want to change.

2. Choose from two ways to apply these attributes:
   o Click the appropriate graphic on the Text toolbar:
     - Align left
     - Center
Highlighting text
You can highlight text. When you highlight text, the color chosen will appear behind the selected text.

To highlight your text:
1. Double-click within the text block and select the text you want to highlight.
2. On the Text toolbar, use the Highlight list to select the highlight color. Select a predefined color, select the eyedropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

   See also: Matching Colors Used within Your Title

Adding indent levels
You can indent text within a text block.

To indent your text:
1. Double-click within the text block and select the text you want to change.
2. Choose from two ways to apply these attributes:
   o Click the appropriate graphic on the Text toolbar:
     Decrease indent
     Increase Indent
   o Right-click, and select the appropriate attribute from the Paragraph submenu:
     Paragraph > Decrease Indent  Decrease Indent
     Paragraph > Increase Indent  Increase Indent

Adding bullets
You can create bulleted lists within a text block
To add bullets to your text:
1. Double-click within the text block and select the text you want to change.

2. Choose from two ways to add bullets:
   - Click the Bullets graphic on the Text toolbar.
   - Right-click, and select **Paragraph > Bulleted List**.

**Adding a numbered list**
You can create a numbered list within a text block

To add bullets to your text:
1. Double-click within the text block and select the text you want to change.

2. Choose from two ways to start a numbered list:
   - Click the Numbered List graphic on the Text toolbar.
   - Right-click, and select **Paragraph > Numbered List**.

You can also change the numbering within your numbered list.

*See also:* Changing numbered lists

**Changing numbered lists**
You can change the numbering used in your numbered list.

To change the numbering used in your numbered list:
1. Double-click within the text block and highlight the numbered list.

2. Right-click, and select **Paragraph > Numbering Options**. Use the **Starting Number** field to specify a new starting number for the current list item. Use the **Numbering Style** field to select the desired numbering scheme. Choose from the following numbering schemes:

<table>
<thead>
<tr>
<th>Numbering</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decimal</td>
<td>1., 2., 3.</td>
</tr>
<tr>
<td>Uppercase Alpha</td>
<td>A., B., C.</td>
</tr>
<tr>
<td>Lowercase Alpha</td>
<td>a., b., c.</td>
</tr>
<tr>
<td>Upper Roman</td>
<td>I., II., III.</td>
</tr>
<tr>
<td>Lower Roman</td>
<td>i., ii., iii</td>
</tr>
</tbody>
</table>

**Changing paragraph spacing**
You can change the spacing between lines of text in a text block.

To change paragraph spacing:
1. Double-click within the text block and select the text you want to change.

2. Right-click, and select **Paragraph > Paragraph Spacing**. The Paragraph Spacing window opens. Use the Paragraph Spacing window to specify the following spacing options for your text:

<table>
<thead>
<tr>
<th>Space Before Paragraph</th>
<th>Specify a number in points to create space before the currently selected</th>
</tr>
</thead>
</table>
paragraph.

**Space After Paragraph** Specify a number in points to create space after the currently selected paragraph.

**Line Spacing** Select one of the following line spacing options:
- Single
- 1.25 Lines
- 1.5 Lines
- Double
- At Least
- Multiple

If you select **At Least**, further specify the spacing number in points. The lines will be spaced at least the value specified and more if necessary.

If you select **Multiple**, specify the new line spacing value in the field.

**Associating References to a Text Block**
You can associate references to your text block.

To associate references to a text block:
1. Highlight the text and click the **Reference** graphic on the Text toolbar. The Reference Properties window opens.
2. Specify the following information:
   - **Author(s)** Specify the names of the authors of the item.
   - **Title of Work/Web Page Address** Specify either the title of the item or the Web page address.
   - **Publisher** Specify the publisher of the item.
   - **Date of Publication** Specify the date of publication of the item.
3. Click **OK**.

**Adding Hyperlinks to Text**
You can add hyperlinks to your text. A hyperlink is specially highlighted text that when clicked, enable users to navigate to another location within your title, open a pop-up window, or perform other actions.

**See also:** [Selecting an action](#)

To add a hyperlink:
Choose from two ways to add a hyperlink:
1. Double-click within the text block and select the text you want to hyperlink.
2. Choose from two ways to add a hyperlink:
   - Click the **Hyperlink** graphic on the Text toolbar.
   - Right-click and select **Add Hyperlink**.

The Text Hyperlink Properties window opens.
3. Select the action you want to execute from the **Action** drop-down list. Specify additional information based on the action you select. For example, to create a hyperlink that allows users to jump to another part of the title when they click on the link, select **Go To** from the **Action** list. Select **Chapter, Section, or Page** in the **Target** list and select the name of the page to which you want to navigate from the **Name** list.

4. Click **OK**.

To edit the Text Hyperlink Properties, double-click on the text block containing the hyperlink, and further double-click on the hyperlink.

**Adding Tables**

You can create tables within text blocks. Tables can be used to structure data or can be used to align textual information.

To insert a table into your text block:
1. Double-click within the text block and place the cursor in the location you want to add a table.
2. Right-click and select **Table** > **Insert Table**. The New Table Parameters window opens.
3. Specify the number of rows and columns you want to display in your table.
4. Click **OK** to display your table.

When the table has been created, you can enter the textual content into the individual cells, and format the table as necessary.

**See also:**  
Formatting tables  
Formatting cells in a table

**Formatting tables**

After a table has been created, you can insert and combine rows and columns or format the table by adjusting table cell widths, colors and alignment.

To format a table:
1. Double-click within the text block containing the table and select the rows or columns of the table you want to format.
2. Right-click and select the appropriate function from the **Table** submenu:

   - **Insert Row** Adds a new row to your table.
   - **Insert Column** Adds a new column to your table.
   - **Header Row** Designates the selected row as a header row. When publishing to any Web-based format, header row text will always be bolded within the table. Header rows are also used by assistive technologies to associate the data in the table with the headers specified.
   - **Merge Cells** Merges the selected cells to form a single cell.
   - **Split Cells** Splits a single cell into two cells.
   - **Delete Cells** Provides you with the option to delete a cell, delete an entire column, or delete an entire row.
   - **Cell Properties** Click this to open the Cell Properties window. Use this dialog box to specify properties relating to the selected cells of the table, such as cell width, color, and alignment.
Select Current Column
Selects the entire column in which your cursor is positioned.

Formatting cells in a table
You can change the appearance of the cells in your table.

To format cells in a table, highlight the cell or cells in the table, right-click, and select Table > Cell Properties. The Cell Properties window opens.

Use the controls on the Cell Properties window to complete the following tasks:

- **Cell tab**
  - Specify row height, cell width and margin properties

- **Cell Color tab**
  - Specify cell color properties

- **Alignment tab**
  - Specify cell alignment properties

- **Border tab**
  - Specify cell border properties

- **Border Color tab**
  - Specify cell border color properties

Specifying row height, cell width and margin properties
You can directly specifying the row height, cell width and margin properties of cells within a table.

To specify the cell width and margin properties:
1. Double-click on the text block containing the table whose cells you want to format.
2. Highlight the cell or cells in the table, right-click, and select Table > Cell Properties. The Cell Properties window opens. Click the Cell tab if the Cell Properties window is not already opened to this tab.
3. In the Range box, select the range of cells to which you want to apply the properties. Click Entire Table to apply the change to the entire table or click Selected Cells to apply the change to the cells you selected.
4. Specify the **Row Height**, **Cell Width** and **Cell Margin** in pixels. A preview of the selections is displayed.
5. Click OK.

Specifying cell color properties
You can specify color properties for cells within a table. Specifying a cell color will change the background color of the selected cells.

To specify the cell color properties:
1. Double-click on the text block containing the table whose cells you want to format.
2. Highlight the cell or cells in the table, right-click, and select Table > Cell Properties. The Cell Properties window opens. Click the Cell Color tab.
3. In the Range box, select the range of cells to which you want to apply the properties. Click Entire Table to apply the change to the entire table or click Selected Cells to apply the change to the cells you selected.
4. Use the Cell list to select a cell color. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.
5. Click OK.

See also: Matching Colors Used within Your Title
Specifying cell alignment properties
You can specify how text should be vertically aligned within cells of a table.

To specify the cell alignment properties:
1. Double-click on the text block containing the table whose cells you want to format.
2. Highlight the cell or cells in the table, right-click, and select Table > Cell Properties. The Cell Properties window opens. Click the Alignment tab.
3. In the Range box, select the range of cells to which you want to apply the properties. Click Entire Table to apply the change to the entire table or click Selected Cells to apply the change to the cells you selected.
4. In the Vertical Alignment box, select how text and objects should be vertically aligned within the cell. Select to align contents at the Top, Center, or Bottom of the cell. A preview of the selections is displayed.
5. Click OK.

Specifying cell border properties
You can specify border widths for cells of a table.

To specify the cell border properties:
1. Double-click on the text block containing the table whose cells you want to format.
2. Highlight the cell or cells in the table, right-click, and select Table > Cell Properties. The Cell Properties window opens. Click the Border tab.
3. In the Range box, select the range of cells to which you want to apply the properties. Click Entire Table to apply the change to the entire table or click Selected Cells to apply the change to the cells you selected.
4. In the Border Width box, use the lists to specify Top, Left, Right, and Bottom border widths. If the Make all borders the same width check box is selected, the top, left, right, and bottom borders will remain the same, and any changes applied to one of the borders will be applied to all borders. Otherwise, the borders can be changed independently, and different border widths for each can be selected. Select Apply border to each cell to apply the specified borders to all cells within the selected range or select Apply border around cell range to apply the specified borders around the cells within the selected range. A preview of the selections is displayed.
5. Click OK.

Specifying cell border color properties
You can specify border colors for cells of a table.

To specify the cell border color properties:
1. Double-click on the text block containing the table whose cells you want to format.
2. Highlight the cell or cells in the table, right-click, and select Table > Cell Properties. The Cell Properties window opens. Click the Border Color tab.
3. In the Range box, select the range of cells to which you want to apply the properties. Click Entire Table to apply the change to the entire table or click Selected Cells to apply the change to the cells you selected.
4. In the Border Color box, specify Top, Left, Right, and Bottom border colors. Select a predefined color, select the eyedropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.
If the Keep all borders the same color check box is selected, the top, left, right, and bottom borders will remain the same color, and any changes applied to one of the borders will be applied to all borders. Otherwise, the borders can be changed independently, and different border colors for each can be selected. A preview of the selections is displayed.

5. Click OK.

Adding an Object to a Text Block
You can add animations, images, equations, or buttons within a text block.

To add an object within a text block:
1. Place the cursor where you want to place the object within the text block.

2. Do one of the following:
   - Select Add > Object from the menu bar and select the object you want to add (Animation, Button, Equation, or Image). Choosing an object other than these four will simply add the object to the page, and not within the text block.
   - Click on the Animation, Button, Equation, or Image toolbar graphic on the Insert toolbar.
   - Right-click and select the appropriate object from the Insert submenu.

3. The object is inserted at the cursor position inside the text block.

See also: Working with Animations
Working with Buttons
Working with Equations
Working with Images

Managing Text Styles
Text styles define text attributes such as the font face, style, size and color. You can create new text styles, edit current text styles, or delete unused text styles. Instead of manually formatting text, you can apply a text style to a text block. They can also be applied to your entire title or to individual chapters, sections, and pages. When a text style is applied, Lectora will format the text to include all attributes that are specified within the text style.

This section covers the following topics:
- Editing a text style
- Creating a new text style
- Deleting a text style
- Importing and exporting text styles

Editing a text style
You can edit existing text styles.

To edit a text style:
1. Click the Text Style drop-down list on the Text toolbar and select Edit Styles. The Text Styles window opens.

2. Select the text style from the list you want to edit and click the Edit button. The Text Style window opens.

3. Use the Text Style window to modify the font attributes. You can select a Font, Font style, font Size, font Color, Underline, and choose the Script type. Click OK to apply the changes to your font style.
4. You will be prompted whether to change all text in the current title using the font style you edited. If you answer **Yes**, all the text using the current font style will be changed. If you answer **No**, text using the current font style is not changed.

5. Click **Done**.

**Creating a new text style**
Create new text styles to use within your titles.

To create a custom text style:
1. Click the **Text Style** drop-down list on the Text toolbar and select **Edit Styles**. The Text Styles window opens.

2. Click the **New** button. The Text Style window opens.

3. Specify a **Style Name** and select the font attributes for your new style. You can select a **Font**, **Font style**, font **Size**, font **Color**, **Underline**, and choose the **Script** type. Click **OK** to create your new font style.

4. The new text style is listed in the Text Styles window and added to the **Text Styles** drop-down list.

5. Click **Done**.

**Deleting a text style**
Delete unused custom text styles. You cannot delete predefined text styles.

To delete a custom text style:
1. Click the **Text Style** drop-down list on the Text toolbar and select **Edit Styles**. The Text Styles window opens.

2. Select the custom text style you want to delete and click the **Delete** button.

   The deleted style is removed from Text Styles window and **Text Style** drop-down menu.

3. Click **Done**.

**Importing and exporting text styles**
You can import and export text styles. This will enable you to add text styles for use within your titles (import) and save a copy of a text style (export) in a location for easy access for sharing or emailing. Custom text style files contain the .als file extension.

To import a text style:
1. Click the **Text Style** drop-down list on the Text toolbar and select **Edit Styles**. The Text Styles window opens.

2. Click **Import Styles** to navigate and add a custom text style to the list of available text styles.

3. Click **Done**.

To export a text style:
1. Click the **Text Style** drop-down list on the Text toolbar and select **Edit Styles**. The Text Styles window opens.

2. Select the text style you want to export and click **Export Styles**.

   You can select multiple text styles by holding down the **Ctrl** key while selecting styles.
The Save As window opens.

3. Navigate and save the text style to the desired location.

4. Click Done.

**Changing the Default Text Style**

You can change the default text style that is used throughout your title. You can also limit a style to be applied within a chapter, a section, or a page. When a text style is specified within the title properties, all text blocks within the title will automatically be formatted with the attributes of the text style chosen. When a text style is specified within chapter properties, it will only be applied to text blocks within that chapter. The same is true for sections. Finally, when a text style is specified within page properties, only the text blocks on that page will be automatically formatted using the style chosen.

To change the default font:

1. Double-click the graphic in the left-hand pane next to the title, chapter, section or page you want to change. The Properties window opens. Click the **Background** tab.

2. Select the **Default Text Style** from the list. To add a new font style or edit an existing font style, click the **Styles** button. The Text Styles window opens. Use the Test Styles window to manage your text styles.

   **See also:** Managing Text Styles

   Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

3. Click OK.

At any time during creating your title, you can return to the Properties window to assign a different text style. Lectora will reformat all existing text blocks within the title to the new text style chosen. This reformatting can occur at any organizational level. For example, use the **Background** tab within a Chapter Properties window to change the default text style for that chapter only.

**See also:** Changing a title's text properties  
Changing text properties for chapters, sections and pages

**Formatting Multiple Text Blocks at Once**

You can simultaneously format multiple text blocks.

To format multiple text blocks at once:

1. Select multiple text blocks in one of the following ways:
   - While holding down the **CTRL** key, select multiple text blocks either from the left-hand pane, or from within your work area.
   - Within the work area, click the left mouse button and while holding it down, draw a rectangular around the text blocks you want to format.

2. When the text blocks are selected, use the Text toolbar to reformat the text. Each selected text block will automatically change based on the reformatting changes you make.

**Finding and Replacing Text**

You can find and replace text throughout the title, including question feedback, messages displayed, menu text, Go To Web addresses, and notes.
To quickly search for every occurrence of a specific word or phrase:

1. Do one of the following:
   - From the Edit menu, select Find.
   - Click the Find toolbar graphic on the Standard toolbar.
   - Type Ctrl+F.

   The Find window opens.

2. In the Find what field, enter the text for which you are searching. Select Match case if you want the capitalization to match.

3. Click Find.

4. Click Find Next or press F3 to find the next instance or click Cancel to cancel a search in progress.

To automatically replace text based on a search for a specific word or phrase:

1. Select Edit > Replace from the menu bar or press Ctrl+H. The Find window opens.

2. In the Find what field, enter the text for which you are searching. In the Replace with field, enter the replacement text. Select Match case if you want the capitalization to match.

3. Click Find to find individual occurrences and replace them individually. Click Replace to replace the occurrence that currently has focus. Click Replace All to replace all occurrences of the found text, or click Cancel to exit the Find window.

Checking Spelling

There are three ways to perform a Spell Check from within Lectora:

- Click on the Spell Check toolbar graphic on the text toolbar.
- Select Tools > Spell Check > Current Page or Entire Title from the menu bar.
- Press F7 to spell check the current page or Ctrl+F7 to spell check the entire title.

You can also configure your Lectora preferences to enable spell check while typing.

See also: Enabling spell check while typing

Spell checks will check for spelling errors within all text blocks, and additional textual information including question feedback, messages used in display message actions, button text, and menu items.

You can complete the following for use in checking spelling:

- Add words to your dictionary
- Configure spelling options

Adding words to your dictionary

You can add words to the Lectora dictionary. Adding words to the dictionary will no longer identify the added word as a misspelled word when checking spelling.

To add a word to your dictionary:
1. Double-click within the text block containing the word you want to add.

2. Highlight or select the word you want to add, right-click and select Add to Dictionary.

**Configuring spelling options**
You can configure different spelling options, including selecting the main dictionary language as well as many other options.

To configure spelling options:
1. From the **Tools** menu, select **Spell Check > Options**. The Spelling Options window opens.

2. Configure the spelling options as necessary. For additional information regarding the spelling options, click the **Help** button.

**Working with Objects**
You can add several types of objects to your title.

This chapter explains how to insert objects into your title, how to change their properties, and how to edit them. The following topics are covered:

- About Adding Objects
- Adding Objects to Your Title
- Changing Common Object Properties
- Working with Animations
- Working with Audio
- Working with Buttons
- Working with Documents
- Working with Equations
- Working with External HTML Objects
- Working with Images
- Working with IPIX Images
- Working with Menus
- Working with Progress Bars
- Working with Reference Lists
- Working with Tables of Contents
- Working with Video
- Adding Shapes, Lines and Arrows
- Grouping and Ungrouping Objects
- Excluding Objects Using Inheritance
- Editing Objects
- Moving and Resizing Objects
- Locking and Unlocking Objects
- Aligning and Positioning Objects
- Layering Objects
- Working with Library Objects
- Working with the Media Organizer

**About Adding Objects**
In most cases, when you add an object to your title in any way other than dragging and dropping, the General object properties will appear. For objects that require a file source, such as images, audio or video, click on the **Import** button to locate and select the appropriate file you want to import. Each object in Lectora supports a variety of file types. For example, the animation object in Lectora can support Flash files (.swf) or animated GIFs (.gif). For those objects that do not require a file source, you will either be prompted to configure the object’s properties, or the object will simply appear within your title.

Any time you add an object to your title, regardless of how you have added it, Lectora creates a copy of the file and places it within the same directory as your title. For example, if you add an image to your title, Lectora will make a copy of that image file, and place it within the **images** folder that coincides with your title. Only supported file types can be dragged and dropped into your Lectora title, otherwise, Lectora will prompt you to add the file as an additional file.

**See also:**
- Supported Media Types
- Adding additional files to your title
How Lectora Organizes Your Content

Adding Objects to Your Title
Choose from the following ways to add objects to your title:

- Select **Add > Object** from the menu bar and select the type of object you want to add.
- Click the corresponding toolbar graphic.
- Drag and drop the object to your work area.
- Right-click in the work area, select **New > Object** and select the type of object you want to add.

Further information on the following is available:

- Dragging and dropping an object
- Shortcuts for adding objects

Dragging and dropping an object
You can add objects by dragging and dropping them into Lectora from your Windows desktop or from Windows Explorer.

To drag and drop objects into your title:
1. Open a Windows Explorer window containing media files (objects such as images, Flash, video, and so on) so that it is along side your Lectora window.
2. Select any object or multiple objects within Windows Explorer.
3. Drag the selected object(s) from your Windows Explorer window into your Lectora work area.

The objects will then appear in your title, where you can arrange them in any way you choose. The object will appear in both your work area and in the left-hand pane. Double-click the object or right-click the object and select **Properties** to access the object's properties.

You can easily re-order items in the left-hand pane by clicking on them, and while holding down the left mouse button, dragging the item within the left-hand pane to its new location. Once the location is chosen, release the left mouse button, and the item will be moved.

Shortcuts for adding objects
The following keyboard shortcuts are available for quickly adding objects:

<table>
<thead>
<tr>
<th>Assignable Unit</th>
<th>Ctrl+0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter</td>
<td>Ctrl+1</td>
</tr>
<tr>
<td>Section</td>
<td>Ctrl+2</td>
</tr>
<tr>
<td>Page</td>
<td>Ctrl+3</td>
</tr>
<tr>
<td>Action</td>
<td>Ctrl+4</td>
</tr>
<tr>
<td>Group</td>
<td>Ctrl+5</td>
</tr>
<tr>
<td>Test</td>
<td>Ctrl+6</td>
</tr>
<tr>
<td>Test Section</td>
<td>Ctrl+7</td>
</tr>
<tr>
<td>Question</td>
<td>Ctrl+8</td>
</tr>
<tr>
<td>Survey</td>
<td>Alt+6</td>
</tr>
<tr>
<td>Survey Question</td>
<td>Alt+8</td>
</tr>
</tbody>
</table>
### Changing Common Object Properties

Many properties for objects in Lectora (images, audio, video and so on) are the same. You can access these properties for individual objects by double-clicking the object or by selecting the object and pressing the **Enter** key.

The following can be completed within most if not all object properties:

- Change the name of an object
- Make an object initially invisible
- Place an object on the top layer
- Lock the size and position of an object
- Enable author control on an object
- Use an empty ALT tag for an object
- Pre-load an object for Web-based publishing
- Specify an object’s position and size
- Specify an object’s transitions
- Add a reference for an object
- Include metadata for an object

<table>
<thead>
<tr>
<th>Object</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Animation</td>
<td>Ctrl+9</td>
</tr>
<tr>
<td>Audio</td>
<td>Ctrl+Shift+0</td>
</tr>
<tr>
<td>Button</td>
<td>Ctrl+Shift+1</td>
</tr>
<tr>
<td>Document</td>
<td>Ctrl+Shift+2</td>
</tr>
<tr>
<td>Equation</td>
<td>Ctrl+Shift+3</td>
</tr>
<tr>
<td>External HTML</td>
<td>Ctrl+Shift+4</td>
</tr>
<tr>
<td>Image</td>
<td>Ctrl+Shift+5</td>
</tr>
<tr>
<td>IPIX Image</td>
<td>Ctrl+Shift+6</td>
</tr>
<tr>
<td>Menu</td>
<td>Ctrl+Shift+7</td>
</tr>
<tr>
<td>Progress Bar</td>
<td>Ctrl+Alt+9</td>
</tr>
<tr>
<td>Reference List</td>
<td>Ctrl+Shift+8</td>
</tr>
<tr>
<td>Table of Contents</td>
<td>Ctrl+Shift+9</td>
</tr>
<tr>
<td>Text Block</td>
<td>Ctrl+Alt+0</td>
</tr>
<tr>
<td>Video</td>
<td>Ctrl+Alt+1</td>
</tr>
<tr>
<td>Form</td>
<td>Ctrl+Alt+2</td>
</tr>
<tr>
<td>Radio Button Group</td>
<td>Ctrl+Alt+3</td>
</tr>
<tr>
<td>Radio Button</td>
<td>Ctrl+Alt+4</td>
</tr>
<tr>
<td>Check Box</td>
<td>Ctrl+Alt+5</td>
</tr>
<tr>
<td>Entry Field</td>
<td>Ctrl+Alt+6</td>
</tr>
<tr>
<td>Drop-down List</td>
<td>Ctrl+Alt+7</td>
</tr>
<tr>
<td>List Box</td>
<td>Ctrl+Alt+8</td>
</tr>
</tbody>
</table>
Changing the name of an object
If the object whose name you want to change relies on a resource file, it is automatically named from the file in which it originates. That is, if you added MyImage.jpg to your title, the image will be named MyImage. You can change the name of your objects.

See also: Using resource names as object names

To change the name of an object:
1. Double-click on the object within your work area. The (Object) Properties window opens. Click the General tab if the (Object) Properties window is not already opened to this tab.
2. Specify the new name of the object in the (Object) Name field. For images and buttons, this is also the name that will be used as the ALT tag when you publish to the Web.
3. Click OK.

Making an object initially invisible
By default, objects are set to be initially visible. That is, they appear when users open the pages on which the objects are located. You can initially hide an object until an action has been executed to show the object.

See also: Selecting an action

To make an object initially invisible:
1. Double-click on the object within your work area. The (Object) Properties window opens. Click the General tab if the (Object) Properties window is not already opened to this tab.
2. Clear the Initially Visible check box.
3. Click OK.

Placing an object on the top layer
You can force an object to always be on the top layer of the page. This is useful when you have multiple objects layered on your page.

To force an object to the top layer:
1. Double-click on the object within your work area. The (Object) Properties window opens. Click the General tab if the (Object) Properties window is not already opened to this tab.
2. Select the Always on Top check box.

   If multiple objects are set to Always on Top, Lectora will refer to the ordering of the objects in the left-hand pane to determine which of the objects is on the top layer. The top-most object listed on the page in the left-hand pane is on the bottom layer of the page.

See also: Layering Objects
3. Click OK.

Locking the size and position of an object
You can lock the size and position of an object. This preserves it from getting accidentally moved by you or by other authors working on your title.

The object will be locked in size and position within Edit mode.
To lock the position and size of an object:
1. Double-click on the object within your work area. The (Object) Properties window opens. Click the General tab if the (Object) Properties window is not already opened to this tab.

2. Select the Size/Position Locked check box.

3. Click OK.

You can also lock the size and position of the object by right-clicking on the object within the left-hand pane (or within your work area) and selecting Size/Position Locked from the right-click context menu. When the object is locked, a check mark will appear to the left of the Size/Position Locked option within the menu.

See also: Locking and Unlocking Objects

Enabling author control on an object
Protect the object by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the object unless they have the master Author Control password. The master Author Control password must first be set within the Title Properties.

See also: Protecting your title with a password

To enable author control on an object:
1. Double-click on the object within your work area. The (Object) Properties window opens. Click the General tab if the (Object) Properties window is not already opened to this tab.

2. Select the Author Control check box.

3. Click OK.

Using an empty ALT tag for an object
You can create an empty ALT tag for an object. An empty ALT tag will ensure that no tip text is displayed when the user rests their mouse over the object. Also, assistive technologies will not recognize or will skip over any objects containing an empty ALT tag.

To use an empty ALT tag for an object:
1. Double-click on the object within your work area. The (Object) Properties window opens. Click the General tab if the (Object) Properties window is not already opened to this tab.

2. Select the Use empty ALT when published to HTML check box.

3. Click OK.

Pre-loading an object for Web-based publishing
You can choose to load an object before the entire Web page is displayed. This option is selected by default, and will ensure that when the page is displayed, the object to which this pertains will be visible to the user.

To pre-load an object:
1. Double-click on the object within your work area. The (Object) Properties window opens. Click the General tab if the (Object) Properties window is not already opened to this tab.

2. Select the Preload image when published to HTML check box.

3. Click OK.
Specifying an object’s position and size
You can directly set the position and size of an object from within its properties.

To specify the position and size of an object:
1. Double-click on the object within your work area. The (Object) Properties window opens. Click the Position and Size tab.
2. Specify the following information. All measurements are based on pixels.
   - **X Coordinate**: Specify the horizontal distance of the object relative to the top-left corner of the page.
   - **Y Coordinate**: Specify the vertical distance of the object relative to the top-left corner of the page.
   - **Offset from right**: Select this to change the reference point (from the right) from which the object is placed.
   - **Offset from bottom**: Select this to change the reference point (from the bottom) from which the object is placed.
   - **Width**: Specify the width of the object.
   - **Height**: Specify the height of the object.
   - **Keep original aspect ratio**: If this option is selected, and you alter the width of the object, the height will automatically be adjusted to maintain the object's original shape. The same is true of the object's width if you alter the height.
3. Click OK.

If you have resized an animation, image or a button, and want to revert back to its original size, click the Reset button within the Original Size box. The original dimensions are displayed.

You can also specify the position of your object directly from the status bar.

See also:  
Using the Status bar
Moving and Resizing Objects
Aligning and Positioning Objects

Specifying an object’s transitions
You can specify how an object is displayed on a page. Transitions will produce a visual effect as the object appears and disappears. You can select from over 20 different transitions. There is a Slow to Fast slider to determine the speed at which the transition takes place.

To specify the transition:
1. Double-click on the object within your work area. The (Object) Properties window opens. Click the Transitions tab.
2. Specify the following information:
   - **Transition In**: Select this to enable a transition when displaying the object as the page opens or the object is made visible with an action.
   - **Transition (In) Type**: Select a transition type as one of the following:
     - Box In
     - Box Out
     - Circle In
     - Circle Out
     - Wipe Up
     - Split out Horizontal
     - Strips Down left
     - Strips Up left
     - Strips Downright
     - Strips Upright
Delay before transition Specify the delay in seconds before starting the transition. Select between 0 and 600 seconds.

Slow > Fast Use the slider to specify the speed at which the transition should occur.

Transition Out Select this to enable a transition when hiding the object as the page closes or the object is hidden with an action.

Transition (Out) Type Select a transition type as one of the following:
- Box In
- Box Out
- Circle In
- Circle Out
- Wipe Up
- Wipe Down
- Wipe Right
- Wipe Left
- Blinds Vertical
- Blinds Horizontal
- Checker Across
- Checker Down
- Dissolve
- Split in Vertical
- Split out Vertical
- Split in Horizontal
- Split out Horizontal
- Strips Down left
- Strips Up left
- Strips Downright
- Strips Upright
- Horizontal Bars
- Vertical Bars
- Fly Top
- Fly Top right
- Fly Right
- Fly Bottom right
- Fly Bottom
- Fly Bottom left
- Fly Left
- Fly Top left
- Random Effect

3. Click OK.

Adding a reference for an object
You can associate reference information with your object. You can add information such as author name and date of publication. Once you specify reference information for your objects, you can create a complete reference list that will include all of the reference information for the objects within your title.
See also: Working with Reference Lists

To specify the reference information:
1. Double-click on the object within your work area. The (Object) Properties window opens. Click the Reference tab.

2. Select the Add a Reference for this Item check box and specify the following information:
   - Author(s): Specify the names of the authors of the item.
   - Title of Work/Web Page Address: Specify either the title of the item or the Web page address.
   - Publisher: Specify the publisher of the item.
   - Date of Publication: Specify the date of publication of the item.

3. Click OK.

Including metadata for an object
Metadata is data about data. It typically includes information such as a description of the object, the author, the date it was created, and so on. Search engines look within metadata for relevant information to the term that was searched. Within Lectora objects, the metadata will be published as standard XML metadata into the accompanying imsmanifest.xml file for any AICC, SCORM, or CourseMill published titles. Metadata added to objects within a title that is published strictly to HTML will be written directly to the resulting HTML pages containing the objects. The metadata can be specified as custom metadata, an external XML file containing metadata, or as name/value pairs using predefined IMS Metadata Data Elements following the IEEE LTSC LOM standard.

To include metadata for an object:
1. Double-click on the object within your work area. The (Object) Properties window opens. Click the Metadata tab.

2. Select the Use Metadata check box and specify the following information:
   - Custom Metadata: Select this to display the Custom Metadata text field for you to directly enter custom metadata.
   - External XML File for Custom Metadata: Select this to import an external XML file containing metadata. Click the Import button to navigate and select the xml file.
   - IMS Metadata Data Elements (IEEE LTSC LOM): Select this to display a pre-populated list of name value pairs for all the SCORM 1.2 required IMS Metadata data elements. Click the Add button to open the Metadata Data Element Entry window. Select a predefined data element from the Name combo box and specify a data element value from the Value edit/combo box. Select OK to accept the data element. Select from previously entered data elements from the Name/Value lists and click Edit or Remove to edit or remove the selected element.

3. Publish this object’s metadata is checked by default so that the metadata is included in the published title. Uncheck this option if you do not want the metadata included in the published title.

3. Click OK.

Working with Animations
Lectora supports the following animation formats:
- GIF (.gif)
Flash files (.swf, .spl)

This section describes:

- Adding an animation

Once you have added an animation, you can complete the following within the Animation Properties window:

**General tab**
- Change the name of an animation
- Edit the animation's resource file
- Make an animation initially invisible
- Place an animation on the top layer
- Automatically start an animation
- Lock the size and position of an animation
- Enable author control on an animation
- Use an empty ALT tag for an animation
- Preload an animation for Web-based publishing

**Position and Size tab**
- Specify an animation's position and size

**Transitions tab**
- Specify an animation's transitions

**Parameters tab**
- Specify Flash parameters

**Reference tab**
- Add a reference for an animation

**Metadata tab**
- Include metadata for an animation

---

**Adding an animation**

Perform the following steps to add an animation to your title:

1. In the left-hand pane, select the location onto which you want to add an animation.

2. Do one of the following:
   - Right-click in your work area and select **New > Object > Animation**.
   - From the **Add** menu, select **Object > Animation**.
   - Click the **Add Animation** toolbar graphic on the Insert toolbar.
   - Type **Ctrl+9**
   - Drag and drop a supported animation file from a Windows Explorer window to the Lectora work area.

   The Animation Properties window opens (unless the animation was dragged and dropped into your work area). Click the **General** tab if the Animation Properties window is not already opened to this tab.

3. Click on the **Import** button to navigate and select the animation file you want to add to your title. A preview of the media is provided to the right. Alternatively, click on the arrow within the **Import** button to choose from the following:

   - **From File**: Select this to navigate and select an animation.
   - **Media Library**: Select this to launch your media library to select an animation. The Flash category in the Media Library contains predefined Flash animations you can add to enhance your title.

   **See also**: [Working with the Media Library Organizer](#)
   [Specifying Flash animation parameters](#)

4. Click **OK**.

The animation will appear within your work area.

**Automatically starting an animation**
You can chose to automatically start the animation when the page containing the animation appears to the user.

To automatically start an animation:
1. Double-click on the animation within your work area. The Animation Properties window opens. Click the General tab if the Animation Properties window is not already opened to this tab.

2. Select the Auto Start check box.

3. Click OK.

Specifying Flash parameters
You can specify additional parameters in the HTML declaration for Flash objects. Specify parameters such as making the background of your object appear transparent. For additional information about the different parameters you can specify, see Adobe's knowledge base on "Flash OBJECT and EMBED tag attributes".

The parameters are only used when a title is published to HTML.

See Specifying Flash animation parameters for information about the parameters associated with the Flash animations available in the Media Library.

To specify Flash parameters:
1. Double-click on the animation within your work area. The Animation Properties window opens. Click the Parameters tab.

2. Click the Add button. The Parameter Entry window opens.

3. Type the parameter Name and Value in the entry fields.

4. Click OK.

Repeat steps 2 through 4 for each parameter you want to define.

5. Click OK.

You can Edit or Remove existing parameters by selecting the parameter name or value within the list and clicking the corresponding button. When you Edit an existing parameter, you can change the name or value of the parameter. When you Remove a parameter, it is removed from the list.

Specifying Flash animation parameters
The Media Library contains configurable Flash animations you can add to enhance your title. The animations contain parameters that you configure as necessary. You can add parameters and remove those you do not use.

Select from the following Flash animations and configure the parameters as necessary:

- Analog Clock (AnalogClock.swf) - Displays an analog clock in a number of different styles.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>BackgroundColor</td>
<td>Color of the clock background</td>
<td>RGB Hex</td>
<td>#FFFFFF</td>
</tr>
<tr>
<td>BorderColor</td>
<td>Color of the border</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>Style</td>
<td>Clock style from 1 to 5</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>UseSecondHand</td>
<td>Show the second hand</td>
<td>True or False</td>
<td>True</td>
</tr>
</tbody>
</table>
- **Arrow Highlight (ArrowHighlight.swf)** - Displays an animated arrow pointing in a custom direction.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Animation</td>
<td>Animation of the arrow from 0 to 7</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>LoopAnimation</td>
<td>Loop the Animation</td>
<td>Boolean</td>
<td>False</td>
</tr>
<tr>
<td>BorderColor</td>
<td>Color of the arrow border</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the arrow border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>BorderOpacity</td>
<td>Opacity of the border</td>
<td>Numeric</td>
<td>100</td>
</tr>
<tr>
<td>FillColor</td>
<td>Color of the arrow</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>FillOpacity</td>
<td>Opacity of the arrow fill color</td>
<td>Numeric</td>
<td>100</td>
</tr>
<tr>
<td>Angle</td>
<td>Angle of the arrow in degrees (0 = right, 90 = down, 180 = left, 270 = up)</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>TailWidth</td>
<td>Width of the tail of the arrow</td>
<td>Numeric</td>
<td>20</td>
</tr>
<tr>
<td>TailLength</td>
<td>Length of the tail of the arrow</td>
<td>Numeric</td>
<td>35</td>
</tr>
<tr>
<td>HeadWidth</td>
<td>Width of the head of the arrow</td>
<td>Numeric</td>
<td>40</td>
</tr>
<tr>
<td>HeadLength</td>
<td>Length of the head of the arrow</td>
<td>Numeric</td>
<td>40</td>
</tr>
</tbody>
</table>

- **Flash Card (CardFlip.swf)** - Displays a flash card that flips-over when clicked.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>CardColor</td>
<td>Color of the card</td>
<td>RGB Hex</td>
<td>#DDDDDD</td>
</tr>
<tr>
<td>ImageFront</td>
<td>Image on the front of the card</td>
<td>Image, animated gif, Flash animation</td>
<td></td>
</tr>
<tr>
<td>ImageBack</td>
<td>Image on the back of the card</td>
<td>Image, animated gif, Flash animation</td>
<td></td>
</tr>
<tr>
<td>TextBack</td>
<td>Text on the back of the card</td>
<td>Text</td>
<td>Click here</td>
</tr>
<tr>
<td>TextBackSize</td>
<td>Text size on the back of the card</td>
<td>Numeric</td>
<td>14</td>
</tr>
<tr>
<td>TextBackColor</td>
<td>Text color on the back of the card</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>TextBackAlign</td>
<td>Text alignment on the back of the card</td>
<td>left, center, right</td>
<td>center</td>
</tr>
<tr>
<td>TextFront</td>
<td>Text on the front of the card</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>TextFrontSize</td>
<td>Text size on the front of the card</td>
<td>Numeric</td>
<td>14</td>
</tr>
<tr>
<td>TextFrontColor</td>
<td>Text color on the front of the card</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>TextFrontAlign</td>
<td>Text alignment on the front of the card</td>
<td>left, center, right</td>
<td>center</td>
</tr>
<tr>
<td>CardSound</td>
<td>Sound to play when card is clicked</td>
<td>Sound file</td>
<td>Default Flip Sound</td>
</tr>
</tbody>
</table>
Question Character Race (CharacterRace.swf) - Displays a game in which the user answers True/False questions to move a game character forward. The user is racing against another character that will move forward after every question except for the number of allowed wrong answers. This provides a degree of difficulty.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>NumberAllowedWrong</td>
<td>Number of allowed wrong answers</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>CharacterImage</td>
<td>Image for the character</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>OpponentImage</td>
<td>Image for the opponent</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>TextQuestionHeader</td>
<td>Text for the question header</td>
<td>Text</td>
<td>True or False?</td>
</tr>
<tr>
<td>TextCorrect</td>
<td>Text for the correct feedback</td>
<td>Text</td>
<td>Correct!</td>
</tr>
<tr>
<td>TextIncorrect</td>
<td>Text for the incorrect feedback</td>
<td>Text</td>
<td>Incorrect</td>
</tr>
<tr>
<td>TextOpponent</td>
<td>Text on the opponent’s lane</td>
<td>Text</td>
<td>Opponent</td>
</tr>
<tr>
<td>TextYou</td>
<td>Text on user's lane</td>
<td>Text</td>
<td>You</td>
</tr>
<tr>
<td>TextFinish</td>
<td>Text inside the finish area</td>
<td>Text</td>
<td>FINISH</td>
</tr>
<tr>
<td>TextStartRace</td>
<td>Text in the Start Race button</td>
<td>Text</td>
<td>Start Race!</td>
</tr>
<tr>
<td>TextTrue</td>
<td>Text on the button that answers True</td>
<td>Text</td>
<td>True</td>
</tr>
<tr>
<td>TextFalse</td>
<td>Text on the button that answer False</td>
<td>Text</td>
<td>False</td>
</tr>
<tr>
<td>TextYouLose</td>
<td>Text on the losing feedback display</td>
<td>Text</td>
<td>You Lose.</td>
</tr>
<tr>
<td>TextYouWin</td>
<td>Text on the winning feedback display</td>
<td>Text</td>
<td>You Win!</td>
</tr>
<tr>
<td>Question1</td>
<td>Text for the 1st question</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Answer1</td>
<td>Text for the 1st answer</td>
<td>True or False</td>
<td>True</td>
</tr>
<tr>
<td>Question2</td>
<td>Text for the 2nd question</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Answer2</td>
<td>Text for the 2nd answer</td>
<td>True or False</td>
<td>True</td>
</tr>
<tr>
<td>Question3</td>
<td>Text for the 3rd question</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Answer3</td>
<td>Text for the 3rd answer</td>
<td>True or False</td>
<td>True</td>
</tr>
<tr>
<td>Question4</td>
<td>Text for the 4th question</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Answer4</td>
<td>Text for the 4th answer</td>
<td>True or False</td>
<td>True</td>
</tr>
<tr>
<td>Question5</td>
<td>Text for the 5th question</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Answer5</td>
<td>Text for the 5th answer</td>
<td>True or False</td>
<td>True</td>
</tr>
<tr>
<td>Question6</td>
<td>Text for the 6th question</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Answer6</td>
<td>Text for the 6th answer</td>
<td>True or False</td>
<td>True</td>
</tr>
<tr>
<td>Question7</td>
<td>Text for the 7th question</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Answer7</td>
<td>Text for the 7th answer</td>
<td>True or False</td>
<td>True</td>
</tr>
<tr>
<td>Question8</td>
<td>Text for the 8th question</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Answer8</td>
<td>Text for the 8th answer</td>
<td>True or False</td>
<td>True</td>
</tr>
<tr>
<td>Question9</td>
<td>Text for the 9th question</td>
<td>Text</td>
<td></td>
</tr>
</tbody>
</table>
Digital Clock (DigitalClock.swf) - Displays a digital clock in a number of different styles.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>BorderColor</td>
<td>Color of the border</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>TextColor</td>
<td>Text color</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>Style</td>
<td>Style of the clock from 1 to 5</td>
<td>Numeric</td>
<td>1</td>
</tr>
</tbody>
</table>

Female Animated Character - Displays a talking female character in two different styles. Use either style with the following options:

- Audio Explanation: The character speaks the audio file with mouth movements and simple hand gestures
- Bullets with One Audio: The character speaks one audio file and presents multiple bullets
- Bullets Sync with Audio: The character speaks one audio file per bullet as she presents each bullet. Each bullet requires its own audio file.

Select from the following female character animations:

- Character_Female_Style1_AudioExplanation.swf
- Character_Female_Style1_BulletswithOneAudio.swf
- Character_Female_Style1_BulletsSyncwithAudio.swf
- Character_Female_Style2_AudioExplanation.swf
- Character_Female_Style2_BulletswithOneAudio.swf
- Character_Female_Style2_BulletsSyncwithAudio.swf

Audio Explanation Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>BorderColor</td>
<td>Color of the border</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>Sound1</td>
<td>Sound spoken by the character</td>
<td>Sound file</td>
<td></td>
</tr>
</tbody>
</table>

Bullets with One Audio Parameters

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>BorderColor</td>
<td>Color of the border</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>Parameter</td>
<td>Description</td>
<td>Type</td>
<td>Value</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------------------------------</td>
<td>---------</td>
<td>--------</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>TextSize</td>
<td>Text size</td>
<td>Numeric</td>
<td>20</td>
</tr>
<tr>
<td>TextColor</td>
<td>Text color</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>TextBold</td>
<td>Specify whether to bold the text</td>
<td>Boolean</td>
<td>False</td>
</tr>
<tr>
<td>UseBullets</td>
<td>Specify whether to use bullets</td>
<td>Boolean</td>
<td>True</td>
</tr>
<tr>
<td>SecondsBetweenBullets</td>
<td>Seconds between each bullet if set to autoplay</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>AutoPlay</td>
<td>Automatically present each bullet</td>
<td>Boolean</td>
<td>True</td>
</tr>
<tr>
<td>Sound1</td>
<td>Sound spoken by character</td>
<td>Sound file</td>
<td></td>
</tr>
<tr>
<td>Bullet1</td>
<td>Text for the 1st bullet</td>
<td>Text</td>
<td>Bullet Point 1</td>
</tr>
<tr>
<td>Bullet2</td>
<td>Text for the 2nd bullet</td>
<td>Text</td>
<td>Bullet Point 2</td>
</tr>
<tr>
<td>Bullet3</td>
<td>Text for the 3rd bullet</td>
<td>Text</td>
<td>Bullet Point 3</td>
</tr>
<tr>
<td>Bullet4</td>
<td>Text for the 4th bullet</td>
<td>Text</td>
<td>Bullet Point 4</td>
</tr>
<tr>
<td>Bullet5</td>
<td>Text for the 5th bullet</td>
<td>Text</td>
<td>Bullet Point 5</td>
</tr>
<tr>
<td>Bullet6</td>
<td>Text for the 6th bullet</td>
<td>Text</td>
<td>Bullet Point 6</td>
</tr>
<tr>
<td>Bullet7</td>
<td>Text for the 7th bullet</td>
<td>Text</td>
<td>Bullet Point 7</td>
</tr>
<tr>
<td>Bullet8</td>
<td>Text for the 8th bullet</td>
<td>Text</td>
<td>Bullet Point 8</td>
</tr>
<tr>
<td>Bullet9</td>
<td>Text for the 9th bullet</td>
<td>Text</td>
<td>Bullet Point 9</td>
</tr>
<tr>
<td>Bullet10</td>
<td>Text for the 10th bullet</td>
<td>Text</td>
<td>Bullet Point 10</td>
</tr>
</tbody>
</table>

**Bullets Sync with Audio Parameters**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Type</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>BorderColor</td>
<td>Color of the border</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>TextSize</td>
<td>Text size</td>
<td>Numeric</td>
<td>20</td>
</tr>
<tr>
<td>TextColor</td>
<td>Text color</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>TextBold</td>
<td>Specify whether to bold the text</td>
<td>Boolean</td>
<td>False</td>
</tr>
<tr>
<td>UseBullets</td>
<td>Specify whether to use bullets</td>
<td>Boolean</td>
<td>True</td>
</tr>
<tr>
<td>SecondsBetweenBullets</td>
<td>Seconds between each bullet if set to autoplay</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>Bullet1</td>
<td>Text for the 1st bullet</td>
<td>Text</td>
<td>Bullet Point 1</td>
</tr>
<tr>
<td>Sound1</td>
<td>Audio for the 1st bullet</td>
<td>Sound file</td>
<td></td>
</tr>
<tr>
<td>Bullet2</td>
<td>Text for the 2nd bullet</td>
<td>Text</td>
<td>Bullet Point 2</td>
</tr>
<tr>
<td>Sound2</td>
<td>Audio for the 2nd bullet</td>
<td>Sound file</td>
<td></td>
</tr>
<tr>
<td>Bullet3</td>
<td>Text for the 3rd bullet</td>
<td>Text</td>
<td>Bullet Point 3</td>
</tr>
<tr>
<td>Sound3</td>
<td>Audio for the 3rd bullet</td>
<td>Sound file</td>
<td></td>
</tr>
<tr>
<td>Bullet4</td>
<td>Text for the 4th bullet</td>
<td>Text</td>
<td>Bullet Point 4</td>
</tr>
<tr>
<td>Sound4</td>
<td>Audio for the 4th bullet</td>
<td>Sound file</td>
<td></td>
</tr>
</tbody>
</table>
Bullet 5: Text for the 5th bullet
Sound 5: Audio for the 5th bullet
Bullet 6: Text for the 6th bullet
Sound 6: Audio for the 6th bullet
Bullet 7: Text for the 7th bullet
Sound 7: Audio for the 7th bullet
Bullet 8: Text for the 8th bullet
Sound 8: Audio for the 8th bullet
Bullet 9: Text for the 9th bullet
Sound 9: Audio for the 9th bullet
Bullet 10: Text for the 10th bullet
Sound 10: Audio for the 10th bullet

- Male Animated Character - Displays a talking male character in two different styles. Use either style with the following options:
  - Audio Explanation: The character speaks the audio file with mouth movements and simple hand gestures
  - Bullets with One Audio: The character speaks one audio file and presents multiple bullets
  - Bullets Sync with Audio: The character speaks one audio file per bullet as he presents each bullet. Each bullet requires its own audio file.

Select from the following male character animations:
  - Character_Male_Style1_AudioExplanation.swf
  - Character_Male_Style1_BulletsWithOneAudio.swf
  - Character_Male_Style1_BulletsSyncWithAudio.swf
  - Character_Male_Style2_AudioExplanation.swf
  - Character_Male_Style2_BulletsWithOneAudio.swf
  - Character_Male_Style2_BulletsSyncWithAudio.swf

<table>
<thead>
<tr>
<th>Audio Explanation Parameters</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>BorderColor</td>
<td>Color of the border</td>
<td>RGB Hext</td>
<td>#000000</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>Sound1</td>
<td>Sound spoken by the character</td>
<td>Sound file</td>
<td></td>
</tr>
<tr>
<td>Bullets with One Audio Parameters</td>
<td>Description</td>
<td>Value</td>
<td>Default</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>------------------------------</td>
<td>------------</td>
<td>---------</td>
</tr>
<tr>
<td>BorderColor</td>
<td>Color of the border</td>
<td>RGB Hext</td>
<td>#000000</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>TextSize</td>
<td>Text size</td>
<td>Numeric</td>
<td>20</td>
</tr>
<tr>
<td>TextColor</td>
<td>Text color</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>TextBold</td>
<td>Specify whether to bold the text</td>
<td>Boolean</td>
<td>False</td>
</tr>
<tr>
<td>UseBullets</td>
<td>Specify whether to use bullets</td>
<td>Boolean</td>
<td>True</td>
</tr>
<tr>
<td>SecondsBetweenBullets</td>
<td>Seconds between each bullet if set to autoplay</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>AutoPlay</td>
<td>Automatically present each bullet</td>
<td>Boolean</td>
<td>True</td>
</tr>
<tr>
<td>Sound1</td>
<td>Sound spoken by character</td>
<td>Sound file</td>
<td></td>
</tr>
<tr>
<td>Bullet1</td>
<td>Text for the 1st bullet</td>
<td>Text</td>
<td>Bullet Point 1</td>
</tr>
<tr>
<td>Bullet2</td>
<td>Text for the 2nd bullet</td>
<td>Text</td>
<td>Bullet Point 2</td>
</tr>
<tr>
<td>Bullet3</td>
<td>Text for the 3rd bullet</td>
<td>Text</td>
<td>Bullet Point 3</td>
</tr>
<tr>
<td>Bullet4</td>
<td>Text for the 4th bullet</td>
<td>Text</td>
<td>Bullet Point 4</td>
</tr>
<tr>
<td>Bullet5</td>
<td>Text for the 5th bullet</td>
<td>Text</td>
<td>Bullet Point 5</td>
</tr>
<tr>
<td>Bullet6</td>
<td>Text for the 6th bullet</td>
<td>Text</td>
<td>Bullet Point 6</td>
</tr>
<tr>
<td>Bullet7</td>
<td>Text for the 7th bullet</td>
<td>Text</td>
<td>Bullet Point 7</td>
</tr>
<tr>
<td>Bullet8</td>
<td>Text for the 8th bullet</td>
<td>Text</td>
<td>Bullet Point 8</td>
</tr>
<tr>
<td>Bullet9</td>
<td>Text for the 9th bullet</td>
<td>Text</td>
<td>Bullet Point 9</td>
</tr>
<tr>
<td>Bullet10</td>
<td>Text for the 10th bullet</td>
<td>Text</td>
<td>Bullet Point 10</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Bullets Sync with Audio Parameters</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>BorderColor</td>
<td>Color of the border</td>
<td>RGB Hext</td>
<td>#000000</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>TextSize</td>
<td>Text size</td>
<td>Numeric</td>
<td>20</td>
</tr>
<tr>
<td>TextColor</td>
<td>Text color</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>TextBold</td>
<td>Specify whether to bold the text</td>
<td>Boolean</td>
<td>False</td>
</tr>
<tr>
<td>UseBullets</td>
<td>Specify whether to use bullets</td>
<td>Boolean</td>
<td>True</td>
</tr>
<tr>
<td>SecondsBetweenBullets</td>
<td>Seconds between each bullet</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>Bullet1</td>
<td>Text for the 1st bullet</td>
<td>Text</td>
<td>Bullet Point 1</td>
</tr>
<tr>
<td>Sound1</td>
<td>Audio for the 1st bullet</td>
<td>Sound file</td>
<td></td>
</tr>
<tr>
<td>Bullet2</td>
<td>Text for the 2nd bullet</td>
<td>Text</td>
<td>Bullet Point 2</td>
</tr>
<tr>
<td>Sound2</td>
<td>Audio for the 2nd bullet</td>
<td>Sound file</td>
<td></td>
</tr>
<tr>
<td>Bullet3</td>
<td>Text for the 3rd bullet</td>
<td>Text</td>
<td>Bullet Point 3</td>
</tr>
</tbody>
</table>
Matching Pair Game (MatchingPairGame.swf) - Displays a game in which the user matches flash cards. Up to eight matching pairs are supported.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>CardColor</td>
<td>Color of the card</td>
<td>RGB Hex</td>
<td></td>
</tr>
<tr>
<td>Image1</td>
<td>Image for the 1st matching pair</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text1</td>
<td>Text for the front of the 1st matching pair</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image2</td>
<td>Image for the 2nd matching pair</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text2</td>
<td>Text for the front of the 2nd matching pair</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image3</td>
<td>Image for the 3rd matching pair</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text3</td>
<td>Text for the front of the 3rd matching pair</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image4</td>
<td>Image for the 4th matching pair</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text4</td>
<td>Text for the front of the 4th matching pair</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image5</td>
<td>Image for the 5th matching pair</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text5</td>
<td>Text for the front of the 5th matching pair</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image6</td>
<td>Image for the 6th matching pair</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text6</td>
<td>Text for the front of the 6th matching pair</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image7</td>
<td>Image for the 7th matching pair</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text7</td>
<td>Text for the front of the 7th matching pair</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image8</td>
<td>Image for the 8th matching pair</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text8</td>
<td>Text for the front of the 8th matching pair</td>
<td>Text</td>
<td></td>
</tr>
</tbody>
</table>
Photo Viewer (PhotoViewer.swf) - Displays photos in a manner similar to cover flow on an iPod. Up to 20 photos are supported.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>AutoPlay</td>
<td>Specify whether to automatically play the photo viewer</td>
<td>Boolean</td>
<td>False</td>
</tr>
<tr>
<td>ChangeDelay</td>
<td>Delay between photos in seconds</td>
<td>Numeric</td>
<td>3</td>
</tr>
<tr>
<td>Image1</td>
<td>Image file for the 1st image</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text1</td>
<td>Text for the 1st photo</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image2</td>
<td>Image file for the 2nd image</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text2</td>
<td>Text for the 2nd photo</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image3</td>
<td>Image file for the 3rd image</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text3</td>
<td>Text for the 3rd photo</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image4</td>
<td>Image file for the 4th image</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text4</td>
<td>Text for the 4th photo</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image5</td>
<td>Image file for the 5th image</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text5</td>
<td>Text for the 5th photo</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image6</td>
<td>Image file for the 6th image</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text6</td>
<td>Text for the 6th photo</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>Image7</td>
<td>Image file for the 7th image</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Text7</td>
<td>Text for the 7th photo</td>
<td>Text</td>
<td></td>
</tr>
<tr>
<td>BorderColor</td>
<td>Color of the border</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>TextSize</td>
<td>Text size</td>
<td>Numeric</td>
<td>24</td>
</tr>
<tr>
<td>TextColor</td>
<td>Color of the text</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>TextBackgroundColor</td>
<td>Background color of the text</td>
<td>RGB Hex</td>
<td>#DDDDDD</td>
</tr>
<tr>
<td>Buttons</td>
<td>Specify whether to enable or disable the buttons</td>
<td>Enabled,</td>
<td>Enabled</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Disabled</td>
<td></td>
</tr>
</tbody>
</table>
### ArrowKeys
Specify whether to enable or disable the arrow keys

- **Enabled**
- **Disabled**

### Text Animation (TextAnimation.swf)
Displays animated user-specified text in a number of ways.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>BorderColor</td>
<td>Color of the border</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>Text</td>
<td>Text to animate</td>
<td>Text</td>
<td>Hello World!</td>
</tr>
<tr>
<td>TextSize</td>
<td>Size of the text</td>
<td>Numeric</td>
<td>24</td>
</tr>
<tr>
<td>TextColor</td>
<td>Color of the text</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>TextBold</td>
<td>Specify whether to bold the text</td>
<td>Boolean</td>
<td>False</td>
</tr>
<tr>
<td>Animation</td>
<td>Animation for text from 1 to 10</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>LetterDelay</td>
<td>Delay between letters in tenths of a second</td>
<td>Numeric</td>
<td>0.1</td>
</tr>
<tr>
<td>LetterSpeed</td>
<td>Speed of the letters in tenths of a second</td>
<td>Numeric</td>
<td>0.5</td>
</tr>
</tbody>
</table>

### Jigsaw puzzle (JigsawPuzzleGame.swf)
Users assemble a jigsaw puzzle of an image you supply.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>Image</td>
<td>Image file for the puzzle</td>
<td>Image file</td>
<td></td>
</tr>
<tr>
<td>Difficulty</td>
<td>A number from 1 to 4 representing the difficulty based on the number of pieces in the puzzle</td>
<td>Numeric</td>
<td>1</td>
</tr>
<tr>
<td>ShowOutlines</td>
<td>Specify whether outlines are displayed to assist the user</td>
<td>Boolean</td>
<td>True</td>
</tr>
</tbody>
</table>

### Tic Tac Toe (TicTacToeGame.swf)
Displays a Tic Tac Toe game. Users answer True/False questions. Correct answers allow them to place an X on the Tic Tac Toe grid. An 0 is placed in the grid when the answer is incorrect.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
<th>Value</th>
<th>Default</th>
</tr>
</thead>
<tbody>
<tr>
<td>BorderColor</td>
<td>Color of the border</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>BorderWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>0</td>
</tr>
<tr>
<td>BackgroundColor</td>
<td>Color of the background</td>
<td>RGB Hex</td>
<td>#FFFFFF</td>
</tr>
<tr>
<td>GridColor</td>
<td>Color of Tic Tac Toe grid</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>GridWidth</td>
<td>Width of the border</td>
<td>Numeric</td>
<td>2</td>
</tr>
<tr>
<td>XColor</td>
<td>Color of the Xs</td>
<td>RGB Hex</td>
<td>#666666</td>
</tr>
<tr>
<td>OColor</td>
<td>Colors of the Os</td>
<td>RGB Hex</td>
<td>#000000</td>
</tr>
<tr>
<td>TextQuestionHeader</td>
<td>Text for the question header</td>
<td>Text</td>
<td>True or False?</td>
</tr>
<tr>
<td>TextCorrect</td>
<td>Text for correct feedback</td>
<td>Text</td>
<td>Correct!</td>
</tr>
<tr>
<td>TextIncorrect</td>
<td>Text for incorrect feedback</td>
<td>Text</td>
<td>Incorrect</td>
</tr>
<tr>
<td>TextTrue</td>
<td>Text on the button that answers True</td>
<td>Text</td>
<td>True</td>
</tr>
<tr>
<td>TextFalse</td>
<td>Text on the button that answers False</td>
<td>Text</td>
<td>False</td>
</tr>
</tbody>
</table>
Working with Audio
Lectora supports the following audio formats:
- Flash Audio (.flv)
- Uncompressed Windows audio (.wav)
- Standard MIDI (.mid)
- MPEG, Audio layer 3 (.mp3)
- Advanced Systems Format (.asf)
- RealMedia streaming media (.rm)
- uLaw audio (.au)
- Windows Media audio (.wma)

This section describes:
- Adding audio
- Converting to Flash (.flv)

Once you have added audio, you can complete the following within the Audio Properties window:

**General tab**
- Change the name of an audio object
- Specify the type of audio
- Edit the audio resource file
- Specify a display type for audio
- Make an audio icon or controller initially invisible
- Place an audio icon or controller on the top layer
- Lock the size and position of an audio icon or controller
- Enable author control on an audio object
- Continuously play audio
- Automatically start audio

**Transitions tab**
- Specify audio display transitions

**Reference tab**
- Add a reference for an audio object

**Metadata tab**
- Include metadata for an audio object

**Events tab**
- Associate actions with audio events

**Skins tab**
- Applying a skin to the controller

Adding audio
Perform the following steps to add audio to your title:
1. In the left-hand pane, select the location onto which you want to add the audio.

2. Do one of the following:
   - Right-click in your work area and select **New > Object > Audio**.
   - From the **Add** menu, select **Object > Audio**.
   - Click the **Add Audio** toolbar graphic on the Insert toolbar.
   - Type `Ctrl+Shift+0`
   - Drag and drop a supported audio file from a Windows Explorer window to the Lectora work area.

   The Audio Properties window opens (unless the audio was dragged and dropped into your work area). Click the **General** tab if the Audio Properties window is not already opened to this tab.

3. Click on the **Import** button to navigate and select the audio file you want to add to your title. A preview of the media is provided to the right. Alternatively, click on the arrow within the **Import** button to choose from the following:

   - **From File** Select this to navigate and select an audio file.
   - **Media Library** Select this to launch your media library to select an audio file.

   **See also:** [Working with the Media Library Organizer](#)

4. Click **OK**.

   The audio will appear within your work area.

**Specifying the type of audio**

When you add audio to your title, you can specify whether the audio is standard or streaming.

To specify the type of audio:

1. Double-click on the audio object within your work area. The Audio Properties window opens. Click the **General** tab if the Audio Properties window is not already opened to this tab.

2. Select the **Audio Type** from the list. For Standard Audio, click the **Import** button to navigate and select an audio file. For streaming audio, enter the Web address of the audio stream in the **URL** field.

   **See also:** [Streaming Media](#)

3. Click **OK**.

**Specifying a display type for audio**

When you add audio to your title, you can specify whether to display a speaker icon for the audio or a controller.

To specify the display type for the audio:

1. Double-click on the audio object within your work area. The Audio Properties window opens. Click the **General** tab if the Audio Properties window is not already opened to this tab.

2. Select the **Display** from the list. Choose from the following four options:

   - **Speaker Icon** This is the default display for an audio object. Lectora displays a speaker graphic that when clicked, will enable users to toggle the audio on and off.
   - **None** This makes the audio transparent on the page. Users will have no control over the audio.
   - **Controller** This will display an audio controller so users have the ability to fast forward, rewind, play,
pause, and stop the audio.

For Flash (.flv) audio, you can select from predefined skins for the controller. See Applying a skin to the controller.

You can specify your own graphic for use as the speaker icon. When you choose your own graphic, users will be able to click on it to toggle the audio on and off. Choose a previously imported image from the list, or click the Import button next to the Display list to navigate and select an image.

3. Click OK.

**Continuously playing audio**

You can have audio automatically restart when it has reached the end. The audio will loop until the user has exited the page.

To continuously play audio:

1. Double-click on the audio object within your work area. The Audio Properties window opens. Click the General tab if the Audio Properties window is not already opened to this tab.

2. Select the Play Continuously check box.

3. Click OK.

**Automatically starting audio**

You can chose to automatically start the audio when the page containing the audio appears to the user.

To automatically start audio:

1. Double-click on the audio object within your work area. The Audio Properties window opens. Click the General tab if the Audio Properties window is not already opened to this tab.

2. Select the Auto Start check box.

3. Click OK.

**Associating actions with audio events**

Events, also known as script commands, set within an audio file can be used to trigger actions while the audio is playing. This is especially useful when you want to synchronize actions with audio.

You must first create the events within the audio. Once the events have been created, you can proceed to associate actions with the audio events.

See also: Selecting an Action

To associate actions with audio events:

1. Double-click on the audio within your work area or left-hand pane. The Audio Properties window opens. Click the Events tab.

2. Select the event label from the Event list.

3. Specify the Action to be executed when the audio has reached the event. Specify additional action information as necessary.

Repeat steps 2 and 3 for each event you want to define.
4. Click **OK**.

**Converting to Flash (.flv) audio**

You can convert your audio objects to Flash (.flv).

When you convert an object to Flash audio or video, all instances of the resource are changed throughout your title.

> Flash .flv files require your user's computer to have the Flash plug-in installed.

To convert to Flash audio:

1. Add the audio to your title.

2. Select the object, right-click, and choose **Convert to FLV**.

   > The option is only available for relevant file types.

   The Convert to FLV window opens.

3. Use the slider to select a compression level.

   Higher compression levels will result in smaller files, but the quality of the media will deteriorate as compression increases.

4. Click **Convert**.

   When the conversion completes, the compression results are displayed and you are asked whether to use the new file.

5. Click **Yes**. Otherwise, click **No** to restore the file to its original type.

   The object is converted to .flv.

**Applying a skin to the controller**

When you have selected to display a Flash (.flv) audio object using a controller, you can apply a predefined or custom skin to the controller. See **Specifying a display type for audio**.

To apply a skin to the controller:

1. Double-click on the audio object within your work area. The Audio Properties window opens. Click the **Skins** tab.

2. Use the drop-down list to select a predefined skin.

3. Click **OK** to add your updated controller to the page.

See also: **Converting to Flash (.flv) audio**

**Working with Buttons**

You can create buttons in Lectora with the use of images or 3-frame animated GIFs or they can be designated as transparent buttons. Buttons can be used for navigating within your title or executing other actions.

This section describes:

- **Adding a button**
Once you have added a button, you can complete the following within the Button Properties window:

**General tab**
- Change the name of a button
- Make a button initially invisible
- Place a button on the top layer
- Lock the size and position of a button
- Enable author control on a button
- Use a 3-frame animated GIF for a button
- Make a button transparent
- Use an empty ALT tag for a button
- Preload a button for Web-based publishing
- Edit the button's resource files

**Position and Size tab**
- Specify a button's position and size

**On Click tab**
- Assign an action to a button

**Condition tab**
- Place a condition on a button's action

**Transitions tab**
- Specify a button's transitions

### Adding a button

Perform the following steps to add a button to your title. You can use images or 3-frame animated gifs for your button, or you can make your button transparent.

1. In the left-hand pane, select the location onto which you want to add a button.

2. Do one of the following:
   - Right-click in your work area and select **New > Object > Button**.
   - From the **Add** menu, select **Object > Button**.
   - Click the **Add Button** toolbar graphic on the Insert toolbar.
   - Type `Ctrl+Shift+1`

   You can also use Lectora's Button Wizard to select from stock buttons from clip art or create buttons with custom text.

   **See also:** [Creating Custom Buttons](#)

   The Button Properties window opens (unless you used the Button Wizard to create your button). Click the **General** tab if the Button Properties window is not already opened to this tab.

3. Use the **Import** buttons located next to the **Normal-State Image**, **Clicked Image**, and **Mouseover Image** lists to navigate and select the images for use within the three different states of the button. Click the **Import** buttons to navigate and select an image or animation of your own. Alternatively, click on the arrow within the **Import** button to choose from the following:

   **From File**
   - Select this to navigate and select an image or animation.

   **Media Library**
   - Select this to launch your media library to select an image or animation.

   **See also:** [Working with the Media Library Organizer](#)

   The **Normal-State Image** represents the normal state of the button. This is how the button will appear to the user on the page. The **Clicked Image** represents the clicked state of the button. This is how the button will appear to the user when they have clicked on the button. The **Mouseover Image** represents the mouseover state of the button. This is how the button will appear to the user when they have placed their mouse over the button.

   You can also use a 3-frame animated gif for your button, or make your button transparent.

   **See also:** [Using a 3-frame animated GIF for a button](#)
Making a button transparent

4. Click **OK**.

The button will appear within your work area.

### Using a 3-frame animated GIF for a button

You can use a 3-frame animated GIF for a button. Three-frame animated GIFs have the 3 button states (normal, clicked, and mouseover) built into them.

To use a 3-frame animated GIF for a button:

1. Double-click on the button within your work area. The Button Properties window opens. Click the **General** tab if the Button Properties window is not already opened to this tab.

2. Select the **Use 3-frame animated GIF** check box. The ability to import a **Clicked Image** or a **Mouseover Image** is disabled.

3. Click on the **Import** button next to the **Normal-State Image** list to navigate and select a 3-frame animated GIF for use with your button.

4. Click **OK**.

### Making a button transparent

You can make a button transparent. Transparent buttons are useful for creating hotspots on regions of an image.

To make a button transparent:

1. Double-click on the button within your work area. The Button Properties window opens. Click the **General** tab if the Button Properties window is not already opened to this tab.

2. Select the **Transparent** check box. The ability to import a **Normal-State Image**, **Clicked Image**, and **Mouseover Image** is disabled.

3. Click **OK**.

### Assigning an action to a button

You can assign an action to your button. The action selected will execute when a user clicks the button.

**See also:** [About Actions](#)

To assign an action to a button:

1. Double-click on the button within your work area. The Button Properties window opens. Click the **On Click** tab.

2. Use the **Action** list to select the action to execute when the user clicks the button.

   **See also:** [Selecting an action](#)

   The **Target** field is enabled when the action requires a target. Specify additional information as necessary.

   **See also:** [Selecting an action's target](#)

3. Click **OK**.

### Placing a condition on a button's action

You can specify single or multiple conditions for the action assigned to the button. This enables you to execute the button's

**See also:** [About Actions](#)
action, only when the specified conditions have been satisfied.

See also: Making an action conditional

To place a condition on a button's action:
1. Double-click on the button within your work area. The Button Properties window opens. Click the Condition tab.

2. Select Perform Action ONLY if the following is TRUE. Conditions require the use of a variable. Select the Variable from the list, select a Relationship and enter a Value. To input multiple conditions, click on the Multiple Conditions button. You can then use the additional fields to specify other variables and relationships. If multiple conditions are defined, select whether All of the Following conditions or Any of the Following conditions should be true to execute the action specified on the On Click tab of the Button Properties window.

3. Click OK.

Working with Documents
You can embed textual documents into your title. Documents will appear in an opaque, scrollable window within your title.

Lectora supports the following document formats:
- Rich Text (.rtf)
- Text (.txt)

This section describes:
- Adding a document

Once you have added a document, you can complete the following within the Document Properties window:

**General tab**
- Change the name of a document
- Edit the document's resource file
- Make a document initially invisible
- Place a document on the top layer
- Lock the size and position of a document
- Enable author control on a document

**Transitions tab**
- Specify a document's transitions

**Reference tab**
- Add a reference for a document

**Metadata tab**
- Include metadata for a document

**Position and Size tab**
- Specify a document's position and size

Adding a document
Perform the following steps to add a document to your title:
1. In the left-hand pane, select the location onto which you want to add a document.

2. Do one of the following:
   - Right-click in your work area and select New > Object > Document.
   - From the Add menu, select Object > Document.
   - Click the Add Document toolbar graphic on the Insert toolbar.
   - Type Ctrl+Shift+2
   - Drag and drop a supported document file from a Windows Explorer window to the Lectora work area.

The Document Properties window opens (unless the document was dragged and dropped into your work area). Click the General tab if the Document Properties window is not already opened to this tab.
3. Click on the **Import** button to navigate and select the document file you want to add to your title. Alternatively, click on the arrow within the **Import** button to choose from the following:

- **From File** Select this to navigate and select a document.
- **Media Library** Select this to launch your media library to select a document.

*See also:* [Working with the Media Organizer](#)

4. Click **OK**.

The document will appear within your work area.

**Working with Equations**

You can create mathematical equations for use in your title. The Trivantis Equation Editor can be used to create your equations. All equations are published as images.

This section describes:
- Adding an equation

Once you have added an equation, you can specify the following within the Equation Properties window:

**General tab**
- Change the name of an equation
- Edit an equation
- Make an equation initially invisible
- Place an equation on the top layer
- Lock the size and position of an equation
- Enable author control on an equation
- Use an empty ALT tag for an equation
- Preload an equation for Web-based publishing

**Position and Size tab**
- Specify an equation's position and size

**Transitions tab**
- Specify an equation's transitions

**Adding an equation**

Perform the following steps to add an equation to your title.

1. In the left-hand pane, select the location onto which you want to add an equation.

2. Do one of the following:
   - Right-click in your work area and select **New > Object > Equation**.
   - From the **Add** menu, select **Object > Equation**.
   - Click the **Add Equation** toolbar graphic [x] on the Insert toolbar.
   - Type **Ctrl+Shift+3**

   The Trivantis Equation Editor window opens.

3. Select one of the 19 template buttons and select the appropriate symbol to insert within your equation. The cursor will blink inside the equation template box on the content page.
4. Enter the appropriate values inside of the equation template boxes within the content page.

5. Click the X at the top-right of the window to close the Trivantis Equation Editor and insert the equation into your title.

Your new equation will appear at the top-left of your Lectora page.

**Editing an equation**

When you create an equation using the Trivantis Equation Editor, you can make changes to your equation by editing it.

To edit an equation:
1. Double-click on the equation within your work area. The Equation Properties window opens. Click the **General** tab if the Equation Properties window is not already opened to this tab.

2. Click on the **Edit** button. The Trivantis Equation Editor is launched with your equation visible in the work area.

3. Make the appropriate changes to your equation, save your changes, and close the Trivantis Equation Editor. All instances of the equation are updated within your title.

**Working with External HTML Objects**

The external HTML object is an advanced Lectora feature that allows you to extend the functionality and contents of your title beyond what Lectora natively supports.

With the external HTML object, you can extend the functionality of your title by adding:

- Java Applets
- Header Scripting (JavaScript)
- Shockwave Movies
- Custom HTML
- ASP Scripts
- JSP Scripts
- Meta Tags
- Top of File Scripting
- Bottom of File Scripting
- PHP Scripts
- Cascading Style Sheets
- ColdFusion
- ASP .NET (.aspx)

This section describes:

- [Adding an external HTML object](#)

Once you have added an external HTML object, you can specify the following within the External HTML Object Properties window:

**General tab**

- Change the name of an external HTML object
- Make an external HTML object initially invisible
- Place an external HTML object on the top layer
- Lock the size and position of an external HTML object
- Enable author control on an external HTML object

**Parameters tab**

- Specify Java Applet parameters

**Additional Files tab**

- Specify additional files used by an external HTML object
Adding an external HTML object

Perform the following steps to add an external HTML object to your title. External HTML objects are only valid if you are publishing to the Web.

1. In the left-hand pane, select the location onto which you want to add an external HTML object.

2. Do one of the following:
   - Right-click in your work area and select **New > Object > External HTML**.
   - From the Add menu, select **Object > External HTML**.
   - Click the **Add External HTML** toolbar graphic on the Insert toolbar.
   - Type **Ctrl+Shift+4**

   The External HTML Object Properties window opens. Click the **General** tab if the External HTML Object Properties window is not already opened to this tab.

3. Select the **Object Type** from the list. Choose from the following types of objects:

   **Java Applet**
   Use this object type to import a Java class or Jar file. If you use a Jar file, you must also specify the class name you would like to use within the Jar file.

   **Header Scripting**
   Use this object type to insert your own JavaScript. When this is selected, your custom script will be placed within the `<script>` tags in the head of the HTML page.

   **Shockwave Movie**
   Use this object type to import a Shockwave file.

   **Other**
   Use this object type to insert your own free-form, custom HTML. Your custom code will be placed within a `<div>` block in the body of the HTML page.

   **ASP script**
   Use this object type to insert your own ASP script. Your custom code will be placed within a `<div>` block in the body of the HTML page. The HTML page will be published with an extension of `.asp`.

   **JSP script**
   Use this object type to insert your own JSP script. Your custom code will be placed within a `<div>` block in the body of the HTML page. The HTML page will be published with an extension of `.jsp`.

   **Meta tags**
   Use this object type to insert meta tags. Meta tags will follow the `<title>` tags within the head of the HTML page. An example of a meta tag is: `<META NAME="Author" CONTENT="Your name">`

   **Top of file scripting**
   Use this object type to insert your own code or comments at the top of the file. Your custom code or comments will be placed above and outside the `<HTML>` tags of the HTML page.

   **Bottom of file scripting**
   Use this object type to insert your own code or comments at the bottom of the file. Your custom code or comments will be placed below and outside the `</HTML>` tags of the HTML page.

   **PHP Script**
   Use this object type to insert your own PHP script. Your custom code will be placed within a `<div>` block in the body of the HTML page. The HTML page will be published with an extension of `.php`.
**Cascading Style Sheet**
Use this object type to apply a cascading style sheet. Cascading style sheets will not cascade to text that Lectora produces, and should only be used to format objects.

**ColdFusion**
Use this object type to insert your own ColdFusion script. Your custom code will be placed within a `<div>` block in the body of the HTML page. The HTML page will be published with an extension of `.cfm`.

**ASP .NET (.aspx)**
Use this object type to insert your own ASP .NET script. Your custom code will be placed within a `<div>` block in the body of the HTML page. The HTML page will be published with an extension of `.aspx`.

ASP, JSP, PHP, ColdFusion and ASP .NET object types cannot be used on the same page within your title.

4. Once you have selected the object type from the list, you can import an external file containing your script, or you can directly write the script or code into the Custom HTML field. Click the Import button to navigate and select the file containing your script. Alternatively, click on the arrow within the Import button to choose from the following:

- **From File** Select this to navigate and select a file.
- **Media Library** Select this to launch your media library to select a file.

*See also:* Working with the Media Library Organizer

5. Click **OK**.

**Specifying Java applet parameters**
You can pass parameters from the HTML page to the Java applet that is included on your page as an external HTML object.

To specify Java applet parameters:
1. Double-click on the external HTML object within your work area. The External HTML Object Properties window opens. Click the **Parameters** tab.
2. Click the **Add** button. The Parameter Entry window opens.
3. Type the parameter **Name** and **Value** in the entry fields.
4. Click **OK**.
   
   Repeat steps 2 through 4 for each parameter you want to define.
5. Click **OK**.

You can **Edit** or **Remove** existing parameters by selecting the parameter name or value within the list and clicking the corresponding button. When you **Edit** an existing parameter, you can change the name or value of the parameter. When you **Remove** a parameter, it is removed from the list.

**Specifying additional files used by an external HTML object**
The custom code within your external HTML object can link to a variety of file types. Each file that your custom code references must be added as an additional file.

To specify additional files used by an external HTML object:
1. Double-click on the external HTML object within your work area. The External HTML Object Properties window opens. Click the **Additional files** tab.
2. Click the Add file button to navigate and select the file referenced by your code. The additional file appears within the list. Repeat this step as necessary for any files that are referenced by your custom code.

To remove unnecessary files, select the file within the list and click on the Remove file button.

3. Click OK.

Working with Images
Lectora supports the following image formats:
- JPEG (.jpeg, .jpg)
- GIF (.gif)
- TIFF (.tif)
- Windows Bitmap (.bmp)
- Windows Enhanced Metafiles (.emf)
- Windows Metafiles (.wmf)
- Portable Network Graphics (.png)

This section describes:
- Adding an image

Once you have added an image, you can specify the following within the Image Properties window:

**General tab**
- Change the name of an image
- Edit the image's resource file
- Make an image initially invisible
- Place an image on the top layer
- Lock the size and position of an image
- Enable author control on an image
- Use an empty ALT tag for an image
- Preload an image for Web-based publishing

**Transitions tab**
- Specify an image's transitions

**Reference tab**
- Add a reference for an image

**Metadata tab**
- Include metadata for an image

**Adding an image**
Perform the following steps to add an image to your title:
1. In the left-hand pane, select the location onto which you want to add an image.

2. Do one of the following:
   - Right-click in your work area and select New > Object > Image.
   - From the Add menu, select Object > Image.
   - Click the Add Image toolbar graphic on the Insert toolbar.
   - Type Ctrl+Shift+5
   - Drag and Shift a supported image file from a Windows Explorer window to the Lectora work area.

The Image Properties window opens (unless the image was dragged and dropped into your work area). Click the General
3. Click on the **Import** button to navigate and select the image you want to add to your title. Alternatively, click on the arrow within the **Import** button to choose from the following:

   **From File**  
   Select this to navigate and select an image.

   **Media Library**  
   Select this to launch your media library to select an image.

   *See also:* [Working with the Media Organizer](#)

4. Click **OK**.

   The image will appear within your work area.

---

**Working with IPIX Images**

IPIX images are 360 degree images that enable users to “look around” the image by navigating left, right, up, or down within the image. For additional information about IPIX images, visit [http://www.ipix.com](http://www.ipix.com).

Lectora supports the following IPIX image formats:

- IPIX files (.ipx, .ips)

This section describes:

- [Adding an IPIX image](#)

Once you have added an image, you can specify the following within the IPIX Properties window:

**General tab**

- [Change the name of an IPIX image](#)
- [Make an IPIX image initially invisible](#)
- [Place an IPIX image on the top layer](#)
- [Lock the size and position of an IPIX image](#)
- [Enable author control on an IPIX image](#)
- [Use Java for rendering an IPIX image](#)

**Position and Size tab**

- [Specify an IPIX image’s position and size](#)

**Additional files tab**

- [Specify additional files used by an IPIX image](#)

**Transitions tab**

- [Specify an IPIX image’s transitions](#)

**Reference tab**

- [Add a reference for an IPIX image](#)

**Metadata tab**

- [Include metadata for an IPIX image](#)

---

**Adding an IPIX image**

Perform the following steps to add an IPIX image to your title:

1. In the left-hand pane, select the location onto which you want to add an IPIX image.

2. Do one of the following:
   - Right-click in your work area and select **New > Object > IPIX Image**.
   - From the **Add** menu, select **Object > IPIX Image**.
   - Click the **Add IPIX** toolbar graphic on the Insert toolbar.
   - Type **Ctrl+Shift+6**
   - Drag and drop a supported IPIX image file from a Windows Explorer window to the Lectora work area.
The IPIX Properties window opens (unless the IPIX image was dragged and dropped into your work area). Click the **General** tab if the IPIX Properties window is not already opened to this tab.

3. Click on the **Import** button to navigate and select the IPIX image you want to add to your title. Alternatively, click on the arrow within the **Import** button to choose from the following:

   - **From File** Select this to navigate and select an IPIX image.
   - **Media Library** Select this to launch your media library to select an IPIX image.

   *See also:* [Working with the Media Organizer](#)

4. Click **OK**.

   The IPIX image will appear within your work area.

**Using Java to render an IPIX image**

You can choose to use Java instead of ActiveX for the functionality of IPIX images in your Web-published title.

To use Java instead of ActiveX for an IPIX image:

1. Double-click on the IPIX image within your work area. The IPIX Properties window opens. Click the **General** tab if the IPIX Properties window is not already opened to this tab.

2. Select the **Use Java Runtime when Publishing to HTML** check box.

3. Click **OK**.

**Specifying additional files used by an IPIX image**

IPIX images can link to additional IPIX images or a variety of other files. Each file that your IPIX image references needs to be added as an additional file.

To specify additional files used by an IPIX image:

1. Double-click on the IPIX image within your work area. The IPIX Properties window opens. Click the **General** tab if the IPIX Properties window is not already opened to this tab.

2. Click the **Add file** button to navigate and select the file referenced by the IPIX image. The additional file appears within the list.

   Repeat this step as necessary for any files that are referenced by your IPIX image.

   To remove unnecessary files, select the file within the list and click on the **Remove file** button.

3. Click **OK**.

**Working with Menus**

You can create menus for use in navigating throughout a title or for executing other actions.

This section describes:

- **Adding a menu**

Once you have added a menu, you can specify the following within the Menu Properties window:

**General tab**

- **Change the name of a menu**

**Submenu Layout tab**

- **Configure a menu's submenu layout**
Adding a menu
Perform the following steps to add a menu to your title.
1. In the left-hand pane, select the location onto which you want to add a menu.

2. Do one of the following:
   - Right-click in your work area and select **New > Object > Menu**.
   - From the **Add** menu, select **Object > Menu**.
   - Click the **Add Menu** toolbar graphic on the Insert toolbar.
   - Type `Ctrl+Shift+7`

   The Menu Properties window opens. Click the **General** tab if the Menu Properties window is not already opened to this tab.

3. Use the **Add Item**, **Add Sub Item**, and **Add Separator** buttons to specify the selectable items within the menu.

   See also: [Specifying menu items and sub items](#)

4. Click **OK**.

Specifying menu items and sub items
When you add a menu to your title, you design the organization of the menu and specify the selectable items within the menu.

To specify menu items and sub items:
1. Double-click on the menu object within your work area. The Menu Properties window opens. Click the **General** tab if the Menu Properties window is not already opened to this tab.

2. Use the buttons beneath the menu organization display area on the left to add menu items, sub items and separators. Click on the following buttons to add the appropriate items to your menu:

   **Add Item**
   - Click this button to add a main menu item. The new menu item will be added following the currently selected menu item in the menu organization display area. Main menu items will appear to the user without the user having to expand a level of the menu.

   **Add Sub Item**
   - Click this button to add a sub menu item. The new sub menu item will be added to the currently selected menu item in the menu organization display area. Sub items will appear to the user when the user has selected the main menu item in which the sub item resides.

   **Add Separator**
   - Click this button to add a separator to the menu. Depending on your menu's orientation, the separator will appear as a horizontal or vertical line within the menu.
3. Click **OK**.

You can also remove items by selecting the menu item and clicking the **Remove Item** button.

### Renaming menu items and sub items
You can change the names of your menu items and sub items at any time. The names used for your menu items and sub items are the options within the menu from which users can choose.

To rename menu items and sub items:

1. Double-click on the menu object within your work area. The Menu Properties window opens. Click the **General** tab if the Menu Properties window is not already opened to this tab.

2. Select the menu item or sub item within the menu organization display area that you want to change. Rename the item by completing one of the following:
   - Click on the **Rename Item** button and type the new item name within the menu organization display area.
   - Type the new name into the **Menu Item Name** field, the change will be reflected in the menu organization display area.
   - Click within the textual label for the menu item within the menu organization display area and type the new item name.

3. Click **OK**.

### Assigning menu item actions
Each menu item and sub item within your menu can be associated with an action. The action specified will execute when a user has selected the corresponding menu item from the menu.

**See also:** [About Actions](#)

To assign menu item actions:

1. Double-click on the menu object within your work area. The Menu Properties window opens. Click the **General** tab if the Menu Properties window is not already opened to this tab.

2. Select the menu item or sub item within the menu organization display area to which you want to assign an action.

3. Use the **Action** list to select the action to execute when the selects the menu item.

**See also:** [Selecting an action](#)

The **Target** field is enabled when the action requires a target. Specify additional information as necessary.

**See also:** [Selecting an action's target](#)

Repeat steps 2 and 3 to assign additional actions to other menu items.

4. Click **OK**.

### Configuring a menu’s top level layout
You can customize your menu’s top level appearance by specifying colors, fonts, margins and the style of the menu.

To configure a menu’s top level layout:

1. Double-click on the menu object within your work area. The Menu Properties window opens. Click the **Top Level Layout** tab.

2. Specify the following for the top level of your menu:
Menu Orientation
Select between Horizontal or Vertical orientation. Horizontally oriented menus enable you to set the top, bottom, left and right margins (in pixels) of both the horizontal menu and the vertical submenus. Vertically oriented menus enable you to set top, bottom, left and right margins (in pixels) of the vertical menu and vertical submenus.

Text Alignment
Choose how you want the text of the menu item aligned within the menu. Select Left, Center, or Right.

Background Color
Select the background color for top level menu items. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

See also: Matching Colors Used within Your Title

Background Highlight Color
Select the background highlight color for the menu. This is the color that will appear in the background of the menu when the user has rolled his or her mouse over a top level menu item. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

See also: Matching Colors Used within Your Title

Text Style
Use the list to select a text style to be used for the top level menu items. To create a new text style, click on the Styles button.

See also: Managing Text Styles

Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

Text Highlight Color
Select the text highlight color for the menu. This is the color of the text that will appear when the user has rolled his or her mouse over a top level menu item. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

See also: Matching Colors Used within Your Title

Background Image
Instead of using a background color with your menu, you can use a background image. Select a previously imported image from the list, or click the Import button to navigate and select a new background image for the menu. Alternatively, click on the arrow within the Import button to choose from the following:

- From File: Select this to navigate and select an image.
- Media Library: Select this to launch your media library to select an image.

See also: Working with the Media Organizer

Margins
Specify values (in pixels) for the Top / Bottom and Left / Right margins for the top level menu items. Margins will determine the spacing between menu items and the borders of the menu.

Outlines/Separators/Frame
Select how outlines, separators, and the menu frame should appear. Select from:

- No Outlines or Frame
- Windows Style 3D Menus
- Draw Frame Around Menu
• Draw Outline Around Each Menu Item

Select the Separator Color and Outline/Frame Color from the lists, when available.

3. Click OK.

Configuring a menu's submenu layout
You can customize the appearance of submenus by specifying colors, fonts, margins and the style of the submenu.

To configure a submenu's top level layout:
1. Double-click on the menu object within your work area. The Menu Properties window opens. Click the Submenu Layout tab.

2. Specify the following for the submenus of your menu:

   - **Text Alignment**
     Choose how you want the text of the submenu item aligned within the menu. Select Left, Center, or Right.

   - **Background Color**
     Select the background color for submenu items. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

     See also: Matching Colors Used within Your Title

   - **Background Highlight Color**
     Select the background highlight color for a submenu. This is the color that will appear in the background of the submenu when the user has rolled his or her mouse over a submenu item. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

     See also: Matching Colors Used within Your Title

   - **Text Style**
     Use the list to select a text style to be used for submenu items. To create a new text style, click on the Styles button.

     See also: Managing Text Styles

     Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

   - **Text Highlight Color**
     Select the text highlight color for a submenu. This is the color of the text that will appear when the user has rolled his or her mouse over a submenu item. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

     See also: Managing Text Styles

   - **Background Image**
     Instead of using a background color with your submenus, you can use a background image. Select a previously imported image from the list, or click the Import button to navigate and select a new background image for submenus. Alternatively, click on the arrow within the Import button to choose from the following:

     - From File
     - Media Library

     Select this to navigate and select an image.

     Select this to launch your media library to select an image.
Margins

Specify values (in pixels) for the Top / Bottom and Left / Right margins for submenu items. Margins will determine the spacing between submenu items and the borders of the submenu.

Outlines/ Separators/ Frame

Select how outlines, separators, and the submenu frame should appear. Select from:
- No Outlines or Frame
- Windows Style 3D Menus
- Draw Frame Around Menu
- Draw Outline Around Each Menu Item

Select the Separator Color and Outline/Frame Color from the lists, when available.

3. Click OK.

Working with Progress Bars

A progress bar can serve as a timer or as a visual representation of the user’s progress through a title.

This section describes:
- Adding a progress bar

Once you have added a progress bar, you can specify the following within the Progress Bar Properties window:

General tab
- Change the name of a progress bar
- Specify the type of progress bar
- Automatically start a timer progress bar
- Make a progress bar initially invisible
- Place a progress bar on the top layer
- Lock the size and position of a progress bar
- Enable author control on a progress bar
- Empty a progress bar as progress increases

Layout
- Specify the layout of a progress bar

Position and Size tab
- Specify a progress bar’s position and size

Transitions tab
- Specify a progress bar’s transitions

Adding a progress bar

Perform the following steps to add a progress bar to your title:

1. In the left-hand pane, select the location onto which you want to add the progress bar.

2. Do one of the following:
   - Right-click in your work area and select New > Object > Progress Bar.
   - From the Add menu, select Object > Progress Bar.
   - Click the Add Progress Bar toolbar graphic on the Insert toolbar.
   - Type Ctrl+Alt+9

The Progress Bar Properties window opens. Click the General tab if the Progress Bar Properties window is not already opened to this tab.

3. Select the Type of progress bar from the list and specify additional information as necessary.

See also: Specifying the type of progress bar
4. Click OK.

**Specifying the type of progress bar**

There are three types of progress bars you can add to your title. Each type is different in its functionality.

To specify the type of progress bar:

1. Double-click on the progress bar within your work area. The Progress Bar Properties window opens. Click the General tab if the Progress Bar Properties window is not already opened to this tab.

2. Select the progress bar Type from the list. Choose from the following options:

   - **Custom**
     Creates a custom progress bar with a specified Range and Step Size. This kind of progress bar must be set or incremented manually using the Set Progress and Step Progress actions.

     **See also:** Selecting an Action

   - **Timer**
     Creates a progress bar based on time with a specified Total Time and Increment. The progress bar can be set to Auto Start or can be started using the Play action. It can be stopped using the Stop action, and an On Done action can be added to the progress bar to execute once the Total Time has elapsed.

     **See also:** Selecting an action’s trigger

   - **Table of Contents**
     Creates a progress bar that automatically tracks progress through a title in accordance with the chapters, sections, and pages that are included in a Table of Contents. That is, the progress bar will increment on every page that is included in a Table of Contents. It is not necessary for a Table of Contents to exist within a title for use of this functionality.

     **See also:** Working with Tables of Contents

3. If your progress bar type is **Custom**, specify the following additional information:

   - **Range**
     The total range of your progress bar. This can be any positive integer value.

   - **Step Size**
     The increment size within the progress bar. This can be any positive integer value.

   If your progress bar type is **Timer**, specify the following additional information:

   - **Total Time**
     The total time for the progress bar. This is the amount of time it will take to completely fill or empty the progress bar.

   - **Increment**
     The frequency with which the progress bar will increment. For example, if the increment value is 2, the progress bar will increment every 2 seconds.

4. Click OK.

**Automatically starting a timer progress bar**

You can choose to automatically start a timer progress bar when the page containing the progress bar appears to the user.

**See also:** Specifying the type of progress bar

To automatically start a timer progress bar:

1. Double-click on the progress bar within your work area. The Progress Bar Properties window opens. Click the General tab
if the Progress Bar Properties window is not already opened to this tab.

2. Select the **Auto Start** check box.

3. Click **OK**.

**Emptying a progress bar as progress increases**
The typical functionality for a progress bar is for it to fill as progress increases. You can specify to empty a progress bar as progress increases instead.

To empty a progress bar as progress increases:
1. Double-click on the progress bar within your work area. The Progress Bar Properties window opens. Click the **General** tab if the Progress Bar Properties window is not already opened to this tab.

2. Select the **Empty Bar As Progress Increases** check box.

3. Click **OK**.

**Specifying the layout of a progress bar**
You can customize the orientation and colors used within your progress bar.

To specify the layout of a progress bar:
1. Double-click on the progress bar within your work area. The Progress Bar Properties window opens. Click the **Layout** tab.

2. Specify the following for the layout of your progress bar:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Orientation</strong></td>
<td>Select between <strong>Horizontal</strong> or <strong>Vertical</strong> orientation for the progress bar.</td>
</tr>
<tr>
<td><strong>Use Default Image</strong></td>
<td>Clear this option to specify a color or image for the progress bar. The <strong>Color</strong> and <strong>Image</strong> lists are enabled.</td>
</tr>
<tr>
<td><strong>Color</strong></td>
<td>If you have cleared the <strong>Use Default Image</strong> check box, you can specify a color for the progress bar. The progress bar will fill solidly with the color selected. Use the <strong>Color</strong> list to select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select <strong>Custom</strong> to select a custom color from the Color wheel.</td>
</tr>
<tr>
<td><strong>Image</strong></td>
<td>If you have cleared the <strong>Use Default Image</strong> check box, you can specify an image for use with your progress bar. When an image is selected, the progress bar will fill using the image. Each increment of the progress bar will replicate the image selected. Select a previously imported <strong>Image</strong> from the list, or click the <strong>Import</strong> button to navigate and select an image for the progress bar. Alternatively, click on the arrow within the <strong>Import</strong> button to choose from the following:</td>
</tr>
<tr>
<td><strong>From File</strong></td>
<td>Select this to navigate and select an image.</td>
</tr>
<tr>
<td><strong>Media Library</strong></td>
<td>Select this to launch your media library to select an image.</td>
</tr>
</tbody>
</table>

**See also:** [Matching Colors Used within Your Title](#)

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Background</strong></td>
<td>Select the background color for the progress bar. Use the <strong>Color</strong> list to select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select <strong>Custom</strong> to select a custom color from the Color wheel.</td>
</tr>
</tbody>
</table>

**See also:** [Working with the Media Organizer](#)
See also: Matching Colors Used within Your Title

Show Tick Marks
Select this to include tick marks in the progress bar.

3. Click OK.

Working with Reference Lists
You can create a reference list within your title. A reference list will compile all of the reference information from objects within your title to create a complete list of all your references.

See also: Adding a reference for an object

This section describes:
- Adding a reference list

Once you have added a reference list, you can specify the following within the Reference List Properties window:

- **General tab**
  - Change the name of a reference list
  - Specify the scope of a reference list
  - Make a reference list initially invisible
  - Place a reference list on the top layer
  - Lock the size and position of a reference list
  - Enable author control on a reference list

- **Position and Size tab**
  - Specify a reference list's position and size

- **Transitions tab**
  - Specify a reference list's transitions

Adding a reference list
Perform the following steps to add a reference list to your title:

1. In the left-hand pane, select the location onto which you want to add the reference list.

2. Do one of the following:
   - Right-click in your work area and select New > Object > Reference List.
   - From the Add menu, select Object > Reference List.
   - Click the Add Reference List toolbar graphic on the Insert toolbar.
   - Type Ctrl+Shift+8

The Reference List Properties window opens. Click the General tab if the Reference List Properties window is not already opened to this tab.

3. Select the Scope of the reference list.

   See also: Specifying the scope of a reference list

4. Click OK.

Specifying the scope of a reference list
You can specify whether the reference list should include information for objects within your entire title, the current chapter, the current section, or just the current page.

To specify the scope of a reference list:

1. Double-click on the reference list within your work area. The Reference List Properties window opens. Click the General tab if the Reference List Properties window is not already opened to this tab.
2. Select the **Scope** from the list. Choose from the following four options:

   **All References in the Title**  
   Will include reference information for all objects within the title.

   **References in this chapter**  
   Will include reference information for only the objects contained in the current chapter.

   **References in this section**  
   Will include reference information for only the objects contained in the current section.

   **References in this page**  
   Will include reference information for only the objects contained on the current page.

3. Click **OK**.

**Working with Tables of Contents**

A Table of Contents is a menu system that is automatically generated from your title’s organization in the left-hand pane. The Table of Contents will automatically be populated with the chapters, sections, and pages that are contained within your title. Users will be able to select the chapter, section or page from the Table of Contents to navigate directly to that area of the title.

This section describes:

- Adding a table of contents
- Removing chapters, sections, and pages from a table of contents

Once you have added a table of contents, you can specify the following within the Table of Contents Properties window:

**General tab**
- Change the name of a table of contents
- Specify the appearance of a table of contents
- Specify the scope of a table of contents
- Specify the frame of reference for a table of contents
- Make a table of contents initially invisible
- Place a table of contents on the top layer
- Lock the size and position of a table of contents
- Enable author control on a table of contents
- Use a transparent background for a table of contents
- Remove all pages from a table of contents
- Remove icons from a table of contents

**Position and Size tab**
- Specify a table of content’s position and size

**Font and Color tab**
- Specify the font and color of a table of contents

**Transitions tab**
- Specify a table of content’s transitions

**Adding a table of contents**

Perform the following steps to add a table of contents to your title:

1. In the left-hand pane, select the location onto which you want to add the table of contents.

2. Do one of the following:
   - Right-click in your work area and select **New > Object > Table of Contents**.
   - From the **Add** menu, select **Object > Table of Contents**.
   - Click the **Add Table of Contents** toolbar graphic on the Insert toolbar.
   - Type Ctrl+Shift+9

The Table of Contents Properties window opens. Click the **General** tab if the Table of Contents Properties window is not already opened to this tab.
3. Select the **Appearance** and **Scope** of the table of contents.

   See also: Specifying the appearance of a table of contents
   Specifying the scope of a table of contents

4. Click **OK**.

**Specifying the frame of reference for a table of contents**

If you are using frames within your title, a table of contents can be generated in one frame while it is used to navigate within the chapters, sections and pages of another frame.

See also: Working with Frames

To specify the frame of reference for a table of contents:

1. Double-click on the table of contents within your work area. The Table of Contents Properties window opens. Click the **General** tab if the Table of Contents Properties window is not already opened to this tab.

2. Select the **Frame that this refers to** from the list.

3. Click **OK**.

**Removing chapters, sections and pages from a table of contents**

By default, all chapters, sections and pages within your title are included in a table of contents. However, if you do not want a specific chapter, section or page to appear within the table of contents, it can be removed.

The following topics describe how to remove chapters, sections and pages from your table of contents:

- Removing a chapter, section or page from the table of contents
- Removing an assignable unit from the table of contents

**Specifying the appearance of a table of contents**

The table of contents object can have three different appearances.

To specify the appearance of a table of contents:

1. Double-click on the table of contents within your work area. The Table of Contents Properties window opens. Click the **General** tab if the Table of Contents Properties window is not already opened to this tab.

2. Select the **Appearance** from the list. Choose from the following options:

   - **Drop-down List**
     A drop-down list will present the table of contents in a single list from which users can select the chapter, section or page to which they want to navigate.

   - **Indented List**
     An indented list will display all of the chapters, sections and pages included in the table of contents. The sections and pages within the list are indented from the chapter or section to which they belong. Users click on the chapter, section or page in the list to which they want to navigate.

   - **Tree View**
     A tree view will display all of the chapters, sections and pages included in the table of contents, organized in a tree, similar to the functionality of the left-hand pane. Chapters and sections will have a [+] sign next to them, enabling users to expand the chapter or section to select a page to which they want to navigate.

3. Click **OK**.

**Specifying the scope of a table of contents**
A table of contents can be generated to include the scope of the entire title, the current chapter, or the current section.

To specify the scope of a table of contents:
1. Double-click on the table of contents within your work area. The Table of Contents Properties window opens. Click the General tab if the Table of Contents Properties window is not already opened to this tab.
2. Select the Scope (when available) from the list. Choose from the following options:
   - **For the entire title**  The table of contents will include all chapters, sections and pages in the entire title.
   - **For this chapter**  The table of contents will only include the sections and pages contained in the current chapter.
   - **For this section**  The table of contents will only include the sub-sections and pages contained in the current section.
3. Click OK.

**Using a transparent background for a table of contents**
If the appearance of your table of contents is Indented List or Tree View, you can set the background of the table of contents to be transparent. This option will only work if you are publishing to the Web.

**See also:** Specifying the appearance of a table of contents

To use a transparent background for a table of contents:
1. Double-click on the table of contents within your work area. The Table of Contents Properties window opens. Click the General tab if the Table of Contents Properties window is not already opened to this tab.
2. Select the Transparent Frame (HTML only) check box.
3. Click OK.

You can also select a color for the background of a table of contents.

**See also:** Specifying the font and color of a table of contents

**Removing all pages from a table of contents**
If the appearance of your table of contents is Drop-down List or Indented List, you can specify to have only the chapters and sections of your title appear in a table of contents. Users can then only directly navigate to the chapters and sections within the title. When users navigate to a chapter or section, they will be directed to the first page of that chapter or section.

**See also:** Specifying the appearance of a table of contents

To remove all pages from a table of contents:
1. Double-click on the table of contents within your work area. The Table of Contents Properties window opens. Click the General tab if the Table of Contents Properties window is not already opened to this tab.
2. Clear the Show Pages check box.
3. Click OK.

**Removing icons from a table of contents**
If the appearance of your table of contents is Indented List or Tree View, you can remove the icons from the table of contents. The table of contents will then only display the names of the chapters, sections, and pages within your title, and not the corresponding chapter, section and page icons.
To remove the icons from a table of contents:
1. Double-click on the table of contents within your work area. The Table of Contents Properties window opens. Click the **General** tab if the Table of Contents Properties window is not already opened to this tab.
2. Clear the **Use Icons** check box.
3. Click **OK**.

### Specifying the font and color of a table of contents

You can specify the background color and font style used within a table of contents.

To specify the font and color of a table of contents:
1. Double-click on the table of contents within your work area. The Table of Contents Properties window opens. Click the **Font and Color** tab.
2. Select the **Background Color** for your table of contents from the list. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

   **See also:** [Matching Colors Used within Your Title](#)

3. Select the **Text Style** from the list. To create a new text style, click on the **Styles** button.

   **See also:** [Managing Text Styles](#)

Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

4. Click **OK**.

### Working with Video

Lectora supports the following video formats:
- Apple QuickTime movie (.mov)
- Audio Video Interleave (.avi)
- Flash Video (.flv)
- Moving Picture Experts Group (.mpg, mpeg)
- Real Media (.rm, .rmm)
- Windows Media Video (.wmv)
- Microsoft and Real Media streaming video formats
- YouTube streaming video (.flv)

**YouTube Security Warning:** YouTube streaming video when published to HTML and run locally from your hard drive might display a security warning. The warning is a Flash security warning related specifically to running the video locally from a machine (as opposed to running it from the Web). When your title is published to a Web server, this error will not occur and users of your published title will not see the security warning.

This section describes:
- [Adding a video](#)
- [Converting to Flash (.flv) video](#)
Once you have added a video, you can specify the following within the Video Properties window:

**General tab**
- Change the name of a video
- Specify the type of video
- Edit the video resource file
- Make a video initially invisible
- Place a video on the top layer
- Lock the size and position of a video
- Enable author control on a video
- Display a video controller
- Continuously play a video
- Automatically start a video

**Position and Size tab**
- Specify a video's position and size

**Transitions tab**
- Specify a video's transitions

**Reference tab**
- Add a reference for a video

**Metadata tab**
- Include metadata for a video

**Events tab**
- Associate actions with video events

**Skins tab**
- Applying a skin to the controller

---

**Adding a video**

Perform the following steps to add a video to your title:

1. In the left-hand pane, select the location onto which you want to add a video.

2. Do one of the following:
   - Right-click in your work area and select **New > Object > Video**.
   - From the **Add** menu, select **Object > Video**.
   - Click the **Add Video** toolbar graphic on the Insert toolbar.
   - Type **Ctrl+Alt+1**
     o Drag and drop a supported video file from a Windows Explorer window to the Lectora work area.

The Video Properties window opens (unless the video was dragged and dropped into your work area). Click the **General** tab if the Video Properties window is not already opened to this tab.

3. Click on the **Import** button to navigate and select the video file you want to add to your title. A preview of the media is provided to the right. Alternatively, click on the arrow within the **Import** button to choose from the following:

   - **From File**: Select this to navigate and select a video.
   - **Media Library**: Select this to launch your media library to select a video.

   **See also**: [Working with the Media Library Organizer](#)

4. Click **OK**.

The video will appear within your work area.

**Specifying the type of video**

When you add a video to your title, you can specify whether the video is standard or streaming.

To specify the type of video:

1. Double-click on the video within your work area. The Video Properties window opens. Click the **General** tab if the Video Properties window is not already opened to this tab.
2. Select the **Video Type** from the list. For Standard Video, click the **Import** button to navigate and select a video file. For streaming video, select from RealNetworks, Windows Media Services, or YouTube streaming video, and enter the Web address of the video stream in the **URL** field.

   **See also:** Streaming Media

3. Click **OK**.

**Displaying a video controller**
When you add a video to your title, you can display a video controller so users have the ability to fast forward, rewind, play, pause, and stop the video.

To display a video controller:
1. Double-click on the video within your work area. The Video Properties window opens. Click the **General** tab if the Video Properties window is not already opened to this tab.

2. Select the **Display Video Controller** check box.

   For Flash (.flv) video objects, you can select from predefined skins for the controller. See **Associating a skin to the controller**.

3. Click **OK**.

**Continuously playing a video**
You can have a video automatically restart when it has reached the end. The video will loop until the user has exited the page.

To continuously play a video:
1. Double-click on the video within your work area. The Video Properties window opens. Click the **General** tab if the Video Properties window is not already opened to this tab.

2. Select the **Play Continuously** check box.

3. Click **OK**.

**Automatically starting a video**
You can choose to automatically start the video when the page containing the video appears to the user.

To automatically start a video:
1. Double-click on the video within your work area. The Video Properties window opens. Click the **General** tab if the Video Properties window is not already opened to this tab.

2. Select the **Auto Start** check box.

3. Click **OK**.

**Associating actions with video events**
Events, also known as script commands, set within a video file can be used to trigger actions while the video is playing. This is especially useful when you want to synchronize actions with a video.

   You must first create the events within the video. Once the events have been created, you can proceed to associate actions with the video events.

   **See also:** Selecting an Action
To associate actions with video events:
1. Double-click on the video within your work area. The Video Properties window opens. Click the Events tab.
2. Select the event label from the Event list.
3. Specify the Action to be executed when the video has reached the event. Specify additional action information as necessary.
   Repeat steps 2 and 3 for each event you want to define.
4. Click OK.

Converting to Flash (.flv) video
You can convert your video objects to Flash (.flv).
When you convert an object to Flash audio or video, all instances of the resource are changed throughout your title.

Flash .flv files require your user's computer to have the Flash plug-in installed.

To convert to Flash video:
6. Add the video to your title.
7. Select the object, right-click, and choose Convert to FLV.
   The option is only available for relevant file types.
   The Convert to FLV window opens.
8. Use the slider to select a compression level.
   Higher compression levels will result in smaller files, but the quality of the media will deteriorate as compression increases.
9. Click Convert.
   When the conversion completes, the compression results are displayed and you are asked whether to use the new file.
10. Click Yes. Otherwise, click No to restore the file to its original type.
   The object is converted to .flv.

Applying a skin to the controller
When you have selected to display a Flash (.flv) video object using a controller, you can apply a predefined or custom skin to the controller. See Displaying a video controller.

To associate a skin to the controller:
1. Double-click on the video object within your work area. The Video Properties window opens. Click the Skins tab.
2. Use the drop-down list to select a predefined skin.
3. Click OK to add your updated controller to the page.
Adding Shapes, Lines and Arrows
Various shapes, lines, and arrows can be added to your title with the use of the Shapes and Lines toolbar. These objects can be used to draw your users’ attention to a particular part of a page. The images are created in Windows Media Format (.wmf) enabling you to resize them without losing quality.

Perform the following steps to add shapes, lines or arrows to your title:

1. In the left-hand pane, select the location onto which you want to add a shape, line or arrow.

2. Do one of the following:
   - From the Tools menu, select Shapes/Lines > Set line/fill properties.
   - Click the Line/Fill Properties toolbar graphic on the Shape bar.

   The Shape/Line Properties window opens.

3. Use the Shape box to specify shape properties or use the Line/Arrow box to specify line and arrow properties. You can specify the following:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shape Fill Color</td>
<td>Select the color to use to fill the shape. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.</td>
</tr>
<tr>
<td>Outline Shape</td>
<td>Select this to place an outline around the shape. This enables the Outline color and Outline width fields.</td>
</tr>
<tr>
<td>Outline color</td>
<td>Select the color to be used for the outline of the shape. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.</td>
</tr>
<tr>
<td>Outline width</td>
<td>Select the width of the outline of the shape. Dimensions are in pixels.</td>
</tr>
<tr>
<td>Line/Arrow color</td>
<td>Select the color of the line or arrow. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.</td>
</tr>
<tr>
<td>Line thickness</td>
<td>Select the thickness of the line. Dimensions are in pixels.</td>
</tr>
</tbody>
</table>

4. Click OK to save your shape and line properties. Any shapes or lines you create will adhere to these properties until the properties are changed.

   Change your shape and line properties at any time by repeating steps 2 through 4.

5. Create the shape or line by completing one of the following:
   - From the Tools menu, select Shapes/Lines and select the shape or line you want to add to your title. You can also select the Block Arrows, Triangles, Parallelograms or Trapezoids submenus to add variations of those types of shapes.
   - Click the toolbar graphic of the shape you want to add from one of the following toolbars:
Use the View menu to display these toolbars if they are not currently displayed within the Lectora interface.

See also: View Menu

6. Using your mouse, draw a rectangle within your work area by clicking, and while holding down the left mouse button, dragging the cursor to define a rectangle. The rectangle you draw defines the size of the shape you are adding. When you release the left mouse button, the shape will appear.

The shape is added as an image object to your title.

See also: Working with Images

Grouping and Ungrouping Objects

When you group objects, you combine them so you can work with them as a single unit. Move, lock and unlock all objects in a group as a single unit. Group properties will enable you to set a transition on the group, applying the transition to all objects within the group. You can also perform actions on groups. For example, using a group as a target on a show or hide action will show or hide all components of the group.

Groups can contain all kinds of objects, images, text blocks, audio, and actions. When a group consists entirely of actions, it is referred to as an Action Group. You can use a single command to run all of the actions inside of an action group.

See also: Selecting an action

You can ungroup a group of objects at any time and then regroup them later.

When a group object is deleted, all objects within that group are deleted as well.

This section describes:
- Grouping objects
- Ungrouping objects

Once you have added a group, you can specify the following within the Group Properties window:

**General tab**
- Change the name of a group
- Enable author control on a group

**Transitions tab**
- Specify a group's transitions

Grouping Objects
You can group objects in one of two ways:
**Add a group to your title and add objects to the group.**

**Select a set of objects and group them.**

### Adding a group

Perform the following steps to add a group to your title:

1. In the left-hand pane, select the location onto which you want to add a group.

2. Do one of the following:
   - Right-click in your work area and select **New > Group**.
   - From the **Add** menu, select **Group**.
   - Click the **Add Group** toolbar graphic on the Insert toolbar.
   - Type **Ctrl+5**

   The group appears within your left-hand pane.

To add an existing object to the group, drag and drop the existing object from the left-hand pane into the group. Complete this by selecting the object and while holding down the left mouse button, drag the object until the cursor is positioned over the group object and the name of the group is highlighted. Release the left mouse button to add the object to the group.

You can select multiple objects by holding down the **Ctrl** key while selecting objects.

### Selecting objects and grouping them

If you have a set of objects within your title that you want to group, you can select the objects and group them.

To select objects and group them:

1. Complete one of the following to select objects within your title:
   - Select the objects within the left-hand pane. Hold down the **Ctrl** key to select multiple objects.
   - Select the objects within your work area. Hold down the **Ctrl** key to select multiple objects.
   - Using your mouse, draw a rectangle within your work area by clicking, and while holding down the left mouse button, dragging the cursor to define a rectangle. All objects within the rectangle will be selected.

2. With the objects selected, right click within the left-hand pane or within your work area and select **Group** from the right-click context menu.

### Ungrouping objects

You can ungroup objects. To ungroup objects, right-click the group graphic of the group of objects you want to ungroup and select **Ungroup** from the right-click context menu.

### Changing the name of an object

To change the name of a group:

1. Double-click on the group graphic within your left-hand pane. The Group Properties window opens. Click the **General** tab if the Group Properties window is not already opened to this tab.

2. Specify the new name of the group in the **Group Name** field.

3. Click **OK**.

### Enabling author control on a group

Protect the group by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the group.
or any of the objects in it unless they have the master Author Control password. The master Author Control password must first be set within the Title Properties.

See also:  Protecting your title with a password

To enable author control on a group:
1. Double-click on the group graphic within your left-hand pane. The Group Properties window opens. Click the General tab if the Group Properties window is not already opened to this tab.
2. Select the Author Control check box.
3. Click OK.

Specifying a group's transitions
You can specify how a group of objects is displayed on a page. Transitions will produce a visual effect as the group appears and disappears. You can select from over 20 different transitions. There is a Slow to Fast slider to determine the speed at which the transition takes place. Transitions assigned to a group will affect all objects within the group.

To specify the transition:
1. Double-click on the group graphic within your left-hand pane. The Group Properties window opens. Click the Transitions tab.
2. Specify the following information:

   **Transition In**  Select this to enable a transition when displaying the group as the page opens or the group is made visible with an action.

   **Transition (In) Type**  Select a transition type as one of the following:
   - Box In
   - Box Out
   - Circle In
   - Circle Out
   - Wipe Up
   - Wipe Down
   - Wipe Right
   - Wipe Left
   - Blinds Vertical
   - Blinds Horizontal
   - Checker Across
   - Checker Down
   - Dissolve
   - Split in Vertical
   - Split out Vertical
   - Split in Horizontal
   - Split out Horizontal
   - Strips Down left
   - Strips Up left
   - Strips Downright
   - Strips Upright
   - Horizontal Bars
   - Vertical Bars
   - Fly Top
   - Fly Top right
   - Fly Right
   - Fly Bottom right
   - Fly Bottom
   - Fly Bottom left
   - Fly Left
   - Fly Top left
   - Random Effect

   **Delay before transition**  Specify the delay in seconds before starting the transition. Select between 0 and 600 seconds.

   **Slow > Fast**  Use the slider to specify the speed at which the transition should occur.

   **Transition Out**  Select this to enable a transition when hiding the group as the page closes or the group is
hidden with an action.

**Transition (Out) Type**
Select a transition type as one of the following:
- Box In
- Box Out
- Circle In
- Circle Out
- Wipe Up
- Wipe Down
- Wipe Right
- Wipe Left
- Blinds Vertical
- Blinds Horizontal
- Checker Across
- Checker Down
- Dissolve
- Split in Vertical
- Split out Vertical
- Split in Horizontal
- Split out Horizontal
- Strips Down left
- Strips Up left
- Strips Downright
- Strips Upright
- Horizontal Bars
- Vertical Bars
- Fly Top
- Fly Top right
- Fly Right
- Fly Bottom right
- Fly Bottom
- Fly Bottom left
- Fly Left
- Fly Top left
- Random Effect

**Delay before transition**
Specify the delay in seconds before starting the transition. Select between 0 and 600 seconds.

**Slow > Fast**
Use the slider to specify the speed at which the transition should occur.

3. Click **OK**.

---

**Excluding Objects Using Inheritance**

With Lectora's inheritance capabilities, objects you add directly to the main title will appear on every page of your title. Furthermore, any objects added directly to a chapter will appear on every page in that chapter including pages that are inside of a section within the chapter. Objects added directly to a section will appear on every page in that section and objects added directly to a page will appear only on that page.

The inherit tab is available within all chapter, section and page properties. If the object is excluded within the properties of a chapter, it will not appear on any page within that chapter. If the object is excluded within the properties of a section, it will not appear on any page within that section, and if the object is excluded within the properties of a page, then the object will simply be excluded from that page.

See the following sections for additional information:
- [Specifying inheritance properties for chapters, sections and pages](#)
- [Specifying an assignable unit's inheritance properties](#)

---

**Editing Objects**

You can directly edit the resource files (such as *myimage.jpg*) for the objects used within your title. This is not the same as editing your object's properties, but will rather enable you to edit the image, video or audio file that is used within your title. You can edit the following types of objects:
- Animations
- Audio
- Buttons (You can edit the images associated with a button.)
- Documents
To edit an object:

1. Double-click on the object within your work area. The (Object) Properties window opens. Click the General tab if the (Object) Properties window is not already opened to this tab.

2. Click on the Edit button associated with the resource file used for the object. The file will be launched using the appropriate application.

   This feature is only available for the above object types if you are using the Lectora Professional Publishing Suite or if you have specified your editor preferences.

   See also: Setting editor preferences

3. Make the necessary changes to your resource file, save the file, and close the application that was used to launch it. All instances of the object are updated within your title.

You can also edit resources from within the Resource Manager.

   See also: Editing a resource

Moving and Resizing Objects

While working in Edit mode, you can easily move and resize objects within your title. Select the object you want to move or resize within your work area and do one of the following:

To move an object:

- Use your keyboard's arrow keys to reposition the object horizontally or vertically. The object will move 1 pixel in the direction of the arrow key pressed. You can also perform these steps while holding your keyboard’s Shift key. Doing so will move the object in increments of 10 pixels, in the chosen direction.

- Click on the object and while holding down the left mouse button, drag the object to its new location. To move the object to a new position that is directly above, below or to either side of its current position, hold down the Shift key while dragging the item to its new location. This will cause the object to move straight, either up, down, left, or right.

- Manually set the position of the object by altering the X and Y position within the Position and Size tab of the object’s properties.

   See also: Specifying an object's position and size

Using the Status bar

To resize an object:

- Click on any corner or side of the object, and while holding down the left mouse button, drag the corner or side of the object to resize it. Holding your keyboard’s Shift key while performing these steps will ensure that the object is resized proportionally.

- Manually set the size of the object by altering the Width and Height of the object within the Position and Size tab of the object’s properties.

   See also: Specifying an object's position and size
Using the Status bar

Locking and Unlocking Objects
You can lock the position of several objects at once. This preserves them from getting accidentally moved by you or by other authors working on your title. You can also unlock the position of several objects at once.

The selected objects will be locked in size and position within Edit mode.

To lock the position and size of multiple objects:
1. Use the Ctrl key to select more than one object on a page.
2. Right-click and select Size/Position Locked. When enabled, a check mark appears next to the Size/Position Locked menu item.

To unlock the position and size of multiple objects:
1. Use the Ctrl key to select more than one object on a page.
2. Right-click and select Size/Position Locked. When disabled, the check mark disappears from the Size/Position Locked menu item.

See also: Locking the size and position of an object

Aligning and Positioning Objects
You can align objects to the same top, bottom, left and right positions, center objects horizontally or vertically on a page, space objects evenly, and make objects the same size. This section presents additional information on the following topics:
- Aligning objects
- Centering objects on a page
- Spacing objects evenly
- Making objects the same size

To directly specify the position or size of an object, you can also modify the object's properties.

See also: Specifying an object's position and size
Using the Status bar

Aligning objects
You can use Lectora's alignment functions to align several objects along their top, bottom, left and right sides, or align them to their horizontal or vertical centers.

To align objects:
1. Hold down your Ctrl key and select the objects you want to align. Multiple objects must be selected to activate the following alignment options.
2. Select from the following alignment options. You can align objects by selecting the alignment option from the Layout menu, or by clicking the toolbar graphic.

<table>
<thead>
<tr>
<th>Alignment</th>
<th>Using the Layout menu</th>
<th>Toolbar graphic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Align objects along their left sides.</td>
<td>Select Align &gt; Left</td>
<td></td>
</tr>
<tr>
<td>Align objects along their right sides.</td>
<td>Select Align &gt; Right</td>
<td></td>
</tr>
</tbody>
</table>
Centering objects on a page
You can center your objects on a page. Centering the objects will place the objects in the horizontal or vertical center of the page.

To center objects on a page:
1. Select the object you want to center. Select multiple objects by holding down your Ctrl key.
2. Select from the following centering options. You can center objects by selecting the centering option from the Layout menu, or by clicking the toolbar graphic.

<table>
<thead>
<tr>
<th>Centering</th>
<th>Using the Layout menu</th>
<th>Toolbar graphic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Centers objects horizontally on the page.</td>
<td>Select Center &gt; Horizontal</td>
<td></td>
</tr>
<tr>
<td>Centers objects vertically on the page.</td>
<td>Select Center &gt; Vertical</td>
<td></td>
</tr>
</tbody>
</table>

Spacing objects evenly
You can space several object evenly on a page either across or down.

To evenly space objects:
1. Hold down your Ctrl key and select the objects you want to evenly space. Multiple objects must be selected to activate the following spacing options.
2. Select from the following spacing options. You can space objects by selecting the spacing option from the Layout menu, or by clicking the toolbar graphic.

<table>
<thead>
<tr>
<th>Spacing</th>
<th>Using the Layout menu</th>
<th>Toolbar graphic</th>
</tr>
</thead>
<tbody>
<tr>
<td>Space objects evenly across.</td>
<td>Select Space Evenly &gt; Across</td>
<td></td>
</tr>
<tr>
<td>Space objects evenly down.</td>
<td>Select Space Evenly &gt; Down</td>
<td></td>
</tr>
</tbody>
</table>

Making objects the same size
You can easily resize objects so they are the same size. Set objects to the same width, height or both.

To make objects the same size:
1. Hold down your Ctrl key and select the objects you want to resize. Multiple objects must be selected to activate the following resizing options.
2. Select from the following resizing options. You can resize objects by selecting the resizing option from the Layout menu, or by clicking the toolbar graphic. Objects will be resized according to the size of the first object you selected.
Make objects the same width. 
Select **Make Same Size > Width**

Make objects the same height. 
Select **Make Same Size > Height**

Make objects the same width and height. 
Select **Make Same Size > Both**

If **Keep original aspect ratio** is selected for any of the selected objects, the objects may not be resized the way you intended.

See also: [Specifying an object's position and size](#)

**Layering Objects**

You can layer objects within your title. The layering affects how the objects will appear to your users, and if objects are overlapping, will determine which object is in the forefront and which object is in the background. The layering of objects is determined by the order of your objects as they are listed in the left-hand pane. When you select any of the layering options for an object, the object's position will be changed accordingly in the left-hand pane.

The example on the right shows three images layered on a page. Notice the order of the objects in the left-hand pane. The top-most object listed in the left-hand pane is on the bottom layer of the page, while the bottom-most object listed in the left-hand pane is on the top layer.

To alter the layering of your objects:

1. Select the object you want to layer differently.
2. Right-click on the the object, select **Layering**, and select the appropriate layering option. Choose from the following options:

   **Bring to Front**
   Places the object on the top layer.

   **Send to Back**
   Places the object on the bottom layer.

   **Up one layer**
   Moves the object one layer closer to the top.

   **Down one layer**
   Moves the object one layer closer to the bottom.

You can also force an object to the top layer.

See also: [Placing an object on the top layer](#)

**Working with Library Objects**

Lectora makes it easy for you to organize various objects in one location for reuse. A Library folder is provided in which to save these objects and easily share them with others. The default location of the Library folder is `C:\Program Files\Trivantis\Lectora\Library`. This location can be changed and kept on a shared network drive.

A library object can be a single object or a set of objects. It can also be an entire chapter, section or page. Library objects are saved with a `.awo` extension and can contain as few or as many Lectora objects as you want.
Follow these steps to create a Library Object:
1. Select the object you want to save as a Library object. Hold down your Ctrl key to select multiple objects.

2. Do one of the following:
   - Right-click in your work area and select Save as Library Object.
   - From the Tools menu, select Library Object > Save current selection as Library Object.

   The Save As window appears.

3. Name the object and click Save. The object is saved as a Lectora Library Object with the extension of .awo.

Follow these steps to insert a Library Object:
1. Select the location in the left-hand pane to which you want to add a library object.

2. From the Tools menu, select Library Object > Insert Library Object from File. The Open window opens.

3. Select the Library Object you want to insert and click Open.

**Working with the Media Library Organizer**

You can use the Media Organizer to find and share digital media files that are on your computer or shared among team members on a network folder. The Media Organizer makes it easy to find the media you are looking for by organizing the files into categories. You can add and remove categories and media as your media library grows.

The Media Library contains three top-level categories: Images, Flash, and My Media. The Images category contains clipart installed with Lectora. The Flash category contains configurable Flash animations installed with Lectora. The My Media category is used for custom media you add and share with your team members.

Before working with the Media Organizer, you should specify the location of your Media Library. By default, this location is set to your Lectora ClipArt folder (C:\Program Files\Trivantis\Lectora\ClipArt), however it can be changed to a shared folder or a folder on a network drive.

*See also:*
  - Specifying the location of your media library
  - Adding a Flash animation

Using the Media Organizer, you can complete the following tasks:
- Search for media
- Add a custom media category
- Rename a custom media category
- Delete a custom media category
- Add media to your media library
- Delete media from your media library
- Specify custom media properties

**Searching for media**

Using the Media Library Organizer, you can search for media by navigating the pre-defined categories or by searching by keyword.

To search for media within your Media Library:
1. From the Tools menu, select Media Library Organizer.

2. Search for your media in the following ways:
Navigate the categories by expanding and collapsing the plus [+] and minus [-] signs before the category names. Previews of the media are displayed in the scrollable window on the right side of the Media Organizer.

Use the media type check boxes located above the preview window to manage the previews. For example, select the All check box to display media of all types in the preview window or select specific media types to preview only media of that type, if available. Clear the check boxes to remove media of that type from the preview window. For External HTML, use the Ext HTML list to preview the following Web-based media types, if available:
- All External HTML
- Text-based HTML
- Java archive files
- Java class files
- Shockwave files
- Cascading style sheets
- XML files

Use the Keyword Search field to search for media by keyword. Type the keyword you want to search in the field and click the Search button. Results are displayed in the preview window.

Adding a custom media category
You can add custom categories to better organize your Media Library.

To add a custom media category:
1. From the Tools menu, select Media Library Organizer.
2. Select My Media in the Category Search box. The buttons on the left are enabled.
3. Use the plus and minus signs before the category names to expand and collapse the My Media categories. Navigate and select the location to which you want to add a category.
4. Click the Add Category button or right-click and select Add Category.
5. Type the name of the category.

If the category is not in the correct location in the category tree, select it and drag it to a new location in the tree.

You can now add media to the new custom category.

See also: Adding media to your media library

When you create custom media categories, you are actually creating new folders within the location of your media library. The folder structure you see for the location of your media library within Windows Explorer should be the same as the category structure you see within Lectora’s Media Library Organizer.

Renaming a custom media category
You can rename custom categories within your Media Library Organizer. Predefined categories cannot be renamed.

To add a custom media category:
1. From the Tools menu, select Media Library Organizer.
2. Select My Media in the Category Search box. The buttons on the left are enabled.
3. Use the plus and minus signs before the category names to expand and collapse the My Media categories. Navigate and select the category you want to rename.
4. Click the **Rename Category** button or right-click the category and select **Rename Category**.

5. Type the new name for the category.

**Deleting a custom media category**
You can delete custom categories within your Media Library Organizer. Predefined categories cannot be deleted.

To delete a custom media category:
1. From the **Tools** menu, select **Media Library Organizer**.
2. Select **My Media** in the Category Search box. The buttons on the left are enabled.
3. Use the plus and minus signs before the category names to expand and collapse the **My Media** categories. Navigate and select the category you want to delete.

   Deleting a category containing media objects will remove the folder and the media objects contained in the folder, from the media library.

4. Click the **Delete Category** button or right-click and select **Delete Category**.
5. Select **Yes** to accept the warning prompt. The custom category is deleted.

**Adding media to your media library**
You can add media to custom categories within your Media Library Organizer. Media cannot be added to predefined categories.

To add media:
1. From the **Tools** menu, select **Media Library Organizer**.
2. Select **My Media** in the Category Search box. The buttons on the left are enabled.
3. Use the plus and minus signs before the category names to expand and collapse the **My Media** categories. Navigate and select the category to which you want to add media.
4. Click the **Add Media** button or right-click and select **Add Media**. The Add Media to Library window opens.
5. Navigate and select the media file you want to add. Click **Open**. The media file is added to your library and will appear within the preview window.

   You can also add media and complete media categories to your media library by dragging and dropping media or folders from a Windows Explorer window into the Media Library Organizer.

**Deleting media from your media library**
You can delete media from custom categories within your Media Library Organizer. Media cannot be deleted from Predefined categories.

To delete media:
1. From the **Tools** menu, select **Media Library Organizer**.
2. Select **My Media** in the Category Search box. The buttons on the left are enabled.
3. Use the plus and minus signs before the category names to expand and collapse the **My Media** categories. Navigate and select the category containing the media you want to delete.
4. Within the preview window, select the media you want to delete. To select multiple objects, hold down the Ctrl key. Click the Delete Media button or right-click and select Delete Media. The media is deleted and no longer appears within the preview window.

Specifying custom media properties
Once you have added custom media to your Media Library, you can specify the following within the media's Properties window:

**General tab**
- Add a description of the media
- Enter keywords for the media

**Metadata tab**
- Include metadata for media

Adding a description of the media
You can add a short description to the custom media within your Media Library.

To add a description of the media:
1. Select the media within your media library to which you want to add a description.
2. Click the Properties button or right-click and select Properties. The Media Properties window opens. Click the General tab if the Media Properties window is not already opened to this tab.
3. Type the description for the media in the Description field.
4. Click OK.

Entering keywords for the media
You can specify keywords for your media. Keywords are words that will be searched within the Keyword Search field of the Media Library Organizer.

To enter keywords the media:
1. Select the media within your media library to which you want to add keywords.
2. Click the Properties button or right-click and select Properties. The Media Properties window opens. Click the General tab if the Media Properties window is not already opened to this tab.
3. Type the keywords for the media in the Keyword(s) field. Separate keywords with commas.
4. Click OK.

Including metadata for media
Metadata is data about data. It typically includes information such as a description of the object, the author, the date it was created, and so on. Search engines look within metadata for relevant information to the term that was searched. Within Lectora objects, the metadata will be published as standard XML metadata into the accompanying imsmanifest.xml file for any AICC, SCORM, or CourseMill published titles. Metadata added to objects within a title that is published strictly to HTML will be written directly to the resulting HTML pages containing the objects. The metadata can be specified as custom metadata or as name/value pairs using predefined IMS Metadata Data Elements following the IEEE LTSC LOM standard.

Metadata added to media within your Media Library will be carried over when the media object is added to a title.

See also: Including metadata for an object

To include metadata for media:
1. Select the media within your media library to which you want to add metadata.
2. Click the Properties button or right-click and select Properties. The (Media) Properties window opens. Click the Metadata tab.

3. Select the Use Metadata check box and specify the following information:

   - **Custom Metadata**: Select this to display the Custom Metadata text field for you to directly enter custom metadata.
   - **IMS Metadata Data Elements (IEEE LTSC LOM)**: Select this to display a pre-populated list of name value pairs for all the SCORM 1.2 required IMS Metadata data elements. Click the Add button to open the Metadata Data Element Entry window. Select a predefined data element from the Name combo box and specify a data element value from the Value edit/combo box. Select OK to accept the data element. Select from previously entered data elements from the Name/Value lists and click Edit or Remove to edit or remove the selected element.

   - Publish this object’s metadata is checked by default so that the metadata is included in the published title. Uncheck this option if you do not want the metadata included in the published title.

4. Click OK.

**Tests, Surveys and Questions**

You can add tests and surveys containing a number of different question types to your title.

In this chapter, the following topics are covered:

- Adding Tests
- Common Test and Survey Properties
- Adding Questions
- Specifying Question Properties
- Adding Surveys
- Adding Survey Questions
- Specifying Survey Question Properties

**Adding Tests**

Use Lectora to easily create interactive tests containing various question types. You can process results and submit them to learning management systems, eMail addresses or custom databases.

In this chapter, the following topics are covered:

- About Tests and Questions
- Creating a Test
- Adding Sections to a Test
- Working with Test Results

**About tests**

Tests are special kinds of chapters in Lectora. They are special in that when they contain questions, Lectora will be able to grade them. Tests can contain test sections and pages. Test sections, similar to the section object, are a means of organizing pages within the test. The pages are the physical pages that your users will see, and will contain the questions that comprise the test.

See also: Understanding the Book Metaphor
Creating a test

Creating a test is similar to creating a chapter. When added to your title, a test is displayed in the left-hand pane as a new chapter following the currently selected chapter. A Page 1 and a Last test page will be added by default to the test. Additional pages can be inserted, and questions can then be added to the pages of the test.

Follow these steps to create a test:

1. In the left-hand pane, select the page after which you want the test to appear and do one of the following:
   - From the Add menu, select Test
   - Click the Add Test toolbar graphic on the Insert toolbar
   - Right-click and select New > Test
   - Type Ctrl+6

   The Test Properties window opens.

2. Use the tabs on the Test Properties window to complete these tasks:

   **General tab**
   - Change the name of a test
   - Change a test's page size and alignment
   - Remove a test from the table of contents
   - Enable author control for a test
   - Add standard navigation to a test
   - Add automatic page numbering to a test

   **Background tab**
   - Change a test's background properties
   - Change a test's text properties

   **Inherit tab**
   - Specify a test's inheritance properties

   **Content tab**
   - Set a test's content properties

   **Results tab**
   - Set test result properties

   **Response tab**
   - Set CGI response properties

   **When Completed/Passed tab**
   - Set the resulting action when a test is passed

   **When Canceled/Failed tab**
   - Set the resulting action when a test is failed

   **Transition tab**
   - Set a test's transition properties

   When you have finished specifying test properties, click OK to create the test. You can then divide your test into test sections or begin adding questions to test pages.

   See also:
   - Adding sections to a test
   - Adding Questions

   **Setting a test's content properties**
   You can specify the test content properties, such as whether students must answer all questions and whether this is a timed test.

   To set a test's content properties:
   1. Double-click the test graphic of the test you want to change in the left-hand pane. The Test Properties window opens. Click the Content tab.
   2. Complete the controls on this tab as follows:
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show per question feedback from each question</td>
<td>Select this to enable the return of feedback on a per-question basis for all questions in the test. If this option is selected, the question feedback for each question will be displayed to the user.</td>
</tr>
<tr>
<td>Ensure that student answers all questions on the test</td>
<td>When enabled, users will not be able to navigate off of the current page, if they have not answered the question(s) on that page.</td>
</tr>
<tr>
<td>Retain answers to all questions between sessions</td>
<td>Select this to enable Lectora to retain the question answers after the Lectora session is closed. If the student returns to the test in a future session, the questions will retain any answers that were previously supplied.</td>
</tr>
<tr>
<td>Timed test</td>
<td>Select this to set a maximum time limit for the test. Use the <strong>Time allowed</strong> field to specify the maximum time in minutes. When the time limit expires, the test will be submitted. All unanswered questions are considered incorrect.</td>
</tr>
<tr>
<td>Random selection of pages</td>
<td>Select this to randomize the selection of pages within the test. Specify the number of pages to use within the test. The student will be presented with the specified number of randomly chosen pages from all the pages in the test.</td>
</tr>
</tbody>
</table>

This option is not initially available. Access the test properties after you have created pages within the test to set this option.

When standard navigation is added to a test, the **Done** button that is added to the last page of the test is programmed with the **Submit/Process Test/Survey** action. This action is necessary at the end of the test so the results will be submitted and the appropriate completion action is taken. If you add your own custom navigation to the test, the button on the last page of the test that navigates users out of the test must have this action.

If you later randomize your test, the **Done** button should be removed and replaced with the same button used to navigate forward within the test.

**See also:** Adding standard navigation to a test/survey

3. Click **OK**.

**Setting test result properties**

You can specify the options pertaining to test results, such as showing test results to the user after the end of the test and whether to grade the test.

To set test result properties:

1. Double-click the test graphic of the test you want to change in the left-hand pane. The Test Properties window opens. Click the **Results** tab.

2. Complete the controls on this tab as follows:

   **Show test results to student after end of test**

   Select this option to display the test results to the user upon completing the test. Lectora will display each question, along with the user’s answer, indicating if it was correct or incorrect. If the answer was incorrect, the correct answer is displayed. Select **Customized Test Results** if you want to create a test results page that will enable you to choose the information to be included in the test results.
It is not recommended to use Customized Test Results if your test consists of a large number of questions. Since the test results are dynamically generated based on the questions within your test, a larger number of questions results in a longer time needed to generate the test results page.

**See also:** Setting test results content properties

### Grade the test

Select this option to have Lectora compute a percentage score for the test upon completion. With Grade the test enabled, use the Lowest Passing Score field to specify the passing percentage score (out of 100%). This value is also used to determine whether the When Completed/Passed or When Canceled/Failed action is executed upon completion of the test.

If you have included either essay or short answer questions in your test, the test cannot be scored unless all essay and short answer questions have a weight of 0.

**See also:** Specifying Question Properties

### Include test score in overall score*

For AICC/SCORM content titles, enable this to specify whether the score of this test is to be included in the overall score of the course.

This option is only available when the title has been specified as a AICC/SCORM title.

**See also:** Specifying the type of title

### Results Submission

Use this section to specify whether test results are to be submitted using email or a CGI program. If the title resides within a learning management system (LMS), results are automatically submitted to the LMS, and no additional information is needed here. If you do not have a LMS or to submit results to an email address or CGI program in addition to the LMS, select Email Results of Test or Submit Test to CGI program.

#### Email Results of Test

Select this to enable the test results to be emailed to the email address specified in the Email To field. (Separate multiple email addresses with a semicolon.) The use of this feature requires that each user have an email client, such as Microsoft Outlook, on the computer from which they are accessing the published title. In addition, the email server must be configured to accept communications from the published title's location, so results can be successfully submitted. Specify the subject line in Email Subject Line. The default is Test Results.

To submit the emailed results in XML format, select Submit in XML format.

#### Submit Test to CGI program

Select this to submit the test results to the CGI application specified in the Submit results to field. Use the Method list to select whether the submission is done using a POST or GET.

The GET method can only support the submission of 256 characters of data. If you have a large test or are submitting a large amount of variable data, use the POST method instead.

**See also:** Submitting Test, Survey and Form Results to CGI
If this options is selected, the controls within the **Response** tab of the Test Properties window are enabled.

**See also:** Setting CGI test/survey response properties

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prompt the student for their name to identify the test</td>
<td>If enabled, users are prompted at the beginning of the test to enter their name. The user's name is submitted with the test results data.</td>
</tr>
<tr>
<td>Include all variable values in submission</td>
<td>If enabled, all defined Lectora variables will be included with the test results data that is submitted. The name of each variable and its value at the time of submission is sent.</td>
</tr>
<tr>
<td>Show the student a success dialog if submission is successful</td>
<td>If enabled, a success message will be presented to the user upon successful submission of the test results.</td>
</tr>
</tbody>
</table>

3. Click **OK**.

**Setting the resulting action when a test is passed**
You can specify the action to take when the test is completed or completed with a passing score if the test is being graded. The passing score is specified in the **Results** tab of your test's properties.

**See also:** Setting test result properties

To set the resulting action when a user completes or passes a test:
1. Double-click the test graphic 🗒️ of the test you want to change in the left-hand pane. The Test Properties window opens. Click the **When Completed/Passed** tab.
2. The only **Action** available is **Go To**. Select the appropriate **Target** from the list.

**See also:** Selecting an action

3. Click **OK**.

**Setting the resulting action when a test is failed**
You can specify the action to take when the test is canceled or completed with a failing score if the test is being graded. The passing score is specified in the **Results** tab of your test's properties.

**See also:** Setting test result properties

To set the resulting action when a user cancels or fails a test:
1. Double-click the test graphic 🗒️ of the test you want to change in the left-hand pane. The Test Properties window opens. Click the **When Canceled/Failed** tab.
2. The only **Action** available is **Go To**. Select the appropriate **Target** from the list.

**See also:** Selecting an action

3. Click **OK**.

**Adding sections to a test**
Test sections can be used to organize the pages in a test. Unlike regular chapter sections, test sections cannot contain subsections, and can only contain pages. Test sections can be configured to randomly present a specified number of pages within the section, and individual test section scores can be presented to the user.
Follow these steps to create a test section:

1. In the left-hand pane, select the test to which you want to add a new section and do one of the following:
   - From the Add menu, select Test Section
   - Click the Add Test Section toolbar graphic on the Insert toolbar
   - Right-click and select New > Test Section
   - Type Ctrl+7

   The Test Section appears within the test in the left-hand pane.

2. Configure the test section properties. Double-click the test section graphic of the test section you want to change in the left-hand pane. The Test Section Properties window opens.

3. Use the tabs on the Test Section Properties window to complete these tasks:

   **General tab**
   - Change the name of a test section
   - Change a test section's page size and alignment
   - Remove a test section from the table of contents
   - Enable author control for a test section

   **Inherit tab**
   - Change a test section's inheritance properties

   **Section Content tab**
   - Set a test section's content properties

   **Transition tab**
   - Set a test section's transition properties

When you have completed configuring test section properties, click the OK button to apply your changes. You can now begin adding questions to populate the test.

See also: Adding Questions

### Changing the name of a test section

To change the name of a test section:

1. Double-click the test section graphic of the test section you want to change in the left-hand pane. The Test Section Properties window opens. Click the General tab if the Test Section Properties window is not already opened to this tab.

2. In the Test Section Name field, specify the new name as you want it to appear in the left-hand pane. Lectora will create a variable using the test name and test section name to store the user's test section score. For example, if the test name is Lab Safety Test, and the test section name is Equipement Safety, the test section score variable will be named Lab_Safety_Test_Equipment_Safety_Score.

3. Click OK.

### Changing a test section's page size and alignment

The page size and alignment of your test section are inherited from the test properties by default. Changes applied to the page size and alignment within your test section's properties will only be applied to the pages contained within the test section. Consideration should be made for your intended users, and the width of the page size should match the most common resolution of users' monitors. The alignment will determine how the content is displayed within the user's browser window for any Web-based, published content.

To change the page size of your test section:

1. Double-click the test section graphic of the test section you want to change in the left-hand pane. The Test Section Properties window opens. Click the General tab if the Test Section Properties window is not already opened to this tab.
2. In the **Page Size in Screen Pixels** box, clear the **Use Default** check box to specify the **Width** and **Height** of the test section's pages. If **Use Default** is selected, the page size you specified in the test properties will apply.

3. Choose the **Page Alignment for HTML Publishing** from the list. The **Default** page alignment is inherited from the test properties.

4. Click **OK**.

**Removing a test section from the table of contents**

A Table of Contents in Lectora is a menu system that is automatically populated with the chapters, sections and pages within your title. Users can use the Table of Contents to navigate to the different areas of your title. By default, all chapters, sections, and pages are included in a Table of Contents, however you can specify not to include individual chapters, sections or pages. When you remove a test section from the Table of Contents, neither the test section nor any of the pages within the test section will appear within the Table of Contents. Users will not be able to navigate to the test section using the Table of Contents. This setting also affects the Table of Contents progress bar.

**See also:**
- Working with Tables of Contents
- Working with Progress Bars

To remove a test section from the Table of Contents:

1. Double-click the test section graphic of the test section you want to change in the left-hand pane. The Test Section Properties window opens. Click the **General** tab if the Test Section Properties window is not already opened to this tab.

2. Clear the **Include in Table of Contents** check box.

3. Click **OK**.

**Enabling author control for a test section**

You can protect the contents of a test section by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the contents of the test section unless they have the master Author Control password. This includes all pages within the test section and all objects on those pages. The master Author Control password must first be set within the Title Properties.

**See also:**
- Protecting your title with a password

To enable Author Control for a test section:

1. Double-click the test section graphic of the test section you want to change in the left-hand pane. The Test Section Properties window opens. Click the **General** tab if the Test Section Properties window is not already opened to this tab.

2. Select the **Author Control** check box.

3. Click **OK**.

**Changing a test section's background properties**

The default background color, the default background image, and the default background sound are inherited from the test properties by default. Changes applied to the background color, image, or sound within your test section's properties will only be applied to the pages contained within the test section.

To change these background properties:

1. Double-click the test section graphic of the test section you want to change in the left-hand pane. The Test Section Properties window opens. Click the **Background** tab.
2. Specify the following background information:

**Default Background Color**

The default background color inherited from the test properties is specified. Use the list to select a new default background color for the pages within your test section. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

*See also:* [Matching Colors Used within Your Title](#)

If you choose a background image, you will not be able to see your background color.

**Default Background Image**

The default background image inherited from the test properties is specified. To use a new background image for the pages of your test section, select a previously imported image from the list or click on the **Import** button to navigate and select the image. You can also click on the arrow within the **Import** button to choose from the following:

- **From File** Select this to navigate and select an image.
- **Media Library** Select this to launch your media library to select an image.

*See also:* [Working with the Media Library Organizer](#)

If you use a background image that is smaller than your page size, Lectora will automatically tile that image across and down your page; however, the browser will cache the image and only load the image one time. This is a much more efficient manner of creating a background as opposed to one large background image that will have a much longer load time.

If you choose a background image, the background color will not be visible, unless the image is somewhere transparent.

**Default Background Sound**

The default background sound inherited from the test properties is specified. To use a new background sound for the pages of your test section, select a previously imported audio file from the list or click on the **Import** button to navigate and select the audio file. You can also click on the arrow within the **Import** button to choose from the following:

- **From File** Select this to navigate and select an audio file.
- **Media Library** Select this to launch your media library to select an audio file.

*See also:* [Working with the Media Library Organizer](#)

A background sound will play continuously throughout the test section. The sound will continue playing as users navigate throughout the test section, and will repeat.

3. Click **OK**.

**Changing a test section's text properties**

The default text style and link color are inherited from the test properties by default. Changes applied to the default text style and default link color within your test section's properties will only be applied to the pages contained within the test section.

To change these text properties:
1. Double-click the test section graphic of the test section you want to change in the left-hand pane. The Test Section Properties window opens. Click the **Background** tab.

2. Specify the following text information:

   **Default Text Style**
   The default text style inherited from the test properties is specified. Use the list to select a new default text style to be used within your test section. Text blocks created within your test section will be automatically formatted to the selected style. To create a new text style, click on the **Styles** button.

   *See also: [Managing text styles](#)*

   ![Flag] Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

   **Default Link Color**
   The default link color inherited from the test properties is specified. Use the list to select the color to be used for all hyperlinks within your test section. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

   *See also: [Matching Colors Used within Your Title](#)*

   Textual hyperlinks are underlined and displayed in the selected color.

3. Click **OK**.

### Specifying a test section's inheritance properties

With Lectora’s inheritance capabilities, objects you add directly to a test will appear on every page in that test including pages that are inside of a test section within the test. Objects added directly to a test section will appear on every page in that section and objects added directly to a page will appear only on that page.

*See also: [Understanding Inheritance](#)*

The inherit tab is available within all test, test section and page properties. If the object is excluded within the properties of a test, it will not appear on any page within that test. If the object is excluded within the properties of a test section, it will not appear on any page within that test section, and if the object is excluded within the properties of a page, then the object will be excluded from that page.

To specify a test section's inheritance properties:

1. Double-click the test section graphic of the test section you want to change in the left-hand pane. The Test Section Properties window opens. Click the **Inherit** tab.

2. Select from one of the following inheritance options:
   - Inherit all objects from parent
   - Inherit no objects from parent
   - Exclude inheritance of certain objects

   **Inherit all objects from parent** will place all objects within the **Inherited** list. These objects will continue to appear throughout your test section. **Inherit no objects from parent** will place all objects within the **Excluded** list. These objects will not appear on any pages within your test section.

   Select **Exclude inheritance of certain objects** to move objects from one list to the other. Select an object in either list
and click the arrow buttons to move items from one list to the other in the direction of the buttons.

You can select several objects by holding down the **Ctrl** key while selecting multiple objects.

3. Click **OK**.

**Setting a test section’s content properties**

You can specify whether to randomly select pages from the test section for each user.

To set a test’s content properties:

1. Double-click the test section graphic of the test section you want to change in the left-hand pane. The Test Section Properties window opens. Click the **Section Content** tab.

2. Select the **Random selection of pages** check box to randomize the selection of pages within the test section. Specify the number of pages to use within the test section. The student will be presented with the specified number of randomly-chosen pages from all the pages in the test section.

When standard navigation is added to a test, the **Done** button that is added to the last page of the test is programmed with the **Submit/Process Test/Survey** action. This action is necessary at the end of the test so the results will be submitted and the appropriate completion action is taken. If you add your own custom navigation to the test, the button on the last page of the test that navigates users out of the test must have this action.

If you later randomize your test sections, and the last page of the test is included in a randomized test section, the **Done** button should be removed and replaced with the same button used to navigate forward within the test.

*See also:* [Adding standard navigation to a test/survey](#)

3. Click **OK**.

**Setting a test section’s transition properties**

The transition type is inherited from the test properties by default. Changes applied to the transition type within your test section’s properties will only be applied to the pages contained within the test section. Transitions will produce a special effect as users navigate from one page to another. You can select from over 20 different transitions. There is a **Slow to Fast** slider to determine the speed at which the transition takes place.

To set your test section's transitions:

1. Double-click the test section graphic of the test section you want to change in the left-hand pane. The Test Section Properties window opens. Click the **Transitions** tab.

2. Select a transition from the **Transition Type** list, and adjust the **Slow/Fast** slider accordingly.

3. Click **OK**.

Transitions are not recommended for titles published to the Web. This is because an entire page needs to load before the transition occurs and a result, buttons and hyperlinks are disabled until the transition is complete.

**Working with test results**

If the **Show test results to student after end of test** and **Customized Test Results** check boxes are enabled on the **Results** tab of the Test properties, a Test Results page appears within the test in the left-hand pane. Similar to other pages in your
Complete these tasks using the controls on the Test Results Properties window:

- **General tab**
  - Change the name of a test results page
  - Change a test results page's size and alignment
  - Enable author control for a test results page

- **Inherit tab**
  - Specify a test results page's inheritance properties

- **Background tab**
  - Change a test results page's background properties
  - Change a test results page's text properties

- **Results Content tab**
  - Set test results content properties

- **Transitions tab**
  - Set a test results page's transition properties

### Changing the name of a test results page
To change the name of your test results page:
1. Double-click the test results graphic of the test results page you want to change in the left-hand pane. The Test Results Properties window opens. Click the **General** tab if the Test Results Properties window is not already opened to this tab.
2. In the **Page Name** field, specify the name of your page as you want it to appear in the left-hand pane.
3. Click **OK**.

### Changing a test result page's size and alignment
Lectora will automatically generate the test results page size based on the number of test results that need to be displayed. However, you can directly specify the size of your test results page. The page alignment will determine how the content is displayed within the user's browser window for any Web-based, published content.

To change your test results page size:
1. Double-click the test results graphic of the test results page you want to change in the left-hand pane. The Test Results Properties window opens. Click the **General** tab if the Test Results Properties window is not already opened to this tab.
2. Select **Use Default** to inherit the page size used within the Test Properties. Otherwise, specify the new page dimensions in the **Width** and **Height** fields.
3. Choose the **Page Alignment for HTML Publishing** from the list. The **Default** page alignment is inherited from the test properties.
4. Click **OK**.

### Enabling author control for a test results page
You can protect the contents of a test results page by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the contents of the page unless they have the master Author Control password. This includes all objects on the test results page. The master Author Control password must first be set within the Title Properties.

See also: **Protecting your title with a password**

To enable Author Control for a test results page:
1. Double-click the test results graphic of the test results page you want to change in the left-hand pane. The Test Results Properties window opens. Click the **General** tab if the Test Results Properties window is not already opened to...
2. Check the **Author Control** check box.

3. Click **OK**.

### Changing a test results page's background properties

The default background color, the default background image, and the default background sound are inherited from the test properties by default. Changes applied to the background color, image, or sound within your page's properties will only be applied to the test results page.

To change these background properties:

1. Double-click the test results graphic of the test results page you want to change in the left-hand pane. The Test Results Properties window opens. Click the **Background** tab.

2. Specify the following background information:

#### Default Background Color

The default background color inherited from the test properties is specified. Use the list to select a new default background color for your test results page. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

**See also:** [Matching Colors Used within Your Title](#)

If you choose a background image, you will not be able to see your background color.

#### Default Background Image

The default background image inherited from the test properties is specified. To use a new background image for your test results page, select a previously imported image from the list or click the **Import** button to navigate and select an image. You can also click on the arrow within the **Import** button to choose from the following:

- **From File** Select this to navigate and select an image.
- **Media Library** Select this to launch your media library to select an image.

**See also:** [Working with the Media Library Organizer](#)

You can also use the **Background Wizard** to create a background for your test results page.

If you use a background image that is smaller than your page size, Lectora will automatically tile that image across and down your page; however, the browser will cache the image and only load the image one time. This is a much more efficient manner of creating a background as opposed to one large background image that will have a much longer load time.

If you choose a background image, the background color will not be visible, unless the image is somewhere transparent.

#### Default Background Sound

The default background sound inherited from the test properties is specified. To use a new background sound for your test results page, select a previously imported sound file from the list or click the **Import** button to navigate and select a sound file. You can also click on the arrow within the **Import** button to choose from the following:
From File  Select this to navigate and select an audio file.
Media Library  Select this to launch your media library to select an audio file.

See also:  Working with the Media Library Organizer

A background sound will play continuously on the test results page. The sound will continue playing while the user is on the page, and will repeat.

3. Click OK.

Changing a test results page's text properties
The default text style and link color are inherited from the test properties by default. Changes applied to the default text style and default link color within your page's properties will only be applied to the test results page.

To change these text properties:
1. Double-click the test results graphic of the test results page you want to change in the left-hand pane. The Test Results Properties window opens. Click the Background tab.

2. Specify the following text information:

   **Default Text Style**  The default text style inherited from the test properties is specified. Use the list to select a new default text style to be used on your test results page. Text blocks created on your page will be automatically formatted to the selected style. To create a new text style, click on the Styles button.

   See also:  Managing text styles

   Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

   **Default Link Color**  The default link color inherited from the test properties is specified. Use the list to select the color to be used for all hyperlinks on your test results page. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

   See also:  Matching Colors Used within Your Title

   Textual hyperlinks are underlined and displayed in the selected color.

3. Click OK.

Specifying a test results page’s inheritance properties
With Lectora’s inheritance capabilities, objects you add directly to a test will appear on every page in that test including pages that are inside of a test section within the test. Objects added directly to a test section will appear on every page in that section and objects added directly to a page will appear only on that page.

See also:  Understanding Inheritance
The inherit tab is available within all test, test section and page properties. If the object is excluded within the properties of a test, it will not appear on any page within that test. If the object is excluded within the properties of a test section, it will not appear on any page within that test section, and if the object is excluded within the properties of a page, then the object will be excluded from that page.

By default, all objects are excluded from a test results page.

To specify a test result page's inheritance properties:
1. Double-click the test results graphic of the test results page you want to change in the left-hand pane. The Test Results Properties window opens. Click the Inherit tab.
2. Select from one of the following inheritance options:
   - Inherit all objects from parent
   - Inherit no objects from parent
   - Exclude inheritance of certain objects

   **Inherit all objects from parent** will place all objects within the Inherited list. These objects are inherited from your test and will appear on the test results page. **Inherit no objects from parent** will place all objects within the Excluded list. These objects will not appear on the test results page.

   Select **Exclude inheritance of certain objects** to move objects from one list to the other. Select an object in either list and click the arrow buttons to move items from one list to the other in the direction of the buttons.

   You can select several objects by holding down the Ctrl key while selecting multiple objects.

3. Click OK.

**Setting test results content properties**
You can specify properties relating to the content of your test results, such as whether to open the results in a pop-up window, show the test score, and show questions answered both correctly and incorrectly. The information you choose to display will be displayed for all questions in the test.

The test results page content is generated dynamically based on the questions within your test and the test results content properties specified. When you add a new question to your test, Lectora will subsequently add the corresponding test results information to your test results page.

To set test results content properties:
1. Double-click the test results graphic of the test results page you want to change in the left-hand pane. The Test Results Properties window opens. Click the Results Content tab.
2. Complete the controls as follows:
   - **Open in Popup Window**: Select this to launch the test results in a new window.
   - **Show Test Score**: Select this to display the overall test score on the test results page.
   - **Show Pass/Fail Status**: Select this to display whether or not the score is passing or failing, based upon the **Lowest Passing Score** specified within the test properties.
   - **Show Correct Questions**: Select this to display the question if the user answered correctly.

   **See also**: Setting test result properties
Show Incorrect Questions  
Select this to display the question if the user answered incorrectly.

Show Unanswered Questions  
Select this to display questions the user did not answer or skipped.

Include Question Number  
Select this to display the question number.

Include Question Text  
Select this to display the text associated with the question.

Include Student's Answer  
Select this to display the answer provided by the user.

Include Correct Answer  
Select this to display the correct answer to the question.

Make Link Back to the Original Question  
Select this to create a standard question button that will link to the corresponding question page.

3. Click OK.

**Setting a test results page's transition properties**

The transition type is inherited from the test properties by default. Changes applied to the transition type within your page's properties will only be applied to the test results page. Transitions will produce a special effect as users navigate from one page to another. You can select from over 20 different transitions. There is a **Slow to Fast** slider to determine the speed at which the transition takes place.

To set your test results page's transition:

1. Double-click the test results graphic of the test results page you want to change in the left-hand pane. The Test Results Properties window opens. Click the **Transitions** tab.

2. Select a transition from the **Transition Type** list, and adjust the **Slow/Fast** slider accordingly.

3. Click **OK**.

Transitions are not recommended for titles published to the Web. This is because an entire page needs to load before the transition occurs and a result, buttons and hyperlinks are disabled until the transition is complete.

**Common Test and Survey Properties**

Many properties for test and surveys in Lectora are the same. You can access these properties for a test or survey by double-clicking the test or survey graphic in the left-hand pane.

The following can be completed within test and survey properties:

- Change the name of a test/survey
- Change a test/survey's page size and alignment
- Remove a test/survey from the table of contents
- Enable author control for a test/survey
- Add standard navigation to a test/survey
- Add automatic page numbering to a test/survey
- Change a test/survey's background properties
- Change a test/survey's text properties
- Change a test/survey's inheritance properties
- Set CGI test/survey response properties
- Set a test/survey's transition properties
Changing the name of a test/survey

To change the name of a test or survey:

1. Double-click the test or survey graphic of the test or survey you want to change in the left-hand pane. The Test or Survey Properties window opens. Click the General tab if the Properties window is not already opened to this tab.

2. In the Name field, specify the new name as you want it to appear in the left-hand pane. For rest, Lectora will create a variable using the test name to store the user's test score. For example, if the test name is Lab Safety Test, the test score variable will be named Lab_Safety_Test_Score. Surveys are not scored.

3. Click OK.

Changing a test/survey's page size and alignment

The page size and alignment of your test or survey are inherited from the title properties by default. Changes applied to the page size and alignment within your test or survey's properties will only be applied to the pages contained within the test or survey. Consideration should be made for your intended users, and the width of the page size should match the most common resolution of users’ monitors. The alignment will determine how the content is displayed within the user's browser window for any Web-based, published content.

To change the page size of your test or survey:

1. Double-click the test or survey graphic of the test or survey you want to change in the left-hand pane. The Test or Survey Properties window opens. Click the General tab if the Properties window is not already opened to this tab.

2. In the Page Size in Screen Pixels box, clear the Use Default check box to specify the Width and Height of the test or survey's pages. If Use Default is selected, the page size you specified in the title properties will apply.

3. Choose the Page Alignment for HTML Publishing from the list. The Default page alignment is inherited from the title properties.

4. Click OK.

Removing a test/survey from the table of contents

A Table of Contents in Lectora is a menu system that is automatically populated with the chapters, sections and pages within your title. Users can use the Table of Contents to navigate to the different areas of your title. By default, all chapters, sections, and pages are included in a Table of Contents, however you can specify not to include individual chapters, sections or pages. When you remove a test or survey from the Table of Contents, neither the test/survey nor any of the pages within the test/survey will appear within the Table of Contents. Users will not be able to navigate to the test/survey using the Table of Contents. This setting also affects the Table of Contents progress bar.

See also: Working with Tables of Contents
Working with Progress Bars

To remove a test or survey from the Table of Contents:

1. Double-click the test or survey graphic of the test or survey you want to change in the left-hand pane. The Test or Survey Properties window opens. Click the General tab if the Properties window is not already opened to this tab.

2. Clear the Include in Table of Contents check box.

3. Click OK.

Enabling author control for a test/survey

You can protect the contents of a test or survey by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the contents of the test/survey unless they have the master Author Control password. This includes all pages within the test/survey and all objects on those pages. The master Author Control password must first be set within the
Title Properties.

See also: Protecting your title with a password

To enable Author Control for a test or survey:
1. Double-click the test or survey graphic of the test or survey you want to change in the left-hand pane. The Test or Survey Properties window opens. Click the General tab if the Properties window is not already opened to this tab.
2. Check the Author Control check box.
3. Click OK.

Adding standard navigation to a test/survey
You can add standard navigation buttons (Cancel, Back, Next, and Done) to the pages of your test or survey. When you select this option, a first and last test/survey page are also automatically added to your test or survey. You can remove these controls and add your own custom navigation, if desired.

The option to add standard navigation to a test or survey is only available when initially specifying the test/survey properties.

While initially specifying test and survey properties, select the Add standard navigation buttons to the test/survey check box.

The Done button that is added to the test is programmed with the Submit/Process Test/Survey action. This action is necessary at the end of the test so the results will be submitted and the appropriate completion action is taken. If you add your own custom navigation to the test, the button on the last page of the test that navigates users out of the test must have this action.

If you later randomize your test, the Done button should be removed and replaced with the same button used to navigate forward within the test.

See also: Setting a test's content properties

Adding automatic page numbering to a test/survey
You can automatically number the pages within your test or survey. When you select this option, page numbering in the form of Page X of XX will appear on each page of your test or survey.

The option to add automatic page numbering to a test or survey is only available when initially specifying the test/survey properties.

While initially specifying test and survey properties, select the Auto number the pages within the test/survey check box.

Page numbering can later be added to the test by using the Page Numbering Tool.

Changing a test/survey's background properties
The default background color, the default background image, and the default background sound are inherited from the title properties by default. Changes applied to the background color, image, or sound within your test or survey's properties will only be applied to the pages contained within the test or survey.

To change these background properties:
1. Double-click the test or survey graphic of the test or survey you want to change in the left-hand pane. The Test or Survey Properties window opens. Click the **Background** tab.

2. Specify the following background information:

   **Default Background Color**
   - The default background color inherited from the title properties is specified. Use the list to select a new default background color for the pages within your test or survey. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

   *See also:* [Matching Colors Used within Your Title](#)

   If you choose a background image, you will not be able to see your background color.

   **Default Background Image**
   - The default background image inherited from the title properties is specified. To use a new background image for the pages of your test or survey, select a previously imported image from the list or click the **Import** button to navigate and select an image. You can also click on the arrow within the **Import** button to choose from the following:

     - **From File**: Select this to navigate and select an image.
     - **Media Library**: Select this to launch your media library to select an image.

     *See also:* [Working with the Media Library Organizer](#)

   You can also use the **Background Wizard** to create a background for your test or survey.

   If you use a background image that is smaller than your page size, Lectora will automatically tile that image across and down your page; however, the browser will cache the image and only load the image one time. This is a much more efficient manner of creating a background as opposed to one large background image that will have a much longer load time.

   **Default Background Sound**
   - The default background sound inherited from the title properties is specified. To use a new background sound for the pages of your test or survey, select a previously imported sound file from the list or click the **Import** button to navigate and select a sound file. You can also click on the arrow within the **Import** button to choose from the following:

     - **From File**: Select this to navigate and select an audio file.
     - **Media Library**: Select this to launch your media library to select an audio file.

     *See also:* [Working with the Media Library Organizer](#)

   A background sound will play continuously throughout the test or survey. The sound will continue playing as users navigate throughout the test or survey, and will repeat.

3. Click **OK**.

**Changing a test/survey's text properties**
The default text style and link color are inherited from the title properties by default. Changes applied to the default text style and default link color within your test or survey's properties will only be applied to the pages contained within the test or survey.
To change these text properties:

1. Double-click the test or survey graphic of the test or survey you want to change in the left-hand pane. The Test or Survey Properties window opens. Click the **Background** tab.

2. Specify the following text information:

   **Default Text Style**
   - The default text style inherited from the title properties is specified. Use the list to select a new default text style to be used within your test or survey. Text blocks created within your test or survey will be automatically formatted to the selected style. To create a new text style, click on the **Styles** button.

   **See also:** Managing text styles

   - Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

   **Default Link Color**
   - The default link color inherited from the title properties is specified. Use the list to select the color to be used for all hyperlinks within your test or survey. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

   **See also:** Matching Colors Used within Your Title

   - Textual hyperlinks are underlined and displayed in the selected color.

3. Click **OK**.

**Specifying a test/survey's inheritance properties**

With Lectora's inheritance capabilities, objects you add directly to a test or survey will appear on every page in that test/survey including pages that are inside of a test/survey section within a test/survey. Objects added directly to a test/survey section will appear on every page in that section and objects added directly to a page will appear only on that page.

**See also:** Understanding Inheritance

The inherit tab is available within all test, test section, survey and page properties. If the object is excluded within the properties of a test/survey, it will not appear on any page within that test/survey. If the object is excluded within the properties of a test section or a section contained in a survey, it will not appear on any page within that test/survey section, and if the object is excluded within the properties of a page, then the object will be excluded from that page.

By default, all objects are excluded from a test/survey.

To specify a test/survey's inheritance properties:

1. Double-click the test or survey graphic of the test or survey you want to change in the left-hand pane. The Test or Survey Properties window opens. Click the **Inherit** tab.

2. Select from one of the following inheritance options:
   - **Inherit all objects from parent**
   - **Inherit no objects from parent**
   - **Exclude inheritance of certain objects**

   **Inherit all object from parent** will place all objects within the Inherited list. These objects will continue to appear throughout your test or survey. **Inherit no objects from parent** will place all objects within the Excluded list. These
objects will not appear on any pages within your test or survey.

Select **Exclude inheritance of certain objects** to move objects from one list to the other. Select an object in either list and click the arrow buttons to move items from one list to the other in the direction of the buttons.

You can select several objects by holding down the **Ctrl** key while selecting multiple objects.

3. **Click OK.**

**Setting CGI test/survey response properties**
When submitting test or survey data to a CGI program, the CGI program can issue a response. You can specify whether you want to enable Lectora to receive a response from the CGI program. If enabled, the response is received and stored as a text string in the specified Lectora variable.

*See also:* [Submitting Test, Survey and Form Results to CGI](#)

To set CGI test/survey response properties:
1. Double-click the test or survey graphic of the test or survey you want to change in the left-hand pane. The Test or Survey Properties window opens. Click the **Response** tab.

2. Select **Receive response from CGI submission**. Use the **Variable to receive response** drop-down list to select the variable into which you want to store the response. Alternatively, click the **New Variable** button to create a new variable in which to store the CGI response. The response is stored as a text string in the specified variable.

*See also:* [About variables](#)

3. **Click OK.**

**Setting a test/survey's transition properties**
The transition type is inherited from the title properties by default. Changes applied to the transition type within your test or survey's properties will only be applied to the pages contained within the test or survey. Transitions will produce a special effect as users navigate from one page to another. You can select from over 20 different transitions. There is a **Slow to Fast** slider to determine the speed at which the transition takes place.

To set your test/survey's transitions:
1. Double-click the test or survey graphic of the test or survey you want to change in the left-hand pane. The Test or Survey Properties window opens. Click the **Transitions** tab.

2. Select a transition from the **Transition Type** list, and adjust the **Slow/Fast** slider accordingly.

3. **Click OK.**

**Transitions are not recommended for titles published to the Web. This is because an entire page needs to load before the transition occurs and a result, buttons and hyperlinks are disabled until the transition is complete.**

**Adding Questions**
Questions can be added to any page of your title, whether it is inside or outside of a test. Questions on pages contained in a test can issue feedback back to the user, can be scored, and can be organized to be randomly presented to the user. Questions need not be contained in a test; they can be interspersed in the title to provide simple knowledge checks to the user.
Follow these steps to add a question to your title:

1. In the left-hand pane, select the test, test section or page to which you want to add a question and do one of the following:
   - From the Add menu, select Question
   - Click the Add Question toolbar graphic on the Insert toolbar
   - Right-click and select New > Question
   - Type Ctrl+8

   The Question Properties window opens.

2. Complete the controls on the window as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Type</th>
<th>Associated Variable Name</th>
<th>Question Weight</th>
</tr>
</thead>
<tbody>
<tr>
<td>Specify the name by which you will recognize this test question.</td>
<td>Select the question type from the list. Choose from one of the following question types:</td>
<td>Specify the associated variable name for this question. This must be a new unique variable that does not already exist. The variable will be used to store the user's answer to the question. It may be accessed from anywhere in the title.</td>
<td>The question weight is irrelevant if the question is not within a test. Select the weight of the test</td>
</tr>
</tbody>
</table>

   - **True/False**
     A question with one correct answer out of two possibilities.
   - **Multiple Choice**
     A question with one or more possible correct answers and multiple possibilities.
   - **Short Answer**
     A question in which the user supplies a short (typically less than 80 characters) answer. This question type cannot be automatically graded by the testing module and therefore cannot be used in titles within AICC or SCORM learning management systems.
   - **Essay**
     A question in which the user supplies a long (typically more than 80 characters) answer. This question type cannot be automatically graded by the testing module and therefore cannot be used in titles within AICC or SCORM learning management systems.
   - **Fill in the Blank**
     A question in which the user supplies a short answer that is compared to a list of known correct answers.
   - **Matching**
     A question with a column of items on the left-hand side and a column of scrambled items on the right-hand side. The user must match items in the left column with items in the right column to answer the question.
   - **Drag and Drop**
     A question that requires the user to drag source objects such as text or images to defined targets within a larger, work area image.
   - **Hot Spot**
     A question with a visual multiple-choice set used to identify areas of an image; one or more possible correct answers are possible.

   It is best to keep the default naming convention (Question_####) for question variables. Lectora will automatically increment the numeric value in the variable to correspond with the number of questions that have been created within the title.
question. Points are used to calculate the percentage weight of each question and will be factored into the overall test score. The default weight of each question is 1. Therefore, without changing this option, all the questions within a test are of equal value. If points are assigned to each question, Lectora will use the sum of test points to calculate question weight and further, the test score.

Set the **Question Weight** to 0 for any short answer or essay questions that are included in a graded test.

**Example:**
Questions 1 – 4 are 1 point each.
Question 5 is 4 points.
The sum of the test points is 8 points. Therefore, questions 1 – 4 are worth approximately 13% each whereas question 5 has a weight of 50%.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
<th>Question Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create new page for the question</td>
<td>This option will automatically create a new page onto which the question will be added. The new page will be added after the currently selected page. If this option is not selected, the question will be added to the currently selected page.</td>
<td>All</td>
</tr>
<tr>
<td>Retain question answer between sessions</td>
<td>This option causes the question answer to be retained after the Lectora session is closed. When the user returns to this question in a future session, the answer provided previously by the student is retained. If this option is not selected, the question will revert back to its default state of unanswered with every launch of the course.</td>
<td>All</td>
</tr>
<tr>
<td>Author Control</td>
<td>With Author Control enabled, additional authors will not be able to edit the question unless they have the master Author Control password.</td>
<td>All</td>
</tr>
</tbody>
</table>

**See also:**  [Protecting your title with a password](#)

3. Click the **Next** button. The Question window opens.

4. Use this window to define how the question will appear to the user. Define the following properties for the different question types:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
<th>Question Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Question</strong></td>
<td>Specify the text of the question.</td>
<td>All</td>
</tr>
<tr>
<td><strong>Show image with question</strong></td>
<td>Select this to show an image with the question. Selecting this enables the <strong>Image</strong> and <strong>Align image</strong> lists.</td>
<td>All</td>
</tr>
<tr>
<td><strong>Image</strong></td>
<td>Select a previously imported image to display with the question text. For Drag and Drop and Hot Spot questions, use the list or <strong>Import</strong> button to specify the destination image upon which the question’s drag objects or hot spot buttons will be placed. Click the <strong>Import</strong> button to navigate and select the image you want to associate with the question. You can also click on the arrow within the <strong>Import</strong> button to choose from the following:</td>
<td></td>
</tr>
<tr>
<td><strong>Drop image</strong></td>
<td>From File: Select this to navigate and select an image.</td>
<td>All</td>
</tr>
<tr>
<td><strong>Hot Spot image</strong></td>
<td><strong>Media Library</strong>: Select this to launch your media library to select an image.</td>
<td>All</td>
</tr>
</tbody>
</table>

   **See also:**  [Working with the Media Library Organizer](#)

   | **Align image**           | Specify where the image should appear in relation to the question text.     | All           |
5. Click the **Next** button.

You will be presented with one or more additional windows that are based on the type of question you selected. Along with defining the question, you can enable the ability to provide feedback to the user for correct and incorrect answers. The feedback will be presented as the feedback text in a message box or as a specified page in a window. The feedback can be displayed immediately after a user has provided an answer, or to the user upon leaving the page. For additional information, select the type of question you are adding:

- True / False
- Multiple Choice
- Short Answer
- Essay
- Fill in the Blank
- Matching
- Drag and Drop
- Hotspot

6. Complete the fields as directed and click **Finish**.

- If the question is included in a test, the feedback will only appear if the test has the **Show per question feedback** option enabled within the test’s properties.

*See also:* Setting a test's content properties

- If there is more than one question on the page with question feedback, the feedback for all questions on the page will be presented when the user attempts to leave the page (unless immediate feedback is selected).

### Creating a true or false question

Once you have configured the properties within the Question Properties and Question windows, the Results and Feedback window opens.

*See also:* Adding Questions

1. Complete the controls within the Results and Feedback window as necessary:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>True Choice Text</td>
<td>Specify the text for the true choice (for example, I agree or Yes). The default text is True. Select the corresponding Correct radio button if the true choice is correct.</td>
</tr>
<tr>
<td>False Choice Text</td>
<td>Specify the text for the false choice (for example, I disagree or No). The default text is False. Select the corresponding Correct radio button if the false choice is correct.</td>
</tr>
<tr>
<td>Show feedback</td>
<td>Select this to enable the question feedback fields for the two possible responses for this question. The feedback will be presented as the feedback text in a message box or as a specified page in a pop-up window. Feedback is provided immediately or upon leaving the page.</td>
</tr>
</tbody>
</table>

*See also:* Setting a test's content properties

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Immediate feedback</td>
<td>Select this to display feedback immediately to the user upon answering the question.</td>
</tr>
</tbody>
</table>
This field is enabled when you select **Show feedback**.

| **Show page for true choice feedback** | Select this to specify the page for the true choice feedback. This enables the **Feedback page for true choice** list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user. |
| **Feedback message for true choice** | Instead of showing a page to the user, specify the text of the feedback message for the true choice. The text will be presented in a generic message box to the user. |
| **Show page for false choice feedback** | Select this to specify the page for the false choice feedback. This enables the **Feedback page for false choice** list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user. |
| **Feedback for message for false choice** | Instead of showing a page to the user, specify the text of the feedback message for the false choice. The text will be presented in a generic message box to the user. |

2. Click **Finish**.

The true or false question is added to your title.

**Creating a multiple choice question**

Once you have configured the properties within the Question Properties and Question windows, the Choices window opens.

*See also:* [Adding Questions](#)

1. Complete the controls within the Choices window as necessary:

   | **Number of choices** | Specify the number of choices to include in the question. |
   | **Correct answer requires more than one choice** | Select this to create a multiple choice question with multiple answers. All of the designated correct answers must be selected for the question to be considered correct. |
   | **Grade each choice item as a separate question** | This option is only available if the correct answer requires more than one choice. Select this to give the user credit for each selection that he or she correctly identifies; otherwise, the user will be required to select all correct answers to receive credit for answering the question correctly. |
   | **Display question as Drop-Down List / List Box** | Select this to display the choices in a drop-down list (for questions with only one answer) or in a list box (for questions requiring multiple answers). |
   | **Show feedback for multi-choice answer** | The feedback on this screen is valid only if the multiple answer option is used, and will override the individual feedback on the following windows. |

   ![Feedback icon](#)

   If the question is within a test, the test must be set to **Show per question feedback from each question**, in order for the feedback to be displayed to the user.

   *See also:* [Setting a test's content properties](#)

   | **Immediate feedback** | Select this to display feedback immediately to the user upon answering the question. This field is enabled when you select **Show feedback for multi-choice answer**. |
   | **Show page for correct answer feedback** | Select this to specify the page for the correct choice feedback. This enables the **Feedback page for correct choice** list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user. |
   | **Feedback for correct multi-choice answer** | Instead of showing a page to the user, specify the text of the feedback message for the
2. Click the **Next** button. The Choice X of XX window is displayed for each choice. The number of windows that follow is equal to the Number of choices that you defined on the Choices window. (Click the **Back** button if you want to return to that window.)

3. For each choice, complete the controls as follows:

**Choice Text**
Specify the text for this choice.

**Correct Choice**
Select the check box if this choice is correct.

You must select at least one of the choices as being the Correct choice for the question.

**Show image with choice**
Select this to show an image with the choice. Selecting this enables the Image and Align image fields.

**Image**
Select a previously imported image to display with the choice text. Alternatively, click on the Import button to navigate and select the image you want to associate with the choice. You can also click on the arrow within the Import button to choose from the following:

- From File
Select this to navigate and select an image.

- Media Library
Select this to launch your media library to select an image.

See also: [Working with the Media Library Organizer](#)

**Align image**
Specify where the image should appear in relation to the choice text.

**Show feedback**
Select this to enable the question feedback fields for this choice. The feedback will be presented as the feedback text in a message box or as a specified page in a pop-up window. Feedback is provided immediately or upon leaving the page.

If the question is within a test, the test must be set to Show per question feedback from each question, in order for the feedback to be displayed to the user.

See also: [Setting a test's content properties](#)

**Immediate feedback**
Select this to display feedback immediately to the user upon selecting this choice. This field is enabled when you select Show feedback.

**Show page for feedback**
Select this to specify the page for the feedback. This enables the Feedback page list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user.

**Feedback message**
Instead of showing a page to the user, specify the text of the feedback message for this choice. The text will be presented in a generic message box to the user.

**Immediate feedback**
Select this to display feedback immediately to the user upon making this choice. This field is enabled when you select Show feedback.
4. Click **Next** until you have finished configuring each choice and click **Finish**.

The multiple choice question is added to your title.

**Creating a short answer question**

Once you have configured the properties within the Question Properties and Question windows, the Feedback window opens.

See also:  **Adding Questions**

1. Complete the controls within the Feedback window as necessary:

   **Maximum answer text length**
   Specify the maximum length of the text answer in number of characters.

   **Show Feedback**
   Select this to show feedback. The feedback will be presented as the feedback text in a message box or as a specified page in a pop-up window. Feedback is provided immediately or upon leaving the page.

   If the question is within a test, the test must be set to **Show per question feedback from each question**, in order for the feedback to be displayed to the user.

   See also:  **Setting a test's content properties**

   **Immediate feedback**
   Select this to display feedback immediately to the user upon answering the question. This field is enabled when you select **Show feedback**.

   **Show page for feedback**
   Select this to specify the page for the feedback. This enables the Feedback page list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user.

   **Feedback message**
   Instead of showing a page to the user, specify the text of the feedback message. The text will be presented in a generic message box to the user.

2. Click **Finish**.

The short answer question is added to your title.

**Creating an essay question**

Once you have configured the properties within the Question Properties and Question windows, the Feedback window opens.

See also:  **Adding Questions**

1. Complete the controls within the Feedback window as necessary:

   **Maximum answer text length**
   Specify the maximum length of the text answer in number of characters.

   **Show Feedback**
   Select this to show feedback. The feedback will be presented as the feedback text in a message box or as a specified page in a pop-up window. Feedback is provided immediately or upon leaving the page.
If the question is within a test, the test must be set to **Show per question feedback from each question**, in order for the feedback to be displayed to the user.

**See also:** [Setting a test's content properties](#)

### Immediate feedback
Select this to display feedback immediately to the user upon answering the question. This field is enabled when you select **Show feedback**.

### Show page for feedback
Select this to specify the page for the feedback. This enables the **Feedback page list**. Use the list to select the feedback page. The page will be presented in a pop-up window to the user.

### Feedback message
Instead of showing a page to the user, specify the text of the feedback message. The text will be presented in a generic message box to the user.

2. Click **Finish**.

The essay question is added to your title.

### Creating a fill in the blank question
Once you have configured the properties within the Question Properties and Question windows, the Feedback window opens.

**See also:** [Adding Questions](#)

1. Complete the controls within the Feedback window as necessary:

   - **Maximum answer text length**
     Specify the maximum length of the text answer in number of characters.

   - **Possible Correct Answers**
     Specify all possible correct answers to the question. This can include common misspellings or additional appropriate correct answers. Type each answer within the space provided, separating the answers by using the **Enter** key. Any of these answers, when supplied by the user, will be sufficient to receive full credit for correctly answering this question. The words entered in this option will be checked in a case-insensitive manner to the answer supplied by the user to determine the score on the question.

   - **Show Feedback**
     Select this to show feedback. The feedback will be presented as the feedback text in a message box or as a specified page in a pop-up window. Feedback is provided immediately or upon leaving the page.

     If the question is within a test, the test must be set to **Show per question feedback from each question**, in order for the feedback to be displayed to the user.

     **See also:** [Setting a test's content properties](#)

   - **Immediate feedback**
     Select this to display feedback immediately to the user upon answering the question. This field is enabled when you select **Show feedback**.

   - **Show page for correct answer feedback**
     Select this to specify the page for correct answer feedback. This enables the **Feedback page for correct answer list**. Use the list to select the feedback page. The page will be presented in a pop-up window to the user.

   - **Feedback message for**
     Instead of showing a page to the user, specify the text of the correct answer feedback
**Correct answer**

Message. The text will be presented in a generic message box to the user.

**Show page for incorrect answer feedback**

Select this to specify the page for incorrect answer feedback. This enables the Feedback page for incorrect answer list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user.

**Feedback message for incorrect answer**

Instead of showing a page to the user, specify the text of the incorrect answer feedback message. The text will be presented in a generic message box to the user.

2. Click Finish.

The fill in the blank question is added to your title.

**Creating a matching question**

Once you have configured the properties within the Question Properties and Question windows, the Matching Pairs window opens.

See also: Adding Questions

1. Complete the controls within the Matching Pairs window as necessary:

   **Number of matching pairs**
   Specify the total number of matching pairs that will be presented to the student.

   **Number of distractors**
   Specify the total number of distractors. Distractors are items that are not part of a matched pair, but are available as a possible choice to the user. They are used to add complexity to a matching question.

   **Grade each matching pair as a separate question**
   Select this to give the user credit for each matching pair that he or she correctly identifies; otherwise, the user will be required to get all the matching pairs correct to receive credit for answering the question correctly.

   **Show Feedback**
   Select this to show feedback. Feedback can be provided for a correct answer, all pairs matched correctly; or for an incorrect answer, one or more pairs matched incorrectly. The feedback will be presented as the feedback text in a message box or as a specified page in a pop-up window. Feedback is provided immediately or upon leaving the page.

   If the question is within a test, the test must be set to Show per question feedback from each question, in order for the feedback to be displayed to the user.

   See also: Setting a test's content properties

   **Immediate feedback**
   Select this to display feedback immediately to the user upon answering the question. This field is enabled when you select Show feedback.

   **Show page for correct answer feedback**
   Select this to specify the page for correct answer feedback. This enables the Feedback page for correct answer list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user.

   **Feedback message for correct answer**
   Instead of showing a page to the user, specify the text of the correct answer feedback message. The text will be presented in a generic message box to the user.

   **Show page for incorrect answer feedback**
   Select this to specify the page for incorrect answer feedback. This enables the Feedback page for incorrect answer list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user.

   **Feedback message for incorrect answer**
   Instead of showing a page to the user, specify the text of the incorrect answer feedback message. The text will be presented in a generic message box to the user.
2. Click **Next**. The Pair X of XX window opens for each matching choice.

3. For each matching pair, enter the text of the choice as it should be presented to the student in both the left and right column of the question. Select optional images to display. For a distractor, only one column will need to be filled in, depending on which type of distractor is selected. Complete the controls as follows:

<table>
<thead>
<tr>
<th>Matching Pair Type</th>
<th>Left Column</th>
<th>Right Column</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select the type of Matching Pair as either <strong>Matching Pair</strong>, <strong>Left Column Distractor</strong>, or <strong>Right Column Distractor</strong>.</td>
<td>Specify the text of the choice as it should be presented to the user in the left column of the question. Click <strong>Show image with item</strong> to show an image with the matching item. Selecting this enables the <strong>Image</strong> and <strong>Align image</strong> fields.</td>
<td>Specify the text of the choice as it should be presented to the student in the right column of the question. The text or image selected should be the corresponding match to the information entered for the left column. Click <strong>Show image with item</strong> to show an image with the matching item. Selecting this enables the <strong>Image</strong> and <strong>Align image</strong> fields.</td>
</tr>
<tr>
<td>Use the <strong>Image</strong> list to select a previously imported image to display with the choice. Alternatively, click on the <strong>Import</strong> button to navigate and select the image you want to associate with the choice. You can also click on the arrow within the <strong>Import</strong> button to choose from the following:</td>
<td>Use the <strong>Align image</strong> list to specify where the image should appear in relation to the choice text.</td>
<td>Use the <strong>Align image</strong> list to specify where the image should appear in relation to the choice text.</td>
</tr>
<tr>
<td><strong>From File</strong></td>
<td>Select this to navigate and select an image.</td>
<td>From File</td>
</tr>
<tr>
<td><strong>Media Library</strong></td>
<td>Select this to launch your media library to select an image.</td>
<td>Media Library</td>
</tr>
</tbody>
</table>

*See also:* [Working with the Media Library Organizer](#)

4. Click **Next** to continue through the remaining choices for the question. Then click **Finish**.

The matching question is added to your title.

Lectora will automatically scramble the options in the right-hand column. The resulting page will represent how the question will appear to the users when they encounter the question. You can also manually rearrange the pairs on the page as appropriate.
See also: Moving and Resizing Objects

The user will always know which item is selected in one column as the matching item in the opposite column is being selected. The user will see a blue highlight around their first selected item in one column. Once the user selects a matching item from the opposite column, another blue highlight will briefly appear around that item. Lectora will automatically draw a line between the two selected items once the user has made both selections for a matching pair. Lectora will maintain a one-to-one relationship for matching pairs. That is, one object can only be matched to a single, different object.

Test results for matching questions do not reflect the actual matching pairs the user has selected within the test. Instead, a generic result of 1-1, 2-2, 3-3... is displayed.

Creating a drag and drop question

Once you have configured the properties within the Question Properties and Question windows, the Drag Items window opens.

See also: Adding Questions

1. Complete the controls within the Drag Items window as necessary:

- **Number of drag/drop pairs**: Specify the total number of pairs that will be presented to the user.
- **Number of distractors**: Specify the total number of distractors. A Drag Item Distractor is a draggable item (text or image) with no correct point within the drop image. A Drop Point Distractor is an area within the drop image, which can accept a drag item, but is not one of the correct locations. They are used to add complexity to a drag and drop question.
- **Grade each dragged item as a separate question**: Select this to give the user credit for each dragged item that he or she drags to the correct location on the destination image; otherwise, the user will be required to drag all the items to their correct locations to get credit for answering the question correctly.
- **Show Feedback**: Select this to show feedback. Feedback can be provided for a correct answer, all dragged items placed correctly; or for an incorrect answer, at least one dragged item placed incorrectly. The feedback will be presented as the feedback text in a message box or as a specified page in a pop-up window. Feedback is provided immediately or upon leaving the page.

   If the question is within a test, the test must be set to **Show per question feedback from each question**, in order for the feedback to be displayed to the user.

See also: Setting a test's content properties

- **Immediate feedback**: Select this to display feedback immediately to the user upon answering the question. This field is enabled when you select **Show feedback**.
- **Show page for correct answer feedback**: Select this to specify the page for correct answer feedback. This enables the Feedback page for correct answer list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user.
- **Feedback message for correct answer**: Instead of showing a page to the user, specify the text of the correct answer feedback message. The text will be presented in a generic message box to the user.
- **Show page for incorrect**: Select this to specify the page for incorrect answer feedback. This enables the Feedback
answer feedback  
page for incorrect answer list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user.

Feedback message for incorrect answer  
Instead of showing a page to the user, specify the text of the incorrect answer feedback message. The text will be presented in a generic message box to the user.

2. Click **Next** button. The Drag X of XX window opens for each drag item.

3. For each drag item, enter the text and select the image to display. Complete the controls as follows:

   **Drag/Drop Item Type**  
   Select the type of Drag/Drop item as either Drag/Drop Pair, Drag Item Distractor, or Drop Point Distractor.

   **Drag Item Text**  
   Specify an optional label that will appear next to the drag item in the question.

   **Drag Image**  
   Select a previously imported image for the drag image. Alternatively, click on the Import button to navigate and select the drag image. You can also click on the arrow within the Import button to choose from the following:

   From File  
   Select this to navigate and select an image.

   Media Library  
   Select this to launch your media library to select an image.

   See also: Working with the Media Library Organizer

   **Align image**  
   Use the list to specify where the image should appear in relation to the text.

   **Place drop point**  
   The window displays a small representation of the drop image with a green rectangle representing the current drag choice and its location on the drop image.

   To set the location where the drag image is to reside, click the Place drop point button. This launches the Place drag item window. Use the window to move the drag image over the drop image to define the location where the drag image must reside to get credit for answering that part of the question correctly. In addition to moving the image with your mouse, you can move the image using the arrow buttons and keys. Once the drag image is placed correctly on the drop image, click the OK button to return to the drag choice window.

4. Click **Next** to continue through the remaining choices for the question. Then click **Finish**.

The drag and drop question is added to your title.

**Creating a hot spot question**
Once you have configured the properties within the Question Properties and Question windows, the Choices window opens.

See also: Adding Questions

1. Complete the controls within the Choices window as necessary:

   **Number of hot spots**  
   Specify the number of choices to include in the question.

   **Correct answer requires more than one choice**  
   Select this to create a hot spot question with multiple answers. All of the designated correct answers must be selected for the question to be considered correct.

   **Grade each choice item as a separate question**  
   This option is only available if the correct answer requires more than one choice. Select this to give the user credit for each selection that he or she correctly identifies;
otherwise, the user will be required to select all correct answers to receive credit for answering the question correctly.

**Show feedback for multiple choice answer**

The feedback on this screen is valid only if the multiple answer option is used, and will override the individual feedback on the following windows.

If the question is within a test, the test must be set to **Show per question feedback from each question**, in order for the feedback to be displayed to the user.

*See also:* [Setting a test's content properties]

---

### Immediate feedback

Select this to display feedback immediately to the user upon answering the question. This field is enabled when you select **Show feedback for multiple choice answer**.

### Show page for correct answer feedback

Select this to specify the page for the correct answer feedback. This enables the **Feedback page for correct answer** list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user.

### Feedback for correct multiple choice answer

Instead of showing a page to the user, specify the text of the feedback message for the correct choice. The text will be presented in a generic message box to the user.

### Show page for incorrect answer feedback

Select this to specify the page for the incorrect answer feedback. This enables the **Feedback page for incorrect answer** list. Use the list to select the feedback page. The page will be presented in a pop-up window to the user.

### Feedback for incorrect multiple choice answer

Instead of showing a page to the user, specify the text of the feedback message for the incorrect choice. The text will be presented in a generic message box to the user.

---

2. Click **Next**. The Choice X of XX window opens for each choice.

   (insert screen cap)

3. For each choice, place the hotspot on the image as desired. Complete the controls as follows:

   **Correct Choice**

   Select this if this choice is correct.

   You must select at least one of the choices as being the **Correct choice** for the question.

   **Show feedback**

   Select this to show feedback. The feedback will be presented as the feedback text in a message box or as a specified page in a pop-up window. Feedback is provided immediately or upon leaving the page.

   If the question is within a test, the test must be set to **Show per question feedback from each question**, in order for the feedback to be displayed to the user.

   *See also:* [Setting a test's content properties]

   **Immediate feedback**

   Select this to display feedback immediately to the user upon selecting this choice. This field is enabled when you select **Show feedback**.

   **Feedback message**

   Specify the text of the feedback message. The text will be presented in a generic message box to the user.

   **Show page for feedback**

   Select this to specify the page for feedback. This enables the **Feedback page** list.
Use the list to select the feedback page. The page will be presented in a pop-up window to the user.

**Place hot spot**

The window displays a small representation of the hot spot radio button with a green square representing the current choice and its location on the hot spot image.

To set the location where the choice is to reside, click the **Place hot spot** button. This launches the Place Hot Spot window. Use the window to move the hot spot radio button over the hot spot image to define the location. In addition to moving the radio button with the mouse, you can move the radio button using the arrow buttons and keys. Once the hot spot radio button is placed correctly on the image, click the **OK** button to return to the hot spot choice screen.

4. Click **Next** to continue through the remaining choices for the question. Click **Finish**.

The hot spot question is added to your title.

**Specifying Question Properties**

To access the properties of a question, double-click the question graphic of the question in the left-hand pane.

See also:  Adding Questions

Use the controls on the Question Properties window to complete the following tasks:

**General tab**
- Change the name of a question
- Change the associated variable name of a question
- Edit the question
- Retain the question answer between sessions
- Enable author control on a question

**Transitions tab**
- Specify a question's transitions

**Changing the name of a question**

To change the name of question:

1. Double-click the question or survey question graphic of the question you want to change in the left-hand pane. Click the **General** tab if the Question Properties window is not already opened to this tab.

2. Specify the new name of the question in the **Question Name** field.

3. Click **OK**.

**Changing the associated variable name of a question**

You can change the name of the variable associated with a question. The variable associated with the question is used to store the user's answer to the corresponding question.

See also:  Actions and Variables

To change the associated variable name of question:

1. Double-click the question or survey question graphic of the question you want to change in the left-hand pane. Click the **General** tab if the Question Properties window is not already opened to this tab.

2. Specify the associated variable name in the **Associated Variable Name** field. This name must be unique to all existing variable names. Variable names cannot contain spaces or special characters. The variable will be used to store the user’s
answer to the question. It can be accessed from anywhere in the title.

It is best to keep the default naming convention (Question_#####) for question variables. Lectora will automatically increment the numeric value in the variable name to correspond with the number of questions that have been created within the title.

3. Click OK.

**Editing a question**

You can change the possible answers, alter the question text, and edit other properties of your question.

To edit a question:

1. Double-click the question graphic of the question you want to edit in the left-hand pane. Click the General tab if the Question Properties window is not already opened to this tab.

2. Click on the Edit button. The Edit a Question Window opens.

3. Change the **Question Type** or question **Weight** as necessary.

### Type

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>True/False</td>
<td>A question with one correct answer out of two possibilities.</td>
</tr>
<tr>
<td>Multiple Choice</td>
<td>A question with one or more possible correct answers and multiple possibilities.</td>
</tr>
<tr>
<td>Short Answer</td>
<td>A question in which the user supplies a short (typically less than 80 characters) answer. This question type cannot be automatically graded by the testing module and therefore cannot be used in titles within AICC or SCORM learning management systems.</td>
</tr>
<tr>
<td>Essay</td>
<td>A question in which the user supplies a long (typically more than 80 characters) answer. This question type cannot be automatically graded by the testing module and therefore cannot be used in titles within AICC or SCORM learning management systems.</td>
</tr>
<tr>
<td>Fill in the Blank</td>
<td>A question in which the user supplies a short answer that is compared to a list of known correct answers.</td>
</tr>
<tr>
<td>Matching</td>
<td>A question with a column of items on the left-hand side and a column of scrambled items on the right-hand side. The user must match items in the left column with items in the right column to answer the question.</td>
</tr>
<tr>
<td>Drag and Drop</td>
<td>A question that requires the user to drag source objects such as text or images to defined targets within a larger, work area image.</td>
</tr>
<tr>
<td>Hot Spot</td>
<td>A question with a visual multiple-choice set used to identify areas of an image; one or more possible correct answers are possible.</td>
</tr>
</tbody>
</table>

### Question Weight

The question weight is irrelevant if the question is not within a test. Select the weight of the test question. Points are used to calculate the percentage weight of each question and will be
factored into the overall test score. The default weight of each question is 1. Therefore, without changing this option, all the questions within a test are of equal value. If points are assigned to each question, Lectora will use the sum of test points to calculate question weight and further, the test score.

Set the **Question Weight** to 0 for any short answer or essay questions that are included in a graded test.

4. Click **Next**. The Question window opens. Alter the following properties as appropriate:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
<th>Question Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Question</td>
<td>Specify the text of the question.</td>
<td>All</td>
</tr>
<tr>
<td>Show image with question</td>
<td>Select this to show an image with the question. Selecting this enables the Image and Align image lists.</td>
<td>All</td>
</tr>
<tr>
<td>Image</td>
<td>Select a previously imported image to display with the question text. For Drag and Drop and Hot Spot questions, use the list or <strong>Import</strong> button to specify the destination image upon which the question’s drag objects or hot spot buttons will be placed. Click the <strong>Import</strong> button to navigate and select the image you want to associate with the question. You can also click on the arrow within the <strong>Import</strong> button to choose from the following:</td>
<td>All</td>
</tr>
<tr>
<td>Drop image Hot Spot image</td>
<td>From File Select this to navigate and select an image.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Media Select this to launch your media library to select an image.</td>
<td></td>
</tr>
<tr>
<td>Align image</td>
<td>Specify where the image should appear in relation to the question text.</td>
<td>All</td>
</tr>
</tbody>
</table>

5. Click **Next**. You will be presented with one or more additional windows that are based on the type of question you selected. For additional information, select the type of question you are adding:

- True or False
- Multiple Choice
- Short Answer
- Essay
- Fill in the Blank
- Matching
- Drag and Drop
- Hot Spot

6. Edit the question as necessary, click **Next** to proceed through the question windows and finally click **Finish**.

**Retaining the question answer between sessions**

You can enable Lectora to retain question answers after the Lectora session is closed. If the user returns to the question in a future session, the question will retain any answer that was previously supplied.

To retain the question answer between sessions:

1. Double-click the question or survey question graphic of the question you want to change in the left-hand pane. Click the **General** tab if the Question Properties window is not already opened to this tab.
2. Select the Retain question answer between sessions check box.

3. Click OK.

Enabling author control on a question
Protect the question by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the question unless they have the master Author Control password. The master Author Control password must first be set within the Title Properties.

See also:  Protecting your title with a password

To enable author control on a question:
1. Double-click the question or survey question graphic of the question you want to change in the left-hand pane. Click the General tab if the Question Properties window is not already opened to this tab.

2. Select the Author Control check box.

3. Click OK.

Specifying a question’s transitions
You can specify how a question is displayed on a page. Transitions will produce a visual effect as the question appears and disappears. You can select from over 20 different transitions. There is a Slow to Fast slider to determine the speed at which the transition takes place.

To specify the transition:
1. Double-click the question or survey question graphic of the question you want to change in the left-hand pane. Click the Transitions tab.

2. Specify the following information:

   **Transition In**
   Select this to enable a transition when displaying the question as the page opens or the object is made visible with an action.

   **Transition (In) Type**
   Select a transition type as one of the following:
   - Box In
   - Box Out
   - Circle In
   - Circle Out
   - Wipe Up
   - Wipe Down
   - Wipe Right
   - Wipe Left
   - Blinds Vertical
   - Blinds Horizontal
   - Checker Across
   - Checker Down
   - Dissolve
   - Split in Vertical
   - Split out Vertical
   - Split out Horizontal
   - Strips Down left
   - Strips Up left
   - Strips Downright
   - Strips Upright
   - Horizontal Bars
   - Vertical Bars
   - Fly Top
   - Fly Top right
   - Fly Right
   - Fly Bottom right
   - Fly Bottom
   - Fly Bottom left
   - Fly Left
   - Fly Top left
3. Click OK.

Adding Surveys
Add surveys to obtain feedback from your users about your title. You can process results and submit them to learning management systems, email addresses or custom databases.

In this chapter, the following topics are covered:
- About Surveys
- Creating a Survey
- Adding Sections to a Survey

About surveys
Surveys are only slightly different from tests. They are different in that surveys are not graded and there are no correct answers or feedback for survey questions. Like a test, surveys can contain sections and pages. Use sections to organize pages within a survey. The pages are the physical pages that your users will see, and will contain the questions that comprise the survey.

See also: Understanding the Book Metaphor

Creating a survey
Creating a survey is similar to creating a chapter. When added to your title, a survey is displayed in the left-hand pane as a new chapter following the currently selected chapter. A Page 1 and a Last survey page will be added by default to the survey. Additional pages can be inserted, and survey questions can then be added to the pages of the survey.

Follow these steps to create a survey:
1. In the left-hand pane, select the page after which you want the survey to appear and do one of the following:
   - From the Add menu, select Survey
   - Click the Add Survey toolbar graphic on the Insert toolbar
   - Right-click and select New > Survey
   - Type Alt+6

   The Survey Properties window opens.

2. Use the tabs on the Survey Properties window to complete these tasks:
   - **General tab**
     - Change the name of a survey
     - Change a survey's page size and alignment
     - Remove a survey from the table of contents
     - Enable author control for a survey
     - Add standard navigation to a survey
     - Add automatic page numbering to a survey
   - **Background tab**
     - Change a survey's background properties
     - Change a survey's text properties
   - **Inherit tab**
     - Specify a survey's inheritance properties
   - **Content tab**
     - Set a survey's content properties
   - **Results tab**
     - Set survey result properties
   - **Response tab**
     - Set CGI survey response properties
   - **When Completed tab**
     - Set the resulting action when a survey is completed
   - **When Canceled tab**
     - Set the resulting action when a survey is canceled
   - **Transition tab**
     - Set a survey's transition properties

   When you have finished specifying survey properties, click OK to create the survey. You can then divide your survey into sections or begin adding questions to survey pages.

**See also:** Adding Sections to a Survey
Adding Survey Questions

**Setting a survey's content properties**
You can specify the survey content properties, such as whether students must answer all questions and whether to retain survey question answers.

To set a survey's content properties:
1. Double-click the survey graphic of the survey you want to change in the left-hand pane. The Survey Properties window opens. Click the Content tab.
2. Complete the controls on this tab as follows:
   - **Ensure that student** When enabled, users will not be able to navigate off of the current page, if they have not
answers all questions on the survey

Retain answers to all questions between sessions

Select this to enable Lectora to retain the question answers after the Lectora session is closed. If the student returns to the survey in a future session, the questions will retain any answers that were previously supplied.

3. Click OK.

Setting survey result properties
You can specify if survey results should be submitted to an email address or CGI script.

To set survey result properties:
1. Double-click the survey graphic of the survey you want to change in the left-hand pane. The Survey Properties window opens. Click the Results tab.

2. Complete the controls on this tab as follows:

Survey Data Submission
Use this section to specify whether survey data are to be submitted using email or a CGI program. Survey data are not automatically sent to learning management systems.

Email Survey Data
Select this to enable the survey data to be emailed to the email address specified in the Email results to field. (Separate multiple email addresses with a semicolon.) The use of this feature requires that each user have an email client, such as Microsoft Outlook, on the computer from which they are accessing the published title. In addition, the email server must be configured to accept communications from the published title's location, so results can be successfully submitted. Specify the subject line in Email Subject Line. The default is Survey Results.

To submit the emailed results in XML format, select Submit in XML format.

Submit Survey Data to CGI program
Select this to submit the survey data to the CGI application specified in the Submit results to field. Use the Method list to select whether the submission is done using a POST or GET.

The GET method can only support the submission of 256 characters of data. If you have a large survey or are submitting a large amount of variable data, use the POST method instead.

See also: Submitting Test, Survey and Form Results to CGI

If this option is selected, the controls within the Response tab of the Survey Properties window are enabled.

See also: Setting CGI test/survey response properties

Prompt the student for their name to identify the survey
If enabled, users are prompted at the beginning of the survey to enter their name. The user's name is submitted with the test results data.

Include all variable values in submission
If enabled, all defined Lectora variables will be included with the survey results data that is submitted. The name of each variable and its value at the time of submission is sent.

Show the student a success dialog if submission is
If enabled, a success message will be presented to the user upon successful submission of the survey results.
successful

3. Click OK.

**Setting the resulting action when a survey is completed**
You can specify the action to take when the survey is completed.

To set the resulting action when a user completes a survey:
1. Double-click the survey graphic of the survey you want to change in the left-hand pane. The Survey Properties window opens. Click the **When Completed** tab.

2. The only Action available is **Go To**. Select the appropriate Target from the list.

   *See also:* [Selecting an action](#)

3. Click OK.

**Setting the resulting action when a survey is canceled**
You can specify the action to take when the survey is canceled.

To set the resulting action when a user cancels a survey:
1. Double-click the survey graphic of the survey you want to change in the left-hand pane. The Survey Properties window opens. Click the **When Canceled** tab.

2. The only Action available is **Go To**. Select the appropriate Target from the list.

   *See also:* [Selecting an action](#)

3. Click OK.

**Adding sections to a survey**
Survey sections can be used to organize the pages in a survey. Unlike regular chapter sections, survey sections cannot contain subsections, and can only contain pages.

To add a section to a survey, follow these steps:
1. In the left-hand pane, select the survey to which you want to add a new section and do one of the following:
   - From the Add menu, select **Section**
   - Select the **Add Section** toolbar graphic on the Insert toolbar
   - Right-click and select **New > Section**
   - Type **Ctrl+2**

   When you add the new section, a section graphic appears in the left-hand pane in the survey you selected.

2. Configure the survey section properties. Double-click the section graphic representing the Survey Section in the left-hand pane. The Section Properties window opens.

3. Complete the controls within the Section Properties window as necessary.

   *See also:* [Working with Sections](#)

**Adding Survey Questions**
Survey questions are only slightly different from other questions in Lectora. They are different in that they do not contain correct or incorrect answers and they do not issue feedback. Survey questions can be added to any page of your title, whether it is inside or outside of a survey. Survey questions on pages contained in a survey will be submitted using the survey results submission properties specified.

See also: Setting survey result properties

Follow these steps to add a survey question to your title:

1. In the left-hand pane, select the survey, survey section or page to which you want to add a survey question and do one of the following:
   - From the Add menu, select Survey Question
   - Click the Add Survey Question toolbar graphic on the Insert toolbar
   - Right-click and select New > Survey Question
   - Type Alt+8

   The Survey Question Properties window opens.

2. Complete the controls on the window as follows:

   Name
   Specify the name by which you will recognize this survey question.

   Type
   Select the survey question type from the list. Choose from one of the following question types:
   - True/False
     A question with two possible answers.
   - Multiple Choice
     A question with one or more possible answers.
   - Short Answer
     A question in which the user supplies a short (typically less than 80 characters) answer.
   - Essay
     A question in which the user supplies a long (typically more than 80 characters) answer.
   - Hot Spot
     A question with a visual multiple-choice set used to identify areas of an image; one or more possible answers.
   - Likert
     A question that asks users to specify their level of agreement to a statement.
   - Likert Table
     A series of likert questions that asks users to specify their level of agreement according to a single statement; presented in a table.
   - Ordinal
     A question that asks users to rank a series of statements, typically in order of importance.

   Associated Variable Name
   Specify the associated variable name for this question. This must be a new unique variable that does not already exist. The variable will be used to store the user’s answer to the question. It may be accessed from anywhere in the title.

   It is best to keep the default naming convention (Question_####) for question variables. Lectora will automatically increment the numeric value in the variable to correspond with the number of questions that have been created within the title.

   Create new page for the question
   This option will automatically create a new page onto which the question will be added. The new page will be added after the currently selected page. If this option is not selected, the question will be added to the currently selected page.

   Retain question
   This option causes the question answer to be retained after the Lectora session is closed. When
answer between sessions the user returns to this question in a future session, the answer provided previously by the student is retained. If this option is not selected, the question will revert back to its default state of unanswered with every launch of the course.

Author Control With Author Control enabled, additional authors will not be able to edit the question unless they have the master Author Control password.

See also: Protecting your title with a password

3. Click the Next button. The Survey Question window opens.

4. Use this window to define how the question will appear to the user. Define the following properties for the different question types:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
<th>Question Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Question</td>
<td>Specify the text of the question.</td>
<td>All but Likert Table</td>
</tr>
<tr>
<td>Show image with question</td>
<td>Select this to show an image with the question. Selecting this enables the</td>
<td>All but Hot Spot and</td>
</tr>
<tr>
<td></td>
<td>Image and Align image lists.</td>
<td>Likert Table</td>
</tr>
<tr>
<td>Image</td>
<td>Select a previously imported image to display with the question text.</td>
<td>All but Likert Table</td>
</tr>
<tr>
<td></td>
<td>Alternatively, click on the Import button to navigate and select the image</td>
<td></td>
</tr>
<tr>
<td></td>
<td>you want to associate with the question. You can also click on the arrow</td>
<td></td>
</tr>
<tr>
<td></td>
<td>within the Import button to choose from the following:</td>
<td></td>
</tr>
<tr>
<td>From File</td>
<td>Select this to navigate and select an image.</td>
<td></td>
</tr>
<tr>
<td>Media Library</td>
<td>Select this to launch your media library to select an image.</td>
<td></td>
</tr>
<tr>
<td>Align image</td>
<td>Specify where the image should appear in relation to the question text.</td>
<td>All but Likert Table</td>
</tr>
<tr>
<td>Number of likert questions</td>
<td>Specify the number of questions to include in the likert table question.</td>
<td>Likert Table</td>
</tr>
<tr>
<td>Likert Type</td>
<td>Use this list to select the type of Likert question. Select from:</td>
<td>Likert and Likert Table</td>
</tr>
<tr>
<td></td>
<td>• 3 Choices (Agree, Neither Agree nor Disagree, Disagree)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 4 Choices (Strongly Agree thru Strongly Disagree)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 5 Choices (Strongly Agree thru Strongly Disagree with Neither)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 3 Choices (Important, Neutral, Unimportant)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 4 Choices (Very Important thru Very Unimportant)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• 5 Choices (Very Important thru Very Unimportant with Neutral)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Custom (Specify number of choices and choice’s label)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>If you select the Custom type, additional windows will open, prompting you</td>
<td></td>
</tr>
<tr>
<td></td>
<td>for the number of choices and the text to display for each choice.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Additionally choose whether to include a not applicable option by selecting</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Include N/A Choice. If you do not want to show the corresponding text with</td>
<td></td>
</tr>
<tr>
<td></td>
<td>the choices, clear the Show text with choices check box.</td>
<td></td>
</tr>
<tr>
<td>Likert Style</td>
<td>Select from one of the following Likert styles:</td>
<td>Likert and Likert Table</td>
</tr>
<tr>
<td></td>
<td>All but Likert Table</td>
<td></td>
</tr>
<tr>
<td></td>
<td>See also: Working with the Media Organizer</td>
<td></td>
</tr>
</tbody>
</table>
5. Click the **Next** or **Finish** button.

If you clicked **Next**, you will be presented with one or more additional windows that are based on the type of question you selected. For additional information, select the type of survey question you are adding:

- True / False
- Multiple Choice
- Short Answer
- Essay
- Hotspot
- Likert
- Likert Table
- Ordinal

6. Complete the fields as directed and click **Finish**.

**Creating a true or false survey question**

Once you have configured the properties within the Survey Question Properties and Survey Question windows, the Results and Feedback window opens.

**See also:**  Adding Survey Questions

1. Complete the controls within the Results and Feedback window as necessary:
True Choice Text
Specify the text for the true choice (for example, I agree or Yes). The default text is True.

False Choice Text
Specify the text for the false choice (for example, I disagree or No). The default text is False.

2. Click Finish.

The true or false survey question is added to your title.

Creating a multiple choice survey question
Once you have configured the properties within the Survey Question Properties and Survey Question windows, the Choices window opens.

See also: Adding Survey Questions

1. Complete the controls within the Choices window as necessary:

   Number of choices
   Specify the number of choices to include in the question.

   Allow more than one choice
   Select this to create a multiple choice question where users can select multiple answers.

   Display question as Drop-down List / List Box
   Select this to display the choices in a drop-down list (for questions with only one answer) or in a list box (for questions allowing the selection of multiple answers).

2. Click the Next button. The Choice X of XX window is displayed for each choice. The number of windows that follow is equal to the Number of choices that you defined on the Choices window. (Click the Back button if you want to return to that window.)

3. For each choice, complete the controls as follows:

   Choice Text
   Specify the text for this choice.

   Show image with choice
   Select this to show an image with the choice. Selecting this enables the Image and Align image fields.

   Image
   Select a previously imported image to display with the choice text. Alternatively, click on the Import button to navigate and select the image you want to associate with the choice. You can also click on the arrow within the Import button to choose from the following:

   From File
   Select this to navigate and select an image.

   Media Library
   Select this to launch your media library to select an image.

   See also: Working with the Media Library Organizer

   Align image
   Specify where the image should appear in relation to the choice text.

4. Click Next until you have finished configuring each choice and click Finish.

The multiple choice survey question is added to your title.
Creating a short answer survey question
Once you have configured the properties within the Survey Question Properties and Survey Question windows, the Feedback window opens.

See also: Adding Survey Questions

1. Specify the **Maximum answer text length** in number of characters.
2. Click **Finish**.

The short answer survey question is added to your title.

Creating an essay survey question
Once you have configured the properties within the Survey Question Properties and Survey Question windows, the Feedback window opens.

See also: Adding Survey Questions

1. Specify the **Maximum answer text length** in number of characters.
2. Click **Finish**.

The essay survey question is added to your title.

Creating a hot spot survey question
Once you have configured the properties within the Survey Question Properties and Survey Question windows, the Choices window opens.

See also: Adding Survey Questions

1. Complete the controls within the Choices window as necessary:
   - **Number of hot spots** Specify the number of choices to include in the question.
   - **Allow more than one choice** Select this to create a hot spot question where users can select multiple answers.
2. Click **Next**. The Choice X of XX window opens for each choice. The window displays a small representation of the hot spot radio button with a green square representing the current choice and its location on the hot spot image.
3. For each choice, place the hotspot on the image as desired. To set the location where the choice is to reside, click the **Place hot spot** button. This launches the Place Hot Spot window. Use the window to move the hot spot radio button over the hot spot image to define the location. In addition to moving the radio button with the mouse, you can move the radio button using the arrow buttons and keys. Once the hot spot radio button is placed correctly on the image, click the **OK** button to return to the hot spot choice screen.
4. Click **Next** to continue through the remaining choices for the question. Click **Finish**.

The hot spot survey question is added to your title.

Creating a Likert survey question
Once you have configured the properties within the Survey Question Properties and Survey Question windows and you have chosen to specify your own custom choices for the **Likert Type**, the Custom Likert Choices window opens.

See also: Adding Survey Questions
1. Within the Custom Likert Choices window, Specify the **Number of choices** to include in the likert question:

2. Click the **Next** button. The Choice X of XX window is displayed for each choice. The number of windows that follow is equal to the **Number of choices** that you defined on the Choices window. (Click the **Back** button if you want to return to that window.)

3. For each choice, specify the **Choice Text**.

4. Click **Next** until you have finished configuring each choice and click **Finish**.

   The custom Likert survey question is added to your title.

**Creating a Likert table survey question**

Once you have configured the properties within the Survey Question Properties and Survey Question windows the resulting windows differ based upon whether or not you have chosen to specify your own custom choices for the **Likert Type**.

**See also:**  [Adding Survey Questions](#)

If you have chosen to specify custom choices for the Likert Type:

1. Within the Custom Likert Choices window, Specify the **Number of choices** to include in the Likert question.

2. Click the **Next** button. The Choice X of XX window is displayed for each choice.

3. For each choice, specify the **Choice Text**.

4. Click **Next** until you have finished configuring each choice.

   If you haven't chosen to specify custom choices for the **Likert Type**, or have already configured your custom choices, the Likert Question X of XX window is displayed for each question included in the Likert table. The number of questions is specified in the Survey Question window.

   For each Likert question, complete the following:

   1. Specify the **Question** text.

   2. Click **Next** until you have finished configuring each question and click **Finish**.

   The Likert table survey question is added to your title.

**Creating an ordinal survey question**

Once you have configured the properties within the Survey Question Properties and Survey Question windows, the **Items** window opens.

**See also:**  [Adding Survey Questions](#)

1. Specify the **Number of rankable items**. This is the number of statements that will be ranked in order of importance.

2. Click the **Next** button. The Rankable Item X of XX window is displayed for each item. The number of windows that follow is equal to the **Number of rankable items** that you defined on the Items window. (Click the **Back** button if you want to return to that window.)

3. For each rankable item, complete the controls as follows:
Rankable item
Specify the text for this rankable item.

Show image with choice
Select this to show an image with the item. Selecting this enables the Image and Align image fields.

Image
Select a previously imported image to display with the rankable item text. Alternatively, click on the Import button to navigate and select the image you want to associate with the item. You can also click on the arrow within the Import button to choose from the following:

- From File: Select this to navigate and select an image.
- Media Library: Select this to launch your media library to select an image.

See also: Working with the Media Library Organizer

Align image
Specify where the image should appear in relation to the choice text.

4. Click Next until you have finished configuring each rankable item and click Finish.

The ordinal survey question is added to your title.

Specifying Survey Question Properties
To access the properties of a survey question, double-click the survey question graphic of the survey question in the left-hand pane.

See also: Adding Survey Questions

Use the controls on the Survey Question Properties window to complete the following tasks:

**General tab**
- **Change the name of a survey question**
- **Change the associated variable name of a survey question**
- **Edit the survey question**
- **Retain the survey question answer between sessions**
- **Enable author control on a survey question**

**Transitions tab**
- **Specify a question's transitions**

Editing a survey question
You can change the possible answers, alter the question text, and edit other properties of your question.

To edit a question:
1. Double-click the survey question graphic of the survey question you want to edit in the left-hand pane. Click the General tab if the Question Properties window is not already opened to this tab.
2. Click on the Edit button. The Edit a Survey Question Window opens.
3. Change the Question Type as necessary by selecting one of the following:

   - **True/False**: A question with two possible answers.
   - **Multiple Choice**: A question with one or more possible answers.
   - **Short Answer**: A question in which the user supplies a short (typically less than 80 characters) answer.
**Essay**
A question in which the user supplies a long (typically more than 80 characters) answer.

**Hot Spot**
A question with a visual multiple-choice set used to identify areas of an image; one or more possible answers.

**Likert**
A question that asks users to specify their level of agreement to a statement.

**Likert Table**
A series of likert questions that asks users to specify their level of agreement according to a single statement; presented in a table.

**Ordinal**
A question that asks users to rank a series of statements, typically in order of importance.

4. Click Next. Use this window to change how the question will appear to the user. Define the following properties for the different question types:

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
<th>Question Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Question</td>
<td>Specify the text of the question.</td>
<td>All but Likert Table</td>
</tr>
<tr>
<td>Show image with question</td>
<td>Select this to show an image with the question. Selecting this enables the</td>
<td>All but Hot Spot and Likert Table</td>
</tr>
<tr>
<td>Image</td>
<td>Image and Align image lists.</td>
<td></td>
</tr>
<tr>
<td>Number of likert questions</td>
<td>Specify the number of questions to include in the likert table question.</td>
<td>Likert Table</td>
</tr>
<tr>
<td>Likert Type</td>
<td>Use this list to select the type of Likert question. Select from:</td>
<td>Likert and Likert Table</td>
</tr>
<tr>
<td></td>
<td>- 3 Choices (Agree, Neither Agree nor Disagree)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- 4 Choices (Strongly Agree thru Strongly Disagree)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- 5 Choices (Strongly Agree thru Strongly Disagree with Neither)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- 3 Choices (Important, Neutral, Unimportant)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- 4 Choices (Very Important thru Very Unimportant)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- 5 Choices (Very Important thru Very Unimportant with Neutral)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Custom (Specify number of choices and choice’s label)</td>
<td></td>
</tr>
</tbody>
</table>

If you select the Custom type, additional windows will open, prompting you for the number of choices and the text to display for each choice.

Additionally choose whether to include a *not applicable* option by selecting **Include N/A Choice**. If you do not want to show the corresponding text with the choices, clear the **Show text with choices** check box.

**Likert Style**
Select from one of the following Likert styles:

See also: [Working with the Media Library Organizer](#)
5. Click **Next**. You will be presented with one or more additional windows that are based on the type of survey question you selected. For additional information, select the type of question you are adding:

- **True or False**
- **Multiple Choice**
- **Short Answer**
- **Essay**
- **Hot Spot**
- **Likert**
- **Likert Table**
- **Ordinal**

6. Edit the survey question as necessary, click **Next** to proceed through the question windows and finally click **Finish**.

**Working with Test Timers**

When you specify that your test is a timed test, a test timer appears within your left-hand pane. The test timer displays the remaining time left within the test. Within the properties of the test timer, you can complete the following:

**General tab**

- **Change the name of a test timer**
- **Make a test timer initially invisible**

**Position and Size tab**

- **Specify a test timer’s position and size**

**Font and Color tab**
See also: Setting a test's content properties

Specifying the font and color of a test timer
You can specify the background color and font style used for a test timer.

To specify the font and color of a test timer:
1. Double-click on the test timer within your work area. The Test Timer Properties window opens. Click the **Font and Color** tab.

2. Select the **Background Color** for your test timer from the list. Select a predefined color, select the eyedropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

   See also: Matching Colors Used within Your Title

3. Select the **Text Style** from the list. To create a new text style, click on the **Styles** button.

   See also: Managing Text Styles

Keep in mind that if you are publishing to HTML, Lectora does not embed the fonts into the published work. It is best to use common, Web-friendly fonts such as Arial, Verdana, or Tahoma.

4. Click **OK**.

Working with Forms
Forms and form objects enable you to add user controls, such as radio buttons, check boxes and entry fields. Form objects can be used as standalone components to gather information from the user, or they can be used inside of a form to be submitted outside of the published title.

In this chapter, the following topics are covered:
- About Forms
- About Form Objects
- Adding a Form
- Changing Common Form Object Properties
- Adding a Radio Button Group
- Adding a Radio Button
- Adding a Check Box
- Adding an Entry Field
- Adding a Drop-Down List
- Adding a List Box

About Forms
Forms are special Lectora objects that provide a mechanism to communicate outside the Lectora title. You can configure forms to send a collection of data using email or send and receive a collection of data using a CGI-submit/receive command for both CD- and Web-published titles.
Create a form on a page and then add each form object into the form.

Forms are logical objects because they have no physical representation on a page but can contain form objects. The information contained in the form objects of a form can be submitted using email or a CGI program through a **Submit Form** action.

**See also:** [Selecting an action](#)

The following form objects can be created within a form:
- Radio Button Groups
- Radio Buttons
- Check Boxes
- Entry Fields
- Drop-Down Lists
- List Boxes

### About Form Objects

Form objects are special Lectora objects that enable the user to provide information. Form objects can be used within a form or by themselves. When form objects are contained in a form, the data captured by the form objects can be submitted to an email address or a specified CGI program.

**See also:**
- [Adding a Form](#)
- [Submitting Test, Survey and Form Results to CGI](#)

You can add the following form objects to your title:
- Radio Button Groups
- Radio Buttons
- Check Boxes
- Entry Fields
- Drop-down Lists
- List Boxes

Radio buttons, check boxes, entry fields, drop-down lists and list boxes are input objects that have physical representations that can be added to any form or page. A radio button group is a logical input object that does not have a physical representation. It is used to group a set of radio buttons together to enable only one radio button of the group to be selected at a time.

Form objects have one additional attribute that other Lectora objects do not have. They have an associated variable. This variable provides a place for Lectora to store the input data for the form object. This variable can then be accessed from anywhere in the title.

### Adding a Form

Perform the following steps to add a form to your title:

1. In the left-hand pane, select the page onto which you want to add a form and do one of the following:
   - From the **Add** menu, select **Object > Form Object > Form**
   - Click the **Form** toolbar graphic on the Form toolbar
   - Right-click and select **New > Object > Form Object > Form**
   - Type **Ctrl+Alt+2**

The Form Properties window opens.
2. Use the tabs on the Form Properties window to complete these tasks:

**General tab**
- Change the name of a form
- Retain form information between sessions
- Enable author control for a form
- Set form submission properties

**Parameters tab**
- Specify additional parameters to submit with a form

**Response tab**
- Set CGI form response properties

**Transition tab**
- Specifying a form's transitions

Once you have created a form, you can populate it with form objects.

**See also:** About Form Objects

**Changing the name of a form**
To change the name of a form:
1. Double-click the form graphic of the form you want to change in the left-hand pane. The Form Properties window opens. Click the General tab if the Form Properties window is not already opened to this tab.
2. In the Name field, specify the new name as you want it to appear in the left-hand pane.
3. Click OK.

**Retaining form information between sessions**
You can choose to retain the information captured through form elements after the Lectora session is closed. If the user returns to the form in a future session, the values from the previous session will be loaded into the form elements. If this option is not selected, the form element objects will be loaded with their initial values for each new Lectora session.

To retain form information between sessions:
1. Double-click the form graphic of the form you want to change in the left-hand pane. The Form Properties window opens. Click the General tab if the Form Properties window is not already opened to this tab.
2. Select the Retain values of all form elements between sessions check box.
3. Click OK.

**Setting form submission properties**
You can specify if form results should be submitted to an email address or CGI script.

To set form submission properties:
1. Double-click the form graphic of the form you want to change in the left-hand pane. The Form Properties window opens. Click the General tab if the Form Properties window is not already opened to this tab.
2. Complete the controls on this tab as follows:

<table>
<thead>
<tr>
<th>Form Submission</th>
<th>Use this section to specify whether form results are to be submitted using email or a CGI program. Form results are not automatically sent to learning management systems.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Email form</td>
<td>Select this to enable the form results to be emailed to the email address specified in</td>
</tr>
</tbody>
</table>
the Email results to field. (Separate multiple email addresses with a semicolon.) The use of this feature requires that each user have an email client, such as Microsoft Outlook, on the computer from which they are accessing the published title. In addition, the email server must be configured to accept communications from the published title's location, so results can be successfully submitted. Specify the subject line in Email Subject Line. The default is Form Submit.

To submit the emailed results in XML format, select Submit in XML format.

Submit form to CGI program
Select this to submit the survey results to the CGI application specified in the Submit results to field. Use the Method list to select whether the submission is done using a POST or GET.

The GET method can only support the submission of 256 characters of data. If you have a large test or are submitting a large amount of variable data, use the POST method instead.

See also: Submitting Test, Survey and Form Results to CGI

If this options is selected, the controls within the Response tab of the Form Properties window are enabled.

See also: Setting CGI form response properties

Include all variable values in form submission
If enabled, all defined Lectora variables will be included with the form data that is submitted. The name of each variable and its value at the time of submission is sent.

Show the student a success dialog if submission is successful
If enabled, a success message will be presented to the user upon successful submission of the form data.

3. Click OK.

Enabling author control on a form
Protect the form by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the form or any of the form elements within the form unless they have the master Author Control password. The master Author Control password must first be set within the Title Properties.

See also: Protecting your title with a password

To enable author control on a form:
1. Double-click the form graphic of the form you want to change in the left-hand pane. The Form Properties window opens. Click the General tab if the Form Properties window is not already opened to this tab.

2. Select the Author Control check box.

3. Click OK.

Executing an action when a form element is used
You can specify the action to take when the user selects or changes the form data. When this option is enabled, the action specified will execute when a user selects any of the radio buttons or check boxes within the form, uses a drop-down list or list box within the form, or types in an entry field within the form.

See also: About Actions
To execute an action when a form control is used:
1. Double-click the form graphic of the form you want to change in the left-hand pane. The Form Properties window opens. Click the **On Select/Change** tab.

2. Use the **Action** list to select from the following actions:
   - See also: [Selecting an action](#)
     - The **Target** field is enabled when the action requires a target. Specify additional information as necessary.
   - See also: [Selecting an action's target](#)

3. Click **OK**.

### Specifying additional parameters to submit with a form
You can specify additional parameter data in the form of name/value pairs to be submitted with the form. Submitting parameters with form data is optional. This data is communicated using an email or a submit command to a CGI program with the data being formatted as name/value pairs (for example, parameter name = parameter value). In an email, the name/value pairs are listed as one pair per line. For a CGI program, the name/value pairs are submitted as the input for a POST submit or as part of the URL specification for a GET submit.

To specify additional name/value pairs to be included in the form submission:
1. Double-click the form graphic of the form you want to change in the left-hand pane. The Form Properties window opens. Click the **Parameters** tab.

2. Click the **Add** button. The Parameter Entry window opens.

3. Type the parameter **Name** and **Value** in the entry fields.

4. Click **OK**.

   Repeat steps 2 through 4 for each parameter you want to define.

5. Click **OK**.

You can **Edit** or **Remove** existing parameters by selecting the parameter name or value within the list and clicking the corresponding button. When you **Edit** an existing parameter, you can change the name or value of the parameter. When you **Remove** a parameter, it is removed from the list.

### Setting CGI form response properties
When submitting form data to a CGI program, the CGI program can issue a response. You can specify whether you want to enable Lectora to receive a response from the CGI program. If enabled, the response is received and stored as a text string in the specified Lectora variable.

**See also:** [Submitting Test, Survey and Form Results to CGI](#)

To set CGI form response properties:
1. Double-click the form graphic of the form you want to change in the left-hand pane. The Form Properties window opens. Click the **Response** tab.

2. Select **Receive response from CGI submission**. Use the **Variable to receive response** drop-down list to select the variable into which you want to store the response. Alternatively, click the **New Variable** button to create a new variable in which to store the CGI response. The response is stored as a text string in the specified variable.
See also: About variables

3. Click OK.

Specifying a form’s transitions
You can specify how all of the form objects within a form are displayed on a page. Transitions will produce a visual effect as the form objects appear and disappear. You can select from over 20 different transitions. There is a Slow to Fast slider to determine the speed at which the transition takes place.

To specify the transition:
1. Double-click the form graphic of the form you want to change in the left-hand pane. The Form Properties window opens. Click the Transitions tab.

2. Specify the following information:

   **Transition In**
   - Select this to enable a transition when displaying the form as the page opens or the form is made visible with an action.

   **Transition (In) Type**
   - Select a transition type as one of the following:
     - Box In
     - Box Out
     - Circle In
     - Circle Out
     - Wipe Up
     - Wipe Down
     - Wipe Right
     - Wipe Left
     - Blinds Vertical
     - Blinds Horizontal
     - Checker Across
     - Checker Down
     - Dissolve
     - Split in Vertical
     - Split out Vertical
     - Split in Horizontal
     - Split out Horizontal
     - Strips Down left
     - Strips Up left
     - Strips Downright
     - Strips Upright
     - Horizontal Bars
     - Vertical Bars
     - Fly Top
     - Fly Top right
     - Fly Right
     - Fly Bottom right
     - Fly Bottom
     - Fly Bottom left
     - Fly Left
     - Fly Top left
     - Random Effect

   **Delay before transition**
   - Specify the delay in seconds before starting the transition. Select between 0 and 600 seconds.

   **Slow > Fast**
   - Use the slider to specify the speed at which the transition should occur.

   **Transition Out**
   - Select this to enable a transition when hiding the form as the page closes or the form is hidden with an action.

   **Transition (Out) Type**
   - Select a transition type as one of the following:
     - Box In
     - Box Out
     - Circle In
     - Circle Out
     - Wipe Up
     - Split in Vertical
     - Split out Vertical
     - Split in Horizontal
     - Split out Horizontal
     - Strips Down left
     - Strips Up left
     - Strips Downright
     - Strips Upright
Changing Common Form Object Properties

Many properties for form objects in Lectora (radio buttons, check boxes, drop-down lists and so on) are the same. You can access these properties for individual form objects by double-clicking the form object or by selecting the object and pressing the Enter key.

The following can be completed within most form object properties:

- Change the name of a form object
- Make a form object initially invisible
- Place a form object on the top layer
- Lock the size and position of a form object
- Enable author control on a form object
- Retain a form object's selection between sessions
- Specify a form object's position and size
- Specify a condition for submitting form object data
- Display a conditional message
- Specify a form object's transitions

Changing the name of a form object

To change the name of a form object:

1. Double-click on the form object within your work area. The (Form Object) Properties window opens. Click the General tab if the (Form Object) Properties window is not already opened to this tab.

2. Specify the new name of the form object in the (Form Object) Name field.

3. Click OK.

Making a form object initially invisible

By default, form objects are set to be initially visible. That is, they appear when users open the pages on which the form objects are located. You can initially hide a form object until an action has been executed to show the form object.
To make a form object initially invisible:
1. Double-click on the form object within your work area. The (Form Object) Properties window opens. Click the General tab if the (Form Object) Properties window is not already opened to this tab.
2. Clear the Initially Visible check box.
3. Click OK.

Placing a form object on the top layer
You can force a form object to always be on the top layer of the page. This is useful when you have multiple objects layered on your page.

To force a form object to the top layer:
1. Double-click on the form object within your work area. The (Form Object) Properties window opens. Click the General tab if the (Form Object) Properties window is not already opened to this tab.
2. Select the Always on Top check box.

If multiple objects are set to Always on Top, Lectora will refer to the ordering of the objects in the left-hand pane to determine which of the objects is on the top layer. The top-most object listed on the page in the left-hand pane is on the bottom layer of the page.

See also: Layering Objects
3. Click OK.

Locking the size and position of a form object
You can lock the size and position of a form object. This preserves it from getting accidentally moved by you or by other authors working on your title.

The object will be locked in size and position within Edit mode.

To lock the position and size of a form object:
1. Double-click on the form object within your work area. The (Form Object) Properties window opens. Click the General tab if the (Form Object) Properties window is not already opened to this tab.
2. Select the Size/Position Locked check box.
3. Click OK.

You can also lock the size and position of the form object by right-clicking on the form object within the left-hand pane (or within your work area) and selecting Size/Position Locked from the right-click context menu. When the object is locked, a check mark will appear to the left of the Size/Position Locked option within the menu.

See also: Locking and Unlocking Objects

Enabling author control on a form object
Protect the form object by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the form object unless they have the master Author Control password. The master Author Control password must first be set within the Title Properties.

See also: Protecting your title with a password
To enable author control on a form object:

1. Double-click on the form object within your work area. The (Form Object) Properties window opens. Click the General tab if the (Form Object) Properties window is not already opened to this tab.

2. Select the Author Control check box.

3. Click OK.

Retaining a form object's selection between sessions

You can enable Lectora to retain user selections made with form objects after the Lectora session is closed. If the user returns to the form object in a future session, the form object will retain the previously supplied selection.

To retain the form object's selection between sessions:

1. Double-click on the form object within your work area. The (Form Object) Properties window opens. Click the General tab if the (Form Object) Properties window is not already opened to this tab.

2. Select the Retain value between sessions check box.

3. Click OK.

Specifying a form object's position and size

You can directly set the position and size of a form object from within its properties.

To specify the position and size of a form object:

1. Double-click on the form object within your work area. The (Form Object) Properties window opens. Click the Position and Size tab.

2. Specify the following information. All measurements are based on pixels.

   - **X Coordinate**: Specify the horizontal distance of the form object relative to the top-left corner of the page.
   - **Y Coordinate**: Specify the vertical distance of the form object relative to the top-left corner of the page.
   - **Offset from right**: Select this to change the reference point (from the right) from which the form object is placed.
   - **Offset from bottom**: Select this to change the reference point (from the bottom) from which the form object is placed.
   - **Width**: Specify the width of the object.
   - **Height**: Specify the height of the object.

3. Click OK.

You can also specify the position of your form object directly from the status bar.

**See also:**
- Using the Status bar
- Moving and Resizing Objects
- Aligning and Positioning Objects

Specifying a condition for submitting form object data

If your form object is included in a form, and you intend on submitting the results of the form, you can specify a condition on form object data. When a condition is specified, the form data will not be submitted unless the condition is met. If a condition
is used, a condition message should be specified so users can complete the form appropriately.

See also: Displaying a conditional message

To specify a condition for submitting for object data:

1. Double-click on the form object within your work area. The (Form Object) Properties window opens. Click the **Condition** tab.

2. Select *Allow form object to be submitted ONLY if the following is TRUE*. Conditions require the use of a variable. Select the **Variable** from the list, select a **Relationship** and enter a **Value**. To input multiple conditions, click the **Multiple Conditions** button. Use the additional fields to specify other variables and relationships. If multiple conditions are defined, select whether **All of the Following** conditions or **Any of the Following** conditions should be true to execute the action specified on the **On Select/Change** tab.

   See also: Making an action conditional

3. Click **OK**.

Displaying a conditional message

If you have specified a condition for submitting form object data, you can further display a message to the user when the conditions are not met. This message notifies the user so they can complete the form appropriately.

To display a message when form object conditions are not met:

1. Double-click on the form object within your work area. The (Form Object) Properties window opens. Click the **Condition Message** tab.

2. Type the message you want to display to the user in the field provided.

3. Click **OK**.

Specifying a form object’s transitions

You can specify how a form object is displayed on a page. Transitions will produce a visual effect as the form object appears and disappears. You can select from over 20 different transitions. There is a **Slow** to **Fast** slider to determine the speed at which the transition takes place.

To specify the transition:

1. Double-click on the form object within your work area. The (Form Object) Properties window opens. Click the **Transitions** tab.

2. Specify the following information:

<table>
<thead>
<tr>
<th>Transition In</th>
<th>Transition (In) Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select this to enable a transition when displaying the form object as the page opens or the form object is made visible with an action.</td>
<td></td>
</tr>
<tr>
<td>Select a transition type as one of the following:</td>
<td></td>
</tr>
<tr>
<td>- Box In</td>
<td></td>
</tr>
<tr>
<td>- Box Out</td>
<td></td>
</tr>
<tr>
<td>- Circle In</td>
<td></td>
</tr>
<tr>
<td>- Circle Out</td>
<td></td>
</tr>
<tr>
<td>- Wipe Up</td>
<td></td>
</tr>
<tr>
<td>- Wipe Down</td>
<td></td>
</tr>
<tr>
<td>- Wipe Right</td>
<td></td>
</tr>
<tr>
<td>- Split out Horizontal</td>
<td></td>
</tr>
<tr>
<td>- Strips Down left</td>
<td></td>
</tr>
<tr>
<td>- Strips Up left</td>
<td></td>
</tr>
<tr>
<td>- Strips Downright</td>
<td></td>
</tr>
<tr>
<td>- Strips Upright</td>
<td></td>
</tr>
<tr>
<td>- Horizontal Bars</td>
<td></td>
</tr>
<tr>
<td>- Vertical Bars</td>
<td></td>
</tr>
</tbody>
</table>
Wipe Left  ●  Fly Top
Blinds Vertical   ●  Fly Top right
Blinds Horizontal ●  Fly Right
Checker Across   ●  Fly Bottom right
Checker Down     ●  Fly Bottom
Dissolve         ●  Fly Bottom left
Split in Vertical●  Fly Left
Split out Vertical●  Fly Top left
Split in Horizontal●  Random Effect

Delay before transition Specify the delay in seconds before starting the transition. Select between 0 and 600 seconds.

Slow > Fast Use the slider to specify the speed at which the transition should occur.

Transition Out Select this to enable a transition when hiding the form object as the page closes or the form object is hidden with an action.

Transition (Out) Type Select a transition type as one of the following:

- Box In  ●  Split out Horizontal
- Box Out ●  Strips Down left
- Circle In ●  Strips Up left
- Circle Out ●  Strips Downright
- Wipe Up ●  Strips Upright
- Wipe Down ●  Horizontal Bars
- Wipe Right ●  Vertical Bars
- Wipe Left ●  Fly Top
- Blinds Vertical ●  Fly Top right
- Blinds Horizontal ●  Fly Right
- Checker Across ●  Fly Bottom right
- Checker Down ●  Fly Bottom
- Dissolve ●  Fly Bottom left
- Split in Vertical ●  Fly Left
- Split out Vertical ●  Fly Top left
- Split in Horizontal ●  Random Effect

Delay before transition Specify the delay in seconds before starting the transition. Select between 0 and 600 seconds.

Slow > Fast Use the slider to specify the speed at which the transition should occur.

3. Click OK.

Adding a Radio Button Group
Radio button groups are logical objects because they have no physical representation on a page. Radio button groups are used to group individual radio buttons. When a set of radio buttons is placed within a radio button group, the user will only be able to select one of the radio buttons contained within the group.

To add a radio button group:
1. Select the form or page in the left-hand pane to which you want to add the radio button group and do one of the following:
   ○ From the Add menu, select Object > Form Object > Radio Button Group
Click the **Radio Button Group** toolbar graphic.

Right-click and select New > Object > Form Object > Radio Button Group

Type Ctrl+Alt+3

The Radio Group Properties window opens.

2. Use the tabs on the Radio Group Properties window to complete these tasks:

**General tab**
- Change the name of a radio button group
- Change the associated variable name of a radio button group
- Retain the radio button group's selection between sessions
- Enable author control on a radio button group

**Condition tab**
- Specify a condition for submitting the radio button group data

**Condition Message tab**
- Display a message when the conditions for submitting radio button group data are not met

**Transition tab**
- Specifying a radio button group's transitions

**On Select/Change tab**
- Execute an action when a radio button group is used

### Changing the associated variable name of a radio button group

The associated variable of a radio button group takes on the value specified for the radio button chosen by the user. For example, if the radio button group's associated variable name is `Age_Range`, and within it are 5 radio buttons with the options Under 21, 21-30, 31-45, 45-60, and Over 60, then when the user selects from the available radio buttons, the `Age_Range` variable will take on the value of that radio button. Suppose the user selects 21-30, then `Age_Range = 21-30`. If no selection is made, the variable remains empty (has no value).

To change the associated variable name of a radio button group:
1. Double-click on the radio button group graphic within your left-hand pane. The Radio Group Properties window opens.
   - Click the **General** tab if the Radio Group Properties window is not already opened to this tab.
2. Specify the associated variable name in the **Associated Variable Name** field. This name must be unique to all existing variable names. Variable names cannot contain spaces or special characters. The variable will be used to store the user's selection within the radio button group. The variable can be accessed from anywhere in the title.

   The name/value pair submitted from the published title using email or CGI is the radio button group's associated variable name and its value.

   **See also:** Submitting Test, Survey and Form Results to CGI

3. Click **OK**.

### Executing an action when a radio button group is used

You can execute an action anytime a user makes a selection within a radio button group. The action selected will execute when a user clicks on any of the radio buttons contained within the radio button group.

**See also:** About Actions

To execute an action when a radio button group is used:
1. Double-click on the radio button group graphic within your left-hand pane. The Radio Group Properties window opens.
   - Click the **On Select/Change** tab.
2. Use the **Action** list to select from the following actions:

   **See also:** Selecting an action

   The **Target** field is enabled when the action requires a target. Specify additional information as necessary.

   **See also:** Selecting an action's target

3. Click **OK**.

**Adding a Radio Button**

Radio buttons are input objects that enable users to select a specified option. Radio buttons can be added to any form or page. When radio buttons are contained within a radio button group, users will only be able to select one of the radio buttons.

   **See also:** Adding a Radio Button Group

You can customize the appearance of radio buttons within your title. Set the desired appearance of your radio buttons within your Lectora Preferences.

To add a radio button:

1. Select the radio button group, form, or page in the left-hand pane to which you want to add the radio button and do one of the following:
   - From the **Add** menu, select **Object > Form Object > Radio Button**
   - Click the **Radio Button** toolbar graphic on the Form toolbar
   - Right-click and select **New > Object > Form Object > Radio Button**
   - Type **Ctrl+Alt+4**

   The Radio Button Properties window opens.

2. Use the tabs on the Radio Button Properties window to complete these tasks:

   **General tab**
   - Change the name of a radio button
   - Change the associated variable name of a radio button
   - Specify the label for a radio button
   - Make a radio button initially invisible
   - Place a radio button on the top layer
   - Lock the size and position of a radio button
   - Enable author control on a radio button
   - Place the radio button label on the left side
   - Set a radio button to be selected by default
   - Retain the radio button's value between sessions

   **Position and Size tab**
   - Specify the radio button's position and size

   **On Select/Change tab**
   - Execute an action when a radio button is selected

   **Condition tab**
   - Specify a condition for submitting the radio button data

   **Condition Message tab**
   - Display a message when the conditions for submitting radio button data are not met

   **Transition tab**
   - Specifying a radio button's transitions

**Changing the associated variable name of a radio button**

Radio buttons contained in a radio button group do not have an associated variable. The radio button group will have the variable used to hold the value of the selected radio button. If the radio button is not contained within a radio button group, the
Radio button has an associated variable. The associated variable will take on a value of "on" if the radio button is selected, and otherwise will remain empty (have no value).

To change the associated variable name of a radio button group:
1. Double-click on the radio button graphic within your left-hand pane. The Radio Button Properties window opens. Click the General tab if the Radio Button Properties window is not already opened to this tab.
2. Specify the associated variable name in the Associated Variable Name field. This name must be unique to all existing variable names. Variable names cannot contain spaces or special characters. The variable will be used to store a value of "on" if the user has selected the corresponding radio button.

The name/value pair submitted from the published title using email or CGI is the radio button's associated variable name and its value.

See also: Submitting Test, Survey and Form Results to CGI

3. Click OK.

Specifying the label for a radio button
You can specify the textual label to appear with the radio button. This is the text that will appear next to the radio button. By default, the label is placed to the right of the radio button, however you can also place it to the left of the radio button.

See also: Placing the radio button label on the left side

To specify the label for a radio button:
1. Double-click on the radio button graphic within your left-hand pane. The Radio Button Properties window opens. Click the General tab if the Radio Button Properties window is not already opened to this tab.
2. Specify the label for the radio button in the Label field.
3. Click OK.

Placing the radio button label on the left side
By default, the textual label associated with a radio button is placed to the right of the radio button.

To place the radio button label to the left of a radio button:
1. Double-click on the radio button graphic within your left-hand pane. The Radio Button Properties window opens. Click the General tab if the Radio Button Properties window is not already opened to this tab.
2. Select the Text on left side check box.
3. Click OK.

Setting a radio button to be selected by default
You can set a radio button to be automatically selected. The radio button is selected when the control is displayed to the user.

To set a radio button to be selected by default:
1. Double-click on the radio button graphic within your left-hand pane. The Radio Button Properties window opens. Click the General tab if the Radio Button Properties window is not already opened to this tab.
2. Select the Initially selected check box.
3. Click OK.
Executing an action when a radio button is selected
You can execute an action anytime a user selects a radio button. The action selected will execute when the user selects the corresponding radio button.

See also: About Actions

To execute an action when a radio button is selected:
1. Double-click on the radio button graphic within your left-hand pane. The Radio Button Properties window opens. Click the On Select/Change tab.

2. Use the Action list to select from the following actions:

See also: Selecting an action

The Target field is enabled when the action requires a target. Specify additional information as necessary.

See also: Selecting an action's target

3. Click OK.

Adding a Check Box
Check boxes are input objects that enable users to select and clear a specified option. Check boxes can be added to any form or page.

You can customize the appearance of check boxes within your title. Set the desired appearance of your check boxes within your Lectora Preferences.

To add a check box:
1. Select the form, or page in the left-hand pane to which you want to add the check box and do one of the following:
   o From the Add menu, select Object > Form Object > Check Box
   o Click the Check Box toolbar graphic on the Form toolbar
   o Right-click and select New > Object > Form Object > Check Box
   o Type Ctrl+Alt+5

The Check Box Properties window opens.

2. Use the tabs on the Check Box Properties window to complete these tasks:

General tab
- Change the name of a check box
- Change the associated variable name of a check box
- Specify the label for a check box
- Make a check box initially invisible
- Place a check box on the top layer
- Lock the size and position of a check box
- Enable author control on a check box
- Place the check box label on the left side
- Set a check box to be selected by default
- Retain the check box's value between sessions

Position and Size tab
- Specify the check box's position and size

On Select/Change tab
- Execute an action when a check box is selected

Condition tab
- Specify a condition for submitting the check box data

Condition Message tab
- Display a message when the conditions for submitting check box data are not met
Changing the associated variable name of a check box
Check boxes have an associated variable that will store whether the check box has been checked. The associated variable will take on a value of "on" if the check box is selected, and otherwise will remain empty (have no value).

To change the associated variable name of a check box:
1. Double-click on the check box graphic within your left-hand pane. The Check Box Properties window opens. Click the General tab if the Check Box Properties window is not already opened to this tab.
2. Specify the associated variable name in the Associated Variable Name field. This name must be unique to all existing variable names. Variable names cannot contain spaces or special characters. The variable will be used to store a value of "on" if the user has selected the corresponding check box.

The name/value pair submitted from the published title using email or CGI is the check box's associated variable name and its value.

See also: Submitting Test, Survey and Form Results to CGI

3. Click OK.

Specifying the label for a check box
You can specify the textual label to appear with the check box. This is the text that will appear next to the check box. By default, the label is placed to the right of the check box, however you can also place it to the left of the check box.

See also: Placing the check box label on the left side

To specify the label for a check box:
1. Double-click on the check box graphic within your left-hand pane. The Check Box Properties window opens. Click the General tab if the Check Box Properties window is not already opened to this tab.
2. Specify the label for the check box in the Label field.
3. Click OK.

Placing the check box label on the left side
By default, the textual label associated with a check box is placed to the right of the check box.

To place the check box label to the left of a check box:
1. Double-click on the check box graphic within your left-hand pane. The Check Box Properties window opens. Click the General tab if the Check Box Properties window is not already opened to this tab.
2. Select the Text on left side check box.
3. Click OK.

Setting a check box to be selected by default
You can set a check box to be automatically selected. The check box is checked when the control is displayed to the user.

To set a check box to be selected by default:
1. Double-click on the check box graphic within your left-hand pane. The Check Box Properties window opens. Click the **General** tab if the Check Box Properties window is not already opened to this tab.

2. Select the **Initially selected** check box.

3. Click **OK**.

### Executing an action when a check box is selected

You can execute an action anytime a user selects or clears a check box. The action selected will execute when the user selects the corresponding check box, either to select it or clear it.

*See also:* [About Actions](#)

To execute an action when a check box is selected:

1. Double-click on the check box graphic within your left-hand pane. The Check Box Properties window opens. Click the **On Select/Change** tab.

2. Use the **Action** list to select from the following actions:

*See also:* [Selecting an action](#)

The **Target** field is enabled when the action requires a target. Specify additional information as necessary.

*See also:* [Selecting an action's target](#)

3. Click **OK**.

### Adding an Entry Field

Entry fields are input objects that enable users to type a value. Entry fields can be added to any form or page.

To add an entry field:

1. Select the form, or page in the left-hand pane to which you want to add the entry field and do one of the following:
   - From the **Add** menu, select **Object > Form Object > Entry Field**
   - Click the **Entry** toolbar graphic on the Form toolbar
   - Right-click and select **New > Object > Form Object > Entry Field**
   - Type **Ctrl+Alt+6**

   The Entry Field Properties window opens.

2. Use the tabs on the Entry Field Properties window to complete these tasks:

   **General tab**
   - Change the name of an entry field
   - Change the associated variable name of an entry field
   - Specify default text for an entry field
   - Specify a background color for an entry field
   - Specify the maximum number of characters for an entry field
   - Make an entry field initially invisible

   **Position and Size tab**
   - Specify an entry field's position and size

   **On Select/Change tab**
   - Execute an action when a user types within an entry field

   **Condition tab**
   - Specify a condition for submitting the entry field data

   **Condition Message tab**
Changing the associated variable name of an entry field

Entry fields have an associated variable that will store the value that a user types into the entry field.

To change the associated variable name of an entry field:

1. Double-click on the entry field graphic within your left-hand pane. The Entry Field Properties window opens. Click the General tab if the Entry Field Properties window is not already opened to this tab.

2. Specify the associated variable name in the Associated Variable Name field. This name must be unique to all existing variable names. Variable names cannot contain spaces or special characters. The variable will be used to store the value the user types into the entry field.

   The name/value pair submitted from the published title using email or CGI is the entry field's associated variable name and its value.

   See also: Submitting Test, Survey and Form Results to CGI

3. Click OK.

Specifying default text for an entry field

You can specify default text for an entry field. The default text will appear within the entry field when the control is displayed to the user.

To specify default text for an entry field:

1. Double-click on the entry field graphic within your left-hand pane. The Entry Field Properties window opens. Click the General tab if the Entry Field Properties window is not already opened to this tab.

2. Specify the default text in the Default text field.

3. Click OK.

Specifying a background color for an entry field

To specify a background color for an entry field:

1. Double-click on the entry field graphic within your left-hand pane. The Entry Field Properties window opens. Click the General tab if the Entry Field Properties window is not already opened to this tab.

2. Select a background color from the Default background color list. The default color is white. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

   See also: Matching Colors Used within Your Title

3. Click OK.
Specifying the maximum number of characters for an entry field
You can specify the maximum number of characters users can type into an entry field.

To specify the maximum number of characters for an entry field:
1. Double-click on the entry field graphic within your left-hand pane. The Entry Field Properties window opens. Click the General tab if the Entry Field Properties window is not already opened to this tab.
2. Enter the maximum number of characters in the Maximum characters allowed field. Users will not be able to type more than the maximum number of characters in the field.
3. Click OK.

Creating a multi-line entry field
You can enable your entry field to accept multiple lines of text. Instead of only being able to type a single line of text, users will be able to supply multiple lines or an entire paragraph.

To create a multi-line entry field:
1. Double-click on the entry field graphic within your left-hand pane. The Entry Field Properties window opens. Click the General tab if the Entry Field Properties window is not already opened to this tab.
2. Select the Multi-line check box.
3. Click OK.

Creating a password entry field
You can specify that your entry field will be used for a password. When you select this option, an asterisk (*) will be displayed for every character the user types within the entry field. The value of the associated variable will reflect the actual characters typed into the field.

See also: Changing the associated variable name of an entry field

To create a password entry field:
1. Double-click on the entry field graphic within your left-hand pane. The Entry Field Properties window opens. Click the General tab if the Entry Field Properties window is not already opened to this tab.
2. Select the Password field check box.
3. Click OK.

Creating a read-only entry field
You can set an entry field to be read-only. That is, users will be able to see the value within the entry field, but they will not be able to change it.

To create a read-only entry field:
1. Double-click on the entry field graphic within your left-hand pane. The Entry Field Properties window opens. Click the General tab if the Entry Field Properties window is not already opened to this tab.
2. Select the Read Only check box.
3. Click OK.

Executing an action when a user types within an entry field
You can execute an action anytime a user types a character within an entry field.

See also: About Actions

To execute an action when a user types within an entry field:
1. Double-click on the entry field graphic within your left-hand pane. The Entry Field Properties window opens. Click the On Select/Change tab.
2. Use the Action list to select from the following actions:

   See also: Selecting an action

   The Target field is enabled when the action requires a target. Specify additional information as necessary.

   See also: Selecting an action’s target
3. Click OK.

Adding a Drop-Down List
Drop-down lists are input objects that enable users to select a value from a list of pre-defined values. Drop-down lists can be added to any form or page.

To add a drop-down list:
1. Select the form, or page in the left-hand pane to which you want to add the drop-down list and do one of the following:
   o From the Add menu, select Object > Form Object > Drop-Down List
   o Click the Drop-Down List toolbar graphic on the Form toolbar
   o Right-click and select New > Object > Form Object > Drop-Down List
   o Type Ctrl+Alt+7

   The Drop-down List Properties window opens.

2. Use the tabs on the Drop-Down List Properties window to complete these tasks:

   General tab
   - Change the name of a drop-down list
   - Change the associated variable name of a drop-down list
   - Specify a background color for a drop-down list
   - Make a drop-down list initially invisible
   - Place a drop-down list on the top layer
   - Lock the size and position of a drop-down list
   - Enable author control on a drop-down list
   - Retain the drop-down list’s value between sessions
   - Add items to a drop-down list
   - Specify the default value of a drop-down list

   Position and Size tab
   - Specify a drop-down list’s position and size

   On Select/Change tab
   - Execute an action when a user makes a selection from a drop-down list

   Condition tab
   - Specify a condition for submitting the drop-down list data

   Condition Message tab
   - Display a message when the conditions for submitting drop-down list data are not met

   Transition tab
   - Specifying a drop-down list's transitions

Changing the associated variable name of a drop-down list
Drop-down lists have an associated variable that will store the value a user selects from the drop-down list.

To change the associated variable name of a drop-down list:
1. Double-click on the drop-down list graphic within your left-hand pane. The Drop-down List Properties window opens. Click the General tab if the Drop-down List Properties window is not already opened to this tab.

2. Specify the associated variable name in the Associated Variable Name field. This name must be unique to all existing variable names. Variable names cannot contain spaces or special characters. The variable will be used to store the value the user selects from the drop-down list.

   The name/value pair submitted from the published title using email or CGI is the drop-down list's associated variable name and its value.

   See also: Submitting Test, Survey and Form Results to CGI

3. Click OK.

Specifying a background color for a drop-down list
To specify a background color for a drop-down list:
1. Double-click on the drop-down list graphic within your left-hand pane. The Drop-down List Properties window opens. Click the General tab if the Drop-down List Properties window is not already opened to this tab.

2. Select a background color from the Default background color list. The default color is white. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

   See also: Matching Colors Used within Your Title

3. Click OK.

Adding items to a drop-down list
You specify the list of items that users can choose from within a drop-down list. You can add as many or as few items as you want, and you can further reorganize and delete items from the list.

To add items to a drop-down list:
1. Double-click on the drop-down list graphic within your left-hand pane. The Drop-Down List Properties window opens. Click the General tab if the Drop-Down List Properties window is not already opened to this tab.

2. Click the Add button. The Initial Values window opens. Type the values you want within your drop-down list in the space provided. Separate different values by pressing the Enter key on your keyboard. Each new line of text is a new value that can be selected from the drop-down list.

   Repeat steps 2 and 3 to add additional items to your drop-down list.

3. Click OK to accept your changes and return to the Drop-Down List Properties window.

4. The values you entered are displayed in the list on the bottom-left of the Drop-Down List Properties window. Each has a check box located to its left. Highlight any of the items in the list to reorganize or remove the items. To remove an item from the list, highlight the item and click the Remove button. To reorganize the list of items, highlight the item you want to move within the list and click either the Move Up or Move Down button. The Move Up button will move the item one place higher in the list, while the Move Down button will move the item one place lower in the list.

5. Click OK.
Specifying the default value of a drop-down list
You can specify if one of the values contained in a drop-down list should be selected by default. The default value will appear selected within the drop-down list when the control is displayed to the user.

To specify the default value of a drop-down list:
1. Double-click on the drop-down list graphic within your left-hand pane. The Drop-Down List Properties window opens. Click the General tab if the Drop-Down List Properties window is not already opened to this tab.

2. To specify which of the drop-down list's values should be used as the default, select the check box next to the appropriate value within the list of possible values. Only one item can be specified as the default. The list of values is only available if you have already populated your drop-down list.

*See also:* [Adding items to a drop-down list](#)

3. Click OK.

Executing an action when a user makes a selection from a drop-down list
You can execute an action any time a user makes a selection from a drop-down list.

*See also:* [About Actions](#)

To execute an action when a user makes a selection from a drop-down list:
1. Double-click on the drop-down list graphic within your left-hand pane. The Drop-Down List Properties window opens. Click the On Select/Change tab.

2. Use the Action list to select from the following actions:

*See also:* [Selecting an action](#)

   The Target field is enabled when the action requires a target. Specify additional information as necessary.

*See also:* [Selecting an action's target](#)

3. Click OK.

Adding a List Box
List boxes are input objects that enable users to select one or more values from a list of pre-defined values. List boxes can be added to any form or page.

To add a list box:
1. Select the form, or page in the left-hand pane to which you want to add the list box and do one of the following:
   - From the Add menu, select Object > Form Object > List Box
   - Click the List Box toolbar graphic on the Form toolbar
   - Right-click and select New > Object > Form Object > List Box
   - Type Ctrl+Alt+8

   The List Box Properties window opens.

2. Use the tabs on the List Box Properties window to complete these tasks:

   General tab

   Position and Size tab
Changing the associated variable name of a list box

List boxes have an associated variable that will store the value a user selects from the list box. If multiple items are selected in a list box, the value of the associated variable will be a comma-separated list of the list items selected.

To change the associated variable name of a list box:

1. Double-click on the list box graphic within your left-hand pane. The List Box Properties window opens. Click the General tab if the List Box Properties window is not already opened to this tab.

2. Specify the associated variable name in the Associated Variable Name field. This name must be unique to all existing variable names. Variable names cannot contain spaces or special characters. The variable will be used to store the values selected from the list box.

   The name/value pair submitted from the published title using email or CGI is the list box's associated variable name and its value.

   See also: Submitting Test, Survey and Form Results to CGI

3. Click OK.

Specifying a background color for a list box

To specify a background color for a list box:

1. Double-click on the list box graphic within your left-hand pane. The List Box Properties window opens. Click the General tab if the List Box Properties window is not already opened to this tab.

2. Select a background color from the Default background color list. The default color is white. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

   See also: Matching Colors Used within Your Title

3. Click OK.

Enabling multiple selections within a list box

You can enable the selection of multiple items within a list box. When this is enabled, users will be able to select multiple items in the list box while holding down the Ctrl key.
To enable multiple selections within a list box:
1. Double-click on the list box graphic within your left-hand pane. The List Box Properties window opens. Click the General tab if the List Box Properties window is not already opened to this tab.
2. Select the Allow multi-select check box.
3. Click OK.

**Adding items to a list box**
You specify the list of items that users can choose from within a list box. You can add as many or as few items as you want, and you can further reorganize and delete items from the list.

To add items to a list box:
1. Double-click on the list box graphic within your left-hand pane. The List Box Properties window opens. Click the General tab if the List Box Properties window is not already opened to this tab.
2. Click on the Add button. The Initial Values window opens. Type the values you want within your list box in the space provided. Separate different values by pressing the Enter key on your keyboard. Each new line of text is a new value that can be selected from the list box.
3. Click OK to accept your changes and return to the List Box Properties window.
4. The values you entered are displayed in the list on the bottom-left of the List Box Properties window. Each has a check box located to its left. Highlight any of the items in the list to reorganize or remove the items. To remove an item from the list, highlight the item and click the Remove button. To reorganize the list of items, highlight the item you want to move within the list and click either the Move Up or Move Down button. The Move Up button will move the item one place higher in the list, while the Move Down button will move the item one place lower in the list.
    Repeat steps 2 and 3 to add additional items to your list box.
5. Click OK.

**Specifying the default value of a list box**
You can specify if one or more (if multiple selections is enabled) of the values contained in a list box should be selected by default. The default value will appear selected within the list box when the control is displayed to the user.

See also: [Enabling multiple selections within a list box](#)

To specify the default value of a list box:
1. Double-click on the list box graphic within your left-hand pane. The List Box Properties window opens. Click the General tab if the List Box Properties window is not already opened to this tab.
2. To specify which of the list box’s values should be used as the default, select the check box next to the appropriate value within the list of possible values. Only one value can be specified as the default, unless multiple selections is enabled for the list box. The list of values is only available if you have already populated your list box.
    See also: [Adding items to a list box](#)
3. Click OK.

**Executing an action when a user makes a selection from a list box**
You can execute an action any time a user makes a selection within a list box.
To execute an action when a user makes a selection from a list box:

1. Double-click on the list box graphic within your left-hand pane. The List Box Properties window opens. Click the On Select/Change tab.

2. Use the Action list to select from the following actions:

See also: Selecting an action

The Target field is enabled when the action requires a target. Specify additional information as necessary.

See also: Selecting an action's target

3. Click OK.

Actions and Variables

Actions and variables can be used to create interesting titles with varying interactivity and dynamically updated information.

This chapter covers the following topics:
- About Actions
- Adding an Action
- Working with Variables

About Actions

Three components make up an action:

- **On**: Specifies which event should trigger an action, such as a keystroke or a mouse click.
- **Action**: Specifies what should happen when the **On** trigger occurs, such as display a message, launch a program, or cancel a test.
- **Target**: Specifies a target used by the action. Targets can be chapters, sections, pages, tests, surveys, questions, objects, or variables. The **Action** defines which targets can be used.

These three parts work together to create the end result. Depending on where you are adding an action, the options available to you will vary.

Actions added to organizational levels including the title, chapters, sections, pages, tests, test sections and surveys adhere to the same inheritance principles as other objects within your title. That is, if an action is added to the title level, the action will execute on every page of the title if the action is triggered. Similarly, if an action is added to a chapter, section, test, survey or test section, it will execute on every page within the chapter, section, test, survey, or test section, respectively, if the action is triggered. Finally, if an action is added to a page, it will only execute on that page if the action is triggered.

See also: Understanding inheritance

The following table lists all events, actions, and targets available in your title:

<table>
<thead>
<tr>
<th>On</th>
<th>Action</th>
<th>Target</th>
</tr>
</thead>
<tbody>
<tr>
<td>Keystroke</td>
<td>Cancel Test/Survey</td>
<td>Back</td>
</tr>
<tr>
<td>Mouse Click</td>
<td>Change Contents</td>
<td>Chapter, Section, or Page</td>
</tr>
<tr>
<td>Mouse Double-Click</td>
<td>Display Message</td>
<td>Next Chapter, Page, or Section</td>
</tr>
<tr>
<td>Mouse Enter</td>
<td>Exit Title/Close Window</td>
<td>Current Page</td>
</tr>
</tbody>
</table>
### Adding an Action
You can add actions to the organizational levels of your title (chapters, sections, and pages) and to objects within your title. Actions are dependent upon 3 major parts: the on event, the action, and the target.

**See also:** [About Actions](#)

To add an action to your title:

1. In the left-hand pane, select the location onto which you want to add an action and do one of the following.
   - From the **Add** menu, select **Action**
   - Click the **Action** toolbar graphic on the Insert toolbar
   - Right-click and select **New > Action**
   - Type `Ctrl+4`

   The Action Properties Window opens.

2. Use the tabs on the Action Properties window to complete these tasks:

   **General tab**
   - [Change the name of an action](#)
   - [Select an action's trigger](#)
   - [Select an action](#)
   - [Select an action's target](#)
   - [Delay an action](#)

   **Condition tab**
   - [Make an action conditional](#)

   **Else tab**
   - [Execute an alternative action when conditions are not met](#)
Enable author control on an action

When you have completed defining your action, you can preview the functionality of the action within your title by clicking the Run Mode or Preview Mode toolbar graphic on the Mode bar. You can also preview the functionality of the action within your title by clicking the Debug Mode toolbar graphic on the Mode bar. This will also launch the Debug Window, which will display when the action was fired and any variable manipulations that occur with the action.

See also: Using Lectora's Modes

Changing the name of an action
To change the name of an action:

1. Double-click on the action graphic of the action you want to change within your left-hand pane. The Action Properties window opens. Click the General tab if the Action Properties window is not already opened to this tab.

2. Specify the new name of the action in the Action Name field.

3. Click OK.

Selecting an action's trigger
The action trigger determines when an action is executed. Different action triggers are available based on the location to which you are adding an action.

Use the On list within the Action Properties window to select from the following triggers:

<table>
<thead>
<tr>
<th>On Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any Key</td>
<td>Executes the action when the user presses any key on his or her keyboard. Actions with this trigger can only be applied to organizational levels such as the title, chapters, sections, pages, tests, test sections, and surveys.</td>
</tr>
<tr>
<td>Done Playing</td>
<td>Executes the action when a media object (such as a video) to which the action is attached, has completed playing. The action will only execute in titles published to the Web if the media is converted to Flash. Actions with this trigger can also be applied to timer progress bars. When the time specified within the timer progress bar has elapsed, the action will execute.</td>
</tr>
<tr>
<td>Hide</td>
<td>Executes the action when an object to which the action is attached, is hidden. This trigger can also be used to execute an action when navigating off of a page and can be applied to organizational levels such as the title, chapters, sections, pages, tests, test sections, and surveys.</td>
</tr>
<tr>
<td>Keystroke</td>
<td>Executes the action when the user presses a specified key on his or her keyboard. Click the Next Key Typed button, and press the key you want to execute the action. Key combinations using the Shift, Alt, and Ctrl keys are accepted. This will capture the keystroke for the action. Actions with this trigger can only be applied to organizational levels such as the title, chapters, sections, pages, tests, test sections, and surveys.</td>
</tr>
</tbody>
</table>
| Mouse Click | Executes the action when a user clicks his or her left mouse button on the object or page to which the action is attached. This trigger cannot be applied to organizational levels such as the title, chapters, sections, pages, tests, test sections, and surveys if the title is
being published to the Web.

**Mouse Double Click**
Executes the action when a user double clicks his or her left mouse button on the object or page to which the action is attached. This trigger cannot be applied to organizational levels such as the title, chapters, sections, pages, tests, test sections, and surveys if the title is being published to the Web.

**Mouse Enter**
Executes the action when a user places the mouse cursor over the object to which the action is attached. This trigger cannot be applied to organizational levels such as the title, chapters, sections, pages, tests, test sections, and surveys.

**Mouse Exit**
Executes the action when a user moves the mouse cursor off of the object to which the action is attached. This trigger cannot be applied to organizational levels such as the title, chapters, sections, pages, tests, test sections, and surveys.

**Show**
Executes the action when an object to which the action is attached, is displayed. This trigger can also be used to execute an action when navigating on to a page and can be applied to organizational levels such as the title, chapters, sections, pages, tests, test sections, and surveys.

**Right Mouse Click**
Executes the action when a user clicks his or her right mouse button on the object or page to which the action is attached. This trigger cannot be applied to organizational levels such as the title, chapters, sections, pages, tests, test sections, and surveys if the title is being published to the Web.

**Timer**
Executes the action continuously on a specified time interval. When this is selected, specify the time interval (in seconds) by typing a value in the **Time Interval** field.

### Selecting an action
The action determines what action will be taken when the specified **On** trigger has occurred. Different actions are available based on the trigger selected.

**On** triggers do not apply to actions specified within button, form object, test or survey properties.

Use the **Action** list within the Action Properties window to select from the following actions:

<table>
<thead>
<tr>
<th>Action Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cancel Test/Survey</strong></td>
<td>This action cancels the target test or survey and causes the <strong>When Canceled/Failed</strong> action within the target test’s or target survey’s properties to execute.</td>
</tr>
<tr>
<td><strong>See also:</strong></td>
<td>Setting the resulting action when a test is failed</td>
</tr>
<tr>
<td></td>
<td>Setting the resulting action when a survey is canceled</td>
</tr>
<tr>
<td><strong>Change Contents</strong></td>
<td>This action changes the contents of the object to which the action is applied and replaces it with the target object specified. This action can be used to change the contents of a text block to a specified variable value or can be used to change images, audio, video and other objects.</td>
</tr>
<tr>
<td><strong>Display Message</strong></td>
<td>This action can be used to display two different types of messages. You can display specified text in a generic message box or you can display one of your title’s pages in a pop-up window.</td>
</tr>
<tr>
<td></td>
<td>To display specified text in a generic message box, select <strong>Standard Message Window</strong> and specify the custom message.</td>
</tr>
<tr>
<td></td>
<td>To display one of your title's pages in a pop-up window, select <strong>Custom Message Window</strong> and select the page you want to display. If the location selected is scrollable, you can also choose to</td>
</tr>
</tbody>
</table>
automatically scroll to an object on the page. Select the object from the Scroll To list. If the content on the page fits within the viewing window without requiring a scrollbar, this setting has no effect. When the action is executed, it will display the page with the scroll point at the top of the window.

**Exit Title/Close Window**
This action exits the title if it is executed from the main window presenting the title or closes the current window if it is executed from a secondary or pop-up window.

**Flash Command**
This action enables communications with a Flash animation and is only available if a Flash animation exists in the location to which you are adding the action. When you select this option, further specify the Flash command and additional information as necessary.

*See also:* Executing Flash commands

**Go To**
This action navigates to the target location specified. When you select this option, you can further specify if the target location should be opened in a separate window.

*See also:* Executing Go To actions

**Hide**
This action causes the target object to become hidden if it is currently visible. When the target object is hidden, the selected transition (out) will be applied to the target object.

*See also:* Specifying an object's transitions

**Launch a Program/Document**
This action will launch the specified program or document. You can launch one of the additional files contained within your title, or you can specify a relative or fully qualified Web address of the file you want to launch.

To display an additional file, select the **Use Attached File** check box and select the file from the **Attached File** list. If you have not yet added the additional file, click the **Add File** button to navigate and select the file you want to add.

*See also:* Adding additional files to your title

To specify a relative or fully qualified Web address of the file you want to launch, specify the file's location in the **Program/Document** field.

**Mail To**
This action launches the user's email application and creates a new email to the address specified in the **Email Address** field.

This action requires that each user have an email client, such as Microsoft Outlook, on the computer from which they are accessing the published title. In addition, the email server must be configured to accept communications from the published title's location, so the email can be successfully submitted.

**Modify Variable**
This action enables you to set or change the value of a variable.

*See also:* Modifying variable values

**Move To**
This action repositions the target object to a specified **X Coordinate** and **Y Coordinate** at the **Animation Speed** you select. You can directly specify the coordinates, specify random coordinates, or specify the value of an existing variable to use for either coordinate.

To specify a random X or Y coordinate, enter `RAND(min, max)` in the **X Coordinate** or **Y Coordinate** field. The random number assigned will be greater than or equal to the `min` value specified and less than or equal to the `max` value specified. The random number generated will be used to reposition the object to the new **X Coordinate** or **Y Coordinate**.
To specify the value of an existing variable to use for the X or Y coordinate, enter \texttt{VAR(Variable\_Name)} in the \texttt{X Coordinate} or \texttt{Y Coordinate} field, where \texttt{Variable\_Name} is the name of the variable whose value will be used to reposition the object to the new \texttt{X Coordinate} or \texttt{Y Coordinate}.

Use the \textbf{Animation Speed} slider to select a speed from \textbf{Slow} to \textbf{Fast}.

**None**
This action does nothing. This is the default action.

**Pause**
This action causes the target media object such as a video or audio clip to pause, if it is currently playing.

**Play**
This action causes the target media object such as a video or audio clip to begin playing, if it is not already playing. This action can also be used to begin a timer progress bar.

\textit{See also:} \texttt{Working with Progress Bars}

**Print Current Page**
This action will launch the user's Print window, enabling the user to print the current page.

**Process Question**
This action processes the target question. Processing the question includes determining whether the answer is correct or incorrect and displaying the corresponding feedback (if any) defined within the question properties.

\textit{See also:} \texttt{Adding Questions}

**Reset All Variables**
This action causes all the variables contained in the title (except for the read-only, reserved variables) to be reset to their initial or default values. This will reset all test results, questions, and form objects.

**Reset Form**
This action causes all the form objects of the target form to be reset to their initial or default values.

**Reset Question**
This action resets the target question. This will clear the question's answer if it was previously supplied, and reset the question back to its default, unanswered state.

**Reset Test/Survey**
If the target is a test, this action causes the test score to be reset to 0, and will reset all of the questions contained within the test to their default, unanswered state. If the target test is randomized, the action will additionally cause the test pages to be re-randomized.

If the target is a survey, this action will reset all of the survey questions contained within the survey to their default, unanswered state.

**Run Action Group**
This action starts the target action group (a group containing only actions). The actions contained within the action group will begin executing one-by-one, from top to bottom, as the actions are listed within the group in the left-hand pane.

\textit{See also:} \texttt{Grouping and Ungrouping Objects}

**Set Progress**
This action sets the target custom progress bar to a specified \textbf{Position}. This position is relative to the \textbf{Range} specified within the target progress bar's properties. You can directly specify a position, specify a random position, or specify the value of an existing variable to use for the position.

To specify a random position, enter \texttt{RAND(min, max)} in the \textbf{Position} field. The random number assigned will be greater than or equal to the \textit{min} value specified and less than or equal to the \textit{max} value specified. The random number generated will be used to specify the new \textbf{Position} of the progress bar.

To specify the value of an existing variable to use for the position, enter \texttt{VAR(Variable\_Name)} in the \textbf{Position} field, where \texttt{Variable\_Name} is the name of the variable whose value will be used to specify the new \textbf{Position} of the progress bar.
**Show**

This action causes the target object to become visible if it is currently hidden. When the target object is shown, the selected transition (in) will be applied to the target object.

*See also:*  [Specifying an object's transitions](#)

**Size To**

This action resizes the target object to a specified **Width** and **Height** in pixels at the **Animation Speed** you select. You can directly specify a width and height in pixels, specify a random width or height, or specify the value of an existing variable to use for the width and height. You can also specify a percentage relative to the target object's current size.

To specify a random width or height, enter \texttt{RAND(min, max)} in the **Width** or **Height** field. The random number assigned will be greater than or equal to the \texttt{min} value specified and less than or equal to the \texttt{max} value specified. The random number generated will be used to specify the new **Width** or **Height** of the object.

To specify a percentage relative to the target object's current size, select the **Use Percentage** check box. Select the percentage from the **Percentage** list, or directly type a value into the field.

To specify the value of an existing variable to use for the width, height, or percentage enter \texttt{VAR(Variable\_Name)} in the **Width**, **Height** or **Percentage** field, where \texttt{Variable\_Name} is the name of the variable whose value will be used to specify the new **Width**, **Height** or **Percentage** of the object.

Use the **Animation Speed** slider to select a speed from **Slow** to **Fast**.

**Step Progress**

This action increments the target custom progress bar according to the specified **Step Size** within the target progress bar's properties.

*See also:*  [Working with Progress Bars](#)

**Stop**

This action causes the target media object such as a video or audio clip to stop playing, if it is currently playing.

**Submit Form**

This action submits the target form using the specified submission properties set for the target form.

*See also:*  [Setting form submission properties](#)

**Submit Variable Values**

This action submits the values of all defined variables to the relative or fully qualified Web address (typically a CGI script) specified in the **Submit Address** field.

You can also specify \texttt{mailto:<email\_address>} in this field, where \texttt{<email\_address>} is the email address of a recipient to which you want to submit the variable values. This action requires that each user have an email client, such as Microsoft Outlook, on the computer from which they are accessing the published title. In addition, the email server must be configured to accept communications from the published title's location, so the email can be successfully submitted.

*See also:*  [Submitting Test, Survey and Form Results to CGI](#)

**Submit/Process Test/Survey**

If the target is a test, this action causes the test to be scored, results to be submitted, and the appropriate **When Completed/Passed** or **When Canceled/Failed** test actions to be executed.

*See also:*  [Creating a test](#)

If the target is a survey, this action causes the survey results to be submitted, and the appropriate **When Completed** or **When Canceled** survey actions to be executed.
**Toggle Play Mode**
This action causes the target media object such as a video or audio clip to either start or stop playing, depending on whether it is currently stopped or currently playing.

**Toggle Visibility State**
This action causes the target object to either become visible or hidden, depending on its current visibility state. When the target object is shown, the selected transition (in) will be applied to the target object. When the target object is hidden, the selected transition (out) will be applied to the target object.

*See also:* [Specifying an object's transitions](#)

---

**Executing Flash commands**
The Flash Command action is only available if a Flash object (.swf) is accessible from the location to which the action is being added.

*See also:* [Working with Animations](#)

To execute a Flash command:

1. Add an action to your title and select **Flash Command** from the **Action** list.

   *See also:* [Adding an Action](#)

2. Select the target Flash animation from the **Target** list. This is the Flash animation to which you want to apply the Flash command.

3. Use the **Command** list to select from the available Flash commands for communicating with your Flash animation:

   - **Go To Frame**
     When executed, the action will navigate within the target Flash animation to the frame number specified in the **Number** field. The frame number specified is 0-based. That is, if you want to navigate to the first frame of the target Flash animation, enter "0" in the **Number** field. If you want to navigate to the 34th frame of the target Flash animation, enter "33" in the **Number** field.

   - **Go To Next Frame**
     When executed, the action will navigate within the target Flash animation to the next frame.

   - **Go To Previous Frame**
     When executed, the action will navigate within the target Flash animation to the previous frame.

   - **Go To Label**
     Similar to the **Go To Frame** option, when executed, the action will navigate within the target Flash animation to the frame label specified in the **Name** field. The label **Name** specified must match a frame label within the target Flash animation.

   - **Set Variable**
     When executed, the action will set the value of a variable contained within the target Flash animation to the value specified in the **Value** field. Specify the target Flash animation's variable name in the **Name** field and use the **Value** field to specify the value to which this variable should be set. You can directly specify a value, specify a random value, or specify the value of an existing variable to which the Flash animation's variable should be set.

     To specify a random value, enter `RAND(min, max)` in the **Value** field. The random number assigned will be greater than or equal to the **min** value specified and less than or equal to the **max** value specified. The random number generated will be assigned to the value of the variable specified in the **Name** field.
To specify the value of an existing variable to which Flash animation's variable should be set, enter `VAR(Variable_Name)` in the Value field, where `Variable_Name` is the name of the variable within your title whose value will be assigned to the value of the variable specified in the Name field.

**Get Variable**

When executed, the action will retrieve the value of a variable contained within the target Flash animation and save it to a specified variable within your title. Specify the target Flash animation's variable name in the Name field and use the Variable list to select the variable within your title to which you want to save the value.

**Play**

When executed, the action will play the target Flash animation.

**Stop**

When executed, the action will stop the target Flash animation.

**Pause**

When executed, the action will pause the target Flash animation.

**Call Function**

When executed, the action will execute a function defined within the target Flash animation. Use the Name field to specify the name of the function you want to execute. Use the Value field to optionally specify a string-valued argument for the function. For example, if your Flash animation contains a function `myFunction( arg )`, that you want to execute, specify `myFunction` in the Name field and specify the appropriate value (representing `arg`) that you want passed into the function in the Value field.

The function `myFunction` must be registered as callable from a container within Flash.

4. Click OK.

**Executing Go To actions**

The Go To action enables direct navigation within a title. The resulting action is dependent upon the target used with the action.

See also: Selecting an action's target

When the Go To action is selected and the Target is either Chapter, Section or Page or Web Address, the Open in New Window check box is enabled. This option gives you the ability to open the target location in a new window.

To open the target location in a new window:

1. Select the Open in New Window check box. The Window Properties button is enabled.

2. Click the Window Properties button to configure the new window's properties. The resulting window enables you to define the window size, where it should appear relative to the parent window, and additional HTML properties that determine the controls that should be displayed within the browser window if the title is published to the Web.

3. Specify the following information within the New Window Properties window:

   **Window Name**
   The name specified will appear at the top of the new window.

   **Window Style**
   Use the drop-down list to select the style of the window. Select from the following:

   - **Use Publish Option**
     Select this to use the publishing option for pop-up windows (Use Web 2.0 Style Pop Ups) to determine the style of the window. This is the default.

     See also: Publishing Options

   - **Web 2.0 Style Pop Up**
     Select this to display a Web 2.0-based pop-up window.
This will override the publishing option for pop-up windows (Use Web 2.0 Style Pop Ups).

Using Web 2.0 style pop-ups eliminate issues your users might encounter with pop-up blockers.

**New Browser Window** Select this to create a new browser window.

**Window Size**
This specifies the size to which the new window will open. If **Use Default Size** is selected, the window will open to the page size of the target location. Clear this option to specify the **width** and **height** of the new window size in pixels.

**Screen Position**
This specifies the location of where the new window will open, relative to the upper-left corner of the parent window. Clear this option to specify the exact x and y coordinates of where you want the new window to open.

**No Scrollbars**
When this option is selected, the scrollbars are disabled within the browser window.

**No Menubar**
When this option is selected, the menu bar is disabled within the browser window.

**No Toolbar**
When this option is selected, the toolbar is disabled within the browser window.

**Non resizable Window**
When this option is selected, users will not be able to resize the browser window.

**No Status Bar**
When this option is selected, the status bar is disabled within the browser window.

**No Location Bar**
When this option is selected, the location bar is disabled within the browser window.

4. Click **OK**.

**Selecting an action’s target**
The target is the object or location to which the action is applied. Different targets are available based on the action selected.

Use the **Target** list within the Action Properties window to select from the following targets:

<table>
<thead>
<tr>
<th>Target Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Back</strong></td>
<td>This target can be used with the <strong>Go To</strong> action. When the action is executed, it will take the user to the previously viewed page, regardless of its location within the title.</td>
</tr>
<tr>
<td><strong>Chapter, Section, or Page</strong></td>
<td>This target can be used with the <strong>Go To</strong> action. When this target is selected, you can select a specific chapter, section or page from the <strong>Name</strong> list. If the location selected is scrollable, you can also choose to automatically scroll to an object on the page. Select the object from the <strong>Scroll To</strong> list. If the content on the page fits within the viewing window without requiring a scrollbar, this setting has no effect. When the action is executed, it will take the user to the location and scroll point specified. When this target is used, you have the ability to open the target location in a new window. <strong>See also:</strong> Executing Go To actions</td>
</tr>
<tr>
<td><strong>Current Page</strong></td>
<td>This target can be used with the <strong>Go To</strong> action. When this target is selected, you can scroll to an object on the current page. Select the object from the <strong>Scroll To</strong> list. When the action is executed, the current page will scroll to present the scroll point object at the top of the window.</td>
</tr>
<tr>
<td><strong>Next Chapter, Next Section, or Next</strong></td>
<td>These targets can be used with the <strong>Go To</strong> action. When the action is executed, it will take the user to the next chapter, next section, or next page, relative to the current location.</td>
</tr>
</tbody>
</table>
These targets can be used with the Go To action. When the action is executed, it will take the user to the previous chapter, previous section, or previous page, relative to the current location.

This target can be used with the Go To action. When the action is executed, it will open the title specified in the Title location field.

This target can be used with the Go To action. When the action is executed, it will take the user to the Web address specified in the Web address field. A relative or fully qualified path can be specified within the Web address field.

When this target is used, you have the ability to open the target location in a new window.

Objects
Objects such as images, audio, video and progress bars can be targets of many actions.

Variables
Variables are the targets for any Modify Variable actions and Change Contents actions where the target is a text block.

Delivering an action
You can delay an action by a specified number of seconds. When the action's trigger is fired, the action will not execute until the delay time has elapsed.

To delay an action:
1. Double-click on the action graphic of the action you want to change within your left-hand pane. The Action Properties window opens. Click the General tab if the Action Properties window is not already opened to this tab.
2. Select the Delay before action check box and specify the number of seconds to delay the action.
3. Click OK.

Enabling author control on an action
Protect the contents of an action by enabling Author Control. With Author Control enabled, additional authors will not be able to edit the action unless they have the master Author Control password. The master Author Control password must first be set within the Title Properties.

To enable author control on an action:
1. Double-click on the action graphic of the action you want to change within your left-hand pane. The Action Properties window opens. Click the General tab if the Action Properties window is not already opened to this tab.
2. Select the Author Control check box.
3. Click OK.

Making an action conditional
Using variables, you can create conditional actions. Conditional actions are actions that will only execute when a logical variable statement such as $MyVariable equals 1$, is true. You can specify single or multiple conditions for an action. This
enables you to execute the action, only when the specified conditions have been satisfied.

Consider the following example:

- **Action A**
  The action specified on the **General** tab of the Action Properties window.

- **MyVariable = 1**
  The condition specified on the **Condition** tab of the Action Properties window.

If **MyVariable = 1**, **Action A** will execute when the **On** trigger specified on the **General** tab of the Action Properties window is fired. If **MyVariable** is equal to anything other than 1, the action will not execute.

*See also:*  [Defining Conditions](#)

To place a condition on an action:

1. Double-click on the action graphic of the action you want to change within your left-hand pane. The Action Properties window opens. Click the **Condition** tab.

2. Select **Perform Action ONLY if the following is TRUE**. Conditions require the use of a variable. Select the **Variable** from the list, select a **Relationship** and enter a **Value**. To input multiple conditions, click on the **Multiple Conditions** button. You can then use the additional fields to specify other variables and relationships. If multiple conditions are defined, select whether **All of the Following** conditions or **Any of the Following** conditions should be true to execute the action specified on the **General** tab of the Action Properties window.

3. Click **OK**.

You can copy and paste multiple conditions from one action to another. Once you have finished defining your actions, click the **Copy Conditions** button. Create the new action as necessary. From the **Conditions** tab of the new Action Properties window, click the **Multiple Conditions** button and further click the **Paste Conditions** button to paste the copied conditions to the new action.

**Defining conditions**

Three components make up a condition:

- **Variable**: The name of the variable whose value must satisfy the **Relationship** with the **Value** for the action to execute.

- **Relationship**: The relationship between the value of the **Variable** and the value in the **Value** field that must be true for the action to execute.

- **Value**: The value to which the value of the **Variable** is being compared. You can directly specify a value, specify a random number or specify the value of an existing variable.

  To specify a random number, enter `RAND(min, max)` in the **Value** field. The random number assigned will be greater than or equal to the `min` value specified and less than or equal to the `max` value specified. The random number generated will be used to determine the **Relationship** with the **Variable**.

  To specify the value of an existing variable, enter `VAR(Variable_Name)` in the **Value** field, where `Variable_Name` is the name of the variable whose value will be used to determine the **Relationship** with the **Variable**.

These three parts work together to create a single condition.
Within each condition, the following relationships can be used:

**Contains**
Determines if the value of the Variable contains the value typed in the Value field. If so, the condition is true.

**Does Not Contain**
Determines if the value of the Variable contains the value typed in the Value field. If not, the condition is true.

**Equal To**
Determines if the value of the Variable is equal to the value typed in the Value field. If so, the condition is true.

**Greater Than**
Determines if the value of the Variable is greater than the value typed in the Value field. If so, the condition is true.

**Greater Than or Equal**
Determines if the value of the Variable is greater than or equal to the value typed in the Value field. If so, the condition is true.

**Is Correct**
Determines if the question associated with the Variable was answered correctly. If so, the condition is true.

**Is Empty**
Determines if the Variable has a value. If not, the condition is true.

**Is Not Correct**
Determines if the question associated with the Variable was answered correctly. If not, the condition is true.

**Is Not Empty**
Determines if the Variable has a value. If so, the condition is true.

**Is Passed**
Determines if the test associated with the Variable was passed. If so, the condition is true. Based on the test's Lowest Passing Score.

*See also:* [Setting test result properties](#)

**Is Not Passed**
Determines if the test associated with the Variable was passed. If not, the condition is true. Based on the test's Lowest Passing Score.

*See also:* [Setting test result properties](#)

**Less Than**
Determines if the value of the Variable is less than the value typed in the Value field. If so, the condition is true.

**Less Than or Equal**
Determines if the value of the Variable is less than or equal to the value typed in the Value field. If so, the condition is true.

**Not Equal To**
Determines if the value of the Variable is equal to the value typed in the Value field. If not, the condition is true.

### Executing an alternative action when conditions are not met
You can execute an alternative action when the conditions specified on the Condition tab of the Action Properties window have not been met.

Consider the following example:

- **Action A**
  The action specified on the General tab of the Action Properties window.

- **MyVariable = 1**
  The condition specified on the Condition tab of the Action Properties window.

- **Action B**
  The action specified on the Else tab of the Action Properties window.
If MyVariable = 1, Action A will execute and otherwise, Action B will execute when the On trigger specified on the General tab of the Action Properties window is fired.

To execute an alternative action when the conditions are not met:
1. Double-click on the action graphic of the action you want to change within your left-hand pane. The Action Properties window opens. Click the Else tab.
2. Select the If the conditions are not met, perform the following action check box.
3. Use the Action list to select the action to execute when the conditions are not met.

See also: Selecting an action
The Target field is enabled when the action requires a target. Specify additional information as necessary.

See also: Selecting an action's target

4. Click OK.

Working with Variables
Lectora gives you the ability to use variables within your title. Every title has a set of reserved variables and you can create your own variables. Variables can be used to create conditional actions or display dynamic information to the user.

This section covers the following topics:
- About variables
- Reserved variables
- Using the Variable Manager
- Modifying variable values within a title
- Displaying a variable value

About Variables
Variables are logical objects within a Lectora title that enable you to store, modify, and test values of numbers or strings during the runtime of a published title. You can conditionally perform actions in a title based on variable values and you can display variable values to the user.

There are many uses for variables, including branching to different sections of a title depending on user preferences and displaying information based on multiple user inputs. Variables enable you, as the title author, to capture what a user has done (such as click on a button) within the title and to conditionally act on that at a later time.

For example, suppose you want to give users 3 opportunities to answer a question correctly. You can create a question with a Check My Answer button. The user will click on the button to see if their answer is correct. Every time the user clicks on the button, you can increment the value of a Question_Count variable. The Question_Count variable is initially 0, and can modified to increase by a value of 1 every time the user clicks on the Check My Answer button. Finally, you can execute a conditional action that if the Question_Count is greater than or equal to 3, reveal the correct answer to the user.
Reserved variables

Every Lectora title has a set of predefined, reserved variables. These variables are read-only; they cannot be modified. Additional variables, some of which are read-only, are available within the title depending upon the type of title you are creating.

See also: Specifying the type of title

<table>
<thead>
<tr>
<th>Predefined Variable</th>
<th>Description</th>
<th>Dynamically Updated?</th>
</tr>
</thead>
<tbody>
<tr>
<td>BrowserType</td>
<td>This variable contains the name of the browser currently used to view the title. The variable is set to Lectora when run in preview mode, and LectoraViewer when run as a published CD title. For titles published to the Web, the variable value contains the browser used to view the title, such as Internet Explorer.</td>
<td>No</td>
</tr>
<tr>
<td>CurrentChapterName</td>
<td>This variable contains the name of the chapter that includes the current page being displayed. If there is no current chapter, then this variable has the value of Unknown.</td>
<td>Yes</td>
</tr>
<tr>
<td>CurrentDate</td>
<td>For titles published to the Web, this variable contains today’s date in the form &lt;Day of the Week&gt;, &lt;Month&gt; &lt;Day&gt;, &lt;Year&gt;. For example: Wednesday, March 11, 2008. For titles published to a single-file executable or CD-ROM, this variable contains today’s date in the form &lt;Month&gt; &lt;Day&gt;, &lt;Year&gt;. For example: March 11, 2008.</td>
<td>No</td>
</tr>
<tr>
<td>CurrentPageName</td>
<td>This variable contains the name of the current page.</td>
<td>Yes</td>
</tr>
<tr>
<td>CurrentSectionName</td>
<td>This variable contains the name of the section that includes the current page being displayed. If there is no current section, then this variable has the value of Unknown.</td>
<td>Yes</td>
</tr>
<tr>
<td>CurrentTime</td>
<td>This variable contains the current time in the form hh:mm AM/PM. For example, 4:20 PM.</td>
<td>No</td>
</tr>
<tr>
<td>CurrentTitleName</td>
<td>This variable contains the name of the title.</td>
<td>Yes</td>
</tr>
<tr>
<td>ElapsedTime</td>
<td>This variable contains the amount of time the user has spent within the current title.</td>
<td>No</td>
</tr>
<tr>
<td>PageInChapter</td>
<td>This variable contains the current page number relative to the pages within the current chapter.</td>
<td>Yes</td>
</tr>
<tr>
<td>Variable</td>
<td>Description</td>
<td>Readability</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>PagesInChapter</td>
<td>This variable contains the total number of pages in the current chapter.</td>
<td>Yes</td>
</tr>
<tr>
<td>PageInSection</td>
<td>This variable contains the current page number relative to the pages within the current section.</td>
<td>Yes</td>
</tr>
<tr>
<td>PagesInSection</td>
<td>This variable contains the total number of pages in the current section.</td>
<td>Yes</td>
</tr>
<tr>
<td>PageInTitle</td>
<td>This variable contains the current page number relative to the entire title. If your title contains frames, this variable contains the current page relative to the total number of pages within that frame.</td>
<td>Yes</td>
</tr>
<tr>
<td>PagesInTitle</td>
<td>This variable contains the total number of pages in the title. If your title contains frames, this variable contains the total number of pages within that frame.</td>
<td>Yes</td>
</tr>
<tr>
<td>Platform</td>
<td>This variable contains the name of the platform on which the published title is running. For CD-published titles, this could contain Microsoft Windows NT, Microsoft Windows XP, and so on. For titles published to the Web, the variable contains Win32 for 32-bit Windows platforms, and MacPPC for Macintosh PowerPC platforms.</td>
<td>No</td>
</tr>
<tr>
<td>PublishDate</td>
<td>This variable contains the date and time that the title was published in the form `&lt;Month&gt; &lt;Day&gt;, &lt;Year&gt; hh:mm AM/PM. For example, July 21, 2008 4:20 PM.</td>
<td>No</td>
</tr>
<tr>
<td><code>&lt;test name&gt;_&lt;Score</code></td>
<td>For each test in the title, a variable will be created that will contain the score of the test. If the test has not yet been taken or the test cannot be scored, the value is 0.</td>
<td>No</td>
</tr>
<tr>
<td><code>&lt;test name&gt;_&lt;test section&gt;_Score</code></td>
<td>For each test section in the title, a variable will be created that will contain the score of the test section. If the test has not yet been taken or the test cannot be scored, the value is 0.</td>
<td>No</td>
</tr>
<tr>
<td>Question_#####</td>
<td>This variable contains the user's answer to the question. This variable name can be changed within the question's properties.</td>
<td>Yes</td>
</tr>
<tr>
<td>RadioGroup_#####</td>
<td>This variable contains the user's selection from the radio buttons contained in the group. This variable name can be changed within the radio button group's properties.</td>
<td>Yes</td>
</tr>
<tr>
<td>Radio_#####</td>
<td>For each radio button (not contained in a radio button group) in the title, a variable will be created that will contain whether the radio button is selected. If selected, the variable will have a value of &quot;on&quot; and otherwise will have no value. This variable name can be changed within the radio button's properties.</td>
<td>Yes</td>
</tr>
<tr>
<td>Checkbox_#####</td>
<td>For each check box in the title, a variable will be created that will contain whether the check box is selected. If selected, the variable will have a value of &quot;on&quot; and otherwise will have no value. This variable name can be changed within the check box's properties.</td>
<td>Yes</td>
</tr>
<tr>
<td>Entry_#####</td>
<td>For each entry field in the title, a variable will be created that will contain what the user has typed within the entry field. This</td>
<td>Yes</td>
</tr>
</tbody>
</table>
variable name can be changed within the entry field's properties.

**DropList_####**
For each drop-down in the title, a variable will be created that will contain what the user has selected from the drop-down list. This variable name can be changed within the drop-down list's properties.

**List_####**
For each list box in the title, a variable will be created that will contain what the user has selected from the list box. This variable name can be changed within the list box's properties.

If you have designated your title as an **AICC/SCORM/CourseMill (3.x and above) Published Title**, the following additional variables are available within your title:

<table>
<thead>
<tr>
<th>Predefined Variable</th>
<th>Description</th>
<th>Modifiable?</th>
</tr>
</thead>
<tbody>
<tr>
<td>AICC_Core_Lesson</td>
<td>This variable contains information used by the published title to properly calculate the score of the user in the current title. If you modify the value of this variable within the content of a title that contains more than one automatically graded test, then the AICC_Score of the student cannot be properly updated and reflected to the AICC/SCORM Learning Management System (LMS).</td>
<td>Yes</td>
</tr>
<tr>
<td>AICC_Core_Vendor</td>
<td>This variable contains the information required by Lectora when running an AICC-compliant title within an AICC learning management system. This variable is not used by Lectora-published content.</td>
<td>No</td>
</tr>
<tr>
<td>AICC_Course_ID</td>
<td>This variable contains the id of the course in the AICC/SCORM learning management system.</td>
<td>No</td>
</tr>
<tr>
<td>AICC_Credit</td>
<td>This variable reflects whether the AICC/SCORM title is being taken for &quot;credit&quot; or just in a &quot;browse&quot; mode.</td>
<td>No</td>
</tr>
<tr>
<td>AICC_Lesson_ID</td>
<td>This variable contains the name of the title's assignable unit.</td>
<td>No</td>
</tr>
<tr>
<td>AICC_Lesson_Location</td>
<td>This variable contains the current location within the title content. The Lectora published content sets this variable on every page of the title to reflect the current location of the student within the AICC/SCORM LMS.</td>
<td>Yes</td>
</tr>
<tr>
<td>AICC_Lesson_Status</td>
<td>This variable contains the current status of the course within the AICC/SCORM LMS. Lectora sets the value of this variable to <code>incomplete</code>. The AICC/SCORM LMS will further modify the variable based on the current AICC_Score for the user and the value specified as the Mastery Score.</td>
<td>Yes</td>
</tr>
<tr>
<td>AICC_Score</td>
<td>This variable contains the average of all test scores in the published title. If you modify the value of this variable within the content of a course that contains more than one automatically graded test, the modification will be lost when the user completes an automatically graded test.</td>
<td>Yes</td>
</tr>
<tr>
<td>AICC_Student_ID</td>
<td>This variable contains the user id as reported by the AICC/SCORM LMS.</td>
<td>No</td>
</tr>
<tr>
<td>AICC_Student_Name</td>
<td>This variable contains the user name as reported by the AICC/SCORM LMS.</td>
<td>No</td>
</tr>
</tbody>
</table>
AICC_Time

This variable contains the total time the user has been in the published title. This value is automatically updated while the student is viewing the title. If you modify the value of this variable, the modification will be lost when the student exits the title. Also, this variable must be in the format of HH:MM:SS:mm to be valid when reported to the AICC LMS.

Yes

CMI_Core_Entry

This variable is only accessible in SCORM 2004 published titles and contains information related to whether the student has previously accessed the published title.

No

CMI_Core_Exit

This variable is only accessible in SCORM-published titles and is used to indicate how or why the student exited the published title.

Yes

CMI_Completion_Status

This variable is only accessible in SCORM 2004 published titles and determines the point at which the student has actually completed viewing the published title. In a SCORM 2004 published course, the author MUST set this variable at the point in the course that the student has been determined to have completed viewing the necessary content for the course.

Yes

If the title is being created for placement on the CourseMill 2.0 learning management system, the following additional variables are available:

<table>
<thead>
<tr>
<th>Predefined Variables</th>
<th>Description</th>
<th>Modifiable?</th>
</tr>
</thead>
<tbody>
<tr>
<td>CM_Course_ID</td>
<td>This variable contains the ID of the course as defined in CourseMill.</td>
<td>No</td>
</tr>
<tr>
<td>CM_Course_Name</td>
<td>This variable contains the name of the title as defined in CourseMill</td>
<td>No</td>
</tr>
<tr>
<td>CM_Student_ID</td>
<td>This variable contains the student ID as reported by CourseMill.</td>
<td>No</td>
</tr>
<tr>
<td>CM_Student_Name</td>
<td>This variable contains the student name as reported by CourseMill.</td>
<td>No</td>
</tr>
</tbody>
</table>

Using the Variable Manager

You can use the Variable Manager to browse, add, edit, and delete variables. All reserved and user-defined variables within your title are accessible from the Variable Manager window.

From the Tools menu, select Variable Manager. The Variable Manager window opens. Use the tabs within the Variable Manager window to display the lists of variables within your title. You can display all of the User-Defined variables, Unused variables, or Reserved variables by clicking the corresponding tabs.

Use the Variable Manager window to complete the following tasks:

- View a variable's usage
- Create a variable
- Edit a variable
- Delete a variable

Viewing a variable's usage

The Variable Manager will display the details of where your variables are being used within the title.
To view a variable’s usage:
1. From the **Tools** menu, select **Variable Manager**. The Variable Manager window opens.

2. Click the **User-Defined** tab if you want to see the usage of one of your user-defined variables or click the **Reserved** tab if you want to see the usage of a reserved variable.

3. Select the variable within the list. The variable’s usage details are displayed within the **Variable Used** box.

   If the variable is used within an action at the title level, the action name will appear within the list. Otherwise, the specific chapter, section, or page containing the action using the variable will be displayed. For example:
   - Action 1
   - Chapter 1 > Page 1 > My Action
   - Chapter 2 > Section 3 > Page 4 > My Other Action

   Click on any of the locations within the **Variable Used** box to highlight the corresponding action within the left-hand pane of your title.

4. Click **Close**.

### Creating a variable
Every Lectora title has a set of reserved variables, however, you can also create your own variables.

**See also:** [Reserved variables](#)

To create a variable:
1. From the **Tools** menu, select **Variable Manager**. The Variable Manager window opens. Click on the **User-Defined** tab if the Variable Manager window is not already opened to this tab.

2. Click the **Add** button. The new variable is added to the list.

3. Use the controls within the **Variable Information** box to specify the following:

   - **Variable Name**: Specify the name for the variable. This name must be unique to all existing variable names. Variable names cannot contain spaces or special characters.
   - **Initial Value**: Specify the initial value for the variable. This is the default value of the variable when the published title is launched.
   - **Retain variable value between sessions**: Select this to retain the variable’s value through subsequent launches of the published title. With this selected, if the variable value has changed, the next time the user launches the published title, the variable will load with the previously modified value.
   - **Random initial value**: Select this to assign a random integer value to a variable. When you select this option, specify the **Min Value** and **Max Value** in the fields provided. When the published title is launched, the default value of the variable will be a random number greater than or equal to the **Min Value** specified and less than or equal to the **Max Value** specified.

4. Click **OK** to create the new variable.

### Editing a variable
When you have created a user-defined variable, you can edit its name, initial value, and whether or not it is retained. Reserved variables cannot be edited.

To edit a variable:
1. From the Tools menu, select Variable Manager. The Variable Manager window opens. Click on the User-Defined tab if the Variable Manager window is not already opened to this tab.

2. Select the user-defined variable you want to edit and click the Edit button.

3. Use the controls within the Variable Information box to edit the following:

   **Variable Name**  Specify the name for the variable. This name must be unique to all existing variable names. Variable names cannot contain spaces or special characters.

   **Initial Value**  Specify the initial value for the variable. This is the default value of the variable when the published title is launched.

   **Retain variable value between sessions**  Select this to retain the variable's value through subsequent launches of the published title. With this selected, if the variable value has changed, the next time the user launches the published title, the variable will load with the previously modified value.

   **Random initial value**  Select this to assign a random integer value to a variable. When you select this option, specify the Min Value and Max Value in the fields provided. When the published title is launched, the default value of the variable will be a random number greater than or equal to the Min Value specified and less than or equal to the Max Value specified.

4. Click OK to accept the changes.

**Deleting a variable**
You can delete unused variables within your title. Reserved variables and user-defined variables being used within your title cannot be deleted.

To delete a variable:
1. From the Tools menu, select Variable Manager. The Variable Manager window opens. Click the Unused tab.

2. Select the variable you want to delete and click the Delete button. If you want to delete all unused variables within your title, click the Delete All button.

3. Click Close.

**Modifying variable values within a title**
You can modify the value of a variable during the runtime of a published title. The Modify Variable action enables you to replace, round, add to, subtract from, multiply and divide variable values. All variables can be accessed from anywhere within your title, so this action can be added to any location within your title.

To modify a variable value:
1. Add an action to your title and select Modify Variable from the Action list.

   **See also:**  Adding an Action

2. Select the target variable name from the Target list. This is the variable whose value you want to modify. It can be a string-valued variable (containing non-numeric characters) or a number-valued variable (containing only numeric characters). If you have not created the variable you want to modify, click the New Variable button and add a new variable.

   **See also:**  Creating a variable

3. Select how you want to modify the variable from the Modification Type list. Choose from the following:
Add to Variable
For number-valued variables, this will result in the mathematical addition of the target variable's value and the value specified in the Value field. For example, if the target variable's value is 3 and the value specified in the Value field is 2, the resulting value of the target variable is 5.

For string-valued variables, this will result in the joining of the target variable's value and the value specified in the Value field. For example, if the target variable's value is Hello and the value specified in the Value field is World, the resulting value of the target variable is HelloWorld.

Divide Variable by
This modification type is only applicable for number-valued variables. It will result in the mathematical division of the target variable's value by the value specified in the Value field. For example, if the target variable's value is 21 and the value specified in the Value field is 7, the resulting value of the target variable is 3.

Multiply Variable by
This modification type is only applicable for number-valued variables. It will result in the mathematical multiplication of the target variable's value and the value specified in the Value field. For example, if the target variable's value is 3 and the value specified in the Value field is 7, the resulting value of the target variable is 21.

Round Down Variable
This modification type is only applicable for number-valued variables. It will result in the target variable's value being replaced by the greatest whole number lower than its current value. For example, if the target variable's value is 3.75, the resulting value of the target variable is 3.

Round Variable
This modification type is only applicable for number-valued variables. It will result in the target variable's value being replaced by the nearest whole number greater or lower than its current value. For example, if the target variable's value is greater than or equal to 3.5 and less than 4, the resulting value of the target variable is 4. If the target variable's value is less than 3.5 but greater than 3, the resulting value of the target variable is 3.

Set Variable Contents
This modification type will replace the current value of the target value with the value specified in the Value field.

Subtract from Variable
This modification type is only applicable for number-valued variables. It will result in the mathematical subtraction of the value specified in the Value field from the target variable's value. For example, if the target variable's value is 5 and the value specified in the Value field is 3, the resulting value of the target variable is 2.

4. When necessary, specify the value in the Value field by which you want to modify the target variable's value. You can directly specify a value, select a random number or specify the value of an existing variable.

To select a random number, enter RAND(min, max) in the Value field. The random number assigned will be greater than or equal to the min value specified and less than or equal to the max value specified. The random number generated will be used to modify the Target variable.

To specify the value of an existing variable, enter VAR(Variable_Name) in the Value field. The Variable_Name is the name of the variable whose value should be used to modify the Target variable.

5. Click OK.

When you have completed defining your action, you can preview the functionality of the action within your title by clicking the
Run Mode or Preview Mode toolbar graphic on the Mode bar. You can also preview the functionality of the action within your title by clicking the Debug Mode toolbar graphic on the Mode bar. This will also launch the Debug Window, which will display when the action was fired and any variable manipulations that occur with the action.

See also: Using Lectora's Modes

Displaying a variable value
Using actions, you can display the value of a variable within a title. This enables you to customize your title for each user. Variables are displayed by setting the contents of a text block to the value of a variable. For example, suppose you want to display the page number on each page. You can create a single action to display the value of the PageInTitle variable, and through inheritance, the page number will appear on every page of the title.

See also: Adding a text block and typing the text within the text block
Understanding Inheritance

To display a variable, follow these steps:
1. Select a page in the left-hand pane to which you want to display a variable's value and add a text block by clicking the Add Text Block toolbar graphic on the Insert toolbar.
2. Move or resize the text block as necessary. You can also type text within the text block. This text will be replaced with the variable value when the action is triggered. Note the name of the text block.
3. Select the same page in the left-hand pane, that you selected in step 1 and add an action by clicking the Add Action toolbar graphic on the Insert toolbar. The Action Properties window opens. Click the General tab if the Action Properties window is not already opened to this tab.
4. Complete the controls on the General tab as follows:
   o From the On list, select Show
   o From the Action list, select Change Contents
   o From the Target list, select the name of the text block you created in step 1
   o From the New Contents list, select the name of the variable (PageInTitle, for example) you want to display
5. Click OK.

When you have completed defining your action, you can preview the functionality of the action within your title by clicking the Run Mode or Preview Mode toolbar graphic on the Mode bar. You can also preview the functionality of the action within your title by clicking the Debug Mode toolbar graphic on the Mode bar. This will also launch the Debug Window, which will display when the action was fired and any variable manipulations that occur with the action.

See also: Using Lectora's Modes

Tools and Wizards
This chapter describes many of the tools and wizards provided by Lectora to assist you in building your title.

You can complete the following using various Lectora tools and wizards:
- Run an Error Check
- Check for 508 Compliance
- Import Objects from Existing Lectora Titles
- Check Spelling
- Add Shapes, Lines, and Arrows
Running an Error Check
When you publish your title, Lectora immediately runs your title through an error check process. An error check identifies any logical errors within your title. The errors that are displayed are dependent upon the type of title and publishing format chosen.

See also: Specifying the type of title
Published a Title

Follow these steps to perform an error check on your title:
1. Save your title.
2. From the Tools menu, select Error Check. Lectora rapidly reviews your title for errors and displays the results in the Check Title for Errors window.
3. Review the errors listed. Common errors include pages with duplicate names, pages without objects, and buttons leading to non-existent pages. Double-click items that are warnings (displayed in blue) or errors (displayed in red) to jump to the page containing the object that is causing the problem. Error messages (displayed in red) must be resolved before Lectora can successfully publish your title.
4. Make the necessary changes to your title to resolve the errors and click Done. If you are running the error check during the publishing process, you can click the Publish button to proceed with publishing your title.

Re-run the error check as necessary until you have eliminated all errors. Some warning messages (displayed in blue) may never be resolved. These messages will not impede the publishing process. You can configure the types of warning messages that are displayed during the publishing process.

See also: Specifying publish messages preferences

Checking for 508 Compliance
The 508 Compliance Checker will help in determining if your title complies with Section 508 of the Rehabilitation Act - Paragraph 1194.22 (a) through (p) for Web-based Intranet and Internet Information and Applications. The 508 Compliance Checker only applies to titles that will be published to a Web-based format (HTML, CourseMill, AICC/Web-based, and SCORM/Web-based).

Follow these steps to run the 508 Compliance Check:
1. Save your title.
2. From the **Tools** menu, select **508 Compliance Check**. Lectora rapidly reviews your title for 508 Compliance errors and displays the results in the Check Title for 508 Compliance window.

3. For each item that is flagged by the tool, a reference to the corresponding 508 rule is cited, along with additional information about how to resolve the issue. Double-click items that are warnings (displayed in blue) or errors (displayed in red) to jump to the page containing the object that is causing the problem.

4. Make the necessary changes to your title to resolve the errors and click **Done**.

Re-run the 508 compliance check as necessary until you have eliminated all errors. Some warning messages (displayed in blue) may never be resolved.

**Importing Objects from Existing Lectora Titles**

Importing from other Lectora titles saves time by eliminating the unnecessary re-development of content. This is helpful in many instances, such as when you are creating a title that uses a similar chapter from another title. Simply import the entire chapter into your new Lectora title. You can import entire titles, chapters, sections, and pages, as well as individual objects.

To import content from an existing Lectora title, follow these steps:
1. Select the location in the left-hand pane to which you want to import your content.

2. From the **Tools** menu, select **Import from Existing Title**. The Import from Existing Lectora Title window opens.

3. Use the Import from Existing Lectora Title window to navigate and select the appropriate .awt title file from which you want to import content. Select it and click **Open**. The Import from a Title window opens.

4. The Import from a Title window displays the left-hand pane of the title you selected in step 3. Use the plus [+] and minus [-] signs to expand and contract the objects within the title.

5. Select the object you want to import into the current working title. You can select the entire title, a chapter, section, or page as well as individual objects. Use the **Ctrl** key to select multiple objects.

6. Click **Import**. The content will appear within your current title. Use the left-hand pane to reorganize the imported content within your title.

   **See also:** Using the left-hand pane

**Working with Notes**

Notes can be added throughout a title to serve as reminders or provide instructions to title authors. Notes are only displayed in Edit mode, and do not appear within the published title. You can configure the appearance of your notes within your preferences.

   **See also:** Specifying notes preferences

See Adding a Note for more information.

You can view, download, and print the notes associated with your title using the Notes Report tool. See Creating a Notes Report for more information.

**Adding a Note**

To add a note to a page:
1. In the left-hand pane, select the location in which you want to add a note.
2. Select Add a Note from the Tools menu. The notepad opens within your work area with the cursor inside.

![Image of a note with text: An image needs to be added. Add a highlight around the 3rd quarter portion of the chart. Nov 03 11:28 AM]

3. Type the text of the note and close the note by clicking the close button (X) in the upper-right corner. The note icon appears on the content page.

When you place notes within your title, the left-hand pane reflects the location of the notes. Each page containing a note will appear bolded and italicized in the left-hand pane. If the page is contained in a chapter or section, subsequently the chapter and section names will also appear bolded in the left-hand pane.

In addition to the text contained within the note, notes display the author name of the user that created the note, and the date and time it was written. Double-click any note icon to view its contents.

Creating a Notes Report
Use the Notes Report tool to view the notes associated with a title. You can also print and download the Notes Report.

To use the Notes Report tool, follow these steps:
1. Select Notes Report from the Tools menu.

   The Title Notes window opens. The notes associated with the title are displayed. For each note, the page, color, location, originator, and date and time of the note are displayed.

2. Click Print to print the Title Notes window or click Download to save a copy of the Notes Report as a text file.

3. Click Close to close the Title Notes window and return to the title.

Managing Resources
The Resource Manager gives you access to all of the resources used in your title, and all of the information for those resources. Resources in Lectora are the actual files that are used for objects such as images, audio and video. The name of the file that the resource represents can be changed, the resource can be edited, and the Resource Manager window lists all instances of the resource in the title.

To access the Resource Manager, select Resource Manager from the Tools menu.

Within the Resource Manager window, you can complete the following:
- Search for a resource
- View a resource’s usage
Search for a resource
You can use the Resource Manager to search for a resource you have added to your title.

To search for a resource:
1. From the Tools menu, select Resource Manager. The Resource Manager window opens.

2. Search for your resource in the following ways:
   - Navigate the categories by expanding and collapsing the plus [+] and minus [-] signs before the resource category names. Previews of the resources are displayed in the window on the right side of the Resource Manager window.
   - Click the Search tab, enter the search terms into the field and click the Search button. The resulting list is populated with the resources whose file names contain the search terms provided.

3. Click Close.

Viewing a resource's usage
The Resource Manager will display the details of where your resources are being used within the title.

To view a resource's usage:
1. From the Tools menu, select Resource Manager. The Resource Manager window opens.

2. Click the All tab to navigate the categories and select a resource from the list. Alternatively, click the Search tab to search for a resource within your title.

   See also: Searching for a resource

3. Select the resource within the list. The resource's usage details are displayed within the Resource Used box.

   The location and object name (name of the object as it appears in the left-hand pane) of the resource is displayed. For example:
   - Chapter 1 > Page 1 > My Image
   - Chapter 2 > Section 3 > Page 4 > My Button

   Click on any of the locations within the Resource Used box to place focus on the corresponding object within your title.

4. Click Close.

Changing the name of a resource file
The Resource Manager can be used to change the name of a resource file. This will not affect the name of the object within your title, but rather will change the file name of the resource file used for the object.

To change the name of a resource file:
1. From the Tools menu, select Resource Manager. The Resource Manager window opens.

2. Click the All tab to navigate the categories and select the resource you want to rename. Alternatively, click the Search tab to search for the resource you want to rename.

   See also: Searching for a resource
3. Type the new name of the resource file in the **Name** field and click the **Rename** button.

4. Click **Close**.

**Creating a unique resource**

If a resource is being used multiple times within your title, you can choose to create a unique resource file from one of the instances of the resource. For example, suppose you have an image that is used on multiple pages. If you edit that image, all instances of the image will be changed within your title. If you only want that image to change on one of the pages, you will need to create a unique resource for that image, so you can edit it without affecting the other instances of the image.

To create a unique resource:
1. From the **Tools** menu, select **Resource Manager**. The Resource Manager window opens.

2. Click the **All** tab to navigate the categories and select the resource you want to make unique. Alternatively, click the **Search** tab to search for the resource you want to make unique.

   See also:  
   [Searching for a resource](#)

3. The resource's usage details are displayed within the **Resource Used** box. Select the instance of the resource you want to make unique. The option to create a unique resource is only available if the resource is being used in multiple locations.

4. Click the **Create Unique Resource** button. The additional resource is add to the list of resources on the left, and the location of the resource no longer appears within the **Resource Used** box.

5. Click **Close**.

**Editing a resource**

Using the Resource Manager, you can directly edit the resources used within your title. This is not the same as editing your object's properties, but will rather enable you to edit the image, video or audio file that is used within your title. You can edit the following types of objects:

- Animations
- Audio
- Buttons (You can edit the images associated with a button.)
- Documents
- Images
- Shapes, Lines and Arrows
- Video

To edit a resource:
1. From the **Tools** menu, select **Resource Manager**. The Resource Manager window opens.

2. Click the **All** tab to navigate the categories and select the resource you want to edit. Alternatively, click the **Search** tab to search for the resource you want to edit.

   See also:  
   [Searching for a resource](#)

3. Click the **Edit** button. The file will be launched using the appropriate application.

   ![Note](#)  
   This feature is only available for the above object types if you are using the Lectora Professional Publishing Suite or if you have specified your editor preferences.
4. Make the necessary changes to your resource file, save the file, and close the application that was used to launch it. All instances of the object are updated within your title.

5. Click Close.

Deleting a resource
You can delete unused resources within your title.

To delete a resource:
1. From the Tools menu, select Resource Manager. The Resource Manager window opens.
2. Click the Unused tab to navigate the categories and select the resource you want to delete.
3. Click Remove.
4. Click Close.

Converting to Flash audio and video
You can convert your audio and video objects to Flash (.flv).

When you convert an object to Flash audio or video, all instances of the resource are changed throughout your title.

Flash .flv files require your user's computer to have the Flash plug-in installed.

To convert objects in your title to Flash audio and video:
12. Select the object and click the Convert to FLV button.

   The option is only available for relevant file types.

   The Convert to FLV window opens.
13. Use the slider to select a compression level.

   Higher compression levels will result in smaller files, but the quality of the media will deteriorate as compression increases.
14. Click Convert.

   When the conversion completes, the compression results are displayed and you are asked whether to use the new file.
15. Click Yes. Otherwise, click No to restore the file to its original type.

The object is converted to .flv.

Creating New Media Using the Publishing Suite Tools
If you have the Lectora Professional Publishing Suite, an additional set of tools is available from your Lectora Tools menu. These tools correspond with the media editor applications that are installed with the Lectora Professional Publishing Suite. If you only have Lectora Publisher (also known as the Lectora Enterprise Edition) these tools will not appear within your Lectora
Use the following Publishing Suite Tools to add new images, screen captures, screen recordings and audio to your title:

- Audio Recording Tool
- New Animation Tool
- New Image Tool
- Screen Recording Tool
- Screen Capture Tool

Using the Audio Recording Tool
Using the Audio Recording Tool, you can record new audio files using an external microphone attached to your computer.

To use the Audio Capture Tool:
1. Select the location in the left-hand pane to which you want to add new audio.
2. From the Tools menu, select Audio Capture Tool. The Audio Recording Tool window opens.
3. Select the format to which you want to record the audio. Select from the following formats:
   - Flash Audio: Saves the new audio file with a .flv extension. This is a highly compressed format and has the capability of synchronizing events with the audio. Requires the Flash browser plug-in.
   - Windows Media Audio: Saves the new audio file with a .wma extension. This is a highly compressed format and has the capability of synchronizing events with the audio. Requires the Windows Media Player browser plug-in.
   - Real Audio: Saves the new audio file with a .ra extension. Requires the Real Audio browser plug-in.
   - WAV Audio: Saves the new audio file with a .wav extension. These audio files are not compressed and result in large file sizes and long download times, however, can be played with most players.
4. Click Finish.
5. When you are ready to record, click the Record button. The Audio Recording Tool records the audio. Click the Pause button to pause the recording. You can resume recording by clicking the Record button.
6. Click the Stop button to complete the recording. The recording is added to your title. It will appear in the left-hand pane with the label Audio Capture and the speaker graphic will appear within your work area.

See also: Working with Audio

For additional information about using the Audio Recording Tool, access the help for the Audio Editor. From the Help menu within the Audio Recording Tool, select Contents.

Using the New Animation Tool
Using the New Animation Tool, you can create animated GIF files.

To use the New Animation Tool:
1. Select the location in the left-hand pane to which you want to add a new animation.
2. From the Tools menu, select New Animation Tool. The Animation Tool window opens.
3. Use the Width and Height fields to specify the size of the new animation you want to create. Click Finish.

4. The Image Editor opens with the animation tools enabled. Thumbnails for the animation are displayed in the main window. Use the Image Editor controls to create and save the new animation. When you exit the Image Editor, the new animation is added to your title.

   See also: Working with Animations

For additional information about using the animation tools within the Image Editor, access the help for the Image Editor. From the Help menu within the Image Editor, select Contents.

Using the New Image Tool
Using the New Image Tool, you can create GIF and JPEG images.

To use the New Image Tool:
1. Select the location in the left-hand pane to which you want to add a new image.

2. From the Tools menu, select New Image Tool. The Image Tool window opens.

3. Select whether you want to create a GIF (GIFs can have transparent backgrounds) or a JPEG.

4. Use the Width and Height fields to specify the size of the new image you want to create. Click Finish.

5. The Image Editor opens with the image tools enabled. Use the Image Editor controls to create and save the new image. When you exit the Image Editor, the new image is added to your title.

   See also: Working with Images

For additional information about using the image tools within the Image Editor, access the help for the Image Editor. From the Help menu within the Image Editor, select Contents.

Using the Screen Recording Tool
Using the Screen Recording Tool, you can create screen recordings of the actions you perform on your computer.

To use the Screen Recording Tool:
1. Select the location in the left-hand pane to which you want to add a screen recording.

2. From the Tools menu, select Screen Recording Tool. The Screen Recording Tool window opens.

3. Select the format to which you want to save the screen recording. Select from the following formats:

   Flash Video Saves the new video file with an .flv extension. This is a highly compressed format and has the capability of synchronizing events with the video. Requires the Flash browser plug-in.

   Windows Media Video Saves the new video file with a .wmv extension. This is a highly compressed format and has the capability of synchronizing events with the video. Requires the Windows Media Player browser plug-in.

   Real Video Saves the new video file with an .rm extension. Requires the Real Media browser plug-in.

   AVI Video Saves the new video file with an .avi extension. These video files are generally large in size and thus require longer download times, however, can be played with...
most players.

**Animated GIF** Saves the new video file with a `.gif` extension. Animated GIFs cannot contain audio. They are the smallest of the file sizes and do not require any plug-ins.

3. Click **Finish**. The screen camera is displayed.

4. The screen camera interface is designed to look and operate like a video camera. Use the controls on the screen camera to create and save your screen recording. When you exit the Screen Recording Tool, the new video is added to your title.

**See also:** [Working with Video](#)

For additional information about using the Screen Recording Tool, access the help for the Screen Camera. With the Screen Recording Tool open, press the **F1** key to launch the help.

**Using the Screen Capture Tool**

Using the Screen Capture Tool, you can create screen captures of your computer. The screen captures are saved as images.

To use the Screen Capture Tool:

1. Select the location in the left-hand pane to which you want to add a screen capture.

2. From the **Tools** menu, select **Screen Capture Tool**. The Screen Capture Tool window opens.

3. Specify the format in which you want to capture the screen and click **Finish**. The Screen Capture Preferences window opens.

4. Specify the preferences as appropriate and click **OK**. Perform the appropriate steps to complete your screen capture. When the screen capture has been created, the image will appear within your title.

**See also:** [Working with Images](#)

For additional information about using the Screen Capture Tool, click the **Help** button within the Screen Capture Preferences window.

**Creating Custom Backgrounds**

Using the Background Wizard, you can:

- Create a customized background for your entire title
- Create a customized background for a chapter, section or page

**Creating a background for your entire title**

You can use the Background Wizard to create a background for your title. The background will be applied to your title properties.

**See also:** [Changing a title's background properties](#)

To create a background for your entire title:

1. Select the title at the top of your left-hand pane.

2. From the **Tools** menu, select **Background Wizard**. The Background Type window opens.

3. Select the type of background you want to add to your title and click the **Next** button. Choose from the following types of backgrounds:
Creating a background for a chapter, section or page
You can use the Background Wizard to create a background for individual chapters, sections or pages of your title.

To create a background for a chapter, section or page within your title:
1. Select the location in left-hand pane to which you want to apply the background.
2. From the Tools menu, select Background Wizard.
3. Select the scope to which you want to apply the background. Select from one of the following and click Next.
   - The current page only
   - All pages in the current section
   - All pages in the current chapter
   - All pages in the title
4. Select the type of background you want to add to your title and click the Next button. Choose from the following types of backgrounds:

   **Stock background from clipart**
   Select this to choose from three categories of backgrounds: HighTech, Natural, and Textiles.

   **Gradient**
   Select this to add a colored gradient background to your title. You can configure the starting color, ending color, the direction of the gradient and the percentage of the background the gradient should cover.

   **Beveled Border**
   Select this to create a background with a 3-dimensional, raised border. You can configure the border color, page color, placement of the border and the border size.

   **Shaded Border**
   Select this to create a background with a shaded border. You can configure the border color, page color, placement of the border and the border size.

   **Solid Border**
   Select this to create a background with a solid border. You can configure the border color, page color, placement of the border and the border size.

   **Solid Color**
   Select this to create a solid color for your background.

4. Click the Next button to configure the background properties and click Finish to apply the background to your title.
5. Click the **Next** button to configure the background properties and click **Finish** to apply the background to your title.

**Creating Custom Buttons**

Using the Button Wizard, you can create two different types of buttons:

- Custom color buttons with text
- Stock buttons from clipart

**Creating custom color buttons with text**

Using the Button Wizard, you can create custom color buttons with text. These kinds of buttons enable you to specify the text, appearance and colors used within the button.

To create a custom color button with text:

1. Select the location in the left-hand pane to which you want to add a button.

2. From the **Tools** menu, select **Button Wizard**. The Button Type window opens.

3. Select **Custom color Button with text** and click **Next**. The Custom Button Type window opens.

4. Select the style of button you want to create. Select each style to see samples in the preview window on the right. Click the **Next** button to continue.

5. If you are creating one button, select **Single button**. If you are creating multiple buttons, select **Multiple Buttons** and enter the number of buttons you want to create in the **Number of buttons** field. Optionally, use the **Align buttons** list to select whether you would like the buttons to be aligned across or down and use the **Spacing between buttons** field to specify the number of pixels you would like between each button. Click **Next**.

6. Using the Button window, specify the following information:

   - **Text**: Type the text you want to appear on the button.
   - **Font**: Click the **Font** button to display the Font window for selecting the font attributes of the text within your button.
   - **Highlight Color (Font)**: Select the color to which the text will change when the user places the mouse over the button. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

     **See also**: [Matching Colors Used within Your Title](#)

   - **Bevel Height**: Select the height of the shadowing to appear on the button so that it appears raised on the page.

   - **Button Color**: Select the color of your button. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

     **See also**: [Matching Colors Used within Your Title](#)

   - **Highlight Color (Button)**: Select the color to which the button will change when the user places the mouse over the button. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

     **See also**: [Matching Colors Used within Your Title](#)
Outline Button  
Select this option to outline the button.

Outline Color  
Select the color of the line that will outline the button. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.

See also:  Matching Colors Used within Your Title

Automatically size all buttons to the same height and width  
Select this to size all buttons to the same height and width. This option is only available if you are creating multiple buttons.

Automatically size button to fit this button’s text  
Select this to size the button to fit this button’s text.

Set size of button  
Select this option to manually set the height and width of the button. Specify the height and width of the button (in pixels) in the Height and Width fields.

7. If you are creating multiple buttons, click Next and specify the attributes for the additional buttons. Otherwise, click Finish.

Use the button properties to assign an action to the button.

See also:  Working with Buttons

Creating stock buttons from clipart
Using the Button Wizard, you can select from a gallery of stock buttons to add to your title. All Back, Next, Home and Exit buttons within the gallery are pre-programmed with the corresponding action.

To create a stock button from clipart:
1. Select the location in the left-hand pane to which you want to add a button.

2. From the Tools menu, select Button Wizard. The Button Type window opens.

3. Select Stock Button from clipart and click Next. The Choose a Button window opens.

4. Use the tabs within the Choose a Button window to browse the different button categories. If you are adding the buttons to pages with a light-colored background, select Light backgrounds, and if you are adding the buttons to pages with a dark-colored background, select Dark backgrounds.

5. Select the button you want to add. Hold down your Ctrl key to select multiple buttons.

6. If you selected more than one button, click Next to align the buttons. The Layout for multiple buttons window appears. Use the Align buttons list to select whether you would like the buttons to be aligned across or down and use the Spacing between buttons field to specify the number of pixels you would like between each button.

   Click Finish to add the buttons to your title.

If necessary, use the button properties to assign an action to the button.

See also:  Working with Buttons

Creating Custom Certificates
Create and customize certificates using the Certificate Tool. The tool guides you through customizing a certificate to add to your title. When completed, the certificate is added as a page within your title.
To use the certificate tool:
1. Select the page in the left-hand pane after which you want to add the certificate.


3. Select the style of certificate from the list. A preview of the selected style is displayed to the right of the list.

4. Click the Font buttons to change the font settings for the certificate text. The Font window opens. Use the controls on the Font window to specify the font settings for your certificate. Click OK to apply your font settings.

5. Click Next to continue. The Header window opens.

6. Enter the text you want to use as the header for your certificate and click the Next button.

7. Enter the text you want to use as the body for your certificate, appearing above the name of the certificate recipient. If you want to use a variable value for the name appearing on the certificate, select the Use variable to set student name check box and select the Variable to use from the list. This can be the AICC_Student_Name variable (if publishing to a learning management system) or any other variable used within your title containing the appropriate name for the certificate. If you have not created the variable you want to use, click the New Variable button and add a new variable.

   See also: Creating a variable

8. Click the Next button and enter the text that should appear below the certificate recipient's name. Select if you want to Include date course was completed or Print the certificate when the page is shown.

9. Click the Finish button to complete creating the certificate. The certificate is added as a page to your title.

Creating Custom Charts
Create and customize charts using the Chart Tool. Choose from a variety of charts based on standard spreadsheet-formatted data. When completed, the chart is added as an image that you can size and move within the page.

To use the Chart Tool:
1. Select the page in the left-hand pane on which you want to add the chart.

2. From the Tools menu, select Chart Tool. The Chart Data window opens.

3. Use the Chart Type drop-down list to select the type of chart. A preview is displayed to the right.

4. Use the scrollable spreadsheet to specify the labels and data that comprise your chart. Double-click within the cells of the spreadsheet to edit the cells. Click Clear Data if you need to erase the data from the chart.

5. Click the Title & Legend tab to configure the chart title and legend, if applicable. Use the Chart Title field to specify the chart title. The title is displayed above the chart. To display the legend, enable the Show Legend box and use the drop-down list to select the location of the legend on the page.

   The current fonts for the Chart Title and Legend are displayed. Click the Font buttons to change the font settings. The Font window opens. Use the controls on the Font window to specify the font settings for the chart. Click OK to apply your font settings.

6. Click the Finish button to add the chart to your title.

The chart is added to your title as an image object.
When the chart is added to your title, you can edit it in the Chart Tool. Either double-click on it and click Edit on the General Tab, or right-click on the chart and select Edit from the right-click menu.

Automatically Numbering Pages
Using the Page Numbering Tool, you can:
- Number the pages within your entire title
- Number the pages within a chapter or section of your title

Numbering the pages within a title
To automatically number the pages within your entire title:
1. Select the title at the top of your left-hand pane.
2. From the Tools menu, select Page Numbering Tool. The Details window opens.
3. Complete the controls on the Details window as follows:
   - **Include the total number of pages in the text**: Select this to include the total number of pages within your title. For example, “Page 4 of 12”.
   - **Text**: Specify the text representing the page in the numbering, for example, Slide or Sheet. The default is Page. Use the second field to specify the text used between the page number and the total number of pages, for example, “-” or “/”. The default is “of”.
   - **Text background color**: Select the background color that will appear behind the page numbering text. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select Custom to select a custom color from the Color wheel.
   - **Text font and color**: Click the Select Font button to open the Font window. Select the font characteristics you want to use for the page numbering and click OK. A sample of the text is displayed.
4. Click Finish.

Lectora will create a text block and a series of actions at the title level in the left-hand pane. These objects are necessary for the functionality of the page numbering and should not be deleted unless you want to remove the page numbering from your title. The text block and actions are automatically inherited throughout the rest of the title to display page numbering on every page.

Numbering the pages within a chapter or section
To automatically number the pages within a chapter or section of your title:
1. Select the chapter or section in the left-hand pane to which you want to add the page numbering.
2. From the Tools menu, select Page Numbering Tool. The Scope of the Page Numbering window opens.
3. Complete the controls on the Scope of the Page Numbering window. Select if you want to add page numbering to:
   - The current section only
   - The current chapter only
   - All pages in the title
4. Further select how you would like to number the pages within the title, chapter, or section. Choose from the following:
   - **Number the pages sequentially for the**
entire title sequential order, regardless of their inclusion in chapters or sections.

Number the pages sequentially for each chapter
Will number all of the pages within the scope of the page numbering in sequential order for each chapter. That is, the first page of each chapter will be numbered Page 1.

Number the pages sequentially for each section and chapter
Will number all of the pages within the scope of the page numbering in sequential order for each section. That is, the first page of each section will be numbered Page 1.

5. Click the **Next** button. The Details window opens.

6. Complete the controls on the Details window as follows:

   - **Include the total number of pages in the text**
     Select this to include the total number of pages within your title. For example, “Page 4 of 12”.

   - **Text**
     Specify the text representing the page in the numbering, for example, **Slide** or **Sheet**. The default is **Page**. Use the second field to specify the text used between the page number and the total number of pages, for example, “-” or “/”. The default is “of”.

   - **Text background color**
     Select the background color that will appear behind the page numbering text. Select a predefined color, select the eye-dropper tool to use a color from elsewhere within your title, or select **Custom** to select a custom color from the Color wheel.

   - **Text font and color**
     Click the **Select Font** button to open the Font window. Select the font characteristics you want to use for the page numbering and click **OK**. A sample of the text is displayed.

   - **See also:** [Matching Colors Used within Your Title](#)

4. Click **Finish**.

Lectora will create a text block and a series of actions in the left-hand pane. These objects are necessary for the functionality of the page numbering and should not be deleted unless you want to remove the page numbering from your title. The text block and actions are automatically inherited to display page numbering on the appropriate pages.

**Integrating PowerPoint Presentations into Your Title**
If you have the Lectora Integrator for PowerPoint installed, you can import individual slides from a PowerPoint presentation into your title.

See the Lectora Integrator for PowerPoint Information Center for details about installation and importing PowerPoint slides into your titles.

**Translating Your Title’s Text**
Using the Translation Tool, text from your Lectora title can be extracted and saved to an RTF (rich text format) file. This includes all text within text blocks, text within custom buttons created using the Button Wizard and text used within Display Message actions. RTF files can be edited with most word processing applications, and the content of the RTF file can be translated for importing back into the Lectora title.

To export text for translation:
1. From the **Tools** menu, select **Translation Tool**. The Translation Tool window opens.

2. Select **Export text to a translation file**.

   Select the **Include Chapters/Section/Page names** check box to export the chapter, section, and page names so that they are included for translation.
3. Select the radio button that describes the scope of the text that will be extracted from the title. Choose from the following:
   o The current page only
   o The current chapter only
   o The current section only
   o The entire title

4. Click OK. Lectora will automatically create the RTF file in the same location as your .awt title is stored.

The RTF file created will include text that must not be altered. This text is displayed in red and is similar to the following:
###Do not edit this line.45###

Once the text changes have been made, the altered RTF file can be imported back into the original title.

To import translated text:
1. From the Tools menu, select Translation Tool. The Translation Tool window opens.

2. Select Import text from a translation file. The Increase text box size if needed option allows you to specify whether or not to automatically increase the size of text blocks if the imported text will not fit into the existing text block. If this option is not selected, you may have to manually adjust text block sizes after the translated text is imported.

3. Select the radio button that describes the scope of the text you are importing. Choose from the following:
   o The current page only
   o The current chapter only
   o The current section only
   o The entire title

4. Click the Browse button to navigate and select the RTF file you are importing.

5. Click Open.

The content within your Lectora title will change to reflect the text from the RTF file.

**Matching Colors Used within Your Title**
When you have the ability to select a color, whether it be for a background, text, or link color, an eye-dropper tool is available in the color list. The eye-dropper tool will enable you to select a currently used color from within your title.

To use the eye-dropper tool:
1. Select the eye-dropper tool from the color list. Your mouse cursor will display the eye-dropper.

2. Move your mouse to place the eye-dropper tool over the color within your title that you want to use. This can be a color from the Lectora interface, a color from an image within your title, or a color elsewhere.

3. When the eye-dropper is on top of the color you want to use, click your left mouse button. The new color will be selected within the Color list.

**Publishing a Title**
When you have completed creating your title, you can publish it to the desired format. Publish your title to a single, executable file, usable on all Windows operating systems. Publish to a CD-ROM or the Web. You can also publish your title to AICC, SCORM and LRN learning management systems.

This chapter outlines procedures on the following:
- Publishing to a Single Executable File
Publishing to a Single Executable File

Use the Publish to Single File Executable option to create a self-contained title. This will compact the entire title and all supporting files into a single executable file for easy distribution.

To publish your title to as a single executable file, follow these steps:

1. Save your title.

2. From the Publish menu, select Publish to Single File Executable. Lectora performs an error check and displays the results in the Publish Title to Single File Executable window.

   See also: Running an Error Check

3. Resolve any errors within your title. If necessary, click Cancel and repeat steps 1 and 2 until your title is free of errors.

4. Click Publish when you are satisfied with the results of the error check. The Publish Location window opens.

5. Use the Publish Location window to specify publishing details. Complete the controls as follows:

   - **Destination Folder**: Specify the directory in which you want to save the resulting executable file or click the Choose Folder button to navigate and select a location. This directory listing is for local or network locations, not the Internet. Lectora will automatically create the executable file in the same working directory as the .awt title file, unless otherwise specified.

   - **Publish Only Updated Pages/Resources**: Select this to publish only the pages and resources that have been updated since your title was last published. This option is only available if you have previously published the title.

   - **Publish All Pages/Resources in the Title**: Select this to publish all the pages and resources regardless of whether they have been updated.

   - **Replace Icon**: Select this to use a unique icon representation of the published title. Selecting this option enables the Select Icon button. Click the Select Icon button to navigate and select the icon you want to use for your title. Lectora can only use .ico files for this option.

   - **Encrypt Published Title**: Select this if you want to password-protect the resulting executable file. Selecting this option enables the Set Title Password button. Click the Set Title Password button and enter the password in the Password field. When a user launches the executable file, they will be prompted to enter the password. If the correct password is not provided, the title will not launch.

   - **Name of single file executable**: Specify the name of the resulting executable file.
6. Click OK to publish your title to your local directory as a single executable file. When the publishing process has completed, you can distribute your published title.

**Publishing to a CD-ROM**

Use the Publish to CD-ROM option to create a CD-ROM of your title. When you publish to CD-ROM, Lectora will create the necessary files for you to burn to a CD-ROM. After the CD-ROM is created, users will be able to insert the CD-ROM into their computer's CD-ROM drive, and the published title will automatically start.

To publish your title for a CD-ROM, follow these steps:

1. Save your title.

2. From the **Publish** menu, select **Publish to CDROM**. Lectora performs an error check and displays the results in the Publish Title to CDRom window.

   **See also:** Running an Error Check

3. Resolve any errors within your title. If necessary, click **Cancel** and repeat steps 1 and 2 until your title is free of errors.

4. Click **Publish** when you are satisfied with the results of the error check. The Publish CDRom Location window opens.

5. Use this window to specify publishing details. Complete the controls as follows:

   - **Destination Folder** Specify the directory in which you want to save the resulting CD-ROM files or click the **Choose Folder** button to navigate and select a location.

     This directory listing is for local or network locations, not the Internet. Lectora will automatically create the CD-ROM files in a **cd** folder in the same working directory as the **.awt** title file, unless otherwise specified.

   - **Publish Only Updated Pages/Resources** Select this to publish only the pages and resources that have been updated since your title was last published. This option is only available if you have previously published the title.

   - **Publish All Pages/Resources in the Title** Select this to publish all the pages and resources regardless of whether they have been updated.

   - **Store Published Title in a Zip File** Select this to compress all of the CD-ROM files into a single Zip file.

   - **Remove Bookmark option from Published Title** Select this to turn off the bookmarking feature in CD-ROM published titles. The bookmarking feature will enable users to add bookmarks to the published title so they can quickly navigate to bookmarked pages within the title.

     **See also:** Using bookmarks in a published title

   - **Replace Icon** Select this to use a unique icon representation of the published title. Selecting this option enables the **Select Icon** button. Click the **Select Icon** button to navigate and select the icon you want to use for your title. Lectora can only use **.ico** files for this option.

6. Click **OK** to publish your title to your local directory. When the publishing process has completed, you can burn the resulting files to a CD-ROM.

- Some CD burning software operates by dragging and dropping files from the Windows Explorer interface. If this is how you will be creating your CD, ensure that the Windows Explorer option to **View All Files** is selected. By
default, Windows does not display some files, even though the files are present. This will cause you to not copy all of the needed support files to the CD when you drag and drop to your software.

- If the content of the title contains a test that submits results via either CGI or email, the CD-ROM image contains the Lectora Testing Submission Module which is responsible for transmitting the test results to the internet.

See also: Submitting Test, Survey and Form Results to CGI

Using bookmarks in a published title
In a CD-ROM-published title, bookmarks can be added to enable the user to quickly navigate to bookmarked pages within the title.

To add bookmarks to a CD-ROM-published title, click on the Lectora icon in the upper-left corner of the window presenting the published title. Select Bookmarks from the list and click Add to add a bookmark. The page name of the page bookmarked will appear within the Bookmarks submenu.

To navigate within the title using the added bookmarks, click on the Lectora icon in the upper-left corner of the window presenting the published title. Select Bookmarks from the list and further choose the page to which you want to navigate.

Publishing to HTML
Use the Publish to HTML option if you want to post your title to the Internet or your own Intranet. When you publish to HTML, Lectora will create the necessary files for you to upload to a Web server.

When you publish to HTML, the actions in your title are converted to Web-based programming code, such as JavaScript. If your images are not already in .jpg or .gif format, they are automatically converted.

To publish your title to HTML, follow these steps:
1. Save your title.
2. From the Publish menu, select Publish to HTML. Lectora performs an error check and displays the results in the Publish Title to HTML window.

   See also: Running an Error Check

3. Resolve any errors within your title. If necessary, click Cancel and repeat steps 1 and 2 until your title is free of errors.
4. Click Publish when you are satisfied with the results of the error check. The Publish HTML Location window opens.

   Use the following tabs within this window to specify publishing options, FTP information and compression guidelines:
5. Once you have completed configuring all of the publishing options, click OK. Your title is published to your local directory. When the publishing process has completed, click the FTP Title button to upload your title to the Web server specified. If you did not configure FTP settings, this option is not available.

6. Click the Done button to close the publishing window. When available, you can also click the Preview button to launch the published title.

When you make changes to your title, you will need to republish it so the new changes are reflected in the published title. Repeat these steps as necessary to republish your title.

### Publishing to CourseMill

CourseMill is a learning management system developed by Trivantis and designed especially for easy integration of Lectora titles. The CourseMill learning management system makes the delivery, management, and tracking of online learning across your organization easier and more affordable. For more information about CourseMill, visit [http://www.trivantis.com/products/coursemill.html](http://www.trivantis.com/products/coursemill.html).

Before publishing to CourseMill, make sure the CourseMill server has been defined within your Lectora preferences.

*See also:* [Setting CourseMill preferences](#)

To publish your title to a CourseMill server, follow these steps:

1. Save your title.

2. From the Publish menu, select Publish to CourseMill. Lectora performs an error check and displays the results in the Publish Title to CourseMill window.

   *See also:* [Running an Error Check](#)

3. Resolve any errors within your title. If necessary, click Cancel and repeat steps 1 and 2 until your title is free of errors.

4. Click Publish when you are satisfied with the results of the error check. The Publish CourseMill/SCORM Location window opens.

5. Use this window to specify CourseMill server login details. Complete the controls as follows:

   **Course ID** Specify the Course ID that is defined with CourseMill. You must have the Course ID to send your title to the CourseMill server.

   **Instructor ID** Specify the ID of the instructor that is assigned to the course to which you are uploading the title.

   **Password** Specify the corresponding instructor's password.

6. Use the additional following tabs within this window to specify publishing options and compression guidelines:

   - SCORM Options
   - SCORM Options 2
   - Options
   - Companion CD
5. Once you have completed configuring all of the publishing options, click **OK**. Your title is published to your local directory. When the publishing process has completed, click the **Send Title** button to upload your title to the CourseMill server specified.

6. Click the **Done** button to close the publishing window. When available, you can also click the **Preview** button to launch the published title.

When you make changes to your title, you will need to republish it so the new changes are reflected in the published title. Repeat these steps as necessary to republish your title.

**Publishing to AICC/Web-Based**

The Aviation Industry CBT Committee (AICC) was established in 1988 to define standards on how Computer Managed Instruction (CMI) systems should operate in presenting course materials to students. For the latest specifications, documents, and explanations of terms, see the official AICC website ([http://www.aicc.org](http://www.aicc.org)).

Titles published with Lectora will meet or exceed the guidelines for a Web-based CMI system.

To publish your title to an AICC system, follow these steps:

1. Save your title.

2. From the **Publish** menu, select **Publish to AICC/Web-Based**. Lectora performs an error check and displays the results in the Publish Title to AICC Compliant Web Content window.

   **See also:**  
   Running an Error Check

3. Resolve any errors within your title. If necessary, click **Cancel** and repeat steps 1 and 2 until your title is free of errors.

4. Click **Publish** when you are satisfied with the results of the error check. The Publish AICC Location window opens.

5. Use the following tabs within this window to specify publishing options, FTP information and compression guidelines:
   - **AICC Options**
   - **AICC Options 2**
   - **Options**
   - **Companion CD**
   - **FTP Options**
   - **Proxies**
   - **Compression**

5. Once you have completed configuring all of the publishing options, click **OK**. Your title is publish to your local directory. When the publishing process has completed, click the **FTP Title** button to upload your title to the Web server specified. If you did not configure FTP settings, this option is not available.

6. Click the **Done** button to close the publishing window. When available, you can also click the **Preview** button to launch the published title.

When you make changes to your title, you will need to republish it so the new changes are reflected in the published title. Repeat these steps as necessary to republish your title.

**AICC Options**

Use the **AICC Options** tab within the Publish AICC Location window to specify publishing options pertaining to the AICC system. Complete the controls as follows:
<table>
<thead>
<tr>
<th><strong>Course Creator</strong></th>
<th>Specify the name you want the AICC system to display as the creator of the published title.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Course ID</strong></td>
<td>Specify the ID of the course as it will be known within the AICC system.</td>
</tr>
<tr>
<td><strong>Course Title</strong></td>
<td>Specify the title of the course as you want it to be displayed within the AICC system.</td>
</tr>
<tr>
<td><strong>URL of Course Folder</strong></td>
<td>Specify the Web address of the location of your course within the AICC system.</td>
</tr>
<tr>
<td><strong>Course Description</strong></td>
<td>Specify the description of the course’s contents as you want it to be displayed within the AICC system.</td>
</tr>
</tbody>
</table>

| **The published course will reside on the same network server as the LMS** | Clear this option if you know that the course will be published to a content server that is separate from the AICC system. If you are using the JavaScript Title Manager (see AICC Options) you will need to specify the Cross-domain redirector URL in the field provided. This is typically the location of a script that is used to facilitate the communication between the content server and the AICC system. See Sample. If you are not using the JavaScript Title Manager, a signed applet is automatically provided to facilitate the communication between the content server and the AICC system. |
| **The published course will be presented in a separate window than the LMS** | Select this option if you want the published title to be launched from the AICC system in a new window. When this option is selected, and the user exits the published title, the window will close, and the user will be returned to the AICC system. |
| **The published course will report Test/Survey Interactions to the LMS** | Select this to record interaction data for the questions contained in the graded test being submitted to the AICC system. Interaction data includes the following information for each graded question:  
  - User’s answer  
  - Whether the user’s answer is correct or not  
  - Time the question was answered  
  - Amount of time the user spent on the page containing the answer |

| **The published course will prompt to restore the last viewed location within the LMS** | Select this to enable the automatic bookmarking feature for the published title. When this is selected, and the user is returning to the published title within the AICC system, the user will have the option to skip to the page he or she last viewed within the published title. |

**Sample ASP Script**

```xml
<%@ Language=VBScript %>
<% Response.Buffer = True
Dim objXMLHTTP, xml, command, aicc_loc, version, session_id, aicc_data, postbody

'get passed params depending on method sent'
if(Request.Querystring("aicc_loc") <> "") then
    aicc_loc=Request.Querystring("aicc_loc")
    command=Request.Querystring("command")
    version=Request.Querystring("version")
    session_id=Request.Querystring("session_id")
    aicc_data=Request.Querystring("aicc_data")
else
    aicc_loc=Request.form("aicc_loc")
    command=Request.form("command")
    version=Request.form("version")
    session_id=Request.form("session_id")
    aicc_data=Request.form("aicc_data")
end if

'Build the post body string'
postbody = "command=" + Server.URLEncode(command) + "&version=" + Server.URLEncode(version) + "&session_id=" + Server.URLEncode(session_id)
if aicc_data <> "" then
...
```

---

**Lectora Information Center**
postbody = postbody + "&aicc_data=" + Server.URLEncode(aicc_data)
end if

' Create an xmlhttp object:'
Set xml = Server.CreateObject("Microsoft.XMLHTTP")
' Or, for version 3.0 of XMLHTTP, use:'
' Set xml = Server.CreateObject("MSXML2.ServerXMLHTTP")'

' Opens the connection to the remote server.'
xml.Open "POST", aicc_loc, False
xml.setRequestHeader "Content-Type", "application/x-www-form-urlencoded"

'Actually Sends the request and returns the data:'
xml.Send postbody

'Send back the response'
Response.Write xml.responseText

Set xml = Nothing
%

Publishing to SCORM/Web-Based
The Shareable Content Object Reference Model (SCORM) is a set of inter-related technical specifications built upon the work of the AICC, IMS, and IEEE to create a unified content model for Web-based learning content. For the latest specifications, documents, and explanations of terms, see the official SCORM website (http://www.adlnet.gov/).

Titles published with Lectora will meet or exceed the guidelines for SCORM 1.0, 1.1, 1.2 and 2004.

To publish your title to a SCORM system, follow these steps:
1. Save your title.
2. From the Publish menu, select Publish to SCORM/Web-Based. Lectora performs an error check and displays the results in the Publish Title to SCORM Compliant Web Content window.

See also: Running an Error Check
3. Resolve any errors within your title. If necessary, click Cancel and repeat steps 1 and 2 until your title is free of errors.
4. Click Publish when you are satisfied with the results of the error check The Publish SCORM Location window opens.

Use the following tabs within this window to specify publishing options, FTP information and compression guidelines:
- SCORM Options
- SCORM Options 2
- Options
- Companion CD
- FTP Options
- Proxies
- Compression

5. Once you have completed configuring all of the publishing options, click OK. Your title is published to your local directory. When the publishing process has completed, click the FTP Title button to upload your title to the Web server specified. If you did not configure FTP settings, this option is not available.

6. Click the Done button to close the publishing window. When available, you can also click the Preview button to launch the published title.

When you make changes to your title, you will need to republish it so the new changes are reflected in the published title. Repeat these steps as necessary to republish your title.
SCORM Options
Use the SCORM Options tab within the Publish SCORM Location window to specify publishing options pertaining to the SCORM system. Complete the controls as follows:

**Course Is**
Use the list to select the conformance type and level. Select from
- SCORM 1.0 Conformant
- SCORM 1.1 Conformant
- SCORM 1.2 Conformant
- SCORM 2004 Conformant

**Course Creator**
Specify the name you want the SCORM system to display as the creator of the published title.

**Course ID**
Specify the ID of the course as it will be know within the SCORM system.

**Course Title**
Specify the title of the course as you want it to be displayed within the SCORM system.

**URL of Course Folder**
Specify the Web address of the location of your course within the SCORM system.

**Course Description**
Specify the description of the course’s contents as you want it to be displayed within the SCORM system.

**Additional Keywords**
Specify any additional keywords that can be used to define the content of the course. When users search for courses within the SCORM system, searched terms are compared to course titles and keywords and will help users find the content for which they are searching.

**The published course will be presented in a separate window than the LMS**
Select this option if you want the published title to be launched from the SCORM system in a new window. When this option is selected, and the user exits the published title, the window will close, and the user will be returned to the SCORM system.

**The published course will report Test/Survey Question Interactions to the LMS**
Select this to record interaction data for the questions contained in the graded test being submitted to the SCORM system.

Interaction data includes the following information for each graded question:
- Question text (CourseMill and SCORM 2004 only)
- User’s answer
- Whether the user’s answer is correct or not
- Time the question was answered
- Amount of time the user spent on the page containing the answer

**The published course will prompt to restore the last viewed location within the LMS**
Select this to enable the automatic bookmarking feature for the published title. When this is selected, and the user is returning to the published title within the SCORM system, the user will have the option to skip to the page he or she last viewed within the published title.

Publishing to LRN
LRN (Learning Resource Interchange) is a Microsoft-specified content interchange descriptor that provides to content creators a standard way of identifying, sharing, updating, and creating online content and courseware.

Publishing to LRN is very similar to publishing to HTML, except that LRN provides a standard table of contents and navigation for the course. When using the LRN Viewer from Microsoft to view the published course, the course materials that you create will be contained in a frame on the lower right, with a table of contents on the left, and navigation buttons on the top. Because of this, if you are planning on publishing your title to LRN, it is not necessary to use navigation buttons or a table of contents.
object in your title, and it is strongly recommended that you do not use frames.

To publish your title to LRN, follow these steps:

1. Save your title.

2. From the Publish menu, select Publish to LRN. Lectora performs an error check and displays the results in the Publish Title to LRN window.

   See also: Running an Error Check

3. Resolve any errors within your title. If necessary, click Cancel and repeat steps 1 and 2 until your title is free of errors.

4. Click Publish when you are satisfied with the results of the error check The Publish LRN Location window opens.

   Use the following tabs within this window to specify publishing options, FTP information and compression guidelines:

   - Options
   - Companion CD
   - FTP Options
   - Proxies
   - Compression

5. Once you have completed configuring all of the publishing options, click OK. Your title is published to your local directory. When the publishing process has completed, click the FTP Title button to upload your title to the Web server specified. If you did not configure FTP settings, this option is not available.

6. Click the Done button to close the publishing window. When available, you can also click the Preview button to launch the published title. You can open your browser and view the published HTML files or you can use the Microsoft LRN toolkit to view the content as LRN.

When you make changes to your title, you will need to republish it so the new changes are reflected in the published title. Repeat these steps as necessary to republish your title.

Publishing to SCORM/Disconnected

The Publish to SCORM/Disconnected option is part of an evolving standard that enables users on learning management systems to download SCORM conformant materials for use in an off-line (not connected to the Internet) environment. The user completes the published title, and when they have re-established Internet connectivity, the published title can update the host learning management system with the results of the user's interactions.

To publish your title for a disconnected SCORM system, follow these steps:

1. Save your title.

2. From the Publish menu, select Publish to SCORM/Disconnect. Lectora performs an error check and displays the results in the Publish Title to SCORM Compliant Web Content window.

   See also: Running an Error Check

3. Resolve any errors within your title. If necessary, click Cancel and repeat steps 1 and 2 until your title is free of errors.

4. Click Publish when you are satisfied with the results of the error check The Publish SCORM Location window opens.

   Use the following tabs within this window to specify publishing options, FTP information and compression guidelines:

   - SCORM Options
   - AICC/SCORM Options 2
   - Options
5. Once you have completed configuring all of the publishing options, click **OK**. Your title is publish to your local directory. When the publishing process has completed, click the **FTP Title** button to upload your title to the Web server specified. If you did not configure FTP settings, this option is not available.

6. Click the **Done** button to close the publishing window. When available, you can also click the **Preview** button to launch the published title.

When you make changes to your title, you will need to republish it so the new changes are reflected in the published title. Repeat these steps as necessary to republish your title.

When you publish to SCORM/Disconnected, a sample input parameter file (ims_disconn.xml) is created to illustrate what input parameters are required by Lectora to operate in a disconnected SCORM environment. When the disconnected published title sends the results to the location defined in the `<submitto>` parameter, the results are posted in the following format:

```
Command=command-name (where command-name is one of: LMSSetValue, LMSCommit, or LMSFinish)
```

If the command is LMSSetValue, then the command is followed by URL-encoded name/value pairs that associate to the particular data items in the SCORM data model.

For example, a typical series of commands will be as follows:

```
command=LMSSetValue&cmi%2Ecore%2Esession_time%3D00%3A12%3A34%2E45&cmi%2Ecore%2Escore%2Eraw%3D75
command=LMSCommit
command=LMSFinish
```

These three commands (typically you will receive all three) sets the value of data item `cmi.core.session_time` to `00:12:34.45` and `cmi.core.score.raw` to `75`, commits the SetValue transaction(s), and issue an exit of the SCO.

---

**Command Line Publishing**

Lectora supports command line publishing. This enables you to use a command line invocation of the program to publish to the standard publishing formats that Lectora supports. A benefit of this feature is that a third-party application can issue the batch command to publish without having to go through the Lectora interface to publish the title.

This is an advanced feature and should only be used if you are familiar with command line programming.

If there are special parameters that you want to use when publishing using the command line interface, you must first publish the title using Lectora and select those options. The command line publishing interface will use the most-recent options that have been specified within Lectora.
To invoke command line publishing, open an MS-DOS command prompt, and enter the following:

Lectora: [/p[option]] [/c] [/o log] title

/p[option] Publish the title to necessary format, where option is one of the following:
SFX Single File Executable
CD CDRom
HTML HTML
AICC AICC/Web-based
SCORM SCORM/Web-based
LRN Microsoft’s LRN format
DISCONN SCORM/Disconnected

/c Create a console window for messages
/o Optional LogFile to capture publishing messages
title The full path to the Lectora title that you wish to publish

If you have any of the optional publishing packs installed with Lectora, you can use the abbreviated name for the publishing option to publish.

For example, you would specify the following to publish the title Orientation.awt in c:\mytitles to HTML with a console window and logfile:

Lectora /p HTML /c /o log c:\mytitles\Orientation.awt

**Common Publishing Options**
Many of the publishing options available are the same, regardless of the publishing format you have chosen. This includes the options on the following tabs within the Publishing Location window.

- AICC/SCORM Options 2
- Options
- Companion CD
- FTP Options
- Proxies
- Compression

See also: Publishing a Title

**AICC/SCORM Options 2**
If you have not specified that your title is an AICC/SCORM/CourseMill (3.x and above) Published Title, use the AICC/SCORM Options 2 tab within the Publish AICC/SCORM Location window to specify additional options pertaining to the title.

See also: Specifying the type of Title

Complete the controls as follows:

Course Type Specify the short description for the type of course within the learning management system. The default is Lesson.
### Developer ID
Specify the author's or developer's ID.

### Mastery Score
Specify the lowest passing score for the title. By default, the value is set to 75% of the maximum score of all graded tests within the title.

### Max Time Allowed
Specify the maximum time that users are allowed to access the published title. Leave the field blank to allow unlimited access to the published title.

### Time Limit Action
Specify the action to take when the Max Time Allowed has elapsed. Select from:
- Continue No Message
- Continue With Message
- Exit No Message
- Exit With Message

### Publishing Options
When you publish your title, you have a number of different publishing options. After selecting to publish to the desired format, use the controls on the Options tab to specify the following:

#### Destination Folder
Specify the directory in which you want to save the resulting files of the published title. Click the Choose Folder button to navigate and select a location.

This directory listing is for local or network locations, not the Internet. Lectora will automatically create the files in a new folder in the same working directory as the .awl title file, unless otherwise specified.

#### Publish Only Updated Pages/Resources
Select this to publish only the pages and resources that have been updated since your title was last published. This option is only available if you have previously published the title.

#### Publish All Pages/Resources in the Title
Select this to publish all the pages and resources regardless of whether they have been updated.

#### Use JavaScript Title Manager
This option is selected by default. The JavaScript Title Manager uses a technology called AJAX (Asynchronous JavaScript and XML), which creates a plug-in-free title. AJAX is supported in Internet Explorer 5.0 and above, Safari 1.2 and above, Opera 8.0 and above, Netscape 7.0 and above, and all versions of Mozilla and FireFox.

This option cannot support the submission of emails from a title, and should be cleared if the ability to submit an email is included in your title.

#### Store Published Title in a Zip File
Select this to compress all the HTML, JavaScript, and media files that comprise the published title into a single Zip file.

#### Create ALT Tags for Images and Buttons
This option is selected by default and will create ALT tags for all images and buttons in the title. ALT tags are created based on the names that are used in your title's left-hand pane. An ALT tag will be displayed in a tool tip when the user hovers their mouse over an image or button. ALT tags are also used by screen readers to identify the image or button.

#### Include Title Manager Frame
This option enables you to store all variable data locally, instead of within the browser's cookies. It is suggested to select this option if your title contains a large number of questions or variables. Selecting this will increase your title's performance if your title contains a significant number of questions or variables.

#### Convert accented characters in page names to ASCII
This option defaults as selected only when Lectora encounters a page name with a non-ASCII character. This option will use a replacement ASCII character for all accented or special characters so that the generated HTML page names are compatible with Web
**Generate short ASCII HTML page names**
This option will only default as selected when Lectora encounters a page name with a multi-byte international character. This option will use the page's unique internal number so that the generated HTML page names are compatible with Web browsers.

**Use Web 2.0 Style Pop Ups**
Select this to display Web 2.0/AJAX-based pop-up windows. This option is enabled by default. If you disable this option, your users may encounter issues with pop-up blockers.

**Protect Published Content**
If this option is selected, Lectora will eliminate the functionality of keyboard shortcuts such as copy and paste, as well as equivalent right-click menu options within the browser so users cannot easily copy content material.

**Debug Published Content**
Select this to debug your title within its published format. If this option is selected and you launch your published title, an additional debug window will launch, displaying all of the variable interactions and actions executed within the published title. When this option is selected, the **Debug Options** button is enabled. Click the button to configure the type of information you want to see in the debug window.

*See also:* Setting debug options, Working with the Debug window

**Name of First HTML file for Title**
Specify the HTML page name of the first page of your title. By default, this is *index.html*.

**Companion CD**
If your title includes audio or video, the **Companion CD** tab is available on the Publish Location window. Click this tab to configure the Companion CD settings.

Creating a companion CD-ROM causes everything in your title's media folder (audio and video) to be placed in a separate folder whose contents are intended to be burned to a CD-ROM and distributed to the users of your title. An alternative to using a companion CD-ROM would be to use streaming media, if your Web server supports streaming.

*See also:* Streaming Media

When a user interacts with a title that requires a companion CD-ROM, the user must insert the CD-ROM for the published title to function properly.

**Important:** Only the Windows operating system supports the use of Companion CD-ROMs.

Select **Create Companion CD** to enable the **Publish to Folder** field and **Choose Folder** button. Specify the directory in which you want to save the resulting companion CD-ROM files or click the **Choose Folder** button to navigate and select a location.

**FTP Options**
When you publish your title, you have the ability to immediately FTP the published title to a Web server. Use the controls on the **FTP Options** tab to specify the following:

*FTP Title To Host*  
Select this to enable the **Host Name**, **User ID**, **Password**, and **Initial Remote Folder** fields.

*Host Name*  
Specify the host name of your Web server. For example, www.trivantis.com.

*User ID*  
Specify the user ID that can access the Web server.
Specify the password that corresponds with the user ID to access the Web server.

If you are required to publish to a specific directory, specify the directory in this field. For example, if you specify MyDirectory, your title will be published to www.trivantis.com/MyDirectory.

You can also create a new directory by typing in the name of the directory you want to create in this field.

Proxies
When you publish your title and you want to FTP it to a Web server, if you need to connect to your Web server through a proxy or if you are required to go through a firewall to access your Web server, you can specify proxy information for transferring your title. Use the controls on the Proxies tab to specify the following:

- **Use FTP Proxy**: Select this to enable the FTP Proxy Host, Port, and Login to Firewall fields.
- **FTP Proxy Host**: Specify the host name of your FTP Proxy server.
- **Port**: Specify the port number for the FTP Proxy server.
- **Login to Firewall**: Select this to enable the User ID and Password fields for logging into a firewall.
- **User ID**: Specify the user ID that can access the firewall.
- **Password**: Specify the password that corresponds with the user ID to access your firewall.

Compression
When you publish your title, you can compress audio, video, and images.

Select the Audio, Video, or Images check boxes to compress the corresponding resource types within your title. Use the sliders to select from ten different levels of compression.

Selecting to compress your media objects will compress all audio, video, and image resources within your title. Alternatively, you can compress individual audio and video objects. See Converting to Flash audio and video.

When you choose to compress audio and video, Lectora will automatically convert the audio and video file types to .flv files. This is a highly-compressed file type that can be played with the Flash plug-in. If you are already using highly-compressed audio and video within your title, it is not suggested to further compress these files. This means that if your audio or video files are already in a compressed format such as Windows Media Audio (.wma) or Windows Media Video (.wmv), it is not recommended to further compress, as this will greatly diminish the quality of your audio or video. Even with the compression option selected, Lectora will not further compress any .flv audio or video currently within your title.

You should also take into consideration the type of audio and video you have added to your title. If the audio contains simple voice overs or small sound bytes, this kind of audio can be highly compressed without losing much quality. If the audio is music, high compression will result in a loss of quality of the music. Similarly, if the video contained within your title does not contain a lot of movement, it can be highly compressed without losing much quality. Alternatively, if your video contains a lot of movement, compression will result in a loss of quality of the video.

When you choose to compress images, images types other than .gif or .jpg will be converted to .jpg files. Lectora will attempt to compress all images larger than 10k within your title. Compression will only occur if it results in the image size decreasing by more than 2k. Otherwise, the image will not be compressed.
• When your compression settings are low, the quality of the audio, video and images will be maximized.
• When your compression settings are high, the quality of the audio, video and images will be minimized.

Appendix

- Supported Media Types
- Title Style Gallery
- Importing and Exporting Content
- Streaming Media
- Submitting Test, Survey and From Results to CGI
- Lectora Frequently Asked Questions

Supported Media Types

Lectora supports a wide variety of the most popular types of media found in all aspects of multimedia and the Internet. With such a wide selection, your title can host dazzling video, sound, animations, and even three-dimensional interactive movies. The following chart illustrates the media types that Lectora supports.

Animations
- GIF (.gif)
- Flash files (.swf, .spl)

Audio
- Flash Audio (.flv)
- Uncompressed Windows audio (.wav)
- Standard MIDI (.mid)
- MPEG, Audio layer 3 (.mp3)
- Advanced Systems Format (.asf)
- RealMedia streaming media (.rm)
- uLaw audio (.au)
- Windows Media audio (.wma)

Documents
- Rich Text (.rtf)
- Text (.txt)

Images
- JPEG (.jpeg, .jpg)
- GIF (.gif)
- TIFF (.tif)
- Windows Bitmap (.bmp)
- Windows Enhanced Metafiles (.emf)
- Windows Metafiles (.wmf)
- Portable Network Graphics (.png)

IPIX Images
- IPIX files (.ipx, .ips)

Video
- Apple QuickTime movie (.mov)
- Audio Video Interleave (.avi)
- Flash Video (.flv)
- Moving Picture Experts Group (.mpg, mpeg)
- Real Media (.rm, .rmm)
- Windows Media Video (.wmv)
- Microsoft and Real Media streaming video formats

In addition to the supported media types, Lectora enables you to extend the functionality of your title by adding External HTML Objects. With the use of External HTML Objects, you can further add:
- Java Applets
- Header Scripting (JavaScript)
- Shockwave Movies
- Custom HTML
- ASP Scripts
- JSP Scripts
Title Wizard Gallery

Blank Title

Creates a new title with blank pages, populated with pages and chapters as specified. Add other navigation as you see fit.

Shaded Border Presentation

Creates a title with a colored shaded border on the sides, top, or bottom.

Standard e-Learning Course

Creates a title with commonly used course components and structure suitable for publishing to a learning management system.

Reflection

Creates a title based on chapters or pages with four optional color themes and chapter-name buttons.

Product Launch

Platinum
Creates a title for a product launch announcement with optional default and custom topics.

**Photo Album**

Creates a digital photo album of your own images.

**NaturalWave**

Creates a title with a fun template with five optional color themes and chapter-name buttons.

**ModuleX**

Creates a chapter- or page-based title with three optional color themes and chapter name buttons.

**iPhone Corporate Site**

Creates a Corporate Site title with dimensions formatted for the iPhone.

**iPhone Gel-tech**

Creates a chapter- or page-based title with page dimensions formatted for the iPhone.

**Framed Title with TOC**

Creates a framed title with a table of contents in the left frame.

**Corporate Orientation**

**Certification Course**
Creates a corporate orientation title with optional default and custom topics.

Creates a title containing commonly used course components, structure and a completion certification.

Aqua

Creates a title designed for the 640 x 480 screen format with optional chapter name buttons and scrollable page format.

Tabbed Presentation

Creates a title with a tabbed folder look with three optional styles of folders.

Importing and Exporting Content

Lectora enables you to work with data from text files and other programs in the following formats:

- **CSV Question File**
  Comma-separated value (CSV) files are questions exported from spreadsheets like Microsoft Excel and Access.

- **QTI**
  Question Test Interoperability (QTI) is a test file standard developed by the IMS Global Learning Consortium. Lectora can also export test and test question in QTI format.

- **XML**
  Extensible Mark-up Language (XML) is a popular import and export file type with today’s content management software.

- **ZIP**
  You can share ZIP-compressed titles from within the application.

- **Microsoft PowerPoint**
  You can integrate PowerPoint slides into a title. To enable Lectora to add PowerPoint slides, you must install the Lectora Integrator for PowerPoint.

Importing a CSV question file

Comma-separated value (CSV) files are delimited text files containing questions that have been exported from spreadsheets like Microsoft Excel and Access.

You can import the following questions types within CSV files:

- True/False
Multiple Choice
Essay
Short Answer

The format is the same for each question type. All fields are separated by a comma, and all text fields are enclosed in quotes. Each question record starts on a new line. There can be line breaks within quoted fields. This is the default export format from Microsoft Excel and Access when exporting to CSV.

To import a CSV file:
1. In the left-hand pane, highlight the page onto which you want to add the questions from the CSV file.
2. From the File menu, select Import > CSV Question File. The Comma Separated Value Question Import Options window opens.
3. Click the File Format button to review whether your file meets the CSV requirements.
4. Use the File to Import field to specify the file to import or click the Browse button to navigate and select a CSV file.
5. Use the Default page Size box to specify the Width and Height of the page.
6. To offset the question on the page, select the Offset question on page check box. This enables the X offset and Y offset fields. Specify the distance to the right in the X offset field. Specify the distance above the bottom line in the Y offset field.
7. To added standard navigation to the question pages, select the Add navigation to pages check box.
8. Click OK.

Importing and exporting a QTI file
Question Test Interoperability (QTI) is a test file standard developed by the IMS Global Learning Consortium.

To import a QTI file:
1. In the left-hand pane, highlight the page onto which you want to add the contents from the QTI file.
2. From the File menu, select Import > QTI. The Import from QTI window opens.
3. Navigate and specify the file to import and click Open.

To export a QTI file:
1. In the left-hand pane, select one of the following:
   o a question
   o a page containing one or more questions
   o a test containing one or more questions
2. From the File menu, select Export > QTI. The Export to QTI window opens.
3. Navigate and specify the file to export and click Save.

Importing and exporting a XML file
Extensible Mark-up Language (XML) is a popular import and export file type with today’s content management software. You can export your title to XML and further import any titles you have previously exported to XML.

The Lectora XML Specification describes the basic structure of a Lectora title represented in XML format.
To import a XML file:
1. Save and close the current title on which you are working.
2. From the File menu, select Import > XML. The Import from XML window opens.
3. Navigate and specify the file to import and click Open.

To export a XML file:
1. From the File menu, select Export > XML. The Export to XML window opens.
2. Navigate and specify the file to export and click Save. Your current title is saved in XML format.

**Importing and exporting a ZIP file**
You can share ZIP-compressed titles from within the application.

To import a ZIP file:
1. Save and close the current title on which you are working.
2. From the File menu, select Import > ZIP. The Import from ZIP window opens.
3. Navigate and specify the file to import and click Open.

To export a ZIP file:
1. From the File menu, select Export > ZIP. The Export to ZIP window opens.
2. Navigate and specify the file to export and click Save. Your current title and its contents are compressed and saved in a ZIP file.

*See also:* [How Lectora Organizes Your Content](#)

**Importing PowerPoint presentations**
You can import an entire Microsoft PowerPoint presentation to create a new title.

You must install the Lectora Integrator for PowerPoint to enable Lectora to import PowerPoint slides.

See the Lectora Integrator for PowerPoint Information Center for details about installation and importing PowerPoint slides into your titles.

**Streaming Media**
You can stream long video and audio, or both, in a Web-based title. Streaming media can download and play the video (or audio) simultaneously, and can stream different quality levels of the content depending on the users' Internet connection speed.

Follow these steps to use streaming media with Lectora:
1. Ensure that you have access to a Web server that is configured for streaming media.
2. Inquire as to whether the Web server will be capable of streaming to the number of simultaneous users you expect to be using the server at one time.
3. Produce or acquire a segment of audio or video that you would like to stream.
4. Digitize the segment into one of the popular media types.
   - If you want to produce Real Media streaming content (.rm), obtain a streaming media development kit from [http://](http://)
If you want to produce a Windows Media Services streaming file (.asf), obtain a streaming media development kit from [www.microsoft.com](http://www.microsoft.com).

5. Convert the segment with a streaming media production tool.

6. Have your ISP or server administrator place the converted streaming file on your streaming server. You should be given a URL from your administrator to access the media from Lectora.

To have the video or audio embedded on a page:
- Create a new video or audio object in your Lectora title.
- Select the desired streaming audio/video type from the Video Type or Audio Type list.
- Type in the URL provided by your administrator.

To display the Streaming video outside of the title in a separate window:
- Create a Go To, Web Address action from a button, hyperlink or action.
- Specify the URL provided by your administrator.

See also: [Working with Audio](#) [Working with Video](#)

### Submitting Test, Survey and Form Results to CGI

You can enable Lectora to submit test, survey, form results and variable data to a server-side, CGI program that can then write the information to a file or database. All information for test and surveys, including the user's name and email address, test questions, test answers, and scores is submitted, enabling you to manage user results from your titles more efficiently and effectively.

All data communicated to the CGI program are reported as name/value pairs:
- Variable values are submitted with the name of the variable as the name, and the value of the variable as the value.
- Form object values are submitted with the name of the form object as the name, and the value of the form object selected or provided by the user, as the value.
- For tests and surveys, the name/value pairs that are submitted are fixed as follows:

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>name</td>
<td>The user's name</td>
</tr>
<tr>
<td>email</td>
<td>The user's email address</td>
</tr>
<tr>
<td>TestName</td>
<td>The name of the test/survey</td>
</tr>
<tr>
<td>NumQuestions</td>
<td>The number of questions in the test/survey</td>
</tr>
<tr>
<td>Passing Grade</td>
<td>The value specified as the Lowest Passing Score within the test's properties (not applicable for surveys)</td>
</tr>
<tr>
<td>Score</td>
<td>The total score of the test (if it is scored)</td>
</tr>
</tbody>
</table>

- For questions contained in surveys or tests, the name/value pairs that are submitted iterate for the number of questions contained in the test or survey. In each of the following, the $X$ is replaced by the actual number of the question.

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
</table>
Use the following information to help you design a script to process Lectora output. Combining the information offered here with the expertise of your database manager and IT or ISP staff; you should be able to develop an effective connection between Lectora and your database.

A programmer knowledgeable in server-side scripting and database integration over the Internet/Intranet should perform the integration between Lectora and the database. If you have questions about the information contained here, contact the Trivantis Support team.

The following are examples of scripts that you can use when creating your custom CGI scripts.

- **Sample ASP Script**
- **Sample Perl Script**

**See also:**
- Setting test result properties
- Setting survey result properties
- Setting form submission properties

For titles published to the Web, the script must reside on the same server as the published title content. Cross-domain scripting is forbidden within Web browsers.

### Sample ASP Script

```vbscript
<%@ Language=VBScript %>
<% 
'Get the parameters posted from the test'
    testname=Request.form("TestName")
    score=Request.form("Score")
    user=Request.form("name")
    numQuestions=Request.form("NumQuestions")
    passingGrade=Request.form("PassingGrade")

'Validate that this is actually from a Lectora test'
if testname="" Or score="" Or user="" Or numQuestions="" Or passingGrade="" then Response.Write "<html>"
```
Response.Write "<head><title>Failure</title></head>"
Response.Write "<body>"
Response.Write "STATUS=500"
Response.Write "<br>"
Response.Write "Could not parse test results due to a parameter error." Response.Write "</body></html>"
else

'Write the results to a file named the same as the test'
'This could be a database or any kind of object store, but'
'to keep it simple, we will just use a flat text file'
fileName = "c:\" & testname & ".log"

'Open the results file for append'
Const ForReading = 1, ForWriting = 2, ForAppending = 8
Set objFSO = CreateObject("Scripting.FileSystemObject")
if not objFSO.FileExists(fileName) then
  objFSO.CreateTextFile(fileName)
  Set objInFile = objFSO.OpenTextFile( fileName, ForAppending, True )
else
  objInFile.WriteLine( Date & ", " & Time & ", " & user & ", " & score )

'Older courses produced by Lectora used a zero based index for the questions (i.e. Question0 is the first question)'
'Newer courses are one based (i.e. Question1 is the first question)'
'determine which one it is'
Dim startIndex
valTemp = Request.form("Question0")
if( valTemp="" ) then
  startIndex=1 else
  startIndex=0 end if

'Write all of the questions and answers'
for i = startIndex to cint(startIndex + numQuestions-1)
  nameQ = "Question" + CStr(i) nameA = "Answer" +
  CStr(i) valQ = Request.form(nameQ) valA =
  Request.form(nameA) objInFile.WriteLine( nameQ & ": " & valQ )
  objInFile.WriteLine( nameA & ": " & valA )
Next

'Close results file'
objInFile.Close
Set objInFile = Nothing Set objFSO = Nothing
end if %>

Sample Perl Script
#!perl
use CGI;
$q = new CGI;
#get the parameters passed to the script
$name = $q->param('name'); $testName = $q->param('TestName');
$numQuestions = $q->param('NumQuestions');
$passingGrade = $q->param('PassingGrade');
$score = $q->param('Score');
if( $testName eq "" || $numQuestions eq "" ) {
    print "Content-type: text/html\n\n"
    print "<html>"
    print "<head><title>Failure</title></head>"
    print "<body>"
    print "STATUS=500"
    print "<br>"
    print "Could not parse test results due to a parameter error.";
    print "</body></html>"; exit 0;
}

#$get the current time
($sec,$min,$hour,$mday,$mon,$year,$wday,$yday,$isdst) = localtime (time);
$year = $year + 1900;
$mon = $mon + 1;
$currtime = "$year-$mon-$mday $hour:$min:$sec";

#$open test data file for append and write the data
$testName .= ".log";
open( TESTDATA,">c:\$testName" ) or die;
print TESTDATA "$currtime $name $numQuestions $passingGrade $score\n";

#$Older courses produced by Lectora used a zero based index for the questions (i.e. Question0 is the first question) '# Newer courses are one based (i.e. Question1 is the first question)'
#$determine which one it is'
$startindex = 0;
$tempx = $q->param('Question0'); if( $tempx eq "" ) {
    $startindex = 1;
}

$index = $startindex;

#$write out all of the questions and answers
while( $index < ($startindex + $numQuestions) ) {
    $qst = 'Question$index'; $ans = 'Answer$index';
    $qval = $q->param( $qst ); $aval = $q->param( $ans );
    print TESTDATA "$qst: $qval\n";
    print TESTDATA "$ans: $aval\n";
    $index += 1;
Lectora Frequently Asked Questions

Frequently asked questions about Lectora:
- Why can't I select and edit title objects?
- What is the size or position of my object?
- What if I changed something by accident?
- How do I resize by image?
- How do I check my spelling?
- How do I open a new browser window?
- What file extensions does Lectora support?
- Can I import an existing Lectora title into my current working title?
- How do I keep my objects from moving?
- How do I select all the objects on my page?
- How do I select and format hyperlink text?
- How do I add the same object to every page?
- How do I exclude an item from a page?
- What extensions do my files have?
- Why after publishing to HTML, AICC, or SCORM my send test results by email is giving me an error?
- Why is my random test finishing too soon?
- Can Lectora display Mathematic Equations?
- Does Lectora support book marking?

Why can't I select and edit title objects?
A common occurrence when developing a title in Lectora is to forget that your title is currently in Run mode. When a title is in Run mode, you will not be able to select and manipulate any objects on the screen until you switch back to Edit mode (red light) by using the leftmost Stoplight icon at the far left of Lectora’s toolbar.

See also: Using Lectora's Modes

What is the size or position of my object?
A useful way to find out the dimensions or position of any object on the page is to look at the bottom right corner of the Lectora main window. After you click on any object, its location and size are displayed in a status area in that corner. These numbers will update as you modify the size and/or position of the object.

See also: Using the Status bar

What if I changed something by accident?
Lectora features multiple Undo commands. If you have just changed, resized, added, or deleted something and you suddenly realize that you did not intend to do that, or you were unhappy with the result, Undo the action by holding down the Ctrl-Z keys. Optionally, you can select Undo from the Edit menu.
If you then decide you want to Redo the action then simply press Ctrl-Y. Alternately, select Redo from the Edit menu.

See also: Edit Menu

How do I resize my image?
Objects that can be sized and have an original aspect ratio (width to height ratio) such as images and buttons have a property called Keep original aspect ratio, which is set by default and can be accessed on the objects Position and Size tab. When this property is set, sizing the image keeps the image at the same width to height ratio as the original image imported into the title.

All sizable objects can be sized proportional to their current width and height. By holding down Shift while using the mouse to drag a corner or side of the object, the object will size relative to its current width and height.

See also: Moving and Resizing Objects
Making objects the same size

How do I check my spelling?
Lectora helps you spell check your text. If you are in text edit mode, you can spell check the current block by choosing the Spell Check button on your text toolbar or selecting the Spell Check option on the right-click menu for the text block.

You can also spell check all text blocks on the current page or all text blocks in the entire document by selecting those items from the Tools menu.

See also: Checking Spelling

How do I open a new browser window?
If you are publishing your title to HTML and you want to link to an external Web address, but want the student taking the title to stay in your title, open the external Web address in a different window.

You can do this by creating an action or putting an action on a button or a text link. On the action specify Go To and then Web Address. When this is selected, you will see an option for Open in new Browser window. Checking this box will link to the Web address in a separate window.

This affects a title published to HTML. All CD published titles open Web addresses in a separate browser window.

See also: Executing Go To actions

What file extensions does Lectora support?
Lectora supports several types of files:

<table>
<thead>
<tr>
<th>Sound</th>
<th>Document</th>
<th>Image</th>
<th>Video</th>
</tr>
</thead>
<tbody>
<tr>
<td>.wav</td>
<td>.rtf</td>
<td>.gif</td>
<td>.avi</td>
</tr>
<tr>
<td>.mid</td>
<td>.txt</td>
<td>.jpg</td>
<td>.mov</td>
</tr>
<tr>
<td>.mp3</td>
<td></td>
<td>.bmp</td>
<td>.mpg</td>
</tr>
<tr>
<td>.rmi</td>
<td></td>
<td>.tif</td>
<td>.rmm, .rm</td>
</tr>
<tr>
<td>.au</td>
<td></td>
<td>.ipx</td>
<td>.wmv</td>
</tr>
<tr>
<td>.aiff</td>
<td></td>
<td>.wmf</td>
<td></td>
</tr>
<tr>
<td>.aif</td>
<td></td>
<td>.png</td>
<td></td>
</tr>
<tr>
<td>.mpg</td>
<td></td>
<td>.emf</td>
<td></td>
</tr>
<tr>
<td>.rm, .rmm</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Can I import an existing Lectora title into my current working title?
Yes. To do so, follow these steps:
1. Select **Import from an existing title** from the **Tools** menu.
2. Browse for the appropriate .awt file.
3. Click OK.

**See also:** Working with Objects

How do I keep my objects from moving?
Lectora provides object locking. Once an item is locked, it must be unlocked to change the placement or size. It is a good idea to lock all your objects in a finished title to prevent the user from accidentally moving an object.

1. Right-click on any object.
2. Select **Locked** from the pop-up menu.
   OR
1. Select **Properties** from the pop-up menu.
2. Select the **Size/Position Locked** check box.
3. Click OK.

**See also:** Locking and Unlocking Objects

How do I select all the objects on my page?
You can select all the objects on a page in several ways:
- Hold down the **Ctrl** key on your keyboard and select each object under a page in the left-hand pane.
- Hold down the **Ctrl** key on your keyboard and select each object on your working page.
- Right-click on a page in the left-hand pane and choose **Select All Objects** from the pop-up menu.

**See also:** Selecting objects and grouping them

How do I select and format hyperlink text?
Perform the following steps:
1. Press **Shift** on your keyboard and use your keyboard arrow keys to select the hyperlink text.
2. Continue to press **Shift** and apply any formatting to the text by using your mouse to access the menus.

**See also:** Adding Hyperlinks to Text

How do I add the same object to every page?
The Inherit feature enables you to easily place the same object on every page of your title:
1. If you would like the same object to appear on every page of the entire title, select the title icon in the left-hand pane. A blank page will appear in the working area of Lectora.
2. Add the object to this page in the exact spot you want it to appear on every page of your title.

The Inherit feature also enables you to place the same object on every page of a specific chapter or section by selecting the chapter or section and following the steps above. For more information on the Inherit feature, see Understanding Inheritance.

How do I exclude an item from a page?
Anything you add directly under the main title will appear on every page of your title. Objects that are added directly under a chapter will appear on every page of that chapter. Objects added directly under a section will appear on every page of that section.

Perform the following steps to exclude an item from a page:
1. Right-click the appropriate icon in the left-hand pane.
2. Select Properties from the pop-up menu. The Page Properties window opens.
3. Click the Inherit tab.
4. Select the Exclude Inheritance of Certain Objects radio button.
5. Use the arrow keys to move items from the Include to Exclude list.
6. Click OK.

See also: Understanding Inheritance

What extensions do my files have?
Your Lectora title will have a file extension of .awt.

When you publish to HTML, you will have several different files in the HTML folder. The files that will be published to the Web will have extensions of .html, .js (javascript), .jar (java), and .css (cascading style sheets). All of these files MUST be published to the Web.

If you have added ASP or JSP code to a page using the External HTML Object, your published pages will have the extensions of .asp or .jsp.

See also: Working with External HTML Objects

Why after publishing to HTML, AICC, or SCORM, my send test results by email is giving me an error?
If you are publishing to HTML and wanting to submit the test results, you need to have your server configured to do so. When viewing your title in run/preview mode, from a CD publish/single file executable, it uses your local email program. However, after publishing to HTML, Lectora uses the email server to do this. This means that it will not be able to email from your computer, but once the course is uploaded to the hosting server it should be able to use its email server.

Here is what you need to have on the server end:

- Must have port 25 wide open with absolutely no restrictions.
- Must have a server mail client on that same server that the course is hosted with the relay option enabled that is able to capture the email from port 25.

See also: Publishing a Title

Why is my random test finishing too soon?
This occurs when the done button is left on the last page. In many cases the last page of the exam will be randomly picked before the test is over and the done button will remain on the page.

Remove the done button from the last page and inherit the forward button in its place.

See also: Setting a test's content properties

Can Lectora display Mathematic Equations?
Yes. Use the Equation Editor on the toolbar to create an equation.

See also: Working with Equations

Does Lectora support book marking?
If you are publishing to AICC/SCORM then it should be automatic through your LMS.

If you are publishing to HTML then you can use the “retain test answers between sessions” and also keep track of users taking your course by using variables, make sure “retain variable values between sessions” is selected for your user-defined variables from the tools, manage variables properties. Keep in mind that Lectora is using cookies to keep this information and will only be stored if they come back to the test from the same machine.

See also: Publishing a Title